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Welcome

Avenza welcomes you to map-making in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of map-making by allowing spatial data 
files to be used to create maps inside a vector graphics program. MAPublisher allows all cartographic tasks to be 
performed where they should be done; in a powerful graphics environment.

This manual assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of 
geographic information systems (GIS) terminology and concepts. Please refer to the Adobe Illustrator user guide for 
more information on using Adobe Illustrator. 

The User Guide explains the installation process and the many features of MAPublisher. All MAPublisher panels, 
functions and tools are thoroughly detailed together with the related concepts necessary to build map and perform 
fundamental cartographic and GIS tasks. Please refer to the document Avenza Projections Guide.pdf for more 
information on the projections supported in MAPublisher.

As a complement to these guides, the MAPublisher software installer includes tutorial documents (MAPublisher 8 
Tutorial Guide.pdf, MAPublisher 8 Quick Start Guide.pdf and MAPublisher 8 MAP LabelPro Tutorial Guide) and associated 
GIS datasets. We encourage all users to go through these guides to gain additional experience with MAPublisher 
tools and functions. 

MAPublisher and Adobe Illustrator together constitute an integrated cartographic design software system with 
state-of-the-art graphics tools and geographic functions.
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viii Introduction

Introduction

MAPublisher 8.4 is the newest version of a powerful suite of plug-ins for Adobe Illustrator CS4 and CS5 that bridges 
the gap between geographic information systems (GIS) and high-end graphic design software in order to facilitate 
the map creation process. MAPublisher offers additional panels, functions, tools and functions to the powerful 
Adobe Illustrator design environment that enable GIS data files to be used as a base for cartographic production 
destined for print or Web contents.

Working from a traditional Adobe Illustrator document, users create and edit their data organized through layers 
(either new or imported with MAPublisher). Users benefit from the Adobe Illustrator graphic tools as well as 
additional custom MAPublisher functions and panels to create, edit and query the map data.

MAPublisher Simple and Advanced Import functions allow the import of major GIS and CAD formats (ArcGIS, MapInfo, 
AutoCAD, MicroStation, KLM and more) into Adobe Illustrator, while retaining their native geometry (Point, Line, 
Text, Area), layer structure, geographic location and attribute data.

The cartographic workspace is managed through MAP Views that control the geospatial parameters: coordinate 
system, map anchor, map scale and rotation. Layers organized under the same MAP View share the same 
geographic frame of reference. A layer must reside within a MAP View to be managed by MAPublisher functions 
and keep its spatial and attribute information; however layers not related to a MAP View may still be used for 
presentation purposes (such as title, scale and legend). An Adobe Illustrator document may contain more than one 
MAP View. For example, a map with an inset map at a larger scale to represent a zoomed-in area of interest.

The MAP Attributes panel allows for creating, editing and querying attribute information. For example, for a line layer 
containing street data, each line segment may be linked to a table with information relative to the street name 
and street category. Using the MAP Attributes panel, this information can be viewed, queried, edited or additional 
columns of data may be appended.

MAP Themes make use of the attribute data to apply Adobe Illustrator graphic styles, symbols or character styles 
to map features, depending on a given object’s attribute value. Choose from Stylesheet, Charts, and Dot Density 
themes.

MAPublisher also offers many functions and tools to manage GIS data from within Adobe Illustrator:
•	Import major GIS and CAD formats (MAPublisher Simple and Advanced Import, Spatial Database)
•	Plot a symbol by typing in its world coordinates (MAP Point Plotter)
•	Draw objects with geographic dimensions (MAP Area Tools)
•	Trim the geographic extents of the map (MAP Vector Crop)
•	Join lines or points that share a same attribute value, simplify lines, create a buffer area around a line (Buffer 

Art, Flip Lines, Join Areas, Join Lines, Join Points, Line Plotter, Simplify Lines)
•	Automatically label features based on attribute data (MAP LabelPro, Label Features and MAP Tagger Tool)
•	Select features based on attributes (MAP Selections)
•	Import and export geographically referenced images (Register Image)
•	Create grids and indexes (Grids and Graticules)
•	Create scale bars and north arrows (Scale Bar, Create North Arrow)
•	Export to Geospatial PDF (Export Geospatial PDF) 
•	Export a map to Flash with populated Web tags (MAP Web Author)
•	Export layers to major GIS and CAD formats (MAP Views)
•	And much more... 



ixMAPublisher 8 Features

MAPublisher Features

MAP Web Author
Export Adobe Illustrator documents with GIS data to interactive Flash maps, complete with callout bubbles, 
rollovers, layer control, pan and zoom controls, and with all the underlying GIS attributes intact. Export Flash maps 
without any additional coding or software requirements and embed them to any Web page. Further customization 
using advanced CSS and MAP Web Authort Javascript API is available for advanced users.

MAPublisher Spatial Database import
Import spatial data from Esri Personal Geodatabase (.mdb), File Geodatabase (.gdf ), and ArcSDE servers. This 
function requires Esri software and a valid license installed on the computer and consequently it is only available on 
Windows operating systems. Supported feature types are Point, Polyline, Polygon, Circular Arc, Eliptical Arc, Bezier 
Curve, Annotations (text). The MAPublisher Spatial Database import allows for SQL queries and spatial filters.

MAPublisher LabelPro™
MAPublisher LabelPro™ revolutionizes the way users can label map data, including using symbols as labels and label 
conflict resolution with a high degree of customizable rule-based labeling options. The MAP LabelPro engine uses 
your map data attributes for labeling with styles, rules and controls configured through an intuitive, easy-to-use 
Graphical User Interface. This function is available as an optional add-on to MAPublisher 8.1 and higher.

Export to Geospatial PDF
Export map data to a geospatially enabled PDF. In this process, all objects and associated MAP Attributes 
information (when available) are ported to PDF, while also maintaining the map coordinate system. When a 
geospatial PDF is opened with Adobe Acrobat Reader 9, one can find locations, measure distances, add location 
markers as well as copy coordinates to the clipboard. Additionally, objects can be selected and queried and their 
MAP Attributes can be viewed in the Adobe Acrobat Model Tree.

MAPublisher Panels
MAPublisher panels seamlessly integrate into the user interface and can be resized, moved, and docked just like 
native Adobe Illustrator panels.

MAPublisher Toolbar
The MAPublisher Toolbar allows you to easily launch all the main MAPublisher tools with a single click.

MAP Vector Crop Tool
Crop map documents only to the area of interest by drawing a box around an area of inteterest. Easily remove 
unwanted data while preserving attributes and styles. Perfect for creating inset maps.

MAPublisher Preferences
The new MAPublisher Preferences allow users to fully customize their MAPublisher experience. Control everything 
from the way layers are sorted to the font used to display attribute data or style of the MAP Selections panel. This 
includes several previously hidden options that used to be the domain of advanced users.
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MAP Point Plotter Panel
MAP Point Plotter places points (e.g. locations of towns or cities) based on user input locations onto any projected 
map in projected units or lat/long format (decimal degrees, or Degrees Minutes Seconds). MAP Point Plotter also 
offers the option to instantly plot centroids for line or area features.

Import/Export Data
Import data from mapping applications such as ArcGIS, MapInfo, MicroStation, Google Earth and other sources 
with all attributes and georeferencing intact. Make vector and database edits, data edits, additions and save your 
changes to a variety of GIS data formats. Newly supported formats are KMZ, GML and S-57 (import only).

MAP Views
The MAP Views panel controls the Adobe Illustrator layers organization into geographically referenced entities. It 
offers many ancillary tools: export to GIS format, layer lock and display control, Switch to MAP View, exchange MAP 
Objects between Adobe Illustrator documents.

Several geographical references can be maintained per document (e.g. main map and inset maps), stored as MAP 
Views. Each MAP View scale, transformation, position on the artboard is configured through the MAP View Editor — 
with many option for display, zoom, rescale, rotation, and so on.

MAP Attributes
The attribute table holds map attribute information for line, area and point data. Add and remove columns, edit 
schemas, join tables, calculate and apply expressions to customize map attributes. MAP Attributes are the base 
to many other MAPublisher tools (such as line functions, MAP Themes, and MAP Web Author). They can also be 
exported to text file for further usage.

MAP Themes
MAPublisher quickly and easily styles map features using Stylesheets, Charts and Dot Density themes. Specify 
rules and expressions to apply preset or custom symbols, graphic styles and character styles to artwork based on 
exisiting map attributes.

MAP Selections
Build, edit and apply multiple selection criteria based on the attributes and properties contained in MAP Layers 
using MAP Selections. Selection criteria are created in an expression builder and can be applied to any MAP layer, 
and can be saved so they can be edited or applied later.

MAP Measurement Tool
The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points), 
azimuths, and the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore, 
the measuring path can be converted to a line or area in the currently selected layer.
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Geometry Operations
Join lines or points and flip lines while keeping attributes intact. Use Simplify Line to reduce the number of vertices 
in a point (with preview and information on the number of filtered points). Create lines based on a series of point 
locations. Use Buffer Art to create buffer areas around line, area or point features.

Labeling
Create labels for map objects using values from the MAP Attributes panel. MAPublisher provides two methods of 
adding labels to your map: Label Features labels specified layers automatically; and MAP Tagger Tool labels features 
individually through user selection.

Register Image
Register images accurately to your vector data. MAPublisher determines the parameters of the raster image and the 
coordinate system of a selected MAP Layer in the registration process.

When no matching vector data is available, a new geographic frame (MAP View) can be created directly from the 
image reference file and by specifying a coordinate system (if required, format dependant).

Grids and Graticules
MAPublisher contains tools to easily create map grids and map indexes. Grids can be created for reference 
purposes, or to follow designated lines such as latitude and longitude, and can also be labelled for indexing. When 
a labelled grid has been established, MAPublisher is able to generate index files, containing the location of text 
objects in MAP Layers.

MAP Elements
Easily add customizable map elements such as scale bars, north arrows and map legends. Choose from preset 
designs or edit an existing one.

Split Layer
The Split Layer function splits a layer into new layers based on an expression or by unique attribute value. The 
qualifying features can either be copied or moved to a new layer, while maintaining all their attribute data.

MAPublisher License Management
The new MAPublisher License Management system helps users manage their licensing in a more streamlined and 
user-friendly manner. Users can now evaluate the product, register, retrieve their licenses and checkout a floating 
license, all in a single dialog box. Additionally, MAPublisher panels are now marked with a lock icon when the 
software is not licensed.
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What’s New in MAPublisher 8.4

MAP Themes
The former MAP Stylesheets has been completely revamped. Like the new name implies, MAP Themes creates dot 
density maps, charts and uses stylesheets to create choropleth maps. Use various classification methods to easily 
create data classes. In addition, create highly customizable MAP Theme Legends.

Web Feature Service and Web Map Service
Two new import features: Web Feature Service (WFS) and Web Map Service (WMS). Access these features through 
Simple or Advanced Import. WFS accesses web servers that deliver vector content in GML format. WMS access web 
servers that deliver raster content in a variety of formats.

Join Areas
A new geometry operation: Join Areas. It groups art objects based on a specified similar attribute value. An 
attribute field is defined and a new object is created for each unique value within that field. It can dissolve multiple 
areas into a larger area and still retain attributes.

Import Basic Personal Geodatabase (Mac)
The ability to import Esri Basic Personal Geodatabase is now available for Mac.

Import GPX and Microsoft Excel
Now import GPX and Microsoft Excel formats through the Simple and Advanced Import dialog boxes.

Import ArcGIS map documents
The ability to import ArcMap map documents (*.mxd) is now possible. Due to certain limitations, only the 
coordinate system, layer order and map data are retained when importing an ArcMap Document. Any styles, such 
as strokes, fills and patterns are not preserved.

Image Feature Type and Image Import
A new feature type called Image is introduced. It allows georeferenced images to be placed on it. In addition, 
Simple and Advanced Import now supports image formats which simplifies the process of importing them into an 
Adobe Illustrator document. 

Text Utilities
A new document operation: Text Utilities. It performs many text actions such as correcting upside down text, 
separating multiline text into single line and cropping text path to text length. These actions can be applied to 
either all text layers or specific text on a layer.

Right-to-Left Text
A new document operation: Right-to-Left Text. It is used to apply proper formatting to right-to-left languages such 
as Arabic and Hebrew.
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Geospatial PDF Layer Notes
Layer notes are now included when a geospatial PDF is exported.

MAP Contour Tagger Tool
A new MAPublisher Tool called MAP Contour Tagger can quickly draw labels for line features.

Create Knockouts
A new option to use clipping mask instead of an opacity mask is available.  Included to address an issue when 
exporting opacity mask to geospatial PDF or PostScript.

Scale Bar
A new option to customize labels is available. Override labels for units, scale ratio, map scale with custom text or use 
available text variables.

MAPublisher LabelPro
In the MAPublisher Preferences for MAP LabelPro, a new option merges multiline text into a single text object. In 
addition, MAP LabelPro dialog box settings can now be imported and exported.

MAP View Editor
A new Auto-Scale option scales layers to the extents of either the artboard or margins.

MAPubilsher Licensing
When an Internet connection is available and the current license is up-to-date, MAPublisher will automatically 
retrieve licensing information from Avenza servers to activate the software.

And many more enhancements...
Improved many dialog boxes, including Join Lines, Make Index Advanced, Specify Anchors and more.





15Chapter 1: Getting Started

Before using MAPublisher please read this section to ensure 
that you have a suitable hardware environment, are familiar 
with the installation and activation procedures, and have 
adequately prepared your system and workspace to make 
maps with Adobe Illustrator and MAPublisher 8..

Topics covered in this section:
System Requirements
Installation Instructions
MAPublisher Compatibility Notes
MAPublisher License Management
The MAPublisher Tools
The MAPublisher Toolbar
MAPublisher Preferences 
Preparing the Workspace

Getting 
Started
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System Requirements 

WINDOWS

•	 Adobe Illustrator CS4 / CS5

•	 Intel Pentium 4 processor (Intel Core 2 Duo or better recommended)

•	 Windows XP / Vista / 7 (compatible with 64-bit versions)

•	 2 GB of RAM minimum (4 GB of RAM or higher recommended)

•	 500 MB of available hard-disk space

MAC OS X

•	 Adobe Illustrator CS4 / CS5

•	 Intel processor (Intel Core 2 Duo or better recommended)

•	 Mac OS X 10.5 or higher

•	 2 GB of RAM minimum (4 GB of RAM or higher recommended)

•	 500 MB of available hard-disk space

Notes:	 Not all foreign language versions of Adobe Illustrator may be supported. Please contact support@avenza.com 
for more information. 
 
Installing MAPublisher on a system that does not meet the minimum requirements may produce unexpected 
results or errors. These issues may not be supported by Avenza Technical Support.

Before installing MAPublisher, please ensure that these minimum system requirements are met (recommended  
requirements are mentioned as necessary):
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MAPublisher is licensed for use on a single computer and, once activated, will be node-locked and will only function 
on that computer. Therefore, before proceeding with installation and activation, please ensure that MAPublisher is 
installed on the appropriate computer.

Different versions of MAPublisher can be installed on the same computer if different versions of Adobe Illustrator 
are present. For example, MAPublisher 7.6 for Adobe Illustrator CS2 and MAPublisher 8.4 for Adobe Illustrator CS5.

It is not recommended to do so, but different point releases of MAPublisher 8.x can be installed on the same 
machine. For example, MAPublisher 8.3 for Adobe Illustrator CS4 and MAPublisher 8.4 for Adobe Illustrator CS5. It is 
recommended to uninstall older versions of MAPublisher before installing the newest release. During the uninstall 
process, an option will be given to backup custom coordinates systems and MAPublisher LabelPro rules.

For users intending to use MAPublisher LabelPro, a system restart is recommended after installing MAPublisher. This 
ensures that included fonts are installed correctly.

WINDOWS

•	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe 
Illustrator is running, exit the program.

•	 DVD version: Insert the MAPublisher 8.4 DVD. If Autorun is disabled on the system, navigate to the 
MAPublisher 8.4 directory on the DVD, and double-click the Setup.exe file.

•	 Electronic version: Double-click the mp84wi-e.zip file to open the WinZip self extractor. When the files are 
unzipped, proceed to the MAPublisher directory and double-click the Setup.exe file.

•	 Proceed through the installation screens as instructed. Options are given to install documentation and 
tutorial data. If these components are selected, the files can be subsequently be found here: Start > All 
Programs > Avenza > MAPublisher 8 > MAPublisher Tutorials. 

•	 Launch Adobe Illustrator. Proceed to the section about Registration and Licensing.

MAC OS X

•	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe 
Illustrator is running, exit the program.

•	 DVD version: Insert the MAPublisher 8.4 DVD. Navigate to the MAPublisher 8.4 directory on the DVD, and 
double-click the Install MAPublisher 8.4 icon.

•	 Electronic version: Unstuff the mp84mi-e.dmg file if this operation has not been completed automatically. 
Then proceed to the MAPublisher 8.4 folder and double-click the Install MAPublisher 8.4 icon.

•	 Proceed through the installation screens as instructed. Note that documentation and tutorial data will 
also be installed. After installation, these files can be found in the Applications\Avenza\MAPublisher 8\
MAPublisher Tutorials . An Alias to this folder will be created at the end of the installation process which 
will be placed on the desktop.

•	 Launch Adobe Illustrator. Proceed to the section about Registration and Licensing..

Installation Instructions 
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MAPublisher Compatibility Notes 

MAPublisher 8.4 is compatible with Adobe Illustrator CS4 and CS5. Please read the following important 
compatibility information with respect to working with legacy MAPublisher and Adobe Illustrator documents.

BACKWARDS COMPATIBILITY

All MAPublisher documents are not backwards compatible with previous versions of MAPublisher. 

Saving the Adobe Illustrator document to an older version (e.g. saving a CS5 document as CS4) may have 
unexpected results, such as loss of data attributes. It is recommended to save a copy of the file in the current Adobe 
Illustrator version before attempting to save to a legacy version.

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data
MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents 
will have font based points converted to symbols on opening of the document. 

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Graticules
Grids and Graticules were redesigned in MAPublisher 7. Please note that grids created in previous versions of 
MAPublisher (6.x and earlier) will need to be recreated with the new tool if the generation of an index is required.

Legend to Stylesheet Conversion
Legend functionality (Assign Legend Info, Draw Legend etc) was ported into MAP Stylesheets in MAPublisher 7. 
Legend information held in legacy MAPublisher documents (6.x and earlier) will be converted into stylesheets on 
document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and 
Symbols (for point legends) will automatically be generated and added to the respective Adobe Illustrator panels.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:
•	 Be of a valid art type: i.e. polygon, path, symbol or text
•	 Have a legend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
•	 Have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:
•	 Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking 

this option will immediately apply the new stylesheets to map art on target layers, whereas unchecking 
this option means the new stylesheets will not be applied on document open, allowing you to manually 
drag target layers into the applicable stylesheet later. Note auto assignment conversions are slower.

•	 �Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature 
type and original map layer) into a single stylesheet. Note this option will be disabled if it is not 
applicable.

Tables
Table information held on table layers (i.e. MPTables layers) will be removed on document open. Therefore ensure 
that all tables have been joined to the vector art prior to opening the document in MAPublisher 8.
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ALL MAPUBLISHER DOCUMENTS IN ADOBE ILLUSTRATOR 10 (OR EARLIER) FORMAT 
Legacy Text Conversion
Adobe introduced new methods for dealing with text art in Adobe Illustrator CS. Therefore files containing 
MAPublisher text objects must be converted using Adobe Illustrator and MAPublisher text conversion utilities.

If the Adobe Illustrator legacy text conversion message appears when opening a legacy document, click OK. This 
will allow MAPublisher to use its own conversion utility to update text items while maintain the text attributes. If 
you click Update, the document will be opened, however all attributes associated with this text will be lost. 

At the MAPublisher Legacy Text Conversion dialog box, choose one of the following: 

All text art To convert both MAPublisher text and regular Adobe 
Illustrator text to the new Adobe Illustrator text format

MAPublisher text art only To convert only MAPublisher text to the new Adobe 
Illustrator text format

Nothing To open the file but lose attribute information 
associated with MAPublisher text elements
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MAPublisher License Management 

MAPublisher will not function until it is activated. MAPublisher is available in both single-user and floating license 
configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses 
that can be used and shared on any number of computers over a network. If you have purchased a floating license 
please refer to the floating license installation guide provided with your purchase. The instructions in this user 
guide are for the activation of single-user licenses of MAPublisher only.

IMPORTANT: Some peripheral components might interfere with the activation process. Before activating 
MAPublisher, users must temporarily unplug or disable: mobile phone, blue tooth, wireless or GPS systems. 
Laptop users with a docking station must activate MAPublisher in the undocked state.

After installing MAPublisher, launch Adobe Illustrator. The Welcome to MAPublisher dialog box will appear. When 
an Internet connection is enabled and the lastest license is valid, MAPublisher will automatically activate from 
information provided by Avenza license servers.

This screen also provides several licensing options: Evaluate, Register, Retrieve and Floating. 

Note:	 To continue to use Adobe Illustrator without MAPublisher, cancel this dialog box and activate MAPublisher 
license later by navigating to the Help menu in Adobe Illustrator and then to MAPublisher Licensing > License 
Management. MAPublisher panels are marked with a lock icon  when the software is not licensed.

MAPublisher welcome dialog box

MAPublisher License Management

Machine ID -  When moving or 
activating a license through 
the Internet or by e-mail, the 
computer's Machine ID here 
can be found here.

0022222c1111
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ACTIVATE AN EVALUATION VERSION OF MAPUBLISHER

1.	 After installation of MAPublisher, click the Evaluate button of the MAPublisher Welcome Screen or MAPublisher License 
Management dialog box. Complete the form and click Evaluate.

2.	 When you are ready to purchase the software you can open the MAPublisher License Management dialog box 
from Adobe Illustrator Help menu at MAPublisher Licensing > License Management, click Register button and 
follow the instructions in the next paragraph.

Note:	 A MAPublisher evaluation is fully functional. There are no limitations except that an evaluation license is only 
valid for 14 days from the day of activation.

REGISTER A PURCHASED COPY OF MAPUBLISHER

1.	 To register a purchased copy of MAPublisher, click the Register button in either the MAPublisher Welcome Screen 
or MAPublisher License Management dialog box. Enter the license key that was provided when the product was 
purchased. Complete the form and click Register.

Note:	 The license key for MAPublisher 8.x starts with "MP80-".

RETRIEVE YOUR MAPUBLISHER LICENSE

To retrieve an activated MAPublisher license, click the Retrieve button in either the License Management dialog box 
or Welcome Screen. The license file will be downloaded from the Avenza Systems licensing server.

CHECKOUT A FLOATING LICENSE
If you have purchased a floating license, please refer to the floating license installation guide provided with your 
purchase. Once the server license is fully operational, follow these instructions to checkout a license from the client 
machine (the computer running the actual MAPublisher application).

1.	 After installation of MAPublisher, click the Floating button of the MAPublisher Welcome Screen or MAPublisher 
License Management dialog box.

2.	 Enter the name or IP address of the server where the license manager resides.

3.	 Click the Checkout button to retrieve the one of the licenses from the server. 

Notes:	 If you wish to use Adobe Illustrator without MAPublisher, then click the Check in button from the MAPublisher 
License Management dialog box (at Help > MAPublisher Licensing > License Management). This releases the 
license, so other users can use it.

The link to the server is set once. The next time Adobe Illustrator is started, just click the Checkout button on 
the MAPublisher Welcome Screen or License Management dialog box.
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MAPUBLISHER LABELPRO LICENSING

MAPublisher LabelPro is an optional add-on to MAPublisher (8.1 and higher). Purchased MAPublisher LabelPro 
licenses are added to the main MAPublisher license. During the registration process described earlier in this chapter, 
all valid licenses will be imported. When purchasing a new MAPublisher LabelPro license on top of an existing 
MAPublisher license, the existing license key will be tagged to support MAPublisher LabelPro and the new license 
must be retrieved (see instructions earlier).

To evaluate MAPublisher LabelPro, open the MAPublisher License Management dialog box from the Adobe Illustrator 
menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher LabelPro branch and 
then click the Evaluate button as previously explained.

Click the Log button to see more system information about the license status.

The evaluation version of MAPublisher LabelPro scrambles the text of placed labels but preserves the case, spacing 
and punctuation. The results give a sense of how actual labels would be placed based on the rule settings. See 
chapter 17 for more details on MAP LabelPro functionality and usage. 

Note:	 MAPublisher and MAPublisher LabelPro can only be both floating licenses or both local licenses (fixed or 
evaluation). A user on a floating license wishing to evaluate MAPublisher LabelPro will have their main 
MAPublisher and MAPublisher LabelPro licenses switched to a local evaluation license. At the end of the 
evaluation period, the settings for floating license can be reset as described above.

MOVE A LICENSE

To move a previously activated license to a new computer, use the following steps:

1.	 Uninstall MAPublisher from the current computer.

2.	 Install MAPublisher on the new computer.

3.	 Obtain the machine ID for the new computer (as found in the MAPublisher License Management dialog box 
started from the Adobe Illustrator Help menu at MAPublisher Licensing > License Management.)

4.	 Complete the on-line form at http://www.avenza.com/support/rehost-license. For offline users, call tech support.
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LICENSE TROUBLESHOOTING

If you cannot register or retrieve an evaluation or purchased license from within MAPublisher (e.g. firewall 
limitations), visit the Avenza Systems website (www.avenza.com/activation) and provide the Machine ID displayed 
in the License Management dialog box. A zipped license file attachment will be sent to the registered email address 
on record. Unzip this attachment and save the .lic file to the appropriate folder:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8 
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In

To quickly access the MAPublisher license file directory, right-click a row in the License Management dialog box and 
click Browse to license folder. Copy or move MAPublisher license files directly into this location.

0022222c1111
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MAPublisher Tools
MAPublisher tools can be found in a number of locations in Adobe Illustrator. 

MAPublisher Import functions can be 
found in the File menu

MAPublisher functions can be found under the Object > MAPublisher menu.
The Edit MAP Object function can be found under the Object menu.

MAPublisher Preferences can be 
found in the Edit menu.

Edit MAP Object - for editing Scale Bars, Grids and Graticules  
(menu item name is adjusted accordingly)
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Seven MAPublisher tools can be found in the main Adobe Illustrator Tools panel.

Click tool icon and hold 
to open context menu to 
choose the related MAP 
Area and MAP Tagger tools.

The MAPublisher panels can be found under the Window > MAPublisher menu.

MAP Area Tool (box) MAP Area Tool (ellipse)

MAP Vector Crop Tool

MAP Measurement Tool

MAP Tagger Tool

MAP Location Tool

MAP Contour Tagger
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The MAPublisher Toolbar provides easy access to launch the MAPublisher tools and panels. The MAP toolbar is 
divided into seven sections: Import/Export, Geometry Operations, Labeling, Legends, Imaging, Document Operations and Panels.

	

Note:	 MAPublisher Toolbar cannot be saved in a workspace (Adobe Illustrator main menu Window > Workspace).

MAPUBLISHER IMPORT/EXPORT

Simple Import Advanced Import

Export Geospatial PDF

MAPUBLISHER GEOMETRY OPERATIONS

Buffer Art

Dash Offset

Flip Lines

Join Areas

Line Plotter

Simplify Lines

Join Points

Join Lines

MAPUBLISHER LABELING

Create Knockouts

Label Features

MAP LabelPro

MAPublisher Toolbar 
Window > MAPublisher > MAP Toolbar

MAPublisher  
Geometry Operations

MAPublisher
Legends

MAPublisher PanelsMAPublisher 

Imaging

MAPublisher
Document 
Operations

MAPublisher 
Import/Export

MAPublisher
Labeling



27Chapter 1: Getting Started
MAPublisher Toolbar 

MAPUBLISHER LEGENDS

North Arrow

Grids Graticules

Scale Bar

Make Index

MAPUBLISHER IMAGING

Register Image

MAPUBLISHER DOCUMENT OPERATIONS

Import MAP Objects

Split Layer

Text Utilities

Right-To-Left Text

MAPUBLISHER PANELS

MAP Attributes

MAP Themes

MAP Views

MAP Point Plotter

MAP Web Author

MAP Location Tool

MAP Selections
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MAPublisher Preferences
Edit > MAPublisher Preferences (Windows)
Illustrator > MAPublisher Preferences (Mac)

MAPublisher Preferences are options that allow users to customize MAPublisher panels and editors, including those 
for layer ordering, font for attribute data display and panel style. Settings are available for the following categories:

•	 Expression Builder
•	 General
•	 Import Map Data
•	 MAP Attributes (panel)
•	 MAP LabelPro
•	 MAP Location (panel)
•	 MAP Measurement

•	 MAP Selections (panel)
•	 MAP Themes (panel and editor)
•	 MAP Views (panel and editor)
•	 Spatial Database (Basic Esri ArcSDE 

Server Editor, Esri Geodatabase Editor 
and General Spatial Database Editor). 
Windows only.

MAPublisher Preferences are saved within the Adobe Illustrator preference file called AIPrefs (Windows) or Adobe 
Illustrator Prefs (Mac), which is launched each time Adobe Illustrator is started. Therefore, MAPublisher Preferences 
are not file dependent.

The Adobe Illustrator preference file is located in following directory:

Windows XP: C:\Documents and Settings\[user profile]\Application Data\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Windows Vista / 7: C:\Users/[user]\AppData\Roaming\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Mac OS X: Users/[username]/Library/Preferences/Adobe Illustrator CSX Settings/Adobe Illustrator Prefs

OPEN MAPUBLISHER PREFERENCES

MAPublisher Preferences can be opened from the Adobe Illustrator main menu, Edit > MAPublisher Preferences 
(Windows) or Illustrator > MAPublisher Preferences (Mac), from the panel options menu of the following MAPublisher 
panels: MAP Attributes, MAP Selections, MAP Themes and MAP Views, and by double-clicking the tools buttons: MAP 
Location and MAP Measurement.

When opened through the Adobe Illustrator menu, MAPublisher Preferences opens up with no category selected. 
When started from a specific MAPublisher panel options menu, MAPublisher Preferences open on the current panel 
property sheet. All preferences shown here are the default settings.

Property sheet specific to selected 
preference category.
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MAPUBLISHER PREFERENCES SETTINGS

Clicking one of the MAPublisher category or sub-categories on the left hand list displays the corresponding 
property sheet displayed on the right. 

Expression Builder Preferences
The Expression Builder property sheet shows the settings relative to the Expression Builder dialog box used with 
the MAP Attributes, MAP Themes and MAP Selections panels (see chapter 5 for more information).

Maximum unique values - Set the 
maximum number of unique 
values visible in the Expression 
Builder (Expression Components > 
Description).

The default value is 1000, users with 
high performance computers can 
increase this number.

Maximum recent expressions: - Set the maximum 
number recent expressions displayed in the  
Expression Library (Expression Components > 
Description). 

General Preferences
The General property sheet is used to change the layer ordering rule for all MAPublisher panels. By default, layers 
are sorted alphabetically only. The other option is to first group layers by data type first (Legend, Text, Point, Line 
and Area) and subsequently in alphabetical order for each group.

Sorting Style - Set to Name, then type 
for an alphabetical sorting. Set to 
Type, then name to first sort the layers 
per data type (Legend, Text, Point, 
Line or Area) 

Format numbers for labeling operations and 
display purposes based on locale  
Enable to format how number labels 
are displayed based on country (e.g. 
400.00 in USA compared to 400,00 
in Norway)

Locale - This option affects how 
MAPublisher formats numbers (e.g. 
use comma or point as a decimal 
separator). Use the operating system 
local settings or specify a different 
language and country.

Pinned map units - The selected map 
units are listed first in the unit 
drop-down lists of MAPublisher (e.g. 
in Scale Bar or Buffer Lines dialog 
boxes)

Max recent map units 
Maximum number of 
map units memorized 
by MAPublisher

Preview - Adjust the 
preview quality within 
various MAPublisher 
dialog boxes

Add notes for layers created by MAPublisher operations 
Enable to have layer notes created automatically 
when creating layer through MAPublisher 
operations (e.g. during import, plot centroid, 
buffer lines...).

Maintain point size/stroke weight/text size 
when rescaling - Scale changes (made 
in the MAP View Editor) that affect 
stroke, point and text sizes.
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Import Map Data Preferences
The Import Map Data preference category allows users to sort the order of the attributes columns upon import. 
By default, attributes are imported in the same order as in the source GIS data file and the MAPublisher #Property 
attributes are created in front of the imported attributes (see chapter 5 for additional information).

Attribute sort on import - Set to Do not 
Sort to maintain the attributes order 
of the source GIS file. Set to Order 
attributes alphabetically to apply this 
new ordering.

Property disposition on import - Set to 
Move properties to start or Move 
properties to end

Property corners - Set to Miter, Round 
or Bevel join

Property endings - Set to Butt, Round or 
Projecting cap

Append feature type as suffix on imported 
layer names - By default, the feature 
type is appended to the layer name 
(e.g. '_area' or '_point'). Clear this 
check box to prevent this behaviour.Ensure imported layer names 

are unique By default, 
MAPublisher appends a 
number 1, 2 etc... to an 
imported layer name if the 
layer name already exists. 
Clear this check box to 
prevent this behaviour.

Show extensions in Format drop-down list 
By default, the Format drop-down 
list in the Simple and Advanced 
Import dialog boxes shows the 
format extensions (e.g. '.shp'). Clear 
this check box not to display format 
extensions.

Show full file name in Advanced 
Import table - The Advanced 
Import table shows the list of 
selected files for import. By 
default, only the file name is 
displayed. Check this option 
to display the full path.

Show extents in Advanced Import 
table - Check this option to 
display the data extents 
(lower left and upper right 
corners coordinates)

Import Map Data > Web Services

WMS default output directory 
The default output directory 
for files generated by the 
Web Mapping Service 
import feature

WFS default output directory 
The default output directory 
for files generated by the 
Web Feature Service import 
feature

MAP Attributes Preferences
MAP Attributes Preferences

Replicate attribute data to compound path 
sub-components - Enable this option 
before editing the attribute schema 
so that the attributes do not get 
broken when releasing a compound 
path (see chapter 5)

Default string size - Specify the default 
string size applied when creating a 
new attribute of type  String

Default decimal count - Specify the 
default number of decimals applied 
when creating a new attribute of 
type  Real
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MAP Attributes > Panel Preferences

Table font – Set the text font for 
headers and attribute values

Show icons in column headers – Enable 
this option to display the data type in 
front of the attribute column name  
(  Boolean,  Integer,  Real, and

 String)

Table font size – Set the text font size

Show display names in column headers 
Enable this option to show the 
display name of a column header 
instead of the actual column name

Show recordset navigation – Enable this 
option to show navigation buttons in 
the MAP Attributes panel. Use them 
to scroll through attribute records.

MAP LabelPro Preferences
The MAP LabelPro preference category contains general settings to save the path access to saved rules, styles and 
symbol folders (see chapter 17 for more information on MAP LabelPro). 

Base rule folder – Directory path to the 
rule folder. Click the browse button 

 to open a folder browser and 
change the path.

Base style folder – Directory path to the 
style folder. Click the browse button 

 to open a folder browser and 
change the path.

Symbol folder – Directory path to the 
symbol folder. Click the browse 
button  to open a folder browser 
and change the path.

Ignore invisible artwork – Enable 
this option to ignore individual 
invisible artwork. If this option 
is disabled, individual invisible 
artwork will be taken into account 
as labelling source and obstacle.

Merge multiline text – Merges 
multiple lines of text into a 
single line

Note:	 The default directories for the rule, style and symbol folders:

•	 Default rules and styles folders—respectively Rules and Styles subfolders in the directory: 
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\.. 
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\.. 
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/..

•	 Default symbol folder: 
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols 
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols 
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols
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MAP Location Preferences
The MAP Location preference category does not contain general settings but has a sub-category for the MAP 
Location Tool panel (see chapter 4 for a full description of the MAP Location Tool).

MAP Location > Panel Preferences

Include latitude and longitude when copying 
coordinates - Enable this option to 
copy the positions in both projected 
(WX, WY) and geodetic coordinates 
(longitude, latitude) when using 
Shift+click in the MAP Location Tool 
panel (see chapter 4)

Lat/Long display format- Set the latitude 
and longitude display format:
•	 Decimal degrees 
•	 Delimited Degrees Minutes Seconds 
•	 Degrees.Minutes 
•	 Degrees.MinutesSeconds 
•	 Packed DMS with decimal point
•	 Packed DMS 

Display precision - Set the number of 
decimals shown on the MAP Location 
Tool panel

MAP Measurement Preferences

The MAP Measurement category contains display settings for the MAP Measurement Tool (see chapter 7 for details).

Display precision - Set the number 
of decimals shown on the MAP 
Measurement annotations

Line colour - Set the color of the 
digitized measurement path

Positive angle direction - Set the positive angle 
direction as either counter-clockwise or clockwise

Show azimuths - Display forward and reverse 
azimuth when using the MAP Measurement tool

New line colour - Set the color of 
the current segment (between 
last digitized point and current 
mouse position)

Units - Choose to use the current 
layer's units or select a specific unit in 
the drop-down list
Calculation Method - Choose to calculate 
distance based on datum (geodesic) 
or map projection (Cartesian)
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MAP Selections Preferences
The MAP Selections preference category does not contain general settings but has a sub-category for the MAP 
Selections panel (see chapter 11 for a full description of the MAP Selections panel).

MAP Selections > Panel Preferences

Show selections on two lines - Enable 
this option to display the selection 
filter name and its expression on two 
separate lines. 

	

MAP Themes Preferences
The MAP Themes preference category has a main property sheet and also contains a sub-categories for the MAP 
Themes panel (see chapter 9 for a full description of the MAP Themes editor and panel).

Log notification level – This option 
specifies what is recorded by the 
log. By default, Warnings & critical 
messages is chosen. If needed, 
choose No notification or Critical 
messages only.

Maximum features to use in Rule Generator 
This option specifies the maximum 
number of unique values that can be 
generated by the Rule Generator.

MAP Themes > Panel Preferences 

MAP Themes sort style – By default, 
the General sorting style is applied 
(option Use General preference). Set to 
Name, then type for an alphabetical 
sorting. Set to Type, then name to first 
sort the layers per data type (Legend, 
Text, Point, Line or Area).

Sort list using natural string comparison – 
Enable this option to use the natural 
sorting for layer and MAP Themes 
names using numbers (e.g. 1,2,10 
instead of 1, 10, 2)
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MAP Views Preferences
The MAP Views preference category does not contain general settings but has sub-categories for the MAP Views 
editor and panel (see chapter 4 for a full description of the MAP Views editor and panel).

MAP Views > Editor Preferences

Start centered on - By default, the 
current artboard is centered in the 
preview area of the MAP Views dialog 
box. Change the option to have it 
centered on the current MAP View.

Show Lat/Long ordering option 
Enable this option to show the 
Latitude/Longitude ordering  
drop-down menu in the MAP Views 
dialog box. This effectively swaps the 
order of how latitude and longitude 
values are shown.

MAP Views > Panel Preferences
Sort list using natural string comparison 
Enable this option to use the natural 
sorting for layer and MAP View 
names using numbers (e.g. 1,2,10 
instead of 1, 10, 2).

Show tool tips while dragging – When 
dragging a layer from one MAP 
View to another, a tool tip displays 
information on the destination MAP 
View. Clear this check box to prevent 
tool tips to be displayed. 

Show note indicators – When enabled, 
it displays the note icons next to the 
layer name in the MAP View panel



35Chapter 1: Getting Started
MAPublisher Preferences

Spatial Database Preferences
The MAPublisher Spatial Database preference category does not contain general settings but has three sub-
categories: Basic Esri ArcSDE Server Editor, Esri Geodatabase Editor and General Spatial Database Editor (see chapter 3 
for a full description of the MAPublisher Spatial Database).

Spatial Database > Basic Esri ArcSDE Server Editor Preferences

ArcGIS Bin Directory – Specify the 
location where the ArcGIS Bin 
directory is installed. Click the Browse 
button to open a folder browser and 
change the path.

Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list

Spatial Database > Esri Geodatabase Editor Preferences
Use alias as layer name – Enable this 
option to use feature class' alias 
name rather than its true name

Use abbreviated table name for layer name
ArcSDE geodatabases' tables 
are identified as databaseName.
userName.tableName. The 
abbreviated version uses only the 
table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.

Display coded domain/subtype description 
Option to import attributes with 
coded values from subtypes and 
attribute domains as follow: 
•	 Instead: replace the codes by their 

description (text)
•	 Never: import actual values—codes
•	 In Addition: create two attribute 

columns, one with coded values 
and one with descriptions

Load subtypes as separate layers 
Enable this option to use create 

new layers per subtype

Sort feature datasets alphabetically when 
selecting for import – Enable this option 

to sort feature datasets alphabetically 
in the import dialog boxes

Sort feature classes alphabetically when 
selecting for import – Enable this option 
to sort feature classes alphabetically 
in the import dialog boxes

Sort attributes alphabetically when 
selecting for import – Check this option 
to sort attributes alphabetically in the 
import dialog boxes

Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list
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Spatial Database > General Spatial Database Editor Preferences

Number of SQL queries to remember
Select the number of queries 
memorized in the Recent category

Number of default datasets to remember 
Select the number of default datasets 
saved in memory for later use

RESET MAPUBLISHER PREFERENCES TO DEFAULT SETTINGS

MAPublisher Preferences can be reset directly from the MAPublisher Preferences dialog box. A right click on a 
category will display the choice to reset the preference setting of this category or the entire MAPublisher Preferences.

MAPublisher Preferences will also be reset if the Adobe Illustrator preferences are reset or deleted. Adobe often 
recommends this to solve some problems with the application. Adobe Illustrator preferences are reset by doing one 
of the following:

•	 Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac) as Adobe Illustrator is starting. 
The current settings are deleted.

•	 Remove or rename the AIPrefs file (Windows) or Adobe Illustrator Prefs file (Mac). New preferences files 
are created the next time Adobe Illustrator is restarted.
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Preparing the Workspace 

Before using MAPublisher, you must first set up your Adobe Illustrator document. It is at this point that you define 
your page size and units, set your print orientation and generally prepare your Adobe Illustrator workspace.

Establish the desired page size and orientation before importing map data as MAPublisher will establish 
georeferencing based on the current page. However editing page dimensions after import will maintain correct 
georeferencing based on the new page dimensions.

Note:	 If no document is open, MAPublisher Simple and Advanced Import initiate the New Document dialog box.

SETTING UP A DOCUMENT

1.	 Create a new Adobe Illustrator document by selecting File > New, or Select File > Document Setup if you already 
have a blank document open - The Adobe Illustrator Document Setup dialog box appears.

2.	 Select the size to use for your page. Letter (8.5” x 11”) is the default size*. You may wish to change the 
orientation to landscape for some files. For example, a map of Chile may be best displayed in portrait but a 
map of Indonesia may be best displayed in landscape.

3.	 Select your desired page units. The default unit type is Points.

4.	 Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the 		
rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe Illustrator User Guide.

* In step 2 the default page size of 8.5” x 11” is for North American versions of Adobe Illustrator. Other language versions 
of Adobe Illustrator may have different default page sizes. Consult your Adobe Illustrator User Guide for more information.

Notes:	 Note that the maximum length and width dimension for an Adobe Illustrator document is 227.54 inches. 
 
Adobe Illustrator CS5 introduces a new function to Duplicate Artboard. This new function should be used 
with caution because it also duplicates art and moves it on the page, but the duplicated art reference is the 
same geographic frame as the original art (they are contained in the same layer). Therefore the geographic 
position of the duplicated art will not be correct. 
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MAPublisher 8 imports and exports many of the GIS industry 	
leading file formats.

Import Formats
AutoCAD Drawing/Exchange (*.dxf, *.dwg)
Digital Line Graph (*.dlg, *.opt)
Esri ArcInfo Generate (*.gen)
Esri Interchange File (*.e00)
Esri Shapefile (*.shp)
Esri ArcMap Document (*.mxd)
GML (Simple Features 2.0 +) (*.gml)
GPX GPS Exchange Format (*.gpx)
Images (multiple formats)
MapInfo Interchange (*.mif, *.mid)
MapInfo Table (*.tab)
Microsoft Excel (*.xls)
MicroStation Design (*.dgn)
Delimited Text Data (*.txt, *.csv, *.tsv)
KML (*.kml, *.kmz)
S-57 (*.000)
Spatial Data Transfer Standard (SDTS) (*.ddf )
TIGER/Line (*.rt1, *.bw1)
Web Feature Service
Web Map Service
Basic Esri ArcSDE Server
Esri ArcSDE geodatabase
Esri File geodatabase (*.gdb)
Esri Personal geodatabase (*.mdb)
Basic Personal geodatabase(*.xls)

Export Formats 
Adobe Geospatial PDF (*.pdf )
AutoCAD Drawing/Exchange (*.dxf, *.dwg)
Esri Interchange File (*.e00)
Esri ArcInfo Generate (*.gen)
Esri Shapefile (*.shp)
GML (Simple Features 3.1.1) 
MapInfo Interchange (*.mif, *.mid)
MapInfo Table (*.tab)
Microsoft Excel (*.xls)
MicroStation Design (*.dgn)
Delimited Text Data (*.txt, *.csv, *.tsv)
KML/KMZ (*.kml, *.kmz)

Map Data File 
Formats
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This section provides an overview of the supported formats. For an in-depth analysis of further considerations when 
using these formats during Import, please see appendix A1.

DATA FORMAT DESCRIPTIONS

Adobe Geospatial Portable Document Format (*.pdf)
Export only
The geospatial PDF is considered an Adobe Acrobat Portable Document Format (following the PDF 1.7 specification) 
that contains information that is required to georeference location data. It is an open specification developed and 
maintained by Adobe Systems. See detailed specifications in Section 8.3 at http://www.adobe.com/devnet/acrobat/
pdfs/PDF32000_2008.pdf.

AutoCAD Drawing (*.dwg) and Drawing Exchange (*.dxf)
Import and Export
These file types are most commonly created by Autodesk AutoCAD product, though other computer-aided design 
(CAD) programs such as Bentley MicroStation capable of creating them. Two formats are used by AutoCAD: DXF 
(drawing exchange format) files and ASCII representations of the binary DWG (drawing) files. Logically, both files are 
identical and MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and 
configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad 
support for many AutoCAD entity types and options. Prior to import, set the colour mode of the Adobe Illustrator 
document to the same scheme used in the colour table of the CAD file (RGB or CMYK) to ensure colours are 
imported correctly. Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, 
then line, then area layers. Annotation objects are converted to a point containing attribute information including 
the text value to be labeled and its angle. Certain symbols may import as "exploded" objects in MAPublisher. 

Digital Line Graph (*.dlg, *.opt)
Import only
The USGS (United States Geological Survey) DLG file structure is designed to accommodate categories of spatial 
data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute 
coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography, 

or political and cultural features, as well as additional thematic data categories.

Delimited Text Data (*.txt, *.csv, *.tsv)
Import and Export 
MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the 
data contains coordinate values. File types supported are Text (.txt), Tab Separated (.tsv) and Comma Separated 
(.csv) files. Import Settings dialog box: In order to import point data with MAPublisher the parameters must be set 
by clicking the Settings’ button. This operation is required to choose the columns of the selected attribute file that 
will be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further 
settings are discussed in chapter 6 and in the Delimited Text Data Settings section in appendix A1.

Import and Export Supported Data Formats 
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Esri ArcInfo Generate (*.gen)
Import and Export
ArcInfo Generate files are created by Esri ArcInfo product, and have a simple ASCII from x-y to x-y format. Due to its 
simplicity you can also use a text editor such as Notepad to create text files and save them with a *.gen extension, 
which can then be imported with MAPublisher. 

Esri Interchange File (*.e00)
Import and Export
Esri Interchange File files are created by Esri ArcInfo product. A single E00 file describes a complete ArcInfo 
coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and 
follow a predefined data format. MAPublisher will reproduce these sub files as distinct Adobe Illustrator layers on 
import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

Esri Shapefile (*.shp)
Import and Export
Shapefiles are most commonly created by Esri ArcGIS or ArcView. Shapefiles store both geometry and attributes for 
features, and a single shapefile will consist of at least three physical files: the .shp portion contains the geometric 
data, the .dbf contains attributes for the geometric data, and the .shx contains the index information. There is often 
a .prj file, which stores coordinate system information and is automatically read by MAPublisher on import. If a 
shapefile folder does not contain a .prj file, a coordinate system should be specified in MAPublisher. The important 
things to remember when importing shapefiles are that the .shp file must be the one that is selected through 
the MAPublisher import filter and that all its component files must be in the same folder. You may also find that 
a shapefile directory includes two extra files, a .sbn and a .sbx, which hold the spatial index for the geometric 
data. These two files will not exist unless the shapefile was created with an Esri product, and are not necessary for 
successful import with MAPublisher.

Esri ArcMap Document (*.mxd)
Import
ArcMap Documents (.mxd files) contain information describing the map, page layout, layers associated with it, 
and any objects inserted into the map. The MAPublisher Simple and Advanced Import are used to import ArcMap 
Documents. Due to certain limitations, only the coordinate system, layer order and map data are retained when 
importing an ArcMap Document. Any styles, such as strokes, fills and patterns are not preserved. In addition, to 
import ArcMap documents, at least ArcGIS 9.x must be installed.
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GML (Simple Features 2.0+) (*.gml)
Import and Export
The Geographic Markup Language (GML) was designed as a geographic interface language for the Geo-Web. It is 
currently in draft as an ISO standard (ISO 19136). The goal of the format is to provide users with a set of abstract 
base objects that can be built into working real world dataset. It uses an XML base to store geometry and feature 
information that can easily be transported across the Internet. 

The GML Simple Feature Profile was created by the Open Geospatial Consortium (OGC) as a restricted but useful 
subset of the GML specification. It provides a reduced geometry and metadata profile that can be shared across 
many GIS tasks. This simple feature model can be used as a base to generate local application profiles for a specific 
work area. Since the GML models base abstract classes, these application profiles (schemas) are required for 
accessing and processing any GML datasets. GML data has a *.gml extension, and requires a attributes schema file 
*.xsd. Some GML files may have their .xsd file referenced to a URL path, we recommend to copy the xsd files locally, 
to avoid error messages upon import when no internet connection is available. 
Users have two options to store their .gml and .xsd files: they can be both located in a same directory or the xsd files 
can be kept in the MAPublisher GML Schema directory found here:

Windows XP, Vista and 7: C:\Program Files\Avenza\MAPublisher 8\Data Source Files\GMLSchema
Mac OS X: /Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files/GMLSchema

The second option is the most practical if all the GML files are using a same schema (only one instance of the XSD 
file needs to be saved). Installed with MAPublisher are three default XSD files: 

•	 xml.xsd, generic GML attribute schema. 
•	 nen3610.xsd and top10nl.xsd, models standardized in the Netherlands (maintained by the Dutch 

topographic office Kadaster). 

GML files with a missing XSD file or with an invalid attribute schema will cause a GML validation error upon import 
(see chapter 3). Users have the option to find the appropriate XSD file and copy it to the GML Schema directory or 
to the GML file directory. This option will assign a type string to all attributes. See chapter 3 Importing Map Data for 
more details on these settings. 

MAPublisher supports the import of simple features (points, lines, polygons, donuts, and aggregates) in GML 2.0 
and later versions. MAPublisher supports export to GML 3.1.1. 

KML/KMZ (*.kml, *.kmz)
Import and Export
Keyhole Markup Language (KML) is an XML-based language for managing the display of three-dimensional 
geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies 
a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt, 
heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed 
as KMZ files, which are zipped KML files with a .kmz extension. MAPublisher imports and exports both file type 
based on the KML version 2.2 specifications.
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GPS Exchange Format (*.gpx)
Import only
GPS Exchange Format (GPX for short) is a light-weight XML-based data format designed for the interchange of GPS 
data. MAPublisher supports GPX schema version 1.1. 

Image (*.png, *.jpeg, *.jpg, *.jpe, *.tif, *.tiff *, *.gif, *.jp2, *.jpf, *.jpx, *.j2k, *.j2c, *.jpc, *.psd, *.pdd, *.bmp)
Import only
Referenced raster files of the above mentioned formats can be imported and placed directly into a MAPublisher 
MAP View from the Simple and Advanced Import tools. These images have the option to be linked or embedded 
into Adobe Illustrator upon import. Images cannot be reprojected by MAPublisher in Adobe Illustrator. Use 
Geographic Imager or another third-party software to properly reproject geospatial images.

MapInfo Interchange (*.mif, *.mid)
Import and Export
Files of this type are most commonly created by the MapInfo product, though other products, including 
MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same 
name but ends in either a .mif or .mid file extension. The .mif portion contains the vector geometric data, and the 
.mid contains the associated attributes. Both files are required in order to successfully import a file of this format to 
Adobe Illustrator using MAPublisher. The important things to remember when importing MapInfo files are that the 
.mif file must be the one that is selected through the MAPublisher import filter and that both files must be in the 
same folder. MAPublisher will automatically locate and deal with the .mid file. 

MapInfo Table (*.tab)
Import and Export
The TAB format is a simple, non-topological format for storing the geometric location and attribute information 
of geographic features, and is an integral part of the MapInfo product. The TAB format defines the geometry and 
attributes of geographically-referenced features in several files with specific file extensions that are stored in the 
same folder on disk. They are:

.tab: main file, table structure in ASCII format.

.map: the file that stores the feature geometry.

.id: the file that stores the index of the feature geometry.

.dat: the dBASE file that stores the attribute information of features.

.ind: table field indexes (if necessary)
The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each 
feature are stored as a record in a dBASE table (.dat) associated with the Shapefile (.map). There is one record in the 
dBASE table for each feature in the map file. Raster TAB files cannot be imported in MAPublisher.

To ensure successful import, select the .tab component in the MAPublisher importers.
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Microsoft Excel file (*.xls) 
Import and Export 
Import geographic point data from an Excel spreadsheet (version 2007 and earlier only; *.xlsx is not supported) 
that contains latitude and longitude entries for each row.  In order to import point data, click the Settings button in 
the Import dialog box to choose which columns will be used to as the X and Y coordinates of the data, and ensure 
correct georeferencing. Further settings including other types of are discussed in Appendix A1.

MicroStation Design (*.dgn)
Import and Export
MicroStation Design files (.dgn) are the native files created by Bentley Systems Inc. (and formerly Intergraph) 
MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global 
information including the transformation equation from design units to user coordinates, as well as the dimension 
of the elements in the file. Each element contains standard display information, such as its colour, level, class, and 
style, as well as a number of attributes specific to its element type. During the import process, MAPublisher will 
produce one layer for each Level that exists in the MicroStation Design File. Annotation objects are converted to a 
point containing attribute information including the text value to be labeled and its angle.

MAPublisher supports the import of MicroStation J (version 7 and 8) files, however attached raster file will not 
be imported (ignored). Prior to import, the colour mode of the Adobe Illustrator document should be the same 
scheme used in the colour table of the original file to ensure that the colours are interpreted correctly.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point 
layers, then line layers, then area layers. Raster files attached to DGN files are ignored during the import process.
Files are exported from MAPublisher as MicroStation J files. Upon export, users may select a DGN seed file. All 
information  in the seed file gets carried over to the output file, such as level (layer) definitions, units, colors, line 
styles definitions, etc. If an exported layer name matches a level name in the seed file, the data of that layer is 
appended to the existing level, if not, a new level is created. 

S-57 (*.000)
Import only
S-57 is referring to the IHO (International Hydrographic Office) Special Publication number 57 related to the IHO 
transfer standard for Digital Hydrographic Data . Maintained by the IHO, S-57 format is intended for the exchange of 
digital hydrographic data between national hydrographic offices and for its distribution to manufacturers, mariners 
and other data users. It is used for the supply of ENC cells (Electronic Navigational Charts) to ECDIS (Electronic Chart 
Display and Information System). The objects spatial geometry can be of Point, Line or Area geometry, while object 
descriptions are categorized in object classes, organized in specific attributes schemas. To make full use of this 
format, refer to the online object catalog available on www.s-57.com.

MAPublisher imports non-encrypted S-57 data into MAP layers named per S-57 object acronym, of type Area, Line 
or Points. All S-57 Attributes are converted into MAP Attributes.

An Adobe Illustrator template is supplied to automatically style the map after import. The template contains a series 
of MAPublisher stylesheets linking S-57 imported features to nautical symbols and graphic styles (libraries provided 
by Avenza). This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 
format to interpret the data contents more easily. The S-57 template and the symbols and graphic styles libraries 
can be found in the MAPublisher Helpful Styles & Symbols folder (see Appendix 4).
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Spatial Data Transfer Standard SDTS (*catd.ddf)
Import only
Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are 
generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the catd file 
(xxxxcatd.ddf ), which is the index file that contains a description of the other files in the SDTS transfer. Individual 
DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

TIGER/Line (*.rt1, *.bw1)
Import only
TIGER is an abbreviation of Topologically Integrated Geographic Encoding and Reference System, and was developed 
by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads, 
rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The 
database contains information about these features such as their location in latitude and longitude, the name, the 
type of feature, address ranges for most streets, the geographic relationship to other features, and other related 
information. TIGER/Line files are the public product created from the Census Bureau TIGER database of geographic 
formation. TIGER was developed in order to support the mapping and related geographic activities required by the 
census and sample survey programs. More information on the TIGER/Line file format and data product can be found 
on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the .rt1 or .bw1 file as the TIGER dataset. Even though each county will consist of a series 
of files with a common base name, there may be a number of different extensions. Remember to select the .rt1 or 
.bw1 file when importing TIGER data. 

Web Feature Service
Import only
Web Feature Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS vector 
data transactions across the Web. The MAPublisher WFS import connects to servers that use versions 1.0.0 and 1.1.0 
of the OGC standard. WFS servers provide GML files, which are read using the MAPublisher GML importer. The GML 
importer supports the GML simple features 2.0+ profile. 

As the WFS importer is read-only, WFS-T is not supported. See Web Feature Service in Chapter 3 "Importing Map 
Data" for information on WFS parameters.

Web Map Service
Import only
Web Map Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS raster data 
transactions through http protocol. The MAPublisher WMS import connects to servers that use version 1.1.1 of the 
OGC standard. WMS data formats include .png, .jpg, .tif, and GeoTIFF. See Web Map Service in Chapter 3 "Importing 
Map Data" for information on WFS parameters.
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Basic Esri ArcSDE Server†

Import only
ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise.  The Basic 
Esri ArcSDE Server import option allows users who have a free Esri desktop application called ArcReader to import 
feature classes from ArcSDE geodatabases, but with some limitations on the selection functions — see chapter 3 for 
more information on spatial databases.

† Basic Esri ArcSDE Servers are not supported on Mac due to limitations of the related Esri libraries.

Esri ArcSDE Geodatabase†

Import only
ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Esri 
ArcSDE geodatabase import option allows users who have ArcGIS software and a valid license to import all ArcSDE 
geodatabase types with advanced options for the selection — see chapter 3 for more information on spatial 
databases.

† Esri ArcSDE geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri File Geodatabase† (*.gdb)
Import only
A File geodatabase is a native Esri single-user spatial database. It is a collection of various types of GIS datasets held 
in a file system folder. This is the recommended native data format for ArcGIS. Importing this format requires ArcGIS 
software and a valid license — see chapter 3 for more information on spatial databases.

† Esri File geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri Personal Geodatabase (*.mdb)
Import only
A Personal geodatabase is a native Esri single-user spatial database. This is the original data format for ArcGIS 
geodatabases stored and managed in Microsoft Access data files. Importing this format requires ArcGIS software 
and a valid license — see chapter 3 for more information on spatial databases.

† Esri Personal geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Basic Personal Database Reader (*.mdb) (Mac Supported)

Import only
The basic personal geodatabase reader can import basic feature class geometries and attributes on systems that 
do not have an Esri license. This makes it possible, for the first time, to open .mdb on Mac systems. The basic reader 
provides limited import capabilites supporting geometries and attributes not annotations or subtypes. Spatial 
Filters can be specified and SQL queries are supported on PC only.�
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OTHER SUPPORTED FILES

MAPublisher also supports Adobe Illustrator (*.ai) files created by Cartographica, a third-party GIS software.
Cartographica users who wish to use files in MAPublisher must check the Include data in export option during export.

MAPublisher reads Adobe Illustrator files exported by Cartographica and extracts the geospatial information to 
convert it into layers and MAP Views—including projection, map scale and page position. However, there may be 
limitations when working with these files and it is recommended that they be saved as Adobe Illustrator CS4/CS5 
files (this is required before exporting to geospatial PDF).

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor, 
government office or from a source within your organization, there are a number of important considerations to 
keep in mind.

First and foremost, obtain data in one of the formats supported by the MAPublisher. In cases where the file format 
native to a particular mapping application is not supported by MAPublisher, you can often request the data 
provider to export a file in one of the supported formats.

When obtaining data you should acquire as much metadata about the files as possible. MAPublisher deals with 
data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map 
anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90. 

If you receive projected data you should be aware of the following. MAPublisher will import projected data 
with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/
long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name 
of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this 
information in the data, and you wish to subsequently reproject your data, you will be required to specify the 
coordinate system.

Additionally, please be aware that MAPublisher is a 2D mapping program. Therefore if you attempt to import 3D 
data with MAPublisher it will be converted to two dimensional artwork by the importers. Data provided in a generic 
latitude and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic 
System 1984 - EPSG = 4326) coordinate system by the MAPublisher importers.
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The Import functions are the starting point for most users 
wanting to work with GIS map data in Adobe Illustrator. These 
functions are used to import GIS data, set the initial map scale 
and define your cartographic workspace to start making maps.

The topics covered in this section:
Simple Import
Advanced Import
Web Feature/Map Service
Spatial Databases

See chapter 2 for detailed descriptions of formats that 
MAPublisher can import.

Importing 
Map Data
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Coordinate System Information - This 
area shows information about the 
coordinate systems. (i.e. Name, 
Type, Envelope, EPSG Code). To 
choose a known source coordinate 
system select it from this list.

Search - Click this button and your 
search results will be populated

Simple Import 
File > Import Map Data > Simple and MAP Toolbar 

Format - Select the data type you 
wish to import. This drop-down list 

shows the names of all MAPublisher 
supported data types.

Dataset - Displays the directory 
path and filename for the currently 

selected file(s). You can also 
manually type in the dataset 

location here.

Settings - Opens a Settings dialog box 
if the file format requires the input 
of extra parameters, such as for the 
import of DGN, DXF, DWG, E00, GML, 
KML, MIF/MID, Tab and Delimited 
Text Data (see facing page).

Browse - Opens a Data Source 
browser to enable the selection of 
files for import.

Character Encoding - Assign a codec if 
the attribute information held in the 
selected dataset uses a double byte 
character set.

Specify - If the coordinate system of the 
selected file(s) is known, but it was not 
automatically detected by the program, 
click here. This will open the Specify Source 
Coordinate System dialog box (below).

Source Coordinate System - Provides 
a description of the coordinate 

system and units detected in the 
data source.

Specify Source Coordinate System

Coordinate Systems - Choose a 
category appropriate to the 

data to be imported. To view 
all of the coordinate systems 

select *All*. For a list of the 
last 10 coordinate systems 

used, select *Recent*.

Search - Specify a text string 
to search the database 
for coordinate systems. 

Results are displayed in the 
*Search* category.

RELATED TOOLS

Accessed via the Specify button.

Clear - Click this 
button to clear the 
existing source 
coordinate system.

View Coordinate 
System Information 
Click to view 
more information 
about the current 
coordinate system

Same as - Check this option in 
order to assign a coordinate 

system that matches that of an 
existing MAP View.

Dataset Coordinate Systems
Automatically opens if multiple datasets have been selected and they do not have a matching coordinate system.

Dataset - List of all the datasets 
selected for import

Coordinate System - List the coordinate 
system of each individual dataset
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White Lines and Fills - Set the option:
•	  Import as is: import the data 

true to the original colour 
settings contained in the file. 

•	 Change white lines and fills 
to black: import black lines 
instead of the files native 
white lines.

•	 Create black background: 
incorporate a layer containing 
a black background, to mimic 
the AutoCAD environment.

Group Entities - Group entities by layer 
name or geometry

Read Hatches - Check this box to read 
the hatch pattern on import

AutoCAD DXF/DWG Settings

Add to - Add the incoming data file to a 
matching MAP View

Fit to page based on new MAP View - Create a 
new MAP View for the imported data. 

Existing data and incoming data will be 
treated separately in terms of page scaling 

and position

Matching MAP View

MAP View list - Select the matching coordinate 
system that you wish to align the incoming 
data to.

Resize MAP View to fit - Check this box to rescale the 
matching data so that both the selected layer and 
the incoming data fit inside the page extents.

Automatically opens if there is already a coordinate system in your document which matches the incoming data.

Delimited Text Data Settings

Latitude/Longitude or X/Y Columns - These two drop-down lists 
hold the names of all the numeric columns in the selected file. 
Select the columns containing the coordinate information.

Use first line as a header - Check this box if the first 
line of the text file contains column headings.

Coordinate Format - Select the coordinate format of the data to be 
imported (e.g. Decimal Degrees, Packed DMS... see chapter 6).

X-Y Coordinate Ordering 
Change the order of 
X and Y coordinates. 

This may help 
when an external 

program exports X-Y 
coordinates in reverse.

X-Y Coordinate Ordering 
Change the order of 
X and Y coordinates. 

This may help 
when an external 

program exports X-Y 
coordinates in reverse.

GML (Simple Features 2.0+) Settings Web Feature Service Settings

IMPORT SETTINGS
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KML/KMZ Settings

Image Settings

Allow Random Colour Mode   
Enable this option to 

generate random colour 
settings for the data

Expand Network Links 
Enable this option to 

use of network linked 
KML files

Image placement  
Embed the image 

into the document 
or Link to it. Please 

see note about 
transparency.

Import KML properties as visible attributes - Enable 
this option to import KML-specific attributes 
into the MAP Attributes panel as visible 
entities. When this option is disabled, these 
KML attributes are imported but are hidden 
in the MAP Attributes panel

The KML attributes are Description and 
Address which are displayed  in the MAP 
Attributes panel as kmlDescription (object 
description) and kmlAddress (object address). 

Complex Chains - Component 
of a complex chain returned 

as its own feature. Otherwise 
all elements of the complex 
chain will be merged into a 

single linear feature.

Ignore tags on import - Ignores 
any tags on import so that it 

does not affect spatial extent.

Create groups for like text 
Text in the same graphic 

group or the same text node 
will be grouped in Illustrator

Group Elements - Choose how 
to group the elements. If 
elements are grouped by 

level, it may result in a large 
number of output files.

Coordinate Units - Specifies how 
feature coordinates will be 
interpreted and converted.

MicroStation Design Settings

White Lines and Fills - Set the option:
•	  Import as is: import the data true to the original 

colour settings contained in the file. 
•	 Change white lines and fills to black: import black 

lines instead of the files native white lines.
•	 Create black background:. incorporate a layer 

containing a black background, to mimic the 
Microstation environment.

Ignore TIC Layer - Enable 
to suppress creating of 

_tic_point layer. Disable to 
create a layer holding the 

registration control points. 

Esri Interchange File Settings

Pen and Brush Patterns 
Enable this box to 
view the pen and 

brush pattern values 
in the imported 
attribute table.

MapInfo TAB and MIF/MID Settings

Basic Esri ArcSDE Server, Esri ArcSDE Geodatabase, 
Esri File Geodatabase and Esri Personal Geodatabase

Unicode database - Unless specific issues 
importing converted geodatabases, 

keep this option as default. 

Use locale to decode - This option might be 
required if the geodatabase was created by 
converting a file in a format not supporting 
unicode (e.g. Esri shapefile) and if it contains 
non-ASCII characters.

Locale - Specify the locale name (e.g. en-US), 
leave it as 0 to use the locale of the current 
machine.

Note:	 These are advanced settings. Contact Avenza Technical Support (support@avenza.com) for assistance.

Prepend feature dataset name to layer name 
Select this option to prepend feature 

dataset names to layer names. 
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SIMPLE IMPORT FUNCTIONALITY

The Simple Import function provides a fast, uncomplicated method of importing map data into Adobe Illustrator. Its 
purpose is to import a single piece of map data or several files sharing the same format and coordinate system.

PREREQUISITES

Use Simple Import either before or after an Adobe Illustrator document is created. If no document is open, Simple 
Import will initiate the New Document dialog box.

MAPublisher will interpret the artboard dimensions during the import process, and calculate a map scale for the 
document accordingly. If the document size is changed in the Adobe Illustrator document settings, the scale will 
have to be recalculated using the MAP View Editor (see chapter 4 for more information). Remember, a map of the 
world would fit well into a page with a landscape orientation, whereas a map of South America would fit best into a 
page with a Portrait orientation. 

Some import options are specified in the MAPublisher Preferences Import MAP Data category, such as attribute order, layer 
naming convention or display of extents in the import dialogs. For a full description, please refer to chapter 1 on 
MAPublisher Preferences.

USING SIMPLE IMPORT

The MAPublisher Simple Import function is accessed from the Adobe Illustrator menu File > Import Map Data > 
Simple Import or from the MAPublisher toolbar button .

Overview
The dialog box itself is split into two sections. The upper section provides options to choose a file format, select 
the dataset to import, and choose any additional settings that may be required. The lower section displays the 
coordinate system of the selected file (if available) and provides an option to specify one manually.

Adding Files
First specify the format of the file to be imported. Set the Format drop-down list as <Auto detect format> or to a 
specific format. With the <Auto detect format> option, all supported GIS files will be displayed in the browser. 
Choosing the required format directly is recommended to ease navigation.

Once a format has been selected, click the Browse button to select the file(s) to be imported and then click Open. 
Alternatively type in the full path of the file(s) in the Dataset text box. Only files in a same format and sharing the 
same coordinate system can be imported at once with the MAPublisher Simple Import dialog box.

Notes:	 The import of multiple Delimited Text files is not supported.
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Source Coordinate System
Once the Dataset text box has been populated with a valid path, MAPublisher will read the file(s) to determine if a 
valid coordinate system can be found and will display it in the Source Coordinate System section.

If the program returns the message [No Coordinate System Specified] for the coordinate system, click the Specify 
button to specify it. In the Specify Source Coordinate System dialog box, coordinate systems are separated into categories 
(geodetic or projected) to ease the process of choosing a coordinate system: under the Coordinate System category 
*All* will list all the coordinate systems in the database. For an overview of Geodetic and Projected systems and 
Datums see appendix A2. To view the parameters of a certain coordinate system, click the Info button. 

Character Encoding
Extended and international character sets are supported as attributes on import. To assign a character codec 
suitable for your selected dataset, choose the appropriate value from the list box.

Format Specific Settings
Certain file formats offer additional configuration parameters which can be accessed by clicking the Settings button. 
These file formats are Esri Interchange File, Esri geodatabases (ArcSDE, File and Personal), CAD DWG/DXF, MicroStation DGN, MapInfo 
MIF/MID, MapInfo TAB, KML/KMZ, Delimited Text Data* and GML. After selecting a file, if the format accepts additional 
settings, the Settings button will be enabled. See the import settings in this chapter for an overview of the meanings 
of these options.
*Additional Settings are mandatory only for importing Delimited Text Data.

Delimited Text Data Settings
MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values.  
MAPublisher supports the following delimiters between data values: comma, return, end-of-line and tab.

To import delimited text data, first specify the Format: Projected Units, Decimal Degrees, Delimited Degrees Minutes 
Seconds, Degrees.Minutes, Degrees.MinutesSeconds, Packed DMS with decimals and Packed DMS (see chapter 6, for 
more details). In the Coordinate Columns, specify the fields in the source file that contains the coordinate information. 
The caption of the fields display Longitude and Latitude or X and Y, depending on the selected format.  If the first line 
of the text file contains column headings, check the Use first line as a header option, although MAPublisher generally 
detects it automatically. If the file does not appear to contain column headers, MAPublisher will assign the default 
headers Column1, Column2 to the attribute columns on import.

Importing Data
Once the files are selected and settings specified,  click OK to start the import process.  If the Adobe Illustrator 
document contains a MAP View with a coordinate system matching the incoming data, the Matching MAP View dialog 
box will open with the following options:
•	 Add to: choose the MAP View from the drop-down list in which to add the incoming data. Check the option Resize 

MAP View to fit to rescale all the data (existing and incoming) to fit on the artboard. If this option is not checked, 
the imported data may fall outside the page extents

•	 Fit to page based on new MAP View: the incoming data will be treated separately from the matching data, as if it was 
the first import. The incoming data will overlap with the existing data, use the MAP View Editor to rescale and 
move the data on the page (see chapter 4 on MAP Views). 
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RESULTS

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information. 

Notes:	 When importing data exceeding the allowable 32,000 points per path in Adobe Illustrator, MAPublisher 
automatically simplifies the imported object and shows the following warning message: 

The simplification algorithm compares points in a line or polygon in groups of three.  When the shortest 
segment is found, the center point is removed, and the total segment distances are recalculated.  This 
removal process continues until the maximum allowable number of points is reached.
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Advanced Import 
File > Import Map Data > Advanced and MAP Toolbar 

Add - Allows the selection of 
files for import by opening the 
Advanced Import Data 
Source function (see below).

Remove - Removes selected 
files from the list

Edit - Allows editing of the 
selected file by re-opening 
the Simple Import Data 
Source function (see below)

Format - Select the data type 
you wish to import. This 

drop-down list shows all 
MAPublisher supported data 

types.

Dataset - Displays the directory 
path and filename for the 

currently selected file(s). You 
can also manually type in the 

dataset location here.

Source Coordinate System - This 
section allows the manual 

selection of the coordinate 
system if this information is 
not held in the data source. 

Same as - Check this option in 
order to assign a coordinate 

system that matches that of an 
existing MAP View

View Coordinate System Information 
Click to view the parameters of 

a selected coordinate system

Advanced Import Data Source

Import Settings
See the Simple Import various Import Settings dialog boxes and options.

Settings - Opens Settings dialog box 
for file formats that requires the 
input of extra parameters, such as 
for the import of DGN, DXF, DWG, 
E00, GML, KML, MIF/MID, Tab and 
Delimited Text Data (see chapter 2).

Browse - Opens a Data Source 
browser to enable the selection of 
files for import.

Character Encoding - Assign a codec 
if the attribute information held in 
the selected dataset uses a double 
byte character set.

Specify - Click to open the Specify 
Source Coordinate System tool 
(see Appendix 2), enabling you to 
search for coordinate systems by 
specifying a text string. Results are 
displayed in the *Search* category.

Clear - Click to clear the existing 
parameters of the source 
coordinate system.

Destination MAP View

New based on - Imports all 
of the files to one of the 

coordinate systems in the 
File List

Use existing - Allows users 
to import all of the files in 
a coordinate system that 

already exists in a MAP View 
in the document

Auto scale - If multiple files are 
present in the File List, and 

New Based On or Use Existing 
is selected, check this box to 

ensure the imported artwork 
fits inside the page extents

RELATED TOOLS

Accessed via the Add or Edit button in Advanced Import.

Create new - Allows users to import all 
of the files in a new coordinate system. 
Click the Editor button to open the MAP 
View Editor (see chapter 4).

Coordinate System - coordinate 
system of the data source

Data Source - Map file(s) to be 
imported (full path or just 
file name depending on 
MAPublisher Preferences - see 
chapter 1).

Features - Number of objects to 
be imported

(if enabled in Import MAP Data 
MAPublisher Preferences).
Extents - Displays the lower 
left (LL) and upper right 
(UR) coordinates (XY) of the 
dataset extents.

File List - This is a table 
where all files selected for 

import are listed

Details - Displays details of currently 
selected file: Coordinate System, Unit, 
Page Anchors, Scale, Map Anchors 
and Rotation.
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ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe Illustrator. This function can 
import files in multiple formats and coordinate systems. All files flagged for import are displayed in the dialog 
box with information relative to their coordinate system. All imported files are reprojected to match a selected 
coordinate system. 

Note:	 Advanced Import is recommended when importing data that will require a coordinate system 
transformation that implies redrawing and path divisions (e.g. world data reprojected from European to 
North American aspect). Applying a coordinate system transformation during Advanced Import allows 
MAPublisher to split paths during transformation, which is not possible at a later stage. Divided paths are 
grouped as compound paths.

PREREQUISITES

Use Advanced Import either before or after an Adobe Illustrator document is created. If no document is open, 
Advanced Import will initiate the New Document dialog box. Please refer to the Simple Import Prerequisites section 
in this chapter.

USING ADVANCED IMPORT

The MAPublisher Advanced Import is accessed from the Adobe Illustrator menu File > Import MAP Data > Advanced 
Import or by clicking the MAPublisher Toolbar button  . 

Dialog Box Overview
The top part of the Advanced Import dialog box provides a list of the selected files, their coordinate system 
information and the number of features they contain. The bottom part of the dialog box refers to the Destination 
MAP View settings.

The Add and Edit buttons open a dialog box similar to the Simple Import dialog box. Please refer to the previous 
section for information on the Character Encoding, Format Specific Settings and Delimited Text Data Settings.

Note:	 The dialog box displays the file name or the full path of the selected files depending on the settings specified 
in the MAPublisher Preferences for Import MAP Data (see chapter 1). Users can also choose to display the 
geographical extents of the file.

Adding Files
Click the Add button to select one or more files that share the same format and coordinate system. The Add dialog 
box is similar to the Simple Import dialog box, please refer to previous section for more information. Click OK to add 
the files to the Advanced Import list.

To import more files in a different format or coordinate system, use the Add dialog box again, as often as necessary.
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Advanced Import File List
All selected datasets are listed in the Advanced Import dialog box. Listed features include the filename, the specified 
coordinate system and the number of features contained in the dataset.
Click a row in the file list to select a dataset. Then, click Remove to remove the dataset or click Edit to change the 
import parameters. The Edit dialog box provides the same options as the Add dialog box where users can modify 
the access path, settings or source coordinate system.

Note:	 It is not possible to import multiple files with a mix of unknown and known coordinate systems. Therefore 
the unknown coordinate systems will need to be specified before import.

Destination MAP view
Although the Advanced Import allows users to import files with multiple source coordinate systems, they have to 
be imported into a single coordinate system. This information is stored in the Destination MAP View section (for more 
information on MAP Views, please refer to chapter 4).

Users have three options to select the coordinate system of the Destination MAP View.

•	 New based on option: choose the coordinate system of one of the files selected for import. 
•	 Use existing option: if the Adobe Illustrator document already contains map data, choose the MAP View with the 

desired coordinate system from the list of existing MAP Views in the document

With these two options, check the option Resize MAP View to fit to rescale all the data (existing and incoming) to fit on 
the artboard. If this option is not checked, the imported data may fall outside the page extents

•	 Create new option: specify the parameter for a new MAP View. Click the Editor button to open the MAP View Editor. 
In the Destination Source Coordinate system section, click the Specify button to select a coordinate system from a 
large list of existing system or to create a custom one. The MAP View Editor is explained in depth in chapter 4, in 
brief it allows for the edition of the scale, the position of the data on the page and rotation. 

RESULTS

Once the files have been selected and properly set up, click OK to start the import process.

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and  a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information. 
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WEB FEATURE SERVICE

Import vector data using the Web Feature Service (WFS). It accesses web servers that deliver vector content in GML 
format. To access WFS settings, choose Web Feature Service in the Format drop-down list of the Simple or Advanced 
Import dialog box and click the Settings button.

To manage servers used in the WFS, click Browse. The Browse Web Feature Service dialog box maintains a list of 
loaded map services. To add a new service click the Add button, then add the service URL and version number. This 
list can also be populated with a number of services aggregated by Avenza. To do so, click the Load Services From 
Avenza button. To remove a service, select one, then click the Remove button.

Saved Services
WFS title and map service 

abstract

Add/Remove WFS
Add a WFS by entering a 
name for the service and 

the  connection URL. WMS 
import supports only 

version 1.1.1.

Load Services from Avenza 
Loads an updated list of 
Web Feature Services 
from an Avenza server.

In the Select Features dialog box, choose map features in the layer tree to import them. The layer abstract at the 
bottom of the dialog box displays a descriptive field about the selected layer and its bounding box coordinates. 
Click the Specify Spatial Filter to specify four exact coordinates to limit the area being imported. See Import Personal 
and File Geodatabases for more information. Optionally, check the Save file to directory option and browse to a 
location to save it locally (not required to use the feature). 

Title 
The title of the current WFS

Layer Tree
Structured list of available 

layers. May or may not show 
geometry (Area, Point, Layer) 

type depending on server 
settings

Layer Abstract 
A descriptive field including 

layer metadata

Save file to directory 
Check this and browse to a 

location to save the selected 
map features.

Specify Spatial Filter 
Define a bounding box 
to limit imported 
features

Web Feature/Map Service
Simple or Advanced Import (Format drop-down list)
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Server Info 
WMS title and map service

Layer Tree
Structured list of layers 

available in the current WMS 

Format
Available output formats

Additional Server Parameters 
Additional parameters as 
outlined in WMS abstract

Description 
An abstract of the layer that 

may include metadata 
definitions

Expand/Collapse Layer Items 
Expand or collapse items in 

the layer tree 
Number of X Pixels
Input number of X pixels to  
change output image size. 
Image is resized proportionally.

Preview 
Toggle thumbnail preview 

of WMS image. Spatial 
extents displayed around it.

Style - Choose from 
rendering styles available 
for the selected layer

Coordinate System 
Choose from available 
Spatial Reference Systems 

Set Background Transparent 
Toggle background 
transparency on import

Image Placement 
Choose to have the image embedded 
or linked in the document.

Specify Spatial Filter - Import 
data based on a specified 
geographic bounding box.

Set output directory for 
image - Check to enable 
and browse to a location 
to save the image. 
Optionally, check Write 
reference file to include a 
reference file with the 
output image.

WEB MAP SERVICE

Import raster data with the Web Map Service (WMS). It accesses web servers that deliver raster content in a variety 
of formats. There are no format specific settings associated with this importer. To access WMS, choose Web Feature 
Service in the Format drop-down list in the Simple or Advanced dialog box.

To manage web servers used in the WMS, click Browse. The Browse Web Map Service dialog box maintains a list of 
loaded services. This list can be populated with a number of services aggregated by Avenza. To add a new service 
click the Add button, then add the service URL. MAPublisher WMS importer only supports WMS version 1.1.1.

Saved Services
WMS title and map service 

abstract

Load Services from Avenza - 
Loads an updated list of 
Web Map Services from 
an Avenza server.

Add/Remove WMS
Add a WMS by entering a 

name for the service and the  
connection URL. 
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Spatial Databases

A geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types and managed in either a file folder structure or a relational database, such as:

•	 Feature classes of points, lines, polygons and annotation for discrete features
•	 Feature datasets (group of feature classes)
•	 Descriptive attributes stored in tables 
•	 Raster datasets and raster catalogs for imagery

MAPublisher can import several types of Esri geodatabases:

File 
extension

User 
access

Size 
limit

RDBMS 
Technology

Esri Licensing
(create)*

MAPublisher 
Import access

Personal geodatabase .mdb Single 2 GB Microsoft Access 
(Jet Engine)

ArcInfo
ArcEditor
ArcView

Folder browser

File geodatabase .gdb Single 1 TB No RDBMS - uses 
local file structure

ArcInfo
ArcEditor
ArcView

Folder browser

ArcSDE Desktop 
geodatabase 

(called Personal in 9.2)
- Multiple 

(limited) 4 GB SQL Server 
Express

ArcGIS Engine
ArcInfo

ArcEditor

ArcSDE server 
connection

ArcSDE Workgroup 
geodatabase - Multiple 

(limited) 4 GB SQL Server 
Express

ArcGIS Server 
Workgroup

ArcSDE server 
connection

ArcSDE Enterprise 
geodatabase - Multiple 

(unlimited)

Depends 
on the 
server

DB2
Informix
Oracle

PostgreSQL
SQL server

ArcGIS Server 
Enterprise

ArcSDE server 
connection

*For all geodatabases, an ArcEngine license is the minimum requirement for direct read of vector and raster data.

MAPublisher has the capacity to import all types of geodatabases (categorized as Personal, File and ArcSDE 
geodatabases). The connection to an ArcSDE server requires server access, user account and versioning information 
to be provided by the database administrator. These parameters are exactly the same required to establish a 
connection using Esri ArcCatalog — with a small exception for SQL Server Express connections, explained later on 
in this chapter.

Once imported into Adobe Illustrator, data does not maintain a link with the original database and database 
functions are not valid (topology, table/feature class relationships, subtypes and attributes domains rules). However, 
MAPublisher can make use of the geodatabases spatial and non-spatial relationships, subtypes and attribute 
domains information during the import process (to populate layer names and attributes).

The following sections include how to:
Import Personal and File Geodatabases
Import Using Basic Personal Geodatabase Reader (Mac supported)
Import Esri ArcSDE Geodatabases
Import from Basic Esri ArcSDE server
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SOFTWARE REQUIREMENTS

The MAPublisher Basic Personal Geodatabase Reader does require any ArcGIS licenses for Mac and Windows. 
However, this means that some import functions are limited in use (explained further in this chapter).

To be able to fully import Esri geodatabases or to fully access an ArcSDE server using MAPublisher Simple and 
Advanced Import, a valid Esri software must be installed and licensed—at minimum, ArcGIS Engine Runtime. More 
commonly, higher licenses that may be used are ArcView, ArcEditor and ArcInfo.

Direct access to feature classes on an ArcSDE Server only requires ArcReader, available for free. However, File and 
Personal geodatabases cannot be read using ArcReader. With this license configuration, access to files with a Basic 
Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connections (explained further in 
this chapter). MAPublisher supports all ArcSDE server connections and SQL queries supported by Esri.

If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary 
location in the MAPublisher Preferences, Basic Esri ArcSDE Server Editor (see chapter 1). 
 
MAPublisher supports geodatabases from versions ArcGIS 9.2 and higher. However, there are some 
limitations to the direct connections from 9.2 clients to the ArcSDE 9.3 geodatabases. Please refer to Esri 
documentation on software requirements (service packs) and limitations. 
 
To access geodatabases created by ArcGIS 10 in MAPublisher, an installation of ArcGIS 10 is required. Having 
a valid installation allows for backwards compatibility with geodatabases created by ArcGIS 9.2 and higher.

SUPPORTED FEATURES

Data Types
The following is a list of supported and unsupported geodatabase geometry types for import in MAPublisher:

Supported Unsupported

Point
Polyline
Polygon
Circular Arc*
Elliptical Arc*
Bezier Curve
Annotations

Raster
Grids
MultiPatch
Dimensions

Note:	 To import a geometry type that requires the use of a Representation in ArcGIS (such as Bezier curves), the 
Behavior when Representation Geometry is Edited must be set to Change the geometry of the supporting 
feature—option specified when creating a new Representation in ArcGIS.

*	 Upon import, MAPublisher 
converts an arc to a line 
where a series of vertices 
will maintain the geometry. 
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Aliases
ArcGIS users can give the feature classes an alias that acts as an alternate name. Unlike feature class names, aliases 
can contain spaces, punctuations, and start with a number. In ArcMap, feature classes are referred to with their alias 
name. In ArcCatalog, feature classes are represented by their true names.

Specify to use aliases for layer names in the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor:

Note:	 Aliases for attribute field names are imported as Display Name and true field names as Name of MAP 
Attributes columns.

Subtypes and Attribute domains
Subtypes are particular attribute fields made to create groups of records in a feature class that share the same types 
of properties. The attribute fields designated as subtype fields contain numerical coded values and have a data type 
of short or long integer. Each coded value is associated with a description (textual). In the MAPublisher Preferences 
for Spatial Database > Esri Geodatabase Editor, users may choose to load subtypes as separate layers.

Attribute domains are used to constrain the values allowed in any particular attribute of a feature class (or subtypes). 
There are two types of attribute domain:

•	 A range domain limits the value of a numerical attribute in between minimum and maximum values — 
range domains are not relevant to MAPublisher. 

•	 A coded value domain specifies a valid set of coded values for an attribute (of any type — text, numeric 
or date). Both coded values and their meaningful description are stored in the database.

In the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor, users can set the option to import 
attributes with coded values from subtypes and attribute domains as follow:

•	 Instead: replace the codes by their description (text)
•	 Never: import the actual values (code)
•	 In Addition: create two attribute columns, one containing the coded values and one containing the 

corresponding descriptions. 
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Spatial Filters
During the import process, users can enter two opposite corner coordinate points in any coordinates system unit to 
limit the geographic area for the data being imported (see next section).

Note:	 When importing a feature class that has no art it is considered to have invalid extents and a spatial filter 
cannot be created.

SQL Queries
During the import process, users can use SQL queries on feature classes and tables to limit the objects and 
attributes to be imported. 

Multiple feature classes can be imported using multiple SQL statements as long as all classes share the same source 
coordinate system. SQL queries can also be used to import a feature class and the attribute information from a 
related non-spatial table. To apply SQL queries on multiple feature classes with different source coordinate systems, 
use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more information on the 
Advanced Import).

MAPublisher uses Esri libraries to run SQL queries. Please refer to Esri documentation for more information on 
supported SQL expressions and syntax — it may vary depending on the geodatabase and database server type.

Non-Spatial Relationships
MAPublisher supports non-spatial relationships between feature classes and tables during the import process using 
SQL queries. Here are some examples:

Query Result

ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id
Import and inner join a feature class to a related table (only 
features with entries in the related table are imported)

ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id 
AND Table.Attribute='ABC'

Import and inner join a feature class to a related table and 
apply a query

ÌÌ SELECT * FROM Feature_Class WHERE FeatureClass.Id IN (SELECT 
Table.Id FROM Table WHERE Table.Attribute='ABC')

Import a feature class without joining to a related table, but 
use a table value to make a query

Note:	 SQL syntax may vary depending on the database server type.

Once vector data is imported into Adobe Illustrator, the database relationships rules do not apply anymore. It is 
however possible to use the MAP Attributes panel Join Table function to join geodatabase tables with MAPublisher 
vector data. For more information, please refer to chapter 5.

Note:	 When the non-spatial table information is imported together with the feature class using a SQL query, only 
the vector features that have a record in the related table are imported. Import first the feature class and use 
Join Table in a second step: all vector features are imported and the related table information is added where 
a record match is found. This second option might be recommended if the database is not well known.
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IMPORT PERSONAL AND FILE GEODATABASES

Format - Select Esri File Geodatabase 
or Esri Personal Geodatabase.

<Auto detect format> can only be 
used for Personal Geodatabases.

Simple Import or Advanced Import > Add 

Browse - Opens a Select dataset 
browser. File Geodatabases have 
the extension *.gdb, Personal 
Geodatabases have *.mdb.

FUNCTIONALITY

Esri Personal and File geodatabase feature classes can be imported using Simple Import or Advanced Import. The 
file selection is done in two steps: 1) select the database (*.mdb file for Personal geodatabase, a *.gdb folder for File 
geodatabase); 2) select feature classes directly or through an SQL query. Optionally, define a spatial filter to limit the 
geographic extents of the data being imported.

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets are not imported as such. The feature dataset 
name may be prefixed to the name of the data layer created during import (using an import setting).

For each format, multiple feature classes sharing the same source coordinate system may be selected at once in 
the Simple Import or Advanced Import > Add dialog box. To import feature classes that do not have matching 
spatial reference, use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more 
information on Advanced Import functionality).

The feature classes (objects and attributes) are imported on separated MAP layers. The layer naming convention is 
set in the MAPublisher Preferences for Spatial Databases > Esri Geodatabase Editor.

USING IMPORT ESRI PERSONAL AND FILE GEODATABASES

In the Simple Import or Advanced Import > Add dialog box, set the Format drop-down list to Esri Personal Geodatabase 
or Esri File Geodatabase. Using <Auto detect format> only works with Personal geodatabases (File geodatabases 
cannot be detected because they are directories). The Settings are described in chapter 3. Click the Browse button 
and select a file with the extension *.mdb (Personal geodatabase) or a directory with the extension *.gdb (File 
geodatabase)— only one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog 
box where specific feature classes can be imported.
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Select Feature Classes
In the Select Feature Classes dialog box, import one or more feature classes or build SQL queries to select subsets of 
feature classes. Click the names of the feature classes to select them for import—selected classes are highlighted. To 
deselect a class, click the selected name again.

Select Feature Classes - Click one or more 
feature classes to import, only classes 
sharing the same original coordinate 

system (spatial reference) can be 
imported together

SQL Query - Click this option to access 
the Create SQL Select Query dialog box

Specify Spatial Filter- Click this button to 
open the Specify Spatial Filter dialog box

Specify Spatial Filter
A spatial filter consists of a rectangle that defines the extents of imported data. When first opened, the Specify Spatial 
Filter dialog box displays the two opposite corner coordinates that represent the actual extent of the data. Use 
extents of an existing MAP Layer from the drop-down list or enter new coordinates values. Click the Specify button 
to use an alternate input coordinate system.

Set points manually - Enter two opposite 
corners of the spatial filter boundaries

Use extents of layer - Choose an existing 
MAP Layer and click Update to use its 

spatial extents as the spatial filter

Relationship - Specify features to be 
included (spatail database only):
•	 Intersects: includes features that 

intersects the spatial extent
•	 Contains: includes only features 

that are entirely contained 
within the spatial extent

Source Coordinate System - Coordinate 
system of the selected feature class

Input Coordinate System - Coordinate 
system specified for entering the filter 

coordinates (if different from source)

Data Coordinate System 
Original coordinate system 

of the selected file
Use alternate input coordinate system 

Check this option and click 
Specify to select an alternate 

coordinate system

Clear - Revert to the source 
coordinate system for 
entering the filter positions

For spatial databases, choose whether or not to import objects that intersect with the spatial filter boundaries by 
setting the Relationship: 

•	 Intersects: import objects that intersect the extents of the spatial filter
•	 Contains: import objects fully contained within the extents of the spatial filter
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Create SQL Select Query
An SQL statement can be built to limit the number of objects and attributes imported from a single feature class. 
The SELECT clause should always contain one and one only "Shape" object (actual spatial feature). When possible, 
use the operator button to add formatted query statements (including spaces), to limit the typing errors. 
For example: 

•	 In feature class "FC_Point", import all points and the "Valve" attribute (other attributes are not imported).
ÌÌ SELECT FC_Point.Shape, FC_Point.Valve_ID FROM FC_Point

•	 In feature class "FC_Line", import lines (vector only) that have the attribute "Id" equals to 1, 2, 3 or 4.
ÌÌ SELECT FC_Line.Shape  FROM FC_Line WHERE FC_Line.Id IN (1,2,3,4)

Use the Validate button in the Create SQL Select Query dialog box to verify the query syntax prior to import.

Multiple feature classes can be imported using multiple SQL statements separated by a semi-colon (;) as long as all 
classes share the same source coordinate system. SQL queries can also be used to import a feature class and the 
attribute information from a related non-spatial table (see previous section). To perform SQL queries on multiple 
feature classes with different source coordinate systems, use the Advanced Import and add the feature classes in 
several Add sessions (see chapter 3 for more information on the Advanced Import).

Recently used SQL queries are saved and accessed by clicking the Recent button. The number of recent queries 
saved is set in the MAPublisher Preferences on Spatial Database > General Spatial Database Editor (see chapter 1).

SQL Query Editor - Type in an 
SQL query. The SQL syntax 

must be compliant with 
the DBMS server in use.

One and one only "Shape" 
field must be specified in 

the SELECT clause.

Selection - Select a feature 
class name or attribute  

and double-click or click 
Add to Query to add it 

to the SQL Query Editor 
above. Attribute alias 

names are indicated in 
parenthesis.

Add to Query - Select a feature class name 
or attribute and click this button to add 
the item the SQL statement

Recent - Opens a list of recent SQL 
statements (see also MAPublisher 
Preferences on Spatial Database > General 
Spatial Database Editor - chapter 1)

Specify Spatial Filter - Opens 
the Spatial Filter dialog box 

(see previous page)

Operators - Click an operator button to 
add the corresponding formatted text 
(including spaces) to the query

Validate - Click to verify the query syntax

Delete - Click to delete 
recent SQL queries
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IMPORT USING BASIC PERSONAL GEODATABASE READER

Format - Select Basic Personal Geodatabase 
This works in both Windows and Mac 

without an ArcGIS license.

Simple Import or Advanced Import > Add 

Browse - Opens a Select dataset 
browser. Only Personal Geodatabases 
with *.mdb extension can be chosen.

FUNCTIONALITY

Esri Personal geodatabase feature classes can be imported using Simple Import or Advanced Import. The main 
difference between this format and the Esri Personal Geodatabase format is that the Basic is available to users 
without an ArcGIS license and works on both Mac and Windows.

The Basic Personal Geodatabase Reader can only read the feature classes as tables (and referred to as tables). The file 
selection is done in two steps: 1) select the database (*.mdb only); 2) select tables directly or through an SQL query. 
Optionally, define a spatial filter to limit the geographic extents of the data being imported.

Some limited functions are worth noting. The Basic Personal Geodatabase Reader doesn't support feature datasets, 
doesn't support relationship (intersect/contains) in spatial filters, and doesn't support domain or subtypes. Other 
than the listed differences, the Basic Personal Geodatabase Reader functions similarly to importing an Esri Personal 
Geodatabase (see previous section, Import Personal and File Geodatabases).

USING BASIC PERSONAL GEODATABASE READER

In the Simple Import or the Advanced Import > Add dialog box, in the Format drop-down list, choose Basic Personal 
Geodatabase Reader. Click the Browse button and select a file with the extension *.mdb (Personal geodatabase)—only 
one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog box where specific 
feature classes can be imported.

Select Tables
Feature classes are referred to as tables using the Basic Personal Geodatabase Reader. In the Select Tables dialog box,  
directly import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the 
names of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note:	 Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Specify Spatial Filter and Create SQL Select Query
The Specify Spatial Filter and Create SQL Query for Basic Personal Geodatabase Reader functions similarly to importing an 
Esri Personal Geodatabase (see previous section, Import Personal and File Geodatabases).
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IMPORT ESRI ARCSDE GEODATABASES

Format - Select Esri ArcSDE Geodatabase.
<Auto detect format> cannot be used.

Simple Import or Advanced Import > Add 

Browse - Opens Browse ArcSDE 
Geodatabase dialog box

FUNCTIONALITY

Esri ArcSDE geodatabase feature classes can be imported using Simple Import or Advanced Import. Importing 
ArcSDE geodatabases requires users to create a connection to the database server containing the database. Once a 
connection is established, feature class selection is done in the same manner as Personal and File geodatabases—
by direct selection or SQL query (see previous section) and using spatial filters.

The connection parameters to an ArcSDE server are saved with the application. The dataset selections (called MAP 
Datasets) are also saved. The maximum number of default MAP Datasets saved is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor. MAP Datasets saved with a specific name (other than the 
default one given) are always saved.

Like the other geodatabase formats, multiple feature classes sharing the same source coordinate system may be 
selected all at once. To import feature classes that do not have matching spatial reference, use Advanced Import 
and add the feature classes in several Add sessions (see chapter 3 for more information on the Advanced Import). 

The feature classes (objects and attributes) are imported on separated MAP layers. ArcSDE geodatabase tables 
are identified as databaseName.userName.tableName. An abbreviated version using only the table name as layer 
name can be applied as a preference. This option and other layer naming conventions are set in the MAPublisher 
Preferences for Spatial Databases > Esri geodatabase Editor (see chapter 1 and previous section).

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets as whole cannot be individually imported—only 
its individual feature classes can. An import setting allows the feature dataset name to be prepended to the name 
of the data layer created during import.
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USING IMPORT ESRI ARCSDE GEODATABASES

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Esri ArcSDE 
Geodatabase. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the 
Browse ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE 
servers. It also stores recently used and saved MAP Datasets.

Connections - List of connections already 
created within MAPublisher

Recent/saved MAP Datasets - List of recently 
used and saved MAP Datasets

Create new - Opens the Create new ArcSDE 
Geodatabase Connection dialog box.

Edit
•	 If a connection is selected, it opens 

the Edit ArcSDE Geodatabase 
Connection dialog box

•	 If a MAP Dataset is selected, it opens 
the Edit ArcSDE Geodatabase MAP 
Dataset dialog box

Copy - Copy the selected ArcSDE connection

Delete - Delete the selected ArcSDE 
connection or MAP Dataset

Esri ArcSDE Geodatabase Connection
In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings - Specify the 
connection settings: Connection Name, 

Server, Service and Database Name as 
specified in the database Connection 

Properties in Esri ArcCatalog

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases)

Database Authentication - Enter user 
name and password provided by the 

database administrator

Operating System Authentication
The server connection uses 

Windows authentication. The user 
must be logged into Windows 
with a login name that is also 
valid on the database server.

Test Connection - Test the connection 
parameters prior to accessing datasets

Connection Details - Specify the transactional or historical 
version to be accessed. The interface lists the existing 
versions for the database.
Information to be provided by the database administrator.
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Important Note for SQL Server Express Users
There is an exception for connections to SQL Server Express servers — ArcSDE Desktop (called Personal in ArcGIS 
9.2) and Workgroup geodatabases. In ArcCatalog, users set a "Database Servers" connection where only the server 
name followed by \sqlexpress is required to establish a connection. In MAPublisher, there is no specific interface for 
SQL Server Express connections, the same interface as for the other types of ArcSDE geodatabases must be used 
with specific settings: 

Server Name of the server followed by _SQLEXPRESS

Service The server name must be preceeded by sde:sqlserver and 
followed by \sqlexpress (e.g. sde:sqlserver:ServerName\sqlexpress)

Database name The name of the database must be known

Operating System 
Authentication 

Must use this to authenticate SQL Server Express databases

Select MAP Datasets
To make a new selection of feature classes from an ArcSDE geodatabase, click a connection name on the Connections 
tree of the Browse ArcSDE Geodatabase dialog box and click OK. This opens the Select Feature Classes dialog box. This 
dialog box for ArcSDE geodatabases is very similar to the Select Feature Classes dialog box of Personal and File 
geodatabases described in the previous section: users can directly select one or more feature classes (provided that 
they share the same spatial reference) or build an SQL query to select a subset of some feature classes and apply 
spatial filters. The difference with ArcSDE geodatabases is that the feature class selection is saved as a MAP Dataset. 
Type in a MAP Dataset name for the selection at the top of the dialog box.

Feature classes - Click one or more 
feature classes to import - only classes 

sharing the same original coordinate 
system (spatial reference) can be 

imported together

SQL Query - Click to access the Create SQL 
Select Query dialog box. See  

Import Personal and File Geodatabases.

MAP Dataset - Type a name for the selected 
dataset (by direct selection or SQL 
query). This name will be displayed in 
the Recent/saved MAP Dataset list of the 
Browse ArcSDE Geodatabase dialog box.

The number of default recent MAP 
Datasets saved is set in the MAPublisher 
Preferences for Spatial Database > General 
Spatial Database Editor.

Specify Spatial Filter- Click to open the 
Specify Spatial Filter dialog box. See  

Import Personal and File Geodatabases.
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Click a MAP Dataset in the Recent/saved MAP Datasets tree of the Browse ArcSDE Geodatabase dialog box. The MAP Dataset 
name and connection can be changed in the Edit ArcSDE Geodatabase MAP Dataset dialog box.

MAP Dataset - Edit the name of the 
MAP Dataset. It will be displayed in 

the Recent/Saved MAP Dataset list 
of the Browse ArcSDE Geodatabase 

dialog box.

Connection - Set the name of the 
connection to use to access a dataset

Feature Classes - List of 
selected feature classes

SQL Query - SQL query used to select the 
data features (when used)

Spatial Filter - Spatial fiter used to limit 
the import extents (when used)

The maximum number of recent MAP Datasets saved with the default name is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor (user named datasets are saved until deleted).

Settings
Spatial database parameters can by clicking the Settings button in the Simple Import or Advanced Import > Add 
dialog box. These settings are described in chapter 3. Optionally, prefix the feature dataset names to the layer name 
created on import.

Access it by going to MAPublisher Preferences > Spatial Database > Esri Geodatabase Editor:

Use abbreviated table name for layer name
ArcSDE Geodatabases' tables 
are identified as databaseName.
userName.tableName. The 
abbreviated version uses only the 
table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.
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IMPORT FROM BASIC ESRI ARCSDE SERVER

Format - Select Basic Esri ArcSDE Server
<Auto detect format> cannot be used.

Simple Import or Advanced Import > Add 

Browse - Opens the Browse Basic Esri 
ArcSDE Server dialog box

FUNCTIONALITY

Users who do not have an ArcGIS license can install ArcReader, a free Esri desktop application (www.esri.com). Only 
ArcSDE geodatabases can be read, File and Personal geodatabases are not supported using this format. In addition, 
file access with a Basic Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connection:

•	 Aliases, sub-types and attribute domains are not supported — only true names and actual values 
(codes) are imported.

•	 Feature datasets are not recognized. Feature classes are all listed on the same level, they are not 
grouped by feature dataset.

•	 Feature classes are referred to as "tables"
•	 Operating System Authentication is not supported.

USING IMPORT BASIC ESRI ARCSDE SERVER

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Basic Esri ArcSDE 
Server. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the Browse 
Basic ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE 
servers. It also stores recently used and saved MAP Datasets.

Recent/saved MAP Datasets - List of recently 
used and saved MAP Datasets

Edit
•	 If a connection is selected, it opens 

the Edit Basic Esri ArcSDE Server 
Connection dialog box

•	 If a MAP Dataset is selected, it opens 
the Edit Basic Esri ArcSDE Server MAP 
Dataset dialog box

Connections - List of connections already 
created within MAPublisher

Copy - Copy the selected ArcSDE connection

Delete - Delete the selected ArcSDE 
connection or MAP Dataset

Create new - Opens the Create new Basic 
ArcSDE Server Connection dialog box.
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Basic Esri ArcSDE Server Connection
In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings  
Connection Name, Server, Service and 

Database Name as specified in the database 
Connection Properties in ArcCatalog

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases)

User Name / Password - Specify 
authentication information provided by 

the database administrator

Test Connection - Tests the connection 
parameters prior to accessing datasets.

Version - Enter the transaction 
version information provided by 
the database administrator.

Unlike ArcSDE Geodatabases, the 
ArcSDE server interface does not list 
the versions existing in the database.

Note:	 If ArcReader is not installed in the default installation directory, it may be necessary to edit the binary 
location in the MAPublisher Preferences > Basic Esri ArcSDE Server Editor (see chapter 1).

Important Note For SQL Server Express Users
Some specific settings are required for SQL Server Express connections. See Esri ArcSDE geodatabase connection.

Select Tables
Feature classes are referred to as tables using the Basic Esri ArcSDE Server. In the Select Tables dialog box,  directly 
import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the names 
of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note:	 Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Select Tables - Click one or more tables to 
import. Only tables sharing the same 

original coordinate system (spatial 
reference) can be imported together.

SQL Query - Click to access the Create SQL 
Select Query dialog box. See  

Import Personal and File Geodatabases.

MAP Dataset - Type a name for the selected 
dataset (by direct selection or SQL 
query). This name will be displayed in the 
Recent/saved MAP Dataset list of the Browse 
Basic ArcSDE Geodatabase dialog box.

The number of default recent MAP Datasets 
saved is set in the MAPublisher Preferences 
for Spatial Database > General Spatial 
Database Editor.

Specify Spatial Filter- Click to open the 
Specify Spatial Filter dialog box. See  

Import Personal and File Geodatabases.
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The MAP Views panel is the hub from which many additional 
MAPublisher features may be accessed. This panel organizes 
Adobe Illustrator layers into sub layers of distinct coordinate 
systems known as MAP Views. Use this panel to specify 
coordinate systems for map layers, transform coordinate 
systems, edit scale and data placement, and export to GIS 
formats.

When importing data, an Adobe Illustrator layer is created for 
each feature type, and is by default appended with a _point, 
_line, _area, or _text suffix in the Adobe Illustrator Layers 
panel. Certain file types generate multiple layers, such as 
DGN or DXF, but are similarly split up by feature type. A single 
import of such files produces a single MAP View as an import 
can only take place into a single coordinate system. Custom 
MAP Views may be created in order to georeference existing 
Adobe Illustrator artwork.

The following pages deal with the creation and management 
of MAP Views, specifying and projecting a coordinate system, 
editing scale and data placement on the page, merging Adobe 
Illustrator layers, and exporting to GIS formats.

Topics covered in this section:
Georeferencing
MAP Views Panel
MAP View Editor
Export
Import MAP Objects
MAP Location Tool

MAP Views and 
Georeferencing
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The workflow for georeferencing a non-georeferenced Adobe Illustrator file in MAPublisher can be separated into 
three steps:

1.	 A Source Coordinate System must be specified. The coordinate system gives a method to represent geographic points 
in relation to a world origin (these are also called map, geographic, real world or spatial coordinates).

2.	 A Scale (and sometimes a Rotation) is necessary to translate measurements on the ground to measurements on 
the Adobe Illustrator document artboard.

3.	 MAPublisher bases its georeferencing on a tie point within the Adobe Illustrator artboard. The relationship 
between Page Anchor and Map Anchor is defined below.

The Source Coordinate System and Scale have to be manually set.  One should not estimate this information, it is usually 
provided as metadata by data vendors or indicated as text on the original map. Also, anchors have to be specified 
manually: Map Anchor information can be entered in any coordinate system  unit (for example latitude and longitude 
in degree), Page Anchor are entered in the document units.

The most common way to set up an Adobe Illustrator page is to set the page origin (0,0) to coincide with the lower 
left corner of the map extents. If this information is not known, any point on the map can be used as long as its 
geographic location is known (e.g. a building or graticule grids on a scanned map—this information is usually given 
by the data provider if not obvious on the map itself ).  The position in page coordinates for the same point is found 
using the Adobe Illustrator Info panel.

Once the relationship between the real world coordinates and the page coordinates is established, these two points 
are dynamically linked. MAPublisher uses this anchor point in subsequent data transformations, such as rescaling 
and transforming, as well as in the creation of grids and to maintain georeferencing on export. 

During the import process, MAPublisher reads the coordinate system settings from the input file and calculates 
the scale to best fit the map data to the page. MAPublisher treats the point at (0,0) in the document (Page Anchor) as 
being coincident to the lower left corner of the data in real world coordinates (Map Anchor). 

Note:	 When importing GIS data, if the coordinate system of the source data is not stored or was not saved, 
MAPublisher determines the scale and anchor automatically, only the Source Coordinate System must be set.

For further information, please refer to the appendices. See appendix A1 General Tips on Georeferencing an Adobe 
Illustrator file. Appendix A2 provides general information on the MAPublisher coordinate systems as well as 
customizing options.

Georeferencing

Illustration of page and map anchors
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MAP Views Panel 
Window> MAPublisher > MAP Views and MAP Toolbar 

MAP Views - Each contains 
distinct configurations of 

geospatial parameters

New MAP View - Create a new MAP View and specify its name and coordinate information.

New MAP View For Photoshop Paths- Specify a new MAP View based on paths exported from Geographic Imager/Adobe Photoshop.

Duplicate Selection - Create a duplicate of the currently selected MAP View.

Edit Selection - Open the MAP View Editor to edit the name and coordinate system of the currently selected MAP View.

Delete Selection - Delete the currently selected MAP View or MAP Layer provided it does not contain any Adobe Illustrator layers.

Add MAP Layer - Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors - Manually establish the tie-in point between Map and Page Anchors (should only be used for new MAP Views or 
for the correction of georeferencing errors).

Export Coordinate System to File - Exports the selected MAP View coordinate system to a WKT definition (*.wkt) (see Appendix A2).

Export Selection - Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Layer Name Search & Replace - Search for text within layer names and specify an alternative.  Useful for multi-layer imports.

Sort Art on Layer - Sort art in ascending or descending order based on attribute.

Edit Layer Note - Add or edit the selected layer's note.

Load Custom Coordinate Systems - Load external coordinate systems in .xml format (see Appendix A2).

Edit Custom Coordinate Systems - Open the custom coordinate system editor to create new coordinate systems and edit the 
parameters of existing ones in the data source (see Appendix A2).

Import MAP Objects - Import MAP Views, MAP layers, MAP Themes (including Stylesheets) and MAP Selection Filters from other 
open documents.

Preferences - Opens MAPublisher Preferences on the MAP Views Panel property sheet (see chapter 1).

MAP Layers - An alphabetical 
list of the layers that comprise 

each MAP View, symbolized by 
feature type.

Non-MAP layers - Lists the Adobe 
Illustrator layers that are 

not part of a specified MAP 
View, and do not contain 

georeferenced information.
Delete selection button - Delete the 
currently selected MAP Layer or 
MAP View (provided it does not 
contain any map layers).

Layer Operations - Zoom, toggle lock, 
and toggle visibility of MAP Views 
and MAP layers.

Lock button - Click box to lock 
or unlock a MAP Layer (lock 
check box is mirrored in the 

Adobe Illustrator Layers panel).

Switch MAP View - Click this button to 
switch the selected layer from one 
MAP view to another. Remove GIS 
data moves the selected layer to 
the [Non-MAP layers] section and 
removes the georeferencing and 
attributes in the process. 

Layer Note - Click this button to 
add a layer note. A note with no 
+ symbol contains a note.

Export MAP View  / MAP Layer   
Export the selected MAP View or 
MAP Layer to various GIS formats.

MAP Views Panel Options Menu

Add MAP Layer - Creates a new MAP 
layer (in both the MAP Views panel 
and the Adobe Illustrator Layers 
panel). Opens the Add MAP Layer 
dialog box.
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Missing Coordinate System
Automatically opens when dragging a MAP Layer to an alternate MAP View, and 
either the source or destination MAP View has an unspecified coordinate system.

Select custom coordinate system Choose 
this option and then click the Select 

button to specify the coordinate 
system of the named MAP View via the 
Select Coordinate System dialog box 

(see Appendix 2). Once selected, the 
coordinate system will be displayed 

below it.

Same as - Choose this option in 
order to assign a coordinate 
system to the named MAP View 
that matches that of an existing 
MAP View. The coordinate 
system of the selected MAP 
View will be displayed below.

Layer Name Search and Replace

Find what - Type in the 
variable contained in the 
current layer names on 
which you wish to search

Replace with - Type in the 
variable you wish to change 

the layer names to

Define Layer
Automatically opens when dragging a Non-MAP layer into a specified MAP View.

Apply to all - When multiple layers 
are switched at once to a specified 
MAP View, check this box to apply 
the same feature type to all

RELATED TOOLS

Feature Type -Select the type of feature 
that exists on the layer being dragged. 

This drop-down list presents a choice of 
Area, Line, Point, Image, Text or Legend 

layer types.

Base Attribute Schema on - Check this option to 
copy the attribute schema from the existing 
MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger 
Tool and MAP LabelPro tools make use of this 
option, see specific chapters. 

Add MAP Layer

Specify Anchors
Should only be accessed when creating a new MAP View  

or correcting inaccurate georeferencing information. 
Caution: editing anchors can damage the accuracy of the data.

Map Anchor - The location 
of the Map Anchors in 

the units of the selected 
coordinate system 

Page Anchor - The location 
of the Page Anchors in 
the units of the current 

document (see File > 
Document Setup)

Input Coordinate system - Specify the coordinate system in 
which the anchor position is entered. Use the current 

MAP View's coordinate system or specify a different one 
(by default, the geodetic system base of the projection 
or WGS84, in latitude-longitude format). Click the Select 

button to open the Select Coordinate System dialog box and 
choose an appropriate coordinate system.

Feature Type -Select the type of feature 
of the new layer. This drop-down list 

presents a choice of Area, Line, Point,  
Image, Text or Legend layer types

Base Attribute Schema on - Check this option to 
copy the attribute schema from the existing 

MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger 
Tool and MAP LabelPro tools make use of this 
option, see specific chapters. 

Layer name - Type the name of the new 
layer (it will appear in both MAP Views 

and Adobe Illustrator Layers panels)
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OVERVIEW

The MAP Views panel displays a list of all the Adobe Illustrator layers in the current document and all MAP Views—
defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every 
MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe Illustrator layers that do not have 
georeferencing information (e.g. non-map objects such as diagrams and supplemental art) are placed in the 
[Non-MAP layers] category.

Categories are symbolized in the following manner:

 MAP View Contains  layers with georeferenced and attribute information.

 [Non-MAP layers] Contains layers with no georeferenced or attribute information. 

Each layer that belongs to a MAP View is symbolized in MAPublisher panels and dialog boxes with an icon 
identifying its feature type:

  Area layer (e.g. county boundaries, urban areas, country outlines etc.)

  Line layer (e.g. rivers, roads, railways etc.)

  Point layer (e.g. town and city symbols, railway stations etc.)

  Text layer (e.g. text labels)

  Legend layer (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)

  Image layer (for referenced images)

Note:	 Layers are sorted alphabetically or by data type, as specified in the MAP Views category in the MAPublisher 
Preferences (see chapter 1).

FUNCTIONALITY

MAP Views are designed to give easy access to settings for specifying and transforming coordinate systems, for 
editing scale and data placement on the page and for exporting to GIS formats. The MAP Views panel allows 
toggling Adobe Illustrator layers accessibility, georeferencing existing Adobe Illustrator artwork, changing multiple 
layer names and projecting data on the fly.

USING THE MAP VIEWS PANEL

Creating New MAP Views
To create a new MAP View, click New MAP View in the panel options menu. This opens the MAP View Editor (discussed in 
MAP View Editor section). Specify a coordinate system and enter values for scale, rotation, and page anchors. After 
creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define 
the tie-in point between Map Anchors and Page Anchors.

Note:	 Creating a new MAP View is only recommended when registering a non-referenced Adobe Illustrator 
document. To transform an existing MAP View to a new coordinate system and scale (e.g. to create an inset 
map), use the duplicate MAP View function and transform or rescale the copied MAP View.
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Duplicate And Delete MAP Views
MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the 
new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate. 
Note that MAP Layers can only be duplicated in the Adobe Illustrator Layers panel.

Delete a MAP View or MAP Layer using the Delete button at the base of the panel or through the MAP Views panel 
options menu. To delete a MAP View, its MAP layers must first be deleted. 

Create New MAP Layers 
Create new MAP Layers to hold geospatial data or to generate artwork using MAPublisher tools (plot points, labels, 
legends, grids, scale bars and north arrows).  Click the Add MAP Layer button   to create a new Adobe Illustrator 
layer which simultaneously places it into a selected MAP View. Specify the appropriate Layer name and Feature type for 
the new layer.  Below are examples of the types of MAPublisher tools that require a specific MAP Layer type:

 Area layer Join Areas, Line Plotter (see chapter 8)

Line layer Buffer Art, Join Lines, Line Plotter (see chapter 8)

Point layer MAP Point Plotter (see chapter 6)
Join Points (see chapter 8)

Text layer Label Features, MAP Tagger (see chapter 10) 
MAPublisher LabelPro (see chapter 17)

Legend layer Grids and Graticules (see chapter 13) 
Scale Bars, North Arrows (see chapter 14)

Image layer Import Image, Register Image (see chapter 3 and 12)

Note:	 The Advanced option Base attribute schema on will copy the attribute schema from an existing MAP Layer (see 
chapter 5 for details). This option is required to enable the copying of attributes from source to destination 
layers in the MAPublisher labelling tools and Plot Centroids function. See respective chapters.

Reproject MAP Layers using the MAP Views Panel
The MAP Views panel can be used to move Adobe Illustrator layers from one MAP View to another; projecting 
vector* data-on-the fly. Alternatively, drag-and-drop layers or use the Switch MAP View button .
* Raster imagery cannot be reprojected with MAPublisher.

Alternatively, use the drag-and-drop method. For example, to reproject a layer that has a UTM projection into a 
Lat/Long projection, click it and drag it from the MAP View with the UTM projection and drop it into the MAP View 
with the Lat/Long projection. MAPublisher will automatically reproject and scale artwork on the layer to match the 
destination MAP View. The Missing Coordinate System dialog box appears when neither the origin nor destination 
MAP View contains a defined coordinate system. Two options are available in this dialog box:

1.	 Specify custom coordinate system: specify projection using the Source Coordinate System function.
2.	 Same as: specify coordinate system based on an existing MAP View in the document.
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Note:	 Many transformations will inherently cause the loss of precision by the very nature of the complex 
mathematical calculations that must be performed. Additionally there are differences in precision between 
MAPublisher and Adobe Illustrator. MAPublisher calculations are in 64-bit for accuracy, but the results must 
be stored in Adobe Illustrator as 32-bit. As a result, please be aware that some precision may be lost if layers 
are dragged repeatedly from one coordinate system to another. When determining a coordinate system to 
use via the drag method, we strongly recommend to use Edit > Undo to revert coordinate systems until the 
appropriate system is found.

Assign Georeferencing Information to Adobe Illustrator Layers
Existing Adobe Illustrator layers that do not contain georeferencing or attribute information also appear in this 
panel under the default MAP View entitled [Non-MAP layers]. Such layers can be moved into a specified MAP View with 
a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

Note:	 Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn). 
Users must ensure that the art on the non-MAP layer is positioned and scaled properly on the page with 
regard to the MAP View definition.

Moving a non-MAP layer into a specified MAP View prompts the Define Layer dialog box in order to specify the feature 
type of the layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply to all 
option to assign the same feature type to all layers being moved. The Advanced option Base attribute schema on copies 
the attribute schema from an existing MAP Layer (see chapter 5 for details).

Specify Anchors
The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the 
process of georeferencing an Adobe Illustrator file, see appendix A1) or to correct an inaccurate referencing. 

The MAP Anchor is entered in the unit of the selected coordinate system. MAP Anchor coordinates must be known 
from information written on the map (e.g. graticules crossing) or from external sources (metadata, survey points 
or other). When the Use Current MAP View's coordinate system option is toggled, MAP Anchor coordinate values are 
entered in the current MAP units of the coordinate system of the MAP View. When the Use: [coordinate system] option 
is toggled, the Select button becomes enabled. Clicking the Select button opens the Select Coordinate System dialog box. 
Choose any coordinate system, the coordinates values entered will be in the unit (Point Style) of this coordinate 
system. When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit 
(Point Style) of the coordinate system (e.g. metre, kilometre, feet). When the selected or default coordinate system is 
Geodetic, Lat and Long coordinates are entered in degrees. 

Note:	 When the current MAP View coordinate system is a projected system, the default system specified in 
Use: [coordinate system] is set to the geodetic system base for the projection. For example, if the MAP View 
system is US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to 
enter the latitude/longitude coordinates in degrees).

The Page Anchor is entered in the current unit of the document. This unit can be changed through the Adobe 
Illustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined 
using the Adobe Illustrator Info panel (menu Window > Info). 

Note:	 For CS5 users, Page Anchor values must be relative to Global Rulers. To use Global Rulers, choose View > 
Rulers > Change to Global Rulers.
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Layer Name Search & Replace 
To quickly change the names of multiple Adobe Illustrator layers, use the Layer Name Search & Replace function 
located in the MAP Views panel options menu. For example, MicroStation Design or CAD imports can contain 
a large number of similarly named layers and doing a name search and replace is more efficient than manually 
changing each of them..

Zoom to MAP Layer or to MAP View

To zoom to a MAP Layer, select one and click the Layers Operations button  at the bottom of the MAP Views 
panel. Click the Zoom to "[Layer]" in the context menu. When a MAP View is selected, this option becomes Zoom to all 
layers in "[MAP View]". This is particularly useful for documents containing a large number of layers.

Layers Operations
The Layer Operations button  will perform a variety of layer operations. If a MAP Layer is selected, use the 
context menu to Lock, Unlock, Hide or Show "[Layer]" or to Lock, Unlock, Hide or Show all layers except "[Layer]". If a MAP View is 
selected, the same options become for all layers in "[MAP View]" or all layers except layers in "[MAP View]".

MAP Layer Note
MAP Layer Notes contain general information about the layer, such as how it was created or on its source data. MAP 
Layers that have layer notes attached to them are indicated with the icon . MAP Layers with no layer notes are 
marked with . 

Layer notes can be automatically added when the layers are created through MAPublisher functions (e.g. MAP Data 
Import, Plot Centroids, Web Feature/Map Service, etc.). To do so, enable the MAPublisher General Preferences option 
Add notes for layers created by MAPublisher operations — see chapter 1 for details. The automatic notes show the function 
and parameters used to create it. For example a note of a layer created by import indicates information such as the 
path of the source data, format and date.

To add or edit a layer note, choose the MAP Views panel options menu Edit Layer Note. In the Add/Edit Layer Note 
dialog box, type new text or edit the existing information. Click the Clear button to clear all information.
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Export MAP Views and MAP Layers 

The MAP Views panel offers the option to export a single MAP View or a single MAP Layer  to a 
multitude of GIS formats. This function is explained later in this chapter.

New MAP View For Photoshop Paths
The New MAP View For Photoshop Paths function creates a new MAP View using a reference file and associated 
Adobe Illustrator file exported from Geographic Imager for Adobe Photoshop. 

Adobe Photoshop offers a function to create vector paths and export them to Adobe Illustrator. Adobe Photoshop 
uses Geographic Imager to maintain the spatial reference and outputs it as an .rsf reference file. To import the paths 
into Adobe Illustrator using MAPublisher, use the New MAP View For Photoshop Paths from the MAP View panel options 
menu to create a new MAP View based on the .rsf file. After doing this, the Adobe Illustrator layers can simply be 
dragged from [Non MAP Layers] to the newly created MAP View to finalize the georeferencing. The vector data can 
now be used in a current MAPublisher project, edited, transformed or exported to any external GIS format.

Remove MAPublisher Information
At the end of a project cycle, it may be useful to permanently remove all georeferencing and attribute information 
in the current document. This can be accomplished by switching all MAP Layer(s) to the [Non-MAP layers] category 
in the MAP Views panel via drag and drop or clicking the Switch Map View button  and the Remove GIS data option.

Note:	 This function should only be used as required and as a final step. Be sure to save a copy of the document 
before performing this operation as this will erase all attribute data.
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FUNCTIONALITY

The MAP View Editor displays and controls the geospatial parameters of the MAP View (coordinate systems and 
scale on the artboard), the position of the data extents on the page (alignment and rotation) and provides a way to 
change the MAP View name. A preview pane shows and allows users to move the current MAP View relative to the 
artboard and to the other MAP Views in the document.

The MAP View Editor is also where coordinate system transformations are performed. Transformations affect the 
data geometry on the page as map art is redrawn to match the new coordinate system properties.

MAP View Editor 
MAP Views panel > Edit MAP View / New MAP View, 

Advanced Import > Create New > Editor

Same as - Check this option to 
transform to a coordinate system 
used by another MAP View in the 

document

Specify Datum Shift - Change the 
datum shift for the transformation

Perform Coordinate System 
Transformation - Enable this option 

to transform the data to a new 
coordinate system

Specify - Open the Specify 
Destination Coordinate 

system dialog box to select a 
coordinate system

Preview Pane - Displays the data 
extents of the MAP View:

White rectangle - Artboard extents
Colour rectangle - Data extents of the 

current MAP View

Crosshair - Location of the current 
Map and Page Anchors

Configure Margins - Adjust the 
artboard margins

Show/Hide Preview Details - Display or 
hide the Map and Page Anchors 

and artboard margins

Name - Name of the MAP View 

Zoom buttons - Zoom in/out

Center active artboard on screen - Fit 
preview to the artboard extents

Move MAP View Mode - Move the 
position of the current MAP View

Center current MAP View extents on 
screen - Fit preview to the extents

Pan Preview Mode - Pan around the 
preview pane

Scaling - Maintain point size, stroke 
width and font size when scaling 

Previews and Configure Previews 
Select and configure how the 
previews are shown 

 Page Alignment -  Affects the position 
of the Page Anchor:
•	  LL X, LL Y - Position of the lower left 

corner of the data in document 
units

•	 Alignment Control - Click a position 
on the grid to control the 
alignment of the data extent 
relative to the page (e.g. center 
middle, upper right...)

Scale - Edit the MAP View scale 
relative to the page. Click Auto 

Scale to fit the data extents to the 
artboard or the margins.

Angle - Rotation angle of the MAP 
View. Click  to reset to zero; 

click  to orient the MAP View 
north up. 

Info - View the parameters of a selected coordinate system

Specify - Open the Specify Source Coordinate System dialog 
box to select a new source coordinate system. To be used 
only if the source coordinate system is undefined or is not 
matching the data.
To apply a new coordinate system to a MAP View, use 
Perform Coordinate System Transformation.

Clear - Remove all references to a coordinate system

From File - Load a source 
coordinate system from an 
external file

From File - Load a destination 
coordinate system from an 

external file

Source Coordinate System - Displays 
the current coordinate system 
assigned to the MAP View
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USING THE MAP VIEW EDITOR

The MAP View Editor can be accessed as part of the Advanced Import dialog box or from the MAP Views panel:
•	 Advanced Import: click the Create new option in the Destination MAP View section, and then click the Editor 

button to open the MAP View Editor. 
•	 MAP Views panel: select a MAP View, and then select Edit under the Options arrow in the upper right 

corner of the panel. Alternatively, double-click the MAP View name in the MAP Views panel.

Preview Pane and Configure Previews
By default, the Preview Pane displays the data extents with a green rectangle and the MAP View orientation with an 
arrow pointing north. To move the data on the page, click inside the green rectangle and drag the data to a more 
suitable position relative to the page. Use the Zoom In, Zoom Out and Center buttons to set the magnification of the 
preview. To move the page within the Preview Pane, click outside the MAP View extent and drag to move the page. 

The Previews drop-down list changes the preview to Coloured boxes (previews up to ten MAP views, each with 
different colours as specified in the Configure Previews settings), Thumbnails (preview a reduced image of the 
document contents, including all MAP views) and Thumbnails & Boxes (shows both thumbnails and coloured boxes 
of up to 10 MAP views in the document).

Note:	 Due to Adobe Illustrator rasterization limitations, thumbnails cannot be created for very large MAP Views.

To configure the previews, click the Configure Previews button . To adjust the colour of the current MAP View 
preview, click the colour chip and choose a colour in the colour picker dialog box. Layer visibility can be individually 
toggled under the Visible column. Use the Show All or Hide All buttons to toggle the visibility of the entire list. To 
toggle only the layers of a particular MAP View, right-click the MAP View to access a context menu that has the 
options to Show All or Hide All. Adjust thumbnail quality using the drop-down list at the bottom of the dialog box. 
Quality settings include: Low, Medium, High, and Very High.

Note:	 The Auto-Scale function will apply to the extent of the visible layers only.

MAP Layers

MAP View

Thumbnail quality

Current MAP View preview colour 
Click to change the colour

Toggle Visibility (layer's thumbnails) 

Toggle Visibility (MAP View's coloured box)
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MAP View Name
The current name of the MAP View is listed in the Name box, which is editable. MAP Views are ordered alphabetically 
in the MAP Views panel, so changing a MAP View name may change its position in the panel.

Scale
The scale of the current MAP View is shown in the Scale box. For MAP Views in a projected coordinate system, the 
scale value is a real world scale (exact ratio linear distance on the page over distance on the ground). For MAP Views 
in a geodetic coordinate system (i.e. Lat/Long format in angular unit), the scale value is approximated using the 
common formula 1°= 111.353m (metres per degree at the equator). This is not an accurate number because the 
formula is only valid at the equator, but it is more intuitive for cartographic considerations.

The scale can be edited by typing in a precise value or by using the Up and Down arrows to increase or decrease the 
scale by 10% of the starting value. The Auto Scale button applies the scale to fit the visible data in the preview to the 
artboard or margins and centers the map on the page (see Preview Pane). Click the Auto Scale drop-down arrow to 
use either the artboard or margins as the scale extent.

Rotation
A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the arrow buttons. 
Notice that changes to rotation will be automatically previewed in the Preview Pane with the green rectangle and 
arrow depicting the new orientation of the data. Click  button to reset the angle to 0. Click  button to orient 
the MAP View True North up (True North is calculated at the center of the data extents).

Page Alignment
During the import process, MAPublisher sets the page and map anchors so that the lower left corner of the 
artboard coincides with the lower left corner of the map extents. Note that Adobe Illustrator CS4 and CS5 use 
different locations for the page origin, with (0,0) being located in the lower left corner in CS4 and (0,0) located in the 
upper left corner in CS5. Use the Page Alignment settings to precisely move the data on the page. In the LL X/ LL Y boxes, 
edit the position of the lower left corner of the data extents in document units. Alternatively, the alignment control 
provides pre-set positions of the map extents relative to the page (center-middle, lower-left, upper-right, etc.). Click 
one of the alignment control grid locations to align the MAP View.

Notes:	 Editing the lower left corner position does not affect data integrity. It simply means that the data is shifted on 
the page but the corresponding real world coordinates remain unchanged. 
 
The Page Anchor does not always coincide with the lower left corner of the map extent. When manually 
registering an Adobe document, users can also enter a specific position using the MAP Views panel options 
menu Specify Anchors (see first section of this chapter).
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Set Source Coordinate System
In most cases, the MAP View source coordinate system is initially assigned during the import process if the imported 
data file contains such information (see chapter 3). To view the properties of the source coordinate system, click the 
info button.

If no coordinate system is recognized during the import, the resulting MAP View source coordinate system is set to 
[No Coordinate System Specified]. In order to rescale, rotate or transform the MAP View, a coordinate system must be 
specified. To do so, click the Specify button to open the Specify Source Coordinate System dialog box (explained below). 
Alternatively, use From File to set the source coordinate system using an external file (e.g. .wkt, .map, .prj, or .tab).

Note:	 If you are referencing a non-georeferenced Adobe Illustrator file, it is not enough to specify the source 
coordinate system to reference your map, you'll also need to specify appropriate map and page anchors. See  
Georeferencing an Adobe Illustrator file in appendix A1 General Tips. 

In some rare cases, the source coordinate system may have been wrongly assigned during the import process 
(due to a wrong manual selection or file issue). In this case, users may want to specify another coordinate system. 
This should be done with caution as data integrity may be lost if the current coordinate system is mistakenly 
overwritten. Changing the source coordinate system does not affect the data geometry on the page. To specify a 
new coordinate system for a MAP View, use Perform Coordinate System Transformation.

Coordinate System Transformation
To transform a MAP View to another coordinate system using the MAP View Editor, click the Perform Coordinate System 
Transformation check box (the MAP View must contain data and a source coordinate system for this option to be 
available). Users have three options to select the destination coordinate system:

•	 Select a coordinate system from the MAPublisher database: click the Specify button in the Perform 
Coordinate System Transformation frame to open the Specify Destination Coordinate System dialog box.

•	 Select a coordinate system used by another MAP View in the document: click the Same as check box and 
select the appropriate MAP View in the drop-down list. This does not affect the page position.

•	 Select a coordinate system from another file: click From File to set the destination coordinate system 
using an external file (e.g. .wkt, .map, .prj, or .tab).

The Preview Pane displays the new data extents for the transformed MAP View, however the thumbnails view is not 
available until the transformation is finalized by clicking the OK button in the MAP View Editor. 

Some coordinate system transformations require a datum shift. When this is the case, MAPublisher selects the most 
appropriate datum transformation. This can be edited by clicking the Specify button in the datum shifts frame and 
selecting another datum transformation (see appendix A2 and Avenza Projections Guide.pdf for more information).

Note:	 Coordinate system transformations can also be performed in the MAP Views panel. Simply drag a MAP layer 
from one MAP View to another MAP View of a different coordinate system.
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Specify Coordinate System
The Specify Source/Destination Coordinate System dialog box allows users to select, copy and edit coordinate systems and 
associated parameters from the MAPublisher coordinate systems (Geodetic Data Source). The MAPublisher Geodetic 
Datasource is explained in depth in Appendix A2.

Coordinate systems are divided in two categories: Geodetic and Projected. For convenience, they are sorted in sub-
folders by continent > country > sub-division (e.g. state or county). The *All* category lists all systems with no sorting; 
the *Recent* category lists the last 10 systems recently selected; the *Search* category lists the result of a coordinate 
system search. The MAPublisher coordinate systems may also contain custom systems.

New MAP Views
After clicking the New MAP View button, the MAP View Editor opens for users to set the name, coordinate system and 
page scaling of the new MAP View. After a new MAP View is created, the Specify Anchors option from the MAP Views 
panel must be used to define the tie-in point between Map Anchor and Page Anchor. Map Anchor coordinates can 
be entered in any chosen coordinate system (for example, latitude and longitude in degree for projected map). This 
functionality is explained in detail in Georeferencing an Adobe Illustrator file in appendix A1 General Tips. 

Long/Lat Order (optional)
Enable the Show Latitude/Longitude ordering option in the MAPublisher Preferences for MAP Views > Editor (see chapter 1) 
to see an additional item in the Lat/Lon Order drop-down list:

The latitude/longitude order—Longitude, latitude or Latitude, longitude—applies to the following tools or panels: 
MAP Location Tool, MAP Point Plotter and Line Plotter.

Scaling
When the map scale changes, the point size, stroke and text font are maintained by default. To alter how scaling 
affects these options, click the Scaling button in the MAP View Editor dialog box. In the Scaling dialog box, uncheck 
the preferred options.
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Multiple Artboards
Adobe Illustrator CS4 introduced the concept of multiple artboards (up to 100). MAPublisher uses this new feature 
in the MAP View Editor.

When a document contains multiple artboards, the MAP View Editor dialog box has an additional option to select 
the Active Artboard. When choosing the Active Artboard, the Preview Pane displays the number of each artboard. The 
current active artboard is shown in white, while the others are greyed out. The Page Alignment and Scale calculations 
are based on the Active Artboard dimensions.

To move the data extent (green box in the Preview Pane) from one artboard to another, change the Active Artboard 
number to the artboard where the data is to be moved, then click the Auto Scale button or one of the Page 
Alignment grid positions.

Artboards - Preview of all artboards  
present on the canvas

Active Artboard - White background

Other Artboards - Greyed out

Active Artboard- Select the number 
of the artboard to be set as Active

Note:	 Adobe Illustrator CS4 and CS5 allows users to move artboards. However, this action does not preserve the 
georeferencing (same effect as moving art on the active artboard). Instead of moving the artboard, users 
must do the following:

•	 Create a new artboard at the desired position on the canvas
•	 Open the MAP View Editor and move the MAP View from the initial artboard to the new one
•	 Delete the initial artboard
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Export 
MAP Views panel > Export and buttons  (MAP View)  (MAP Layer)

Dataset - Displays the directory path for 
the export of the currently selected 

layer or MAP View

Format - Select the export format for 
the selected layer or MAP View

Release - Specify the AutoCAD version 
number to export to

AutoCAD Settings

Keep format extension - Check 
this option to export layers 

with their feature extension 
(_area, _line, _point, or _text) 

which may have been 
appended to layer names 

during import

Include header 
Add the column 

headers at the 
first line of the 

exported text file

Settings - Opens a Settings dialog box for 
the input of extra parameters (see below)

Character Encoding - Assign a codec if the 
attribute information held in the selected 
layer or MAP View uses a double byte 
character set

General Settings
Delimited XY Text Data /  

Microsoft Excel

MicroStation Settings

EXPORT SETTINGS

Export visible attributes 
only - Check this 
option to export 
only the attributes 
that are currently 
visible in the MAP 
Attributes panel

Seed File - If required, select a seed file to be applied 
to the exported dgn file . Click Clear to remove the 
seed file selection.

Coordinate Units - Specifies how feature coordinates 
will be interpreted and converted (Master, Sub or 
Units of Resolution).

Allow area fills - Controls whether or not fill linkages 
will be written out for ellipses, shapes, and solids.

KML/KMZ SettingsGML Settings

Use attributes' Display Name instead of Name - Check this 
option to export the Display Name from attributes

Do not export attributes - Check this option for export 
to KML to be used in Google Maps (which does not 
support KML files with attribute values)X-Y Coordinate Ordering - Set the X-Y coordinate ordering 

for GML files. This may help in third-party software.

MIF/MID Settings

Delimiter - Set the field delimiters to either 
comma, semicolon or tab

E00 Settings

E00 Compression Level - Set the compression of 
the exported E00 file (default is None)

Suppress Pen and Brush lines - Check this option to 
remove all pen and brush styles in the output 
MapInfo MID/MIF files

Feature Collection Options - Select output GML schema
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FUNCTIONALITY

MAPublisher supports the export of single MAP Layers or whole MAP Views to various GIS and table formats, 
maintaining all georeferencing and attribute information. The following export formats are supported:

AutoCAD Drawing/Interchange (*.dwg, *.dxf )
Delimited Text Data (*.csv, *.tsv, *.txt)
Esri ArcInfo Generate (*.gen)
Esri Interchange File (*.e00)
Esri Shapefile (*.shp)
Image (*.tif with reference file, see chapter 12)

Microsoft Excel (*.xls)
GML (Simple Features 3.1.1) (*.gml, *.xsd)
KML/KMZ (*.kml, *.kmz)
MapInfo MIF/MID (*.mif, *.mid)
MapInfo TAB (*.tab)
Microstation Design (*.dgn)

Notes:	 Exporting a MAP View to CAD or MicroStation format will assemble all hosted layers into a single file. 
 
Exporting a MAP View to Flash map or Geospatial PDF is explained in chapter 15 and 16, respectively. 
 
Only Point MAP Layers can be exported to Excel and delimited text data formats.

PREREQUISITES

The Export function exports a single selected Adobe Illustrator layer contained in a MAP View or all layers contained 
in a selected MAP View. Both imported and user created MAP Views that contain MAP Layers are suitable for export 
to GIS formats. 

USING MAP EXPORT

Export a MAP View 
To export all the MAP layers within a single MAP View, select the MAP View to be exported in the MAP Views panel, 
then click the Export MAP View button . Alternatively, click Export "[MAP View name]" in the panel options menu.

Export a MAP Layer
To export a single layer, select the MAP Layer to be exported in the MAP Views panel, then click Export MAP Layer 
button . Alternatively, click Export "[MAP View name]" in the panel options menu.  In the Export layer dialog box, 
choose the required export Format. Click the Settings button for additional options.

Note:	 Only a single MAP View or a single layer can be exported at one time.

Keep Format Extension
The name of the MAP Layer or MAP View selected for export is the default name of the exported file. However 
the feature type text (i.e. _area, _line, _point, or _text) appended to Adobe Illustrator layers by MAPublisher in the 
Import process, are removed during the export process, unless the Keep format extension option is checked.
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Export Visible Attributes
Enable this option to export only the attributes that are currently visible in the MAP Attributes panel. If this option is 
not checked, all attribute columns (including MAPublisher #Property attributes) are exported.

Format Specific Settings
Depending on the selected export format, additional specific settings may be available. This is the case for the 
following formats: AutoCAD, Delimited XY Text Data, MicroStation, MID/MIF, E00 and KML/KMZ. See the Export 
Settings above. When exporting to KML/KMZ, specify the format extension (*.kml or *.kmz) in the Select Export File 
dialog box (Save As Type drop-down list).

Note:	 KML/KMZ format only supports WGS84 geodetic coordinate system. Export to KML/KMZ will automatically 
transform the vector data from the MAP View's coordinate system to this system as part of the export process.

Choose a Destination Folder
Most of the export formats require the selection of a destination folder only. For export to Esri or MapInfo formats, 
click the Browse button to specify a destination folder. Click the OK button to export your MAP Layer.
 
When exporting to AutoCAD format, it is required to specify a name for the exported file, and select the file extension 
(*.dxf or *.dwg) to be used. For MicroStation formats, it is required to specify a name for the exported file. To export 
to either of these formats, click the Browse button to name the export file, and then choose the file format from the 
Format drop-down list. 

ADDITIONAL NOTES

Valid Area Direction (Area Layer Exports)
When exporting area layers to GIS formats, polygon outlines must have a positive Area value, whereas holes 
contained inside compound paths (or complex shapes) must have a negative Area value. If some polygons in the 
#Area property column of the MAP Attribute table contradict these guidelines, use the following tools to convert 
the MAPublisher area calculation from a negative to a positive value or vice versa:

•	 Flip Lines tool (chapter 8) to convert multiple areas.
•	 Create a Selection Filter (chapter 11) to select all elements that have an #Area of less than zero (to select 

negative values) or greater than zero (to select positive values). Then use the Flip Lines tool.
•	 Edit the #AreaDirection property value (chapter 5) to convert areas one by one: select the area to edit 

and then choose the alternate value for #AreaDirection in the MAP Attributes panel.

Text Exports 
It is not possible to export values in the #Text property column. An alternative is to create a new string attribute 
column and assign it an expression of #Text. See Edit Schema in chapter 5 on MAP Attributes.

Texts on a path are exported as point text with an angle (main direction of the original path).
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Import MAP Objects 
MAP Views panel > Import MAP Objects or MAP Toolbar 

MAP Views - List of available 
MAP Views to import

MAP Themes - List of available 
MAP Themes to import

MAP Selections - List of available 
MAP Selections to import

Document - Available open 
map document

Import Toggle - Check to 
import the MAP Object

FUNCTIONALITY

MAPublisher Import MAP Objects copies MAP objects from one document to another, including all MAP Views and 
the layers that are within them, MAP Themes, and MAP Selections. This can be a useful tool when merging parts of 
several documents into a single document. For example, it might be useful to import a commonly used inset map.

PREREQUISITES

At least two documents must be open to use Import MAP Objects. The active document does not need to contain 
any MAP View, but the second document must contain at least one MAP View.

Note:	 Import MAP Objects imports all the layers contained in the selected MAP View. To choose specific MAP layers 
to import, in the source document, make a duplicate of the MAP View and copy or move only selected layers 
to it. Then proceed to import the duplicate MAP View.

USING IMPORT MAP OBJECTS

To access the function, click Import MAP Objects in the MAP Views panel options menu or click the Import MAP Objects 
button  on the MAPublisher Toolbar.

The Import MAP Objects dialog box shows all other documents currently open, along with all the MAP Views, MAP 
Themes and MAP Selections they contain. Select at least one MAP object to be imported into the current document 
and click OK to import it.

Note:	 Import MAP Objects can also be accessed from the MAP Themes and MAP Selections panel options menus.
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MAP Location Tool 
MAP Toolbar or Tools > MAP Location Tool  or

Window > MAPublisher > MAP Location

WX/WY - The X and Y coordinates of the 
cursor in current map units

Geodetic Longitude/Latitude - The longitude 
and latitude based on the geodetic 

datum of the coordinate system

WGS84 Longitude/Latitude - The longitude 
and latitude based on the World 

Geodetic System 

FUNCTIONALITY

The MAPublisher Location Tool panel displays the coordinates of the mouse cursor on the selected map layer, in 
current Map Units and in Degrees. Geodetic latitude and longitude values are in reference to the geodetic datum set in 
the coordinate system definition. The WGS84 latitude and longitude values are in reference to the World Geodetic 
System. Ungeoreferenced layers display its coordinates in Page Units. The panel also displays the Map and Page Anchors, 
the Scale, Angle of rotation and the Coordinate System and Units of the MAP Layer.

The MAP Location Tool also enables the X and Y position of the cursor in the current map units (WX and WY) to be 
copied to the clipboard. An example of a use for this function is to build point files in an external text editor; files 
which can be imported with MAPublisher. Coordinates are copied with the X value first and Y value second, and are 
delimited by a comma. For example: -79.396527,43.631979.

USING THE MAP LOCATION TOOL

To use the MAP Location Tool, click the  button in Adobe Illustrator Tools panel, in the MAP Toolbar or open the 
panel through Window > MAPublisher > MAP Location. The map coordinates update in the panel with every change 
of the location of the mouse cursor.

The map units correspond to the units of the currently selected layer. If the selected layer is a MAP Layer, the units 
are taken from the MAP View's source coordinate system. If the selected layer in a Non MAP Layer, the units of the 
Adobe Illustrator documents are used (see File > Document Setup). 

Notes:	 The map coordinates update even when other tools are selected. 
 
When the cursor is placed outside of the MAP View extent of the selected layer, positions' values are 
indicated as Unavailable.

Copy Notification - When the MAP Location tool is 
selected this description is enabled. Shift+click copies 
the current X and Y coordinates of the mouse cursor.

Displays the parameters of the currently selected layer.

Scale - Map scale of the current layer

Map X/Y - Map anchors

Units - Units of the coordinate system 
(if specified)

Coordinate System - Coordinate system of the 
current layer (if specified)

Page X/Y - Page anchors

Angle - Angle of rotation
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When the MAP Location Tool button is enabled in the Adobe Illustrator Tools panel, users are able to copy the 
coordinates of a specific location (position of the cursor). The appropriate layer must be selected in the MAP Views 
panel as the MAP View containing the layer will determine the MAP units and coordinate system used to display the 
geographic position. To copy the position to the clipboard:

•	 Position the cursor at the desired location

•	 Hold the Shift key and click the mouse

The X and Y position are copied to the clipboard and can be pasted into any text editor. Latitude and Longitude 
values are also copied if this is enabled in the MAP Location Tool preferences (see below). Only one set of 
coordinates can be copied at once. When Shift+click is used again, the values previously copied will be overwritten.

MAP LOCATION TOOL PREFERENCES

The MAPublisher Preferences for the MAP Location Tool can be accessed from the menu Edit > MAPublisher 
Preferences or by double-clicking the MAP Location Tool button  in the Adobe Illustrator Tools panel.

In the MAPublisher Preferences dialog box, specify the latitude/longitude display format and number of decimals. 
Enable the option Include Latitude and Longitude values when copying coordinates to copy both the X/ Y and 
Lat/Long positions when using Shift+Click (see above).

The order of the Longitude and Latitude captions can be swapped by changing the Long/Lat Order option of the layer's 
MAP View. See the MAP View Editor Preferences in chapter 1.
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MAPublisher can import GIS files into Adobe Illustrator while 
maintaining both geographic referencing and attribute 
information. This makes it very easy to produce high quality 
maps. 

Attribute information can be used in many powerful 
MAPublisher functions such as MAPublisher labeling engines, 
MAP Themes, MAP Selections and MAP Web Author.

This section explains the principles of attribute information 
and how they are manipulated within MAPublisher. 

Topics covered in this section are:
Attributes Foreword
MAP Attributes Panel
Edit Schema
Expression Builder
Find & Replace Attributes
Apply Expression
Join Table
Export Attributes

MAP 
Attributes
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Attributes Foreword 

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of the data set. It is in the 
attribute table that we find important information such as street names for lines, zoning or zip code numbers for 
areas and elevations for points to go along with our line, area or point vector data. Along with line, area and point 
vector data imported as explained in the previous sections, MAPublisher also imports the attribute data table 
associated with any vector map file that it supports. 

MAP LAYERS

All MAP Layers contain attribute information (except Legend MAP Layers). Each MAP Layer is symbolized in 
MAPublisher panels and dialog boxes with an icon depicting its feature type:

Area layer (e.g. county boundaries, urban areas, country outlines)

Line layer (e.g. rivers, roads, railways)

Point layer (e.g. town and city symbols, railway stations)

Text layer (e.g. city labels)

Image layer (e.g. background terrain shading, orthoimagery)

MAPUBLISHER #PROPERTY ATTRIBUTES

In addition to the attribute values that were imported into a work session, Area, Line, Point, Text and Image MAP 
Layers are also assigned a number of additional MAPublisher attribute columns. These property columns (prefixed 
with a #) are designed to indicate the physical properties of map art on the Adobe Illustrator canvas. Art can be 
modified directly from the attribute table by making edits to values in these columns. The following property 
columns are attached to valid map layers in this version of MAPublisher:

 Area layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The  name of the polygon. Editing this property will change the name in the Layers panel. 
#AreaDirection	 The direction as clockwise or counter-clockwise. Editing it will reverse the direction.
#VertexCount	 The number of points in the art. This property cannot be set.
#Style	 The Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 The stroke weight of the path. Editing this property will alter the stroke weight of the art.
#Perimeter	 The perimeter of the area in world units. This property cannot be set.
#PathClosed	 Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#ArtScale	 The scaling of the line stroke. Editing this value will scale the stroke weight.
#Area	 The area of the path in world units. This property cannot be set.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.
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 Line layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the polygon. Editing this property will change the name in the Layers panel. 
#VertexCount	 The number of points in the art. This property cannot be set.
#Style	 The Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 The stroke weight of the path. Editing this property will alter the stroke weight of the art.
#PathClosed	 Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#Length	 The length of the path in world units. This property cannot be set.
#ArtScale	 The scaling of the line stroke. Editing this value will scale the stroke weight.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.

 Point layers
#LayerName	 The name of the containing layer. This property cannot be set.
#PageX	 The x-coordinate in the document units of the current point. 
#PageY	 The y-coordinate in the document units of the current point.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the point. Editing this property will change the name in the Layers panel.
#HorizontalScale	 The horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
#VerticalScale	 The vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
#Rotation	 The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 The Symbol in use. Editing this property will apply the selected symbol to the art.
#MapX	 The x-coordinate in the world units of the current point. 
#MapY	 The y-coordinate in the world units of the current point.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.
 

 Text layers
#LayerName	 The name of the containing layer. This property cannot be set.
#PageX	 The x-coordinate in the document units of the current point text. For text-on-a-path or  text-in-a-		
			        path, this will be the x-coordinate of the first vertex on the associated path.
#PageY	 The y-coordinate in the document units of the current point. For text-on-a-path or text-in-a-path, this 	
			        will be the y-coordinate of the first vertex on the associated path.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#FontSize	 The font size used by the text.
#FontFamily	 The font family used by the text.
#Name	 The name of the text field. Editing this property will change the name in the Layers panel.
#Text	 The contents of the text. Editing this property will edit text on the page.
#TextLength	 The number of characters in the contents of the text art. This property cannot be set.
#Rotation	 The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 The Character Style in use. Editing this property will apply the selected style to the art.
#MapX	 The x-coordinate in the world units of the current point. 
#MapY	 The y-coordinate in the world units of the current point.
#HorizontalScale	 The horizontal scaling of a point object. Editing this value will scale the text in the X axis.
#VerticalScale	 The vertical scaling of a point object. Editing this value will scale the text in the Y axis.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art. 
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 Image  layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the text field. Editing this property will change the name in the Layers panel.
#PixelWidth	 The number of pixels across the width of the image.
#PixelHeight	 The number of pixels across the height of the image.
#Opacity	 The opacity level of the image. Editing this property will change the opacity of the image.

Warning:	 The #ID property is not persistent. This means that if a document is saved and re-opened, the #ID value 
might change. The value will usually not change over the life of a document session, but there are Adobe 
Illustrator operations that can cause the value to change.

IMPORTANT ADOBE ILLUSTRATOR COMPATIBILITY NOTES

Some Adobe Illustrator functions may cause the link between artwork objects and their attributes to be broken, 
resulting in possible data loss. These functions are:

•	 Compound path (Make)
•	 Pathfinder
•	 Live Paint
•	 Gradient mesh
•	 Blob brush (Adobe Illustrator CS4)
•	 Shape-builder tool (Adobe Illustrator CS5)

By default, releasing a compound path also breaks the link between released paths and the attributes. To avoid 
this behaviour, users may enable the option Replicate attribute data to compound path sub-components in the MAPublisher 
Preferences for MAP Attributes. This option must be enabled before the attribute schema is created or updated for 
the attribute data to be copied to the compound path components. To fully enable this option, follow the simple 
steps below:

1.	 Enable Replicate attribute data to compound path sub-components.
2.	 Change the visibility status of one attribute column to force the attribute schema to update itself.
3.	 Release the compound path.

Note:	 This option has an impact on performance, so it should only be enabled if necessary. 

If required, users should first duplicate their working layer in the Adobe Illustrator Layers panel before using these 
functions. The original layer can be kept for labeling (see chapter 10 and 18) or for information purposes.
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MAP Attributes Panel
Window > MAPublisher > MAP Attributes and MAP Toolbar 

Attributes and Properties 
Attribute and property 

values on the selected layer 
are displayed here

Edit Schema - Edit the properties of 
all columns of the current attribute 
table: column names, visibility, 
type and width, assign expressions 
to columns

Pin Current Selection - Attributes are 
remain active after unselecting art

Click header to sort column 
values alpha/numerically

Delete Column - Delete the 
currently selected column

Edit Column - Edit the properties 
of the selected column

Right-click (Windows) or Ctrl-click (Mac) to display the menus:

Show/Hide Columns - Enable or 
disable column names to show or 
hide columns. Or choose to show 
all columns, or hide all columns.

FUNCTIONALITY

The MAP Attributes panel displays the map attribute and property attribute records for a map layer, which are 
linked to the graphic elements of the map, and makes them available for editing. This panel is also the hub from 
which you can edit column schemas, toggle visibility, add or delete columns, join tables, find and replace attributes, 
and apply expressions to selected art. Only the visible attributes of selected map features will be displayed in the 
dialog box.

USING THE MAP ATTRIBUTES PANEL

Viewing Attributes
Selected features are sorted by layer. The Layer drop-down list shows all the layers that currently have features 
selected, as well as the number of selected map objects for each layer (also reported at the base of the panel). The 
attribute values displayed in columns in the MAP Attributes panel can be sorted in ascending or descending order 
by clicking the column header. The widths of the columns may be changed by clicking the column separator and 
manually dragging it to resize as desired. Use the recordset navigation controls to scroll through table entries.

Zoom to Feature - Click the Feature 
number or right click the attribute 
and select Zoom to Feature

Highlight Feature - Click the feature 
attribute to highlight that feature 
on your map

Layer Selection - If data is 
selected on a number of 

layers, select the map layer 
containing the attributes to 

be viewed with this list

Hide Column - To hide the 
currently selected column

New Column - Adds a new 
column to the attribute table

Join Table - Click to join an external data 
table to the current attribute table

Apply Expression - To assign attribute 
values or graphical properties to 
selected art via the input of an 
expression

Find & Replace - Click to find and 
replace attributes in the current 
attribute table

Export attributes - Export all 
selected attribute information 
to a delimited text file

Preferences - Opens the MAP 
Attributes panel preferences 
(see chapter 1)

Selected objects - Number 
of objects selected on the 

current layer

Recordset Navigation - Navigate 
through table records using 
these controls and indicator

Context menus

In column header: In a row: 

Panel options menu:

Resize all to fit content 
Resize the width of all columns 
to fit the longest value

Resize [column] to fit content 
Resize only the selected 
columns

Add Calculated Data - Add or 
edit an attribute column with 
calculated data

Auto-Zoom - When enabled, the 
map document will zoom to the 
selected attribute automatically
Lock Zoom Level - When enabled, 
locks the zoom level
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The type of attribute is indicated by an icon preceding the column name :

Boolean: column contains True or False values

Integer: column contains only whole numbers (limited to 10 digits)

Real: column contains numbers carrying decimal values

String: column can contain attributes that are both alpha and numeric

Edit Attributes
MAPublisher MAP Attributes panel is a fully editable spreadsheet environment. All attribute values may be edited 
except for certain MAPublisher Property attributes (see earlier in this chapter). To change the value of a cell, 
double-click it and enter the new value. Keep in mind that entered values must correspond with the column type 
(i.e. only enter numbers into a column of type Real or Integer). The edits will be immediately reflected in the map 
documents database records. Existing attribute records may also be edited or modified by performing a find and 
replace operation on them.

Column Visibility
Click the Show/Hide Columns button (or right-click [Windows] or Ctrl+click [Mac] on a column in the dialog box) to edit 
the column visibility, either toggling visibility for individual columns or for all columns. It is also possible to edit the 
visibility of attribute columns with the Edit Schema tool.

This function will also Show All, Show All Except Properties (show only attributes that are non-property attributes, 
consequently hiding any visible property attributes) or Hide All.

Zoom to Feature and Auto-Zoom
To zoom into a specific feature in the attribute table, select a single attribute and click the Zoom to Feature button. This 
will automatically fit this feature to the screen and highlight it—useful for closer examination or to simply locate it 
on the map. To highlight a specific feature on the page maintaining the current zoom level, click another attribute 
of that feature.

To automatically zoom to a selected feature, enable Auto-Zoom in the panel options menu. As long as it is enabled, 
the zoom will change every time a different feature is selected. Use Lock Zoom Level to maintain the same zoom level 
for all features selected afterwards.

Property Attributes
The attribute table can also be configured to display property attributes for datasets. These attributes describe the 
current assignment of graphical properties such as the stroke weight, style, rotation and scale. Some of these fields 
can be edited and provide the ability to modify a map object's graphical properties directly within the context of 
the MAP Attributes panel.

Pin Attributes
Click the Pin button to keep selected attributes active even after the artwork is unselected. This may be helpful 
during attribute editing when accidentally unselecting artwork may occur. To unpin attributes, click the Pin button 
again. When attributes are pinned, attribute values can be manually edited but the functions at the bottom of the 
panel are disabled except for Zoom to Feature (Show/Hide columns, Edit Schema, Find and Replace, Apply Expression, 
Join Table and Add Calculated). The Export Attributes function is also disabled.
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Edit Schema 
MAP Attributes panel > Edit Schema / Edit Column / New Column

In MAPublisher, the term schema is used to define the structure of the MAP Attributes table. 

FUNCTIONALITY
The Edit Schema function provides settings to edit and manage the attribute structure of datasets, create, edit and 
delete columns, set visibility preferences and assign expressions. Any changes made to the schema will instantly be 
reflected in the MAP Attributes panel.

USING EDIT SCHEMA 
Select map artwork containing attributes to populate the MAP Attributes panel. Click the Edit Schema button or 
menu item in the MAP Attributes panel options menu to open the Edit Schema dialog box.

Note:	 Edit Schema can also be accessed via the Edit Column context menu. Within the MAP Attributes panel, select 
the column to be edited, right-click the column heading or cell and click Edit [column name]. Edit Schema opens 
with the same column immediately selected in the column list.

Edit Schema lists all of the columns which currently exist in the MAP Layer attribute structure, including MAPublisher 
Property attributes (see previous section). By default, imported or created attributes will be visible, whereas property 
columns will not be shown by default. Please note some #Property column structures cannot be edited (read-only).

Edit Column Format 
Each column has a name and display name. The name is used in the expression builder and for export. The display 
name is used when exporting to geospatial PDF (see chapter 16) and is shown by default in the column name in the 
MAP Attributes panel (see MAPublisher Preferences in chapter 1).

Punctuation characters are not supported in column names in order to avoid potential conflicts when exporting to 
external formats. The following illegal characters are replaced with an underscore '_' upon data import or join table: 

space ` ~ ! @ # $ % ^ & * ( ) - + = { } [ ] | ; : " ' \ , < . > / ?

Up / Down - Click to move the 
selected column up or down 
the column list. Affects order 

in the attribute table.

Column list - Attribute and  
(#) property columns on the 
current layer are listed here.
Select a column here to edit 

its properties on the right.

Add - Click to add a new 
column to the column list 

Remove - Click to delete 
the selected column

Name - Edit the name of the 
selected column

Display Name - Edit the column 
display name

Type - Choose column type:  
Integer, Real, String or Boolean

Size / Decimals - Adjust the length 
of String type or number	  
of decimals of Real type

Default Value - Assign the 
same value to all items in the 
selected column, if required

Visibility - Choose to show or 
hide the selected column

Read-only - Check this option 
to ensure that values in this 
column can not be editedDerive value from expression - Check this option to assign 

an expression to the selected column. Either enter 
the expression directly into the entry field, or click the 
Browse button to access the Expression Builder dialog box.
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To rename a column enter new text directly into the Name field. All expressions referring to this attribute name are 
updated instantaneously.

Note:	 Some external file formats have limits on the number of characters allowed for field names. Therefore, during 
the export from MAPublisher, some field names may get truncated to comply to the chosen external file 
format. For example, Esri shapefiles are limited to 10 characters (confirmed up to ArcGIS 9.3), Esri Interchange 
File (.e00) to 16 characters, and MapInfo to 30 characters.

Once the name is set, specify a data type by making the appropriate selection in the Type list.

To modify the amount of characters or decimals, enter a value into the Size/Decimal text box (the maximum string 
size is 28000). A Default Value can be assigned for all new objects placed on the selected layer by entering text 
accordingly. Check or uncheck the Visible option to edit a column’s visibility. Check or uncheck the Read-only option 
to edit a column’s read/write status. 

Check the Derive value from expression option to assign an expression to the selected column. Enter a valid expression 
in the Expression field or click the Browse button to enter and edit expressions via the Expression Builder dialog box. 
The Expression Validity icon  will report if the expression entered is valid. Otherwise it will report  and include 
additional warning notes. This function is useful, for example, to populate the column values based on the contents 
of other columns and/or mathematical formulas.

Note:	 Values derived from expressions are dynamically linked to the attributes used in the expression. Therefore, 
they are read-only. Use the Apply Expression function to generate values that can be modified. 

The following are some examples of basic expressions that can be assigned to columns in Edit Schema:

Basic expression Result

“Ontario” (applied to column = NAME) All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style) All area items are assigned the value “MAP Area 01” in the #Style column and 
are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to column = #Rotation) All point items are assigned the value 45 in the #Rotation column and are 
rotated to 45° on the page.

Note:	 String values are case-sensitive and must be entered between quotation marks (“...”).

Add, Delete and Re-Order Columns
Columns display in the MAP Attributes panel according to the display order established in Edit Schema. The display 
order of attribute columns in the MAP Attributes panel can be set by reordering the existing column list. Any 
column may be moved up or down the list by selecting it and clicking the Up or Down buttons.

To create a new column, click the Add button and input the desired column properties. To delete an existing column, 
choose it from the column list and click the Delete button. Click OK to confirm the edits to the schema. These edits 
will be immediately visible in the MAP Attributes panel.
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Expression Builder
Accessed from Edit Schema, Apply Expression, New/Edit MAP Selection,  

Edit Chart Theme, Edit Stylesheet Theme, Rule Generator

Expression Validity - Indicates if the 
expression is valid  or invalid . 

If invalid, additional info is reported.

Advanced toggle - Click to show or hide 
the Expression Components section

Objects - List of attribute and property 
columns, constants and functions for 

use in the expression. Double-click 
items to insert into expression.

Layer attributes - List of the attribute and 
property columns

Constants - List of constants for use in the 
expression if required

Functions - List of functions for use in the 
expression if required

Description - Displays information about 
the selected item in the Objects panel, 
i.e. a description and example of the 
function or constant, or information 
regarding the format of the MAP layer 
along with its attribute values.

When selecting an attribute, click the 
link Display unique values* to display 
the attribute values of the selected 
attribute column.

Cursor Position - Position of the current 
text entry point

Operator buttons - Click to insert an 
operator into the expression at the 

current cursor position

Expression Entry - Area to compose 
expressions

Expression Builder

Library - Access all expressions for the 
document including recently used, 
attribute filters, named expressions

Save - Save the current expression to a 
named expression.

*Display unique values only lists up 
to a maximum set in the MAPublisher 
Preferences for the Expression builder (see 
chapter 1 for more information)

Save Expression
This dialog box appears when the Save button is clicked

FUNCTIONALITY

The MAPublisher Edit Expression tool is used for the entry and editing of expressions. It is used in a number of 
locations such as creating new attribute values and properties, making selections or apply styles. Expressions are 
built using a combination of names, operators and functions.

Edit Expression provides functionality for a number of tools:

Edit Schema: To create or edit an expression for the generation of values in an attribute or column.
(MAP Attributes panel > Edit Schema > Derive value from expression)

Apply Expression: To apply an expression to an attribute or property column for selected art only.
(MAP Attributes panel > Apply Expression)

New/Edit MAP Selection (chapter 11): To create or edit expression criteria for use in selecting map data.
(MAP Selections panel > New/Edit MAP Selection)

Edit Stylesheet Theme (chapter 9): To create or edit an expression for use in styling map data.
(MAP Themes panel > Edit [Stylesheet Theme name] > Advanced Expression mode



106 Chapter 5: MAP Attributes
Expression Builder

ENTER EXPRESSIONS

Expressions can be built by typing or by clicking the operator buttons and items in the Objects list (attribute name 
and values, constants and functions). These items are colour coded for easy identification: attribute names in 
purple, string values in orange, operators and numerical values in grey, constants in green and functions in black. 
Click any of the operator buttons or double-click an item from the Objects list to insert it into the expression.

It is recommended to use the interface rather than the keyboard to build expressions, to guarantee functions are 
formatted correctly (e.g. with brackets and appropriate case) and for attribute values of type strings, quotations 
marks are added automatically. Note that expressions are case-sensitive. For string comparison, all strings values 
can be converted to a same case using the appropriate function (LOWER(“string”) or UPPER(“string”)).

Validity
The validity of the expression will be displayed below the Expression Entry text area and will be updated as the 
expression is built. The Expression Validity icon  will report if the expression entered is valid. Otherwise it will report 

 and include additional warning notes. 

Operator Buttons
Click to insert an operator at the current cursor position. Available operators are as follows:

( Open clause operator < Logical less than comparator
) Close clause operator > Logical greater than comparator
AND Logical AND operator + Mathematical addition operator
OR Logical OR operator - Mathematical subtraction operator
= Logical equal to comparator / Mathematical division operator
!= Logical not equal to comparator * Mathematical multiplication operator

& Text concatenate operator
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Expression Components 

Items in the Objects list are divided 
into three function categories: 
math, string and miscellaneous. 
Information on a selected item is 
displayed in the Description panel. 
Double-click to insert an object at 
the current cursor position.

Function Description
ABS Absolute value of a number
ACOS Inverse of the cosine of an angle
ASIN Arcsine of an angle
ATAN Arctangent of an angle
CONTAINS True if source string contains search string
COS Cosine of an angle
DEGREES Converts values from radians to degrees

<MAP Layer>* ENDSWITH Returns true the source string ends with the suffix string
List of attribute columns† FIXED Numbers as string values
List of #property columns IF Conditional statement

IF_CASE Conditional statement based on multiple cases
LEFT Extracts the first N characters of a string

Constants LENGTH Returns the number of characters in a string

 #false	 Boolean false value LIKE Searches the source string using wild cards

 #true	 Boolean true value LOG Gets the logarithm of the value (base 10 log)

 #pi	 π numerical value (3.141592) LN Gets the natural logarithm (base e log, e = 2.718281828)

MAX Returns biggest attribute value
MAX_COLNAME Returns name of attribute which has biggest value
MIN Returns smallest attribute value
MIN_COLNAME Returns name of attribute which has smallest value
LOWER Converts string to lower case
MID Extracts N characters of a string from a specified location
NUMBER String values as numbers
POW Base to the power of an exponent
PROPER Strings converted to capital case
RADIANS Converts values from degrees to radians
RAND Generates a random value between zero (min) and value (max)
REGEX Searches the source string using a regular expression
RIGHT Extracts the last N characters of a string
ROUND Rounds to specified decimals of precision

ROUNDDOWN Rounds down to specified decimals of precision
ROUNDUP Rounds up to specified decimals of precision
SEARCH Returns the position of a character in a string
SIN The sine of an angle
SPLIT Splits a string and extracts the indexed part of it

SQRT Square root of a value

STARTSWITH Returns true if the source string starts with the prefix string

SUBSTITUTE Replaces a set of characters by another in a string

SUBSTITUTE_RX Replaces a regular expression by characters in a string

TAN Tangent of an angle

TRIM Removes all spaces in a text (except single ones between words)

UPPER Converts string to upper case

* Layer may vary depending on tool. 
For Edit Schema, Apply Expression 
and New/Edit MAP Selections, the 
current layer is displayed. In Edit 
Stylesheet Theme, all layers hosted by 
the stylesheet are displayed.

† Unique values contained in each 
attribute column can be viewed in the 
Description panel.

Notes:	 String values are case-sensitive 
and must be entered in double 
quotes (“...”). 

For functions using indexes for 
text position (MID, SEARCH and 
SPLIT), the first index number 
is 0.
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Examples of Basic Expressions

APPLY EXPRESSION

Expression Result

“Ontario” (applied to column = NAME) All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style) All area items are assigned the value “MAP Area 01” in the #Style column 
and are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to column = #Rotation) All point items are assigned the value 45 in the #Rotation column and are 
rotated to 45° on the page.

MAP SELECTIONS

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
selected.

NAME = “Ontario” OR NAME = “Alberta” All items with the value “Ontario” OR “Alberta” in the NAME column are 
selected.

NAME = “Ontario” AND POPULATION < 1000000 Only the items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are selected.

MAP THEME STYLESHEET

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are assigned the 
selected style.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta” All items with the value “Ontario” OR “Alberta” in the NAME column are 
assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000
Only items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are assigned the 
selected style. 
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EDIT SCHEMA

Expression Result

LOWER(NAME) (applied to column = name) All items in column name are assigned the value of the column NAME in 
lower case (e.g. “ontario” for “Ontario”)

PROPER(name) (applied to column = Proper_name) All items in Proper_name are assigned the value of the column name in 
proper case (or capital case) (e.g. “Ontario” for “ontario”)

TRIM(JOINING_COLUMN)

All items are trimmed with all spaces except single ones between words 
(e.g. "   Route        66 " becomes "Route 66"). This is particularly useful prior 
to using the Join Table function because extra spaces at the beginning, 
end or in between words will cause the join to fail. 

Examples of Complex Expressions
MAP SELECTIONS or MAP THEME STYLESHEET

Expression Result

LIKE (NAME, “*New*”) All items with the string of letters "New" in the NAME column are selected 
(e.g. “New Brunswick” and “Province of Newfoundland”)

STARTSWITH (NAME, “o”) All items that starts with the letter “o” (“Ontario”) are selected.

EDIT SCHEMA

Expression Result

ROUND((POPULATION/ AREA ),3) 
(applied to column=density)

All items are calculated as “population divided by area”, rounded to three 
decimals.

IF_CASE("null", VALUE>0,"positive",VALUE<0,
"negative")

A default status of "null" is assigned unless the value is strictly greater than 
or less than zero.

SUBSTITUTE_RX(ROAD_NAME,"\D","")

All non digit characters (\D is the regular expression for non-digit char-
acter) are replaced by nothing (two double-quotes indicate that the new 
string is blank), therefore only numerical values are kept. For example, if 
the ROAD_NAME equals "Route 66", the result is "66". This can be useful to 
prepare an attribute table prior to labeling roads with road number rather 
than road names.

SPLIT(GEOLOGIC_UNIT,"(",0)

All items containing one or more open parenthesis are split in several text 
blocks (as many as there are open parenthesis, plus one), and returns 
the first block found (index 0). For example, if GEOLOGIC_UNIT equals 
"Qmw(Qc)", the result is "Qmw".

SUBSTITUTE(SPLIT(GEOLOGIC_
UNIT,"(",1),")","")

Removes all closing parenthesis (i.e substitute all closing parenthesis  
with nothing) in the result of the same SPLIT as above, that returns the 
second text block found (index 1). For example, if GEOLOGIC_UNIT equals 
"Qmw(Qc)", the result is "Qc": first the SPLIT function returns "QC)" and 
then ")" is removed with a SUBSTITUTE.

More examples of each individual function can be found in the Expression Builder dialog box. Expand the Expression 
Components, choose a function or constant on the Objects list and the Description tab is updated with explanations 
and examples.



110 Chapter 5: MAP Attributes
Expression Builder

EXPRESSION LIBRARY

Expressions already entered in the MAP Attributes panel, MAP Themes stylesheets (see chapter 9) or MAP Selections 
panel (see chapter 11) can be reused by selecting them from the Expression Library. 

Expressions are sorted in three categories: Recent, Named Expressions or Attribute Filter. One or more entries can be 
selected per category. Click the Insert button to add the selection to the Expression Builder—multiple selections are 
concatenated with the AND statement.

Note:	 It is not possible to insert multiple expressions from different categories at once.

Recent Expressions
Expressions in the Recent tab of the Expression Library are expressions saved in memory for the time of the Adobe 
Illustrator session (they are reset if the document is closed). They correspond to expressions recently typed 
in the Expression Builder from the MAP Attributes panel or MAP Themes stylesheets but were not saved as a 
Named Expression.

To delete a recent expression, select it in the Expression Library dialog box and click the Delete button.

Recent Expressions 
List of expressions recently 

used in MAP Attributes or 
MAP Theme Stylesheets 

during the current session.
Select one or more entries 

in the list.

Insert - Adds the selection 
to the expression builder. 
Multiple selections are 
concatenated with the AND 
statement.

Close - Closes the dialog 
without adding expressions

Delete - Delete the selected 
expression (enabled 

for Recent and Named 
Expressions only)

Note:	 In the MAP Attributes panel, expressions are saved in the recent list only when the Edit Schema dialog 
box is closed.
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Named Expressions
Expressions entered in the Expression Builder can be saved as a Named Expression by clicking the Save button. Unlike 
the Recent expressions, named expressions are saved within the Adobe Illustrator document. They are listed in 
the Named Expressions tab of the Expression Library. To delete a named expression, select it in the Expression Library 
dialog box and click the Delete button.

Named Expressions - Lists 
all the expressions saved 
through the Save Named 

Expressions dialog box.
Select one or more 

entries in the list.

Attribute Filter Expressions
The Attribute Filter tab of the library lists the expressions in use in the MAP Selections of type Attribute Filter. See details 
on the MAP Selections panel in chapter 11. Attribute Filter expressions cannot be deleted from the Expression 
Library (only the the MAP Selections panel).

Attribute Filter Expressions 
Lists the Attribute Filter 
expression saved in the 

MAP Selections Panel 
(see chapter 11).

Select one or more 
entries in the list.
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FUNCTIONALITY

The Find & Replace tool provides settings to search and/or replace attribute values and properties contained in the 
MAP Attributes panel. Note that only values in visible columns can be found and/or replaced.

USING FIND & REPLACE 

Click the Find & Replace button at the bottom of the MAP Attributes panel or choose it from the panel options menu.

Find Only
Click the Find tab and enter the search criteria directly into the Find what entry field (previous criteria can be selected 
from the list). A search may be performed on all attributes by default, or only on specific columns contained within 
the MAP Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further 
refined by enabling the Case sensitive and Match whole word only options. 

Click the Find Next button to perform the search. Search results can be seen in the MAP Attributes panel; the column 
header and row number containing the first matching record will be displayed in bold text. At this point, a search 
for individual records can be done again by clicking the Find Next button. 

Find & Replace
To replace records selected through the Find operation click the Replace tab. Find & Replace criteria can be typed 
directly into the Find what and Replace with entry fields (previous criteria can be selected from the lists). A find and 
replace may be performed on all attributes by default, or only on specific columns contained within the MAP 
Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further refined by 
enabling the Case sensitive and Match whole word only options. 

There are two methods to replace values. The first method requires approving each replacement manually by 
clicking the Replace button so that each instance of the attribute located via the search parameters is successively 
replaced in the map attribute table. The second method allows for the replacement of all found records 
simultaneously, accomplished by clicking the Replace All button. 

Find & Replace Attributes 
MAP Attributes panel > Find & Replace

Find / Replace - Choose to Find variables, or to Find 
and Replace variables simultaneously

Find what - Enter a variable on which to perform a 
search in the current attribute table. Note this list 

will also contain previous criteria.

Replace with - Enter a variable on which to replace 
found items. Note this list will also contain 

previous criteria

Find/Replace All Attributes / Just in Column - Perform 
the Find or Find & Replace on all attributes in the 

current layer or only in a specified column

Find Next - Move to the next value matching the 
Find what variable

Replace - Replace the selected value with the 
Replace with variable

Replace All - Replace all occurrences matching the 
Find what variable

Case sensitive - If checked, only values matching the 
case of the Find what variable will be found

Match whole word only - If checked, only words 
matching the Find what variable will be found 
(words containing the variable will be ignored)
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FUNCTIONALITY

Use the Apply Expression function to assign new values or edit attribute properties. For example, it can be used 
to compute attribute values based on the values in other columns, to assign a style by editing the #Style property 
attribute, or to rotate symbols by assigning a fixed value to the #Rotation property attribute. Read-only attributes 
cannot be edited with Apply Expression.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected 
immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can 
be generated and applied to data based on the values found in an existing attribute column, providing a one-step 
process to transform a vast number of different objects in a single operation. 

Note:	 Unlike the Derive Value From Expression option in Edit Schema, values computed through Apply Expression are not 
tied to the original attributes constructing the expression and can be edited later on. Only currently selected 
artwork is affected by the changes.

APPLY EXPRESSIONS  

Ensure the data required for the application of the expression is selected and appears in the MAP Attributes panel. 
Click the Apply Expression button or choose it from the panel options menu.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The 
columns listed here are representative of the attribute structure unique to the data layer currently displayed in the 
attribute table as well as the standard MAPublisher property attributes. 

To assign an expression to a column, enter a valid expression in the Expression text box. Alternatively, click the 
Expression Builder button to open the Expression Builder dialog box. To access other expressions saved in the map 
document, click the Expression Library button to open the Expression Library dialog box.

The Expression Validity icon will report  if the expression entered is valid. Otherwise it will report  and include 
additional warning notes. 

Apply Expression 
MAP Attributes panel > Apply Expression

Apply to - Select the attribute 
column on which to apply 

the expression. Attribute and 
MAPublisher Property columns can 

be assigned expressions.

Expression - Enter the 
expression into the text box or 

click the Expression Builder or 
Expression Library button

Expression Validity - Indicates if the 
expression is valid  or invalid . 
If invalid, additional info is reported.

Expression Builder - Opens the Expression 
Builder dialog box

Expression Library - Opens the Expression 
Library dialog box
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FUNCTIONALITY

Join Table provides the ability to merge external data tables directly into an existing MAP Layer attribute schema in 
order to create a single extended attribute table. Four of the most common table formats are supported:

dBase (*.dbf ) Delimited Text (*.csv, *.tsv, *.txt)

USGS SDTS (*.ddf ) Microsoft Excel (*.xls)

When exporting tables from spreadsheet applications for use with MAPublisher the preferred format to use is 
Delimited Text (*.csv).

Note:	 dBase tables created or edited in Microsoft Excel must have a proper data type assigned to each column 
through cell formatting before being saved as dbf. For example, numerical values specified in a cell set with a 
format "General" will import as an Integer type by default, therefore loosing all decimal values. 

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of geodatabases 
(ArcSDE, File and Personal). For information on Esri software requirements for this option, please refer to chapter 3.

PREREQUISITES

In order to join a table into an existing attribute schema, both MAP Layer and data table must share at least one 
common attribute column with matching values. The column must be of a matching type (i.e. String, Real, Integer, 
Boolean) in both the Source and the Destination table. If not, the join may not be successful.

Join Table 
MAP Attributes panel > Join Table

Data Type - Choose Files (all Operating 
Systems) or Geodatabase formats 

(Windows only)

Data Set Name - Click the Browse button 
to select the data table to be joined 

Character Encoding - Assign a codec if 
the attribute information held in the 
selected dataset uses a double byte 
character set

Target Layer - Select the layer containing 
the MAP Attribute table about to be 
joined with the source table

Destination Matching Column - Select a 
column from the destination layer to 
match to a column in the Source Table

Case sensitive when matching - Values from 
the two matching columns will be 
matched based on case sensitivity

Specify Schema - Adjust the schema type 
for each column

Add matching column from source - Add 
the matching source column into the 

destination attribute table

Update existing columns instead of adding 
columns when possible - Update existing 

column values instead of adding more

Source Matching Column - Select a column 
from the source table to match to a 

column in the destination layer
First line contains column names 

For Delimited Text and Excel type 
tables, check this box to derive column 

names from the first row

Name/Worksheet - Specify the worksheet 
to use when a Microsoft Excel file is 
selected
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USING JOIN TABLE 

Click the Join Table button or choose Join Table in the MAP Attributes panel options menu.

Source Data (Files)
Click the Browse button to select the data table for import. If a Microsoft Excel file is selected, use the Worksheet 
drop-down list to specify the sheet to be used for joining. Select a column in the Matching Column drop-down list. This 
is the source attribute column to join on.

In MAPublisher, double-byte characters are supported in attributes on import, allowing such attributes to be used 
for labeling and export. To assign a codec suitable for the selected dataset, choose an appropriate entry from the 
Character Encoding drop-down list.

If the table contains column names as headers, check the First line contains column names option. If it does not contain 
headers, do not check this option and each column will be assigned a default heading name: Column1, Column2, etc.

Source Data (Esri geodatabases)
Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of 
geodatabases (ArcSDE, File and Personal are supported but not the multi-OS Basic Personal Geodatabase). 

If the Data type drop-down list is set to Esri ArcSDE Geodatabase, click the Browse button to select the ArcSDE server 
connection and then select the appropriate feature class or non-spatial table. If the Data type drop-down list is set 
to Esri File Geodatabase or Esri Personal Geodatabase, click the Browse button to select a feature class or non-spatial 
table. Please refer to chapter 3 for information on ArcSDE server connection and feature class selection.

The attribute selection is the same as for Files source data.

Destination
The Target Layer is specified under the Destination section. Choose an attribute from the Matching Column drop-down 
list. This column must match the format and values as the column chosen as the Source Matching Column.

Additional Option
If the Case sensitive when matching option is checked, the column entries from the two matching columns will only be 
matched by case. If the Add matching column from source option is checked, the source column is also imported and the 
column name is appended with the number 1. The Update existing columns instead of adding columns when possible option 
attempts to update attributes instead of appending more columns to the table.

Note:	 Attribute names can not contain all numbers. If a source column name contains all numbers the column is 
joined but the attribute column name is changed to Attribute1, Attribute2, etc.



116 Chapter 5: MAP Attributes
Add Calculated Data 

Add Calculated Data 
MAP Attributes panel options > Add Calculated Data

Add Centroid / Position Data

Add Colour Data

Add Statistics Data Add North Angle Data

Not available for text layers

Not available for point layers

This option only available when point data is selected

Calculation - Set the type of calculation:
•	 Centroid (area and line layers)
•	 Position (point layers)
•	 North Angle (point layers)
•	 Statistics (all layers)

Column X - Select or add the attribute 
column to receive the x position value

Column Y - Select or add the attribute 
column to receive the y position value

Type - Select the type of coordinates:
•	 Page coordinates: position in 

Adobe document page units
•	 Projected coordinates: available if 

the coordinate system of the MAP 
View is projected

•	 Geodetic coordinates: Longitude/
Latitude position

•	 WGS84 coordinates: Longitude/
Latitude position

Unit - Set the unit when Projected 
coordinates or Geodetic coordinates is 
selected as Type

Colour attribute labels - Specify attribute 
labels to the associated CMYK or RGB 
colours. Labels must be unique.

Options - Apply the calculation to all art 
or only selected art

Status -  icon indicates that a new 
column is created,  icon indicates 
that an existing column is being 
updated

Target - Select or add 
the attribute column to 

receive statistic values

Colour source - Choose the colour 
source as the fill or the stroke 

of the layer or objects

Target - Select or add 
the attribute column 

to receive north 
angle values

Operation - Specify 
the operation to be 

performed: Distribution, 
Deviation, Sum, Mean 
or Standard Deviation

Colour model - Choose the colour 
model: CMYK or RGB

Source - Select the 
attribute column to be 
used as source for the 

calculations

Indeterminate Colours - Colours 
that cannot be determined 

(such as gradients) are reset or a 
specific value can be specified
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FUNCTIONALITY

The Add Calculated Data function populates existing or new MAP Attribute columns with values calculated from the art 
geometry or from another column of numerical values. The calculation options are:

•	 Geographic information: centroid position for lines and areas or position and north angle for points .
•	 Perform statistic calculations based on the overall attribute data of a specified column.

Calculated values are not updated automatically when the source column changes. Add Calculated Data must be 
run again for updates to be applied.

For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, the 
centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the 
largest polygon or line is used. 

Note:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor 
points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points 
function (Object > Path > Add Anchor Points) before running Add Calculated Data.

Calculated data can be added or updated to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset.

PREREQUISITES

Add Calculated Data can populate new or existing attribute columns. Only attributes of type Real can be updated, 
so users should make sure that the proper data type is applied to these columns. 

For statistics calculations, the source column must be numerical (Integer or Real type). Users may need to use the 
Join Table function to import appropriate numerical data beforehand (e.g. election results per county). See Edit 
Schema in this chapter.

USING ADD CALCULATED DATA 

Make a selection on the MAP layer concerned and click Add Calculated Data from the MAP Attributes panel options menu.

Calculate Centroid or Position
If the selected data is on a Line or Area MAP Layer, choose Centroid from the Calculation drop-down list to calculate 
the x and y position of the line or area centroids. If the selected data is on a Point MAP Layer, choose Position from 
the Calculation drop-down list to calculate the x and y position of points in a specific coordinate format.

Note:	 Centroids positions are calculated using the low accuracy method (see chapter 6 on Plot Centroids for details). 

In the Column X and Column Y drop-down lists, users have the option to keep the default new column names  
(new_position_x and new_position_y), type names of their choice, or select an existing column. Only existing 
columns of data type Real are listed.
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The positions coordinate format is set in the Type drop-down list. The options are:
•	 Page coordinates: x and y positions relative to the Adobe Illustrator page reference, in page units (as 

specified in the Adobe Illustrator document setup).
•	 Projected coordinates: x and y positions in the source coordinate system of the MAP View containing the 

selected layer (if this system is projected).
•	 Geodetic coordinates: longitude and latitude positions — calculated from x and y positions if the source 

coordinate systems of the MAP View containing the selected layer is projected.
•	 WGS84 coordinates: longitude and latitude positions — calculated from x and y positions if the source 

coordinate systems of the MAP View containing the selected layer is projected.

The Unit drop-down list shows a selection of linear or angular units if the coordinate type is set to projected or 
geodetic respectively.

Finally, set the option to calculate the centroid or position to the selected art only or to all art on the current layer.

Calculate Statistics
To calculate statistics based on a source attribute column, choose Statistics from the Calculation drop-down list.

The following statistical operations are available:
•	 Deviation: for each row, difference between the current value and the mean.
•	 Distribution: for each row, current value divided by the sum.
•	 Mean: sum of all the row values divided by the number of rows in the source column (same for all rows).
•	 Standard Deviation: measure of the variability or dispersion of the row values in the source column. A 

low standard deviation indicates that row values are very close to the mean, whereas high standard 
deviation indicates that row values are spread out. Calculated as the square root of the sum of all 
deviations squared, divided by the number of rows in the source column (same for all rows).

•	 Sum: addition of all the row values in the source column (same for all rows).

In the Target drop-down list, users have the options to keep the default new column name (new_stat_col), type a 
name of their choice, or select an existing column. Only existing columns of data type Real are listed.

Then, select the required function in the Operation drop-down list. Deviation and Distribution calculate a value 
specific to each row; Mean, Standard Deviation and Sum create a single value for all rows.

In the Source drop-down list, select the source column from within all numerical attributes of the current layer. 
Users have the option to add calculated data to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset of the source column

Note:	 To obtain a distribution in percents, first use Add Calculated Data with the Distribution operation, then use the 
Apply Expression function to multiply the column values by 100 (e.g. COLUMN = COLUMN * 100).

Calculate North Angle
To calculate north angles of points on a Point layer, , choose North Angle from the Calculation drop-down list.
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Calculate Colours
To calculate colours of layers or objects, choose Colours from the Calculation drop-down list.

In the Colour source drop-down list, choose from either Fill or Stroke of the current layer or objects. This will be the 
source of which MAPublisher retrieves the colour values from.

In the Colour model drop-down list, choose from either CMYK  or RGB. This will change the available colour attribute 
label boxes below it and set the colour attribute values. When CMYK is chosen, colour values in the attribute table 
are populated with Real numbers. For example, a cyan value of 0.2562 is equivalent to 25.62 in the Adobe Illustrator 
Color panel. When RGB is chosen, colour values in the attribute table are populated with Integer numbers. 

By default, the colour attribute label boxes are populated with the name of the colour. These are the attribute 
column heading names and can be edited, however, they must remain unique. An indicator to the right of the box 
displays either "Add" or "Update". When calculating new colour attribute values and a new label is entered, the 
indicator will display "Add". It is possible to update the values in the attribute table when the colour of the layer or 
objects are changed. When using the same attribute labels, the indicator will display "Update". This overwrites the 
existing colour values in the attribute table.

Indeterminate colours are colours that MAPublisher cannot determine for a layer or object. These may be gradients, 
custom effects or graphic styles. In the Indeterminate Colours section, two options are available to deal with these 
situations. Reset attribute to default when colour source is indeterminate sets the attribute values to 0 (zero). The 
Indicate indeterminate colours using option allows you to specify a specific value. The default is -1.0000.
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Export Attributes 
MAP Attributes panel options > Export Attributes

FUNCTIONALITY

The Export Attributes function exports all selected attribute information from the current MAP Layer to a delimited 
text file—comma, semi-colon, space or tab separated.

PREREQUISITES

Attributes will be exported as they are in the MAP Attributes panel. For example, users can change the number of 
decimals for attributes of type Real prior to exporting (see Edit Schema in this chapter), to limit the size of the exported 
file—or to turn on/off the visibility of some attributes, with Edit Schema or the MAP Attributes panel Show/Hide function. 

USING EXPORT ATTRIBUTES

Export attributes is accessed from the MAP Attributes panel options menu. 

In the Export Attributes dialog box, click the Browse button to navigate to the directory where the exported file will 
be saved and type a file name. By default, the exported file will be appended a .txt extension—to export in another 
delimited text format, type another file extension (*.csv or *.tsv) in the file name (e.g. world.csv).

Users have the following options to set:
•	 Export all attributes or visible attributes only. 
•	 Set field delimiter in the exported text file to Comma, Semi-Colon, Space or Tab.
•	 Export or not the column names on the first line.

The result is a delimited text file. Text attributes (type String) are exported in double quotes ("...") and are separated 
by commas in example below.

File name - Click the Browse button to select 
the directory and type the file name where 

to save the exported attributes.

Scope - Choose to export all the attributes 
or only the visible attributes.

Delimiter - Specify the field delimiter. Select 
Comma, Semi-Colon, Space or  Tab from the 

drop-down list. 

Include column names on first line 
Click this option to export the 
column names on the first line of 
the exported text file.
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The ability to accurately place points onto a map is basic to 
cartography. Points can represent the locations of towns and 
cities, shops and malls, airports and train stations and more. 
MAPublisher provides the functionality to create or plot 
points in vector format. 

There may be times when you wish to quickly add a point 
or a small group of points to your map but you do not have 
a GIS or ASCII file containing these points ready for import. 
Alternatively your map may be in a projection that holds 
coordinates in linear units, yet the coordinates of your point 
locations are in angular units (i.e. degrees). 

Provided you have a fully specified MAP View, and know the 
coordinates (coordinate system and unit can be specified) for 
the locations you wish to plot, you can use the MAPublisher 
Point Plotter to have your points placed at their correct 
locations.	

Topics covered in this section:
MAP Point Plotter
Plot Centroids

Plotting 
Points
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MAP Point Plotter 
Window > MAPublisher > MAP Point Plotter and MAPublisher Toolbar 

PREREQUISITES

In order to plot points using the Point Plotter, a fully georeferenced MAP View must be chosen, as this function will 
use the coordinate system in order to generate points. Use an existing Point layer or create a new Adobe Illustrator 
layer as the destination layer to plot the points. Remember to drag a new layer into the desired MAP View and 
specify it as  Point in the Define Layer dialog box.

Scale - Change the size of the chosen 
symbol if required. The arrow keys will 
increase or decrease the scale value by 
10% increments.

Symbol Style - Choose a symbol to use. 
Click the symbol name to open the list 
of symbols to choose from

Coordinates - Enter point coordinates in 
MAP units or in a different choice of 

coordinate system

Current Layer - Displays the selected layer 
name and coordinate system 

Format - Select the input format 
for values in degrees (when input 

coordinate system is geodetic)

Input Coordinate System - Specify the 
reference coordinate system in which 

the point coordinates are entered. 
Use the current layer's coordinate 
system, or specify a different one 

(by default WGS84, lat/long format). 
Click the Select button to open the 

Select Coordinate System dialog box and 
choose any coordinate system.

Plot- Click to plot the symbol after 
coordinates have been entered

Note:	 Points can only be plotted on point layers. The plot button will be 
disabled if another map layer type is the active layer.
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USING POINT PLOTTER

Enter Coordinates
When the Use Current Layer's coordinate system option is selected, coordinate values can be entered in the current MAP 
units of the coordinate system of the MAP View containing the selected layer. 

When the Use: WGS 84 option is selected, the Select button will become enabled. Clicking the Select button will open 
the Select Coordinate System dialog box and choose a coordinate system as required.

When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point 
Style) of the coordinate system (e.g. metre, kilometre, feet). When the selected or default coordinate system is 
Geodetic, Lat/Long coordinates can be entered in degrees in the following formats:

•	 Decimal degrees (D+[.d*])
•	 Delimited Degrees Minutes Seconds (D+ MM SS[.s*])
•	 Degrees.Minutes (D+.MM[m*])
•	 Degrees.MinutesSeconds (D+.MMSS[s*])
•	 Packed DMS with decimal point((D)DDMMSS[.s*])
•	 Packed DMS ((D)DDMMSS[s*])

Notes:	 Items in [ ] are optional, * means zero or more digits, + means one or more digits.

Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South (the 
Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes. 
Negative degree values represent south latitudes and west longitudes. Directions can be entered either 
with positive/negative values or using the N, S, E or W letters preceding or following the numerical values, 
separated or not with a space.

Valid delimiters for Delimited Degrees Minutes Seconds format are: 
JJ space, hyphen (-), colons (:) or underscore (_), e.g. 43 41 48.98N, 43-41-48.98N, 43:41:48.98N or 

43_41_48.98N
JJ d (degree), single quote (minute), double quote (second), e.g. 43d41'48.98"N

Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 digits 
for degrees of longitude (e.g. 1°E must be written 001).



124 Chapter 6: Plotting Points
MAP Point Plotter 

Examples of Latitude/Longitude values

Formats Decimals 
Degrees

Delimited 
Degrees Minutes 
Seconds

Degrees.Minutes Degrees.
MinutesSeconds

Packed DMS with 
decimal point

Packed DMS

Avenza Office:
43°41’48.98”N
79°23’32.38”W
(= 48°41.8163’N | 79°23.5396”W)
(= 48.6969°N | 79.3922°W)

Lat 43.6969N 43d41’48.98”N 43.418163N 43.414898N 434148.98N 43414898N

Long 79.3922W 79d23’32.38”W 79.235396W 79.233238W 0792332.38W 079233238W

Lat 43.6969 43 41 48.98 N43.418163 N 43.414898 434148.98 N 43414898

Long -79.3922 W 079 23 32.38 W79.235396 W 79.233238 -0792332.38 W 079233238

Lat N 43.6969 N 43-41-48.98 43.418163 43.414898 N 434148.98 43414898N

Long -079.3922 W 79:23:32.38 -079.235396 -079.233238 W 0792332.38 -079233238

Warning - Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.

Set up the Symbol Selection
The symbols used by Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols 
panel. To open the Adobe Illustrator Symbols panel, click the menu Window > Symbols. To add symbols to the 
Symbols panel, create symbols as closed Adobe Illustrator objects and drag them into the panel. Alternatively, 
open the Symbols panel, click the panel options menu > Open Symbols Library > MAP Symbols > MAP - Symbols. The 
MAP - Symbols.ai file from the Helpful Styles & Symbols folder is installed with MAPublisher (see Appendix 4).

Choose a Symbol and Scale
After entering coordinate values select an appropriate symbol to use by clicking the symbol name link. Again the 
symbols displayed are the symbols that currently exist in the Adobe Illustrator Symbols panel. To scale the symbol 
used, edit the Scale entry field. Clicking the Up and Down arrows will increase or decrease the value by 10%.

Note:	 When a MAP Themes stylesheet is assigned to a Point layer, it will override the map symbol chosen in the 
MAP Point Plotter panel.

Plot Points
Click Plot to plot the point in the designated MAP layer. To plot subsequent points, edit the coordinates, and also 
choose different symbols if required and click Plot again.
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Plot Centroids 
MAP Point Plotter panel > Plot Centroids

FUNCTIONALITY

The Plot Centroids function adds point symbols at the center of polygons or line, while copying the attributes from 
the source MAP layer when the New Layer option is selected. This function is useful for cartographic generalization 
purpose (e.g. replacing small island area by a symbol), or to simply add a meaningful symbol at the center of 
areas. For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, 
the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the 
largest polygon or longest line is used. 

Note:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor 
points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points 
function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

PREREQUISITES

The document must contain a fully georeferenced MAP View that includes a MAP layer of type Area or Line that 
contains art. An existing Point layer may be used as destination layer (Existing Layer option), in which case this layer 
must be included in the file before running the function. Furthermore, the desired symbol must be present in the 
Adobe Illustrator Symbols panel. 

USING PLOT CENTROIDS

Plot Centroids is located in the Point Plotter panel options menu. 
•	 Select first the MAP View that contains the layers whose centroids are to be plotted..
•	 Select the Source Layer containing the polygons or lines for which the centroids will be plotted (MAP 

Layer of type Area or Line). 
•	 Select the symbol Style and Scale to apply. 
•	 Choose the Destination Layer in which the centroids will be added: select an existing Point layer or create 

a new one. 

Source Layer - Select the Area or Line 
MAP Layer containing the paths on 

which the centroids will be calculated

Destination Layer - Select either an 
existing Point MAP Layer or create a 

new one where centroid symbols will 
be added

Options: 

Style - Select the symbol to use. 
Available Adobe Illustrator Symbols 
are listed.

Scale - Select the symbol 

MAP View - Select the MAP View 
containing the layers of interest (Source 

Layer and Destination Layer)

Use high accuracy - if the selected source 
layer is an Area MAP Layer, check this 
option for a high placement accuracy..



126 Chapter 6: Plotting Points
Plot Centroids 

The high placement accuracy option makes more advanced calculations for the centroid positions so as to force 
them to fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

Note:	 When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new 
Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point 
layer was created with its attribute schema based on the same source MAP Layer (see chapter 4 for more 
information on the Base attribute schema on option when creating new MAP layers).

RESULTS

Symbols are added to the specified Point MAP Layer. Depending on the type of polygon or line (single or 
compound path), symbols are located on the center of the polygons/lines or at the center of the biggest 
polygon/longest line of a group.

Example: result of plotting centroids on a Canadian provincial Area layer.
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Drawing Tools

MAPublisher benefits from Adobe Illustrator drawing tools. 
Any artwork created on a specified MAP layer is incorporated 
into the map data and can be scaled and projected. If the new 
artwork is of the same feature type as the MAP Layer, it will 
automatically be added to the attribute table.

Similarly, objects can be deleted and moved between layers 
with basic Adobe Illustrator tools which makes it very easy to 
quickly add and delete features to MAP Layers.

In addition, MAPublisher provides its own tools for creating 
and managing artwork. MAP Area Tools are designed to draw 
rectangular and elliptical areas of specified dimensions 
in MAP Units. The MAP Vector Crop Tool trims all the vector 
data (on all active layers) falling outside of a crop area. The 
MAP Measurement Tools allows users to measure distances in 
page or world units and to save the measuring path as an art.

Topics covered in this section:
MAP Area Tool
MAP Vector Crop Tool
MAP Measurement Tool
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MAP Area Tools 
Tools > MAP Area Tool (Box)  / MAP Area Tool (Ellipse) 

FUNCTIONALITY

Use the MAP Area Tools to quickly add areas of exact map dimensions to any MAP Layer and its related attribute table. 
Whenever an area is created using the MAP Area Tools, any art objects that are fully contained in or intersect the 
new area are automatically selected.

USING THE MAP AREA TOOLS

Click and hold the MAP Area Tools button to select either the Ellipse or Box area tool. There are two methods of using 
the MAP Area tools: click and drag or enter specific dimensions.

Draw using Click and Drag
To draw shapes at unspecified sizes, click and drag in the MAP document while holding down the left mouse button 
until the desired area has been outlined. Use the Alt key (Windows) or the Option key (Mac) to draw from the centre 
and/or the Shift key to constrain the proportions. Release the left mouse button to finish drawing the area.

Enter Specific Dimensions
To draw shapes at specified sizes, single-click at a point in the MAP document at the desired location to plot the 
shape. In the MAPublisher Add Area dialog box that opens, enter specific dimensions for the area to be drawn. To 
have the area centered over the click point, simply check the Center area on click check box. If the check box is not 
checked, the shape will be drawn from its upper left corner. Click OK to draw the shape.

RESULTS

Drawing an area using either of these methods will select the features that are fully contained in or intersect the 
new area. Therefore, these tools can be also useful for selecting features that are within designated distances away 
from a central location.

Center area on click - Check this option 
if you want the area to be drawn 

centered on the click point

Width/Height - Enter the width and 
height for the area to be drawn

Units - Select a map or page unit to be 
used for width and height values
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MAP Vector Crop Tool 
Tools > MAP Vector Crop 

FUNCTIONALITY

Use the MAP Vector Crop Tool, to trim a map (vector data only) to a rectangular area of interest. Typically, the tool is 
meant to crop imported vector data that might be covering a larger area than the intended map extents. Used on a 
copy of the full original MAP View, MAP Vector Crop can also be utilized to create map insets (smaller maps centered 
on specific areas)—see example below.

PREREQUISITES

Before using the MAP Vector Crop Tool, ensure that the layers to be trimmed are visible and unlocked in the Adobe 
Illustrator Layers panel (invisible and locked layers are not cropped). Similarly, layers that are not supposed to be 
cropped should be locked or invisible. The extent of the map that will remain after cropping must be visible on the 
screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Users should save a copy of the Adobe document prior to performing a crop. Due to some Adobe Illustrator 
limitations, text typed on a path might not return to their prior state after an undo.

USING THE MAP VECTOR CROP

Click the MAP Vector Crop Tool button  in the Adobe Illustrator Tools panel, then click and drag a rectangle over the 
artboard. Upon release of the mouse button, the crop function is completed.

If the remaining map is too large, the MAP Vector Crop can be run again on the remaining data.
If the remaining map is too small, the MAP Vector Crop can be undone (menu Edit > Undo) and run again.

RESULTS

On all visible and unlocked layers: 
•	 Text objects that have their anchor outside of the cropping rectangle are deleted. Text objects with 

their anchor inside the cropping rectangle are retained completely.
•	 Points falling outside of the cropping rectangle are deleted (the position of the center of the symbol is 

relevant). Symbols that have their center inside the cropping rectangle are maintained as a whole.
•	 Lines are clipped at the boundary of the cropping rectangle.
•	 Areas (polygons) that are completely out of the cropping rectangle are deleted. Areas intersecting with 

the cropping rectangle are clipped and closed following the edge of the rectangle. 

The overall result is a map coverage reduced to the cropping rectangle outline. Subsequently, the MAP View can still 
be transformed, rescaled, and so on. See examples on the next page.
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Note:	 The purpose of the MAP Vector Crop is to cut vector data types (points, lines and polygons). Some Adobe 
Illustrator specific objects might not be cropped properly using this tool, for example:

•	 Blend and Live Paint objects.
•	 Any art using effects that have been rasterized.
•	 Custom art such as scale bars, grids/graticules, north arrows (expand custom art to crop).
•	 Images cannot be cropped with this tool.
•	 Legacy Text

Note:	 Due to an Adobe Illustrator limitation, text on a path may flip after a crop operation. This is corrected by 
checking the Flip option from Type on the Path Options dialog box (choose Type > Type on a Path > Type on 
a Path Options).

Examples
Crop vector data

Crop result: lines and area are clipped, text with 1st letter 
within the cropping rectangle and symbol with center point 
in rectangle are maintained. The MAP view can be re-scaled 
to fit better to the document size

Original map
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Create Inset

Create a map inset using MAP Vector Crop:
•	 Open any map, and make a copy of it (choose File > Save a Copy).  

Leave the original map open, make the copy the active document.
•	 Use MAP Vector Crop to crop the area of special interest.
•	 Make the original map active. In the MAP Views panel, select the option menu Import MAP View from 

document. Select the MAP View from the copy .

Original Copy and Crop

The map now contains two MAP Views (at least). Their relative position can be managed from the MAP View Editor, 
as well as the scale of the inset map.



132 Chapter 7: Drawing Tools
MAP Measurement Tool 

MAP Measurement Tool 
Tools > MAP Measurement Tool 

FUNCTIONALITY

The MAP Measurement Tool measures distances (between two points), path distances (multiple points), azimuths, 
and the perimeter and area of closed paths in page or map units. Furthermore, the measuring path can be 
converted to a line or area in the currently selected layer. 

PREREQUISITES

To measure ground distances (great circle distance in map units), the Adobe Illustrator file must contain at least one 
MAP View with an assigned coordinate system.

The map units used by the MAP Measurement Tool are set in MAPublisher Preferences. Use the current layer's map units 
or select alternative units. The layer's map units are defined in the coordinate system definition of the selected MAP 
View and can be viewed in the MAP View Editor by clicking the information button of the Source Coordinate System 
(called Point Style in the Definition tab)—see chapter 4 and Appendix A2 for details.

The Adobe Illustrator page units can be accessed and changed in the Document Setup dialog box (Adobe Illustrator 
menu File > Document Setup > Units drop-down list).

To use vector snapping while measuring, enable the Adobe Illustrator Smart Guides (Adobe Illustrator menu View > 
Smart Guides). The snapping tolerance is set in the Adobe Illustrator Preferences for Smart Guides (Adobe Illustrator 
menu Edit > Preferences > Smart Guides).

USING THE MAP MEASUREMENT TOOL

Click the MAP Measurement Tool button  in the Adobe Illustrator Tools panel. The mouse cursor becomes a cross . 

MAP Layers are measured in map units (great circle or real world distances). Select a MAP Layer and then click to 
measure. The units of the layer's parent MAP View will be used in the measurements. 

Non-MAP Layers are measured in page units (distances on the page). Select a non-MAP Layer and then click to 
measure. The units of the document will be used in the measurements. 

Note:	 While the MAP Measurement Tool is enabled, users can change the selected layer in the Adobe Illustrator 
Layers panel. If the new selected layer is contained in a different MAP View, the distance values are updated 
accordingly on the screen automatically without having to start a new measurement — e.g. if the MAP View 
scale is different, the measurement will significantly change. 

When Adobe Illustrator Smart Guides are enabled, the MAP Measuring Tool can snap to existing anchor points. 
When the mouse cursors is near enough a point, Adobe Illustrator highlights it as shown in the image below.
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Measure Distance
By default, the MAP Measurement Tool measures distance between two points. 

Click a starting point to begin measuring. As the mouse moves on the artboard, a distance label indicates the 
distance (and azimuths, if enabled in MAPublisher Preferences) from the starting point to the current mouse 
position. A second click digitizes the end point. As soon as the second point is clicked, the measurement is ended 
and the total distance is displayed.

Measure Path Distance
Click a starting point to begin measuring. Before clicking a second time, hold down the Shift key. The cursor 
changes from  to . A new point is added on the path, but the measurement does not end.

Keep holding the Shift key while adding more points along the path. As the mouse moves on the artboard, a total 
distance label indicates the length of the path already digitized and the distance from the last added point to the 
current mouse position. 

While digitizing the measuring path, hold the Alt key (Windows) or Alt/Option key (Mac) to display the length of each 
digitized path segment.

Before adding the last point, release the Shift key. As soon as the last point is clicked, the measurement is ended 
and the total distance is displayed. Hold the Alt key (Windows) or Alt/Option key (Mac) while clicking the last point to 
display all annotations (segment lengths and total distance).
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Measure Perimeter and Area
To measure the perimeter and area of a closed path, follow the same steps as measuring the distance of a path. 
When digitizing the last point, release the Shift button and place the mouse cursor over the start point — a box is 
drawn around the starting point — click to close the path and end the measurement.

Hold the Alt key (Windows) or Control key (Mac) while digitizing to display the length of each segment.

Note:	 Holding down the Shift key while clicking the start point again prevents the path from being closed and the 
measurement can continue.

Convert Measurement Line to Art
When any of the above measurement methods are finished, two options are available:

1.	 Click anywhere on the artboard once to clear the measurement line and label
2.	 Hold the Shift key and click anywhere on the artboard once. This converts the measurement line to an 

Adobe Illustrator art object, adds it to the current layer and applies the current stroke settings.

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the 
Adobe Illustrator Tools panel.

MAP Measurement Tool Preferences
Access the MAP Measurement Tool Preferences by double-clicking the MAP Measurement Tool button  on the 
Adobe Illustrator Tools panel or from the menu Edit > MAPublisher Preferences > MAP Measurement.

Set the number of decimals for the measurement values, enable display of azimuths, and change the digitized path 
and new segment colours. See chapter 1 for more information on MAPublisher Preferences.
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The Adobe Illustrator environment offers lots of flexibility 
when working with vector art. To enhance Adobe Illustrator 
functionality, MAPublisher introduces many geometry 
operations designed specifically for cartographic purposes.

Create a proximity around lines using the Buffer Art tool. 
Change the direction of lines using the Flip Lines tool; useful 
for road mapping applications. Easily join points, lines and 
areas to create seamless datasets. In addition, simplify lines 
to reduce the amount of vertex points, while retaining spatial 
referencing.

Topics covered in this section:
Buffer Art
Line Plotter
Flip Lines
Join Lines
Join Points
Simplify Lines
Join Areas

Geometry 
Operations
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Buffer Art 
Object > MAPublisher > Buffer Art or MAP Toolbar 

FUNCTIONALITY

MAPublisher Buffer Art creates  Area objects around points and lines. This may be useful when attempting to 
calculate distances on each side of a road or creating proximity around city points. For example, this tool could be 
used in the planning of new roads, where the actual width of a highway is a major consideration.

PREREQUISITES

To use Buffer Art, the artwork must be on a  Line or   Point layer.

USING BUFFER ART

If required, select the art to buffer and choose Object > MAPublisher > Buffer Art or the MAPublisher toolbar button 
. Buffers are added to all art on the specified layer, unless the option to only buffer select art is checked.

The buffer width can be entered as a fixed value or by selecting an attribute column that contains numeric values. 
With the Static Value option checked, a buffer is created by the specified value. With the Attribute Value option checked, 
a buffer is calculated and created based on the value related to the selected object in the attribute table. Set the 
buffer value units in the Units drop-down list. For example, a value of 10 map units would create a buffer of 5 map 
units around a point or line.

Choose an existing  Area layer as the destination for the new buffer. Alternatively, specify a new layer name to 
create a new layer where the buffer areas will be stored. Click OK to generate the buffers.

Buffer Options
Enable the Dissolve results option to remove any compound path segments and create one resulting buffer area.
Enable the Apply Style option and choose a preset Graphic Style or Custom stroke, fill and transparency.
Enable Add concentric rings and a specify interval distance between rings to create equally spaced rings around points.

Static Value - Enter a specific 
value and choose appropriate 

units to buffer the art by

Attribute Value - Buffer by values 
contained in an attribute table

Apply Style - Enable to choose  
stylization options

Dissolve results - Dissolves separate 
segments to create one buffer area

Concentric Rings - Enable to apply 
evenly spaced rings around points

Source Layer - Specify the layer to 
base the buffer art on. To buffer only 

selected art on the specified layer, 
check the option below it.

Units - Select a unit to use for the 
buffer values. The default is the 
current map unit.

Destination - Select the Area layer 
which will hold the buffered 
objects or choose to create a 
new layer
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Line Plotter 
Object > MAPublisher > Line Plotter* or MAP Toolbar 

Additional Line Points - Choose 
Point By Point to enter the 
consecutive vertices of the line 
by their coordinates

Current Layer - Indicates the 
currently selected layer (can 
be area or line layer) and its 

coordinate system

Input Coordinate system - Specify 
the coordinate system in which 
the starting point coordinate is 
entered. Use the current layer's 

coordinate system, or specify 
a different one (by default, 

the geodetic system base of 
the projection, in latitude-

longitude format). Click the 
Select button to open the Select 

Coordinate System dialog box and 
choose any coordinate system.

Starting Point - Enter the 
coordinates of the first point 
of the line. Valid coordinates 

are marked with , invalid 
ones with  

Format - Select the input 
format for values in degrees 

(when input coordinate 
system is geodetic)

Line Plotter (Point By Point)

Line Plotter (Course & Distance)

Add/Remove - Click  to add a new row. 
Select a row and click  to remove it.

Line vertices - Enter here the 
point coordinates of each 
line vertex

Close Path - Check this option to 
automatically close the path 
(recommended when using the 
Line Plotter on Area layers)

Additional Line Points - Choose 
Course & Distance to enter 

a series of heading and 
distance values

Method - Choose the distance 
method:
•	 Cartesian: distance in the 

map projection
•	 Geodesic: shortest distance 

along the Earth's curvature 
•	 Rhumb Line: distance along 

the Earth curvature at 
constant heading

North Type - In the Cartesian 
method, choose one of the 
north options which headings 
are measured from:
•	 Grid North: north along the 

map projection (straight up 
on the map)

•	 True North: actual north 
direction (as given by a 
north arrow)

Unit - Select the linear unit for 
distances

Direction - Choose Clockwise 
or Counter-clockwise for the 
direction of the heading value

Heading/Distance - Enter here a 
series of heading and distance 
to define the consecutive 
vertices of the line
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FUNCTIONALITY

The MAPublisher Line Plotter creates a new path to a   Line or  Area layer. Enter line vertices using two options:

•	 Point by Point: enter a starting point and consecutive point coordinates. 
•	 Course & Distance: enter a starting point and a series of headings (angles) and real-world distances. Each 

consecutive vertex is defined at an angle and distance from the previous point. Additional options are 
available for angle and distance definitions (see hereafter).

The created path is made of straight segments connecting the points. 

PREREQUISITES

A  Line or  Area layer must be selected before starting this operation. As required, first create a new MAP Layer 
of type Line or Area, or use one of the existing MAP layers of the appropriate type.

USING LINE PLOTTER

Select a  Line or  Area layer in the MAP Views panel or Adobe Illustrator Layers panel. Then choose Objects > 
MAPublisher > Line Plotter or click the Line Plotter button  on the MAPublisher toolbar.

The name of the selected layer and its source coordinate system are displayed under Current Layer.

Input Coordinate System
The Input Coordinate System sets the system in which the starting point coordinates are entered. It also applies to 
the coordinates of each vertex when the Point by Point option is selected.

When the Use Current Layer's coordinate system option is selected, coordinate values can be entered in the current 
coordinate system of the MAP View containing the selected layer. 

When the Use: [coordinate system] option is selected, the Select button becomes enabled. Click the Select button to open 
the Select Coordinate System dialog box and choose a coordinate system as required.
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When the selected or default coordinate system is projected, X and Y coordinates are entered as the unit of the 
coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is Geodetic, 
Lat/Long coordinates are entered as degrees. The degree format is selected from the Format drop-down list—see 
chapter 6 for details on the supported formats.

Note:	 The Input Coordinate System is not applied to the distance settings when plotting a line by Course & Distance. 
In that case, the layer's coordinate system applies.

Starting Point
Enter the coordinates of the first point of the line in the X, Y or Long, Lat fields.

Options
The Close Path option controls if the path will be closed automatically or not. When using Line Plotter on a  Line 
layer, this option is disabled by default. On an  Area layer, the Close Path option is enabled by default—it is not 
recommended to create open paths on an area layer.

A minimum of three vertices are required to create a closed path. If less points are entered, the path is left opened 
by the Line Plotter.

Plot Line Point by Point
The Point by Point option in the Additional Line Points drop-down list provides a method to add consecutive line 
vertices (or nodes) by typing in the coordinates of each point. This option is typically used to create a line from a list 
of known locations.

Note:	 Alternatively the Join Points operation could be used to connect points already plotted on the map.

To add a new point, click the  button. Then enter the new point coordinates based on the selected Input 
Coordinate System and Format (if the coordinate system is geodesic). To remove a point, select a row and click the 

 button.

Plot Line by Course and Distance
The Course & Distance option of the Additional Line Points drop-down list allows to define each consecutive line vertex 
by its heading (azimuth or angle relative to the north direction) and real-world distance from the previous point. 

The Method drop-down list offers three options to define the real-world distances:
•	 Cartesian: Distances in the map projection. They represent the distances as measured on the map and 

multiplied by the scale. This option is only available if the layer's coordinate system is projected.
•	 Geodesic: Shortest distances along the Earth's curvature. Geodesic distances are also known as 

Great-Circle distances and are typically used for navigational purpose maps. They represent the actual 
covered distance while walking or in a moving vehicle. 

•	 Rhumb Line: Distance along the Earth curvature at constant heading. They are typically used for 
navigational purpose maps to represent routes of constant direction.

Note:	 Once the next vertex position is calculated on the map, the path segment is the straight connection between 
the points. The paths are not drawn curved to follow geodesic or rhumb lines
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The North Type drop-down list contains two options to define the north direction when the method is set to Cartesian: 
•	 Grid North: Refers to the northward direction of the map projection grid lines—Grid North is constant 

throughout the map.
•	 True North:  Refers to the actual direction to the geographic North Pole. The True North direction can vary 

depending on a point position on a map. Similarly, graticule longitude lines are pointing to True North 
as well as MAP North Arrows (see chapter 14).

Note:	 The Geodesic and Rhumb Line methods are by definition using the True North as northward direction. The 
North Type drop-down list is therefore disabled in these cases.

The Units drop-down list allows to select a linear unit for the distance. By default, the Units list is set to the Point Units 
of the  current layer's coordinate system, if it is projected. If the current layer's coordinate system is geodesic, the 
Units list is set to Meters.

The Direction drop-down list indicates the direction of the heading angles. Typically, navigational headings (or 
azimuths) are given in Clockwise direction. However, the natural angle direction in Adobe Illustrator is Counter-clockwise, 
which may be preferred for simple drawing purpose. 

Once all options are set, click the  button to create a new entry of heading and distance. To remove an entry, 
select a row and click the  button.
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Flip Lines 
Object > MAPublisher > Flip Lines* or MAP Toolbar  

FUNCTIONALITY

MAPublisher Flip Lines reverses the endpoints of a line or an area (open or closed path). 

Adobe Illustrator Brushes and Type on a Path tools are designed to position patterns and text depending on the 
direction of the endpoints. Two consequences of this are:

•	 Labels are placed upside down and backward when using the MAPublisher labeling tools (MAP Tagger 
tool and Label Features, see chapter 10 - Labeling).

•	 When applying graphic styles with a brush pattern to paths (manually or using MAPublisher MAP 
Themes), patterns are not applied at the right side of the line or in the expected orientation.

In order for the labels or patterns to be consistent for a group of lines, flipping lines may be necessary.

PREREQUISITES

Lines can be flipped on  Line and  Area layers.

USING FLIP LINES

To flip lines, select the lines and then choose Object > MAPublisher > Flip Lines or click the Flip Lines button  on 
the MAPublisher toolbar.

Notes:	 Flip Lines is a discrete operation. It may not be apparent that the lines are flipped.

When exporting Area layers to GIS formats, polygon outlines must have a positive #Area value in the MAP 
Attributes panel. If some values in the #Area column are negative (and #AreaDirection is equal to Counter 
Clockwise), Flip Lines can then be used to reverse the #AreaDirection and convert the #Area to a positive value. 

For compound paths, the #AreaDirection property is always equal to Indeterminate, even though compound 
paths can be flipped.

The MAPublisher MAP Tagger tool and Label Features have an option to enable Flip upside-down labels to create 
text in a consistent orientation, without requiring the use of the Flip Lines operation (see chapter 10).
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Join Lines 
Object > MAPublisher > Join Lines* or MAP Toolbar 

FUNCTIONALITY

Join Lines allows a group of line features to be joined based on a common attribute. For example, it may be desirable 
to join all segments of a particular street by the common attribute of street name in order to create a single line 
element representing that street. When Join Lines is completed, a new map layer is created that contains the joined 
lines. These lines contain an attribute column based on the column used to join them.

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the 
number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labeling 
with Label Features in order to reduce the occurrence of duplicate labels (see chapter 10 Labeling).

PREREQUISITES

Join Lines can be executed on selections on  Line layers.

USING JOIN LINES

To use Join Lines, click the Join Lines button  on the MAPublisher toolbar or choose Object > MAPublisher > Join 
Lines or. In the Target Layer drop-down list, select the  Line layer where the join will be performed. In the Destination 
options, choose either to perform the join on the original target layer or specify a name for the new line layer that 
MAPublisher will create to hold the joined lines.

Under Join Options, a Proximity value should be entered and proximity Units assigned. Units can be specified in map 
units or page units. A proximity value of zero will only join line segments that are touching. If the distance between 

Only apply to grouped 
components that satisfy: 
Use an expression to 
define which joined lines 
the above attribute field 
options will apply to

Only join selected lines: 
Check to only join 
selected lines (before this 
dialog box is opened)

Apply to every grouped 
component - Choose 
to apply Join Lines 
options to every 
grouped component

Only join lines with shared 
values from: - Check to 
join lines that have 
shared attribute values

Target Layer - Layer on which 
the join will be performed

Destination - Defines line 
features to be joined. Join 

original lines on target 
layer or copy results to a 

new layer.

Proximity - Assign a 
proximity value to 

determine how close 
together (in map units) 

the lines must be in order 
to be joined. Optionally, 

choose appropriate units.

Close Segment Gaps - If 
two line segments are 

separated by a distance 
less than the Proximity 

value, checking this 
option will create a line 
segment that connects 

the two lines. Otherwise a 
compound path is created.

Attributes - Determines how 
attributes will be handled 
once features are joined 
into a single object. For 
string fields choose to 
either Clear the field, Clear 
if different (two or more 
unique values are found), 
sort Least Alphabetical (Z-A) 
or Most Alphabetical (A-Z). 
For Integer or Real fields 
options include Clear the 
field, Clear if different (two 
or more unique values are 
found), return the Sum or 
Average of the grouped 
values or enter the Largest 
Value or Smallest Value of 
the grouped fields.
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the end of a segment and the start of another is greater than the set proximity value, these lines will not be joined. 
If two line segments in the selection are separated by a distance less than the set proximity value, check the Close 
segment gaps option to create a line segment that connects the two lines. When not selected, a compound path will 
be created. By default, the Only join lines with shared values from option is checked. Specify an attribute which the join 
will be based on. It is noted in the Operation column as Join on. For example, when joining streets, join based on a 
common identifier or street name. To further narrow down which lines should be joined, check the Only Join selected 
lines option. These lines should be selected prior to opening the Join Lines dialog box.

When lines are joined, many attributes that were valid to the original lines may no longer be valid. For example, 
after joining street line data, an attribute that contains address ranges will no longer be valid because values will 
not be unique anymore. Thus, operations can be set to determine how each attribute field is handled. By default all 
attribute operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique 
values present after the join. Depending on the attribute type (string, boolean, integer or real) other operations 
include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The last three 
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item from 
an alphabetized list of attributes. Concatenate joins string values together and separates them with a separator.

The Concatenate operation has options to adjust the separator. When Concatenate is chosen in the Operation 
column for an attribute, the text Using defaults; double-click to edit appears in the Options column. Double-click the 
text to open the Concatenate Operation Options dialog box. Choose a separator from the Use drop-down list or 
specify a custom one.

String attribute sizes may become lengthy due to a join. Adjust the set string attribute size setting to increase or 
decrease the maximum number of characters of which the attribute field can store.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component 
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder 
to enter an expression that will only apply the attribute operations to values of the object where the expression 
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Street = Main St" 
would only apply the operations to attributes of the object that has the attribute "Street" and value of "Main St". All 
attributes for this art object will maintain its attributes.
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Join Points 
Object > MAPublisher > Join Points* or MAP Toolbar 

 Input Layer - Use this drop-down list to 
select the Point layer containing the 

symbols you wish to join.

All Points / Selected Points
 You can choose to join only those 

points that have been selected or all 
points on the selected MAP Layer.

Close paths - Check this option to 
generate an Area layer. If unchecked, a 

Line layer will be generated.

Sort By Available Columns - Select an 
attribute column containing  

ascending values to sort by. Then click 
the Add button to add the column to 

the Sort Order.

Add / Remove buttons - Click to add or 
remove attributes from the lists

Destination Layer - Enter the name of the 
output layer. This new layer will contain 
the generated lines.

Group By - Specify the attribute column 
containing similar values to determine 
each group of points

Sort Order - Contains a hierarchical list of 
the columns specified to sort by. 
To remove a column from the Sort 
Order, click the Remove button.

Move Up / Move Down - You can move 
columns up and down the 
Sort Order hierarchy by clicking the 
appropriate button . 

FUNCTIONALITY

Join Points allows a group of point symbols to be joined to form a line, based upon attribute values used as sorting 
criteria. For example, it is common to form a line based on points collected by a GPS device. When Join Points 
is completed, a new map layer is created that contains the line art. The generated line layer contains the same 
common attribute column that was used to group the points together.

PREREQUISITES

Join Points can only function on  Point layers, and can be used on both currently selected point symbols or all the 
point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order 
to use Join Points. To open the dialog box, choose Object > MAPublisher > Join Points or click the Join Points button 

 on the MAPublisher toolbar.
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USING JOIN POINTS

From the Source Layer drop-down list, select the Point layer containing the points to be joined. Then choose a join that 
is based on either All Points or only Selected Points.

Specify a name for the Destination Layer that this operation will generate. By default, the program will generate a 
 Line layer. To generate an  Area layer (by linking the line end to the start) check the Close paths option.

In the Group By Column drop-down list, select the attribute column containing the common attributes used to join 
the point together. For example, to join points based on a unique ID, select the column containing the common ID 
names. This will result in point symbols containing the same name being joined together. 

A logical order by which the points are being joined must be specified because each point will be represented by 
a node in a line string. To properly join points, a sort order must be chosen based on an attribute columns. These 
should be attribute columns which contain rising alphabetical or numerical values. For example, GPS data may 
contain an attribute that specifies the order in which the points were collected (first node, second node, etc).

In the Sort By Available Columns list, select the primary sorting column. This should be the attribute column that 
contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1–10, 
the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will 
be at the end of the line. Select a column and then click the Add button to place the column into the Sort Order list. If 
all the values contained in the first Sort By column are unique,it is not required to set a secondary column. 

If the first Sort By column contained any similar values, a secondary column must be specified. Again, click a column 
in the Sort By Available Columns list, and then click the Add button to place the column in the Sort Order list. Similarly 
third, fourth and fifth Sort By columns can be specified in the same manner if previous columns contain similar 
values. Note that the Sort By columns are a hierarchy with the topmost specified column being used for the primary 
sort, then the second, then third, etc. 

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in 
the Sort Order list and click either the Up or Down button. 

To remove any Sort By columns from the hierarchy, select the column in the Sort Order list and click the Remove button. 

Note that a maximum of five columns can be used to sort points into a logical order. If the columns specified to sort 
by do not distinguish an ordering between certain points, the order of these points in the attribute table will be 
used to determine the order of the nodes in the generated line string.

RESULTS

When all the options have been set click OK to join the points on the specified layer. An  Area or  Line layer will 
be generated, depending on the specified output layer type, which will be placed in the same MAP View as the 
Input Point layer which has been joined.
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Units - Select page units or map 
units (angular or linear unit list 
depending if the map coordinate 
system is projected or geodetic) 
used for the proximity tolerance

FUNCTIONALITY

Simplify Lines allows for the simplification or generalization of vector line and area data. It uses the popular 
Douglas-Peucker algorithm for removing nodes and vertices during simplification. For more information about this 
algorithm, see Appendix A1.

Simplify Lines is used to reduce the number of points required to represent a vector-encoded line where the lines 
are approximated by a stream of X-Y coordinates. The operation can be used on  Line or  Area layers and 
removes nodes based upon a proximity value in either Page Units or Map Units. The list of Map Units depends on the 
MAP View coordinate system—e.g. angular units (page units, degrees, etc) for geodetic coordinate systems; linear 
units (such as metre, feet) for projected coordinate systems.

The Proximity value or simplification tolerance is based on the vertical difference between the begin/end line 
and points off a line, not the distance between anchor points on the line. The Douglas-Peucker algorithm takes 
the proximity value and iterates through the line vertices to determine the points that fall within the specified 
proximity distance off the line and removes those vertices. Once all vertices are determined to be greater than the 
proximity value, the line processing ends. A smaller proximity value will usually result in a fewer number of nodes 
being removed.

USING SIMPLIFY LINES

To use Simplify Lines, choose Object > MAPublisher > Simplify Lines or the MAPublisher toolbar button . Enter a 
proximity value in Page Units or Map Units by making a selection from the Units drop-down list. Page Units are the units 
of the current document. Enter a proximity value in the unit specified by typing a value or by using the arrows. 

Click the Preview button to see the simplification result before committing to it. The Vertex Count shows how many 
vertices are in the simplified result (and calculates a percentage of overall simplification). Adjust the proximity as 
necessary in order to achieve the desired results particular to the scale and coverage area. Click OK to perform to 
complete the simplify operation.

Simplify Lines 
Object > MAPublisher > Simplify Lines* or MAP Toolbar 

Proximity - Set the simplification 
tolerance (type or use arrows) 

based on specified units

Vertex Count - Shows the original 
number of vertices of the 

selected lines. Click the Preview 
button to display the number of 

vertices after simplification.
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RESULTS

All selected lines or areas are simplified according to the settings. Simplified lines or areas will not be simplified 
again unless the tolerance value is increased. For example, if a line has been simplified with a proximity of 1.5 km., 
then it will not be simplified again until the tolerance is set to a value larger than 1.5 km.

In practice, it means that simplified lines can be selected again with non-simplified lines to run the operation again, 
when the Simplify Lines operation is run only the new lines will be simplified (unless the proximity value is increased).

Notes:	 It is a good idea to perform simplify lines on artwork before exporting a Flash map. This will reduce the file 
size and improve performance and loading times.

To smooth the appearance of paths using Bezier curves, use the Adobe Illustrator Simplify tool located in the 
menu Object > Path > Simplify.
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Only apply to grouped components that satisfy: 
Use an expression to define which 
joined areas the above attribute field 
options will apply to.

FUNCTIONALITY

Join Areas groups art objects based on a specified similar attribute value. An attribute field is defined and a new 
object is created for each unique value within that field. Options can be set to create Adobe Illustrator groups or 
compound paths, while either maintaining the outlines of the original features or dissolving sub-areas into the 
larger area.

USING JOIN AREAS

To use Join Areas, choose Object > MAPublisher > Join Areas or click the MAPublisher toolbar button . Choose 
the Target Layer on which Join Areas should be performed. Specify the Join Type to either Join all selected areas on target 
layer or Join areas by attribute. Specify an attribute which the join will be based on. It is noted in the Attributes section 
Operation column as Join on.

Select the Join Method type to either Adobe Illustrator Group areas or Create compound areas. For the latter option, 
choose to Dissolve borders between adjacent sub-areas. Not checking this option will maintain the borders of individual 
areas. For example, when grouping the countries of the world by its Continent field attributes, the Continent field 
will result in five new objects, one for each continent. Dissolving borders between adjacent sub-areas will leave the 
continent outlines. Choosing not to dissolve, the outline of each country will remain. In both cases, there will be one 
object for each continent in the attribute table.

When areas are joined, many attributes that were valid to the original lines may no longer be valid. For example, 
after joining the countries of the world on the Continent field, the field containing country capitals will no longer 
be valid, as each continent does not have one capital. Thus, operations can be set to determine how each attribute 
field is handled. By default all attribute operations are set Clear if different, meaning that the attribute is cleared if 

Join Areas 
Object > MAPublisher > Join Areas* or MAP Toolbar 

Target Layer - Layer on which 
the join will be performed

Join Type - Defines art to be 
joined. Choose all art on 

layer or choose to join all 
or selected art on similar 

attribute values. 

Join Method - Group areas 
creates Adobe Illustrator 

groups of joined art. 
Create a compound path 

for each  grouped art 
with the option to outline 

group or leave internal 
group borders intact.

Attributes - Determines how 
attributes will be handled 
once features are joined 
into a single object. For 
string fields choose to 
either Clear the field, Clear 
if different (two or more 
unique values are found), 
sort Least Alphabetical (Z-A) 
or Most Alphabetical (A-Z). 
For Integer or Real fields 
options include Clear the 
field, Clear if different (two 
or more unique values are 
found), return the Sum or 
Average of the grouped 
values or enter the Largest 
Value or Smallest Value of 
the grouped fields.
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there are more than two unique values present after the join. Depending on the attribute type (string, boolean, 
integer or real) other operations include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical 
and Concatenate. The last three operations can only be applied to string attribute types. Alphabetical sorting returns 
either the first or last item from an alphabetized list of attributes. Concatenate joins string values together and 
separates them with a separator.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component 
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder 
to enter an expression that will only apply the attribute operations to values of the object where the expression 
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Continent = 
Africa" would only apply the operations to attributes of the object that has the attribute "Continent" and value of 
"Africa". All attributes for this art object will maintain its attributes.

RESULTS

To tell if areas are joined after executing the Join Areas function, look for visual differences of the features on the 
map or look in the Adobe Illustrator Layers panel. Depending on the join method, compound areas or grouped 
areas, the Layers panel will display the results. In the example below, the original Lower 48 layer is shown and two 
join method possibilities. The Group areas method shows states grouped by the attribute Sub Region (W S Cen, 
Pacific, etc). The Create compound areas method shows states joined by compound path (and in this case, with the 
option Dissolve borders between adjacent sub-areas enabled).

Original Join Method: Group Areas Join Method: Compound Areas
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MAPublisher MAP Themes provide tools for a variety of 
thematic mapping operations. Stylesheet themes are used 
for quick, easy and accurate styling of points, lines, areas 
and text. Chart themes produces feature specific bar and pie 
charts while Dot Density themes aid in the generation of the 
thematic dot density maps.

No map is complete without a legend. Easily create MAP 
Theme legends with a wide array of options to adjust and 
tweak its appearance.

The topics covered in this section are as follows:
MAP Themes
Stylesheet Themes
Dot Density Themes
Chart Themes
MAP Theme Legends

MAP 
Themes
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MAP Themes
Window > MAPublisher > MAP Themes or MAP Toolbar 

OVERVIEW

MAP Themes, new to MAPublisher 8.4, are a collection of thematic cartography tools designed to increase 
productivity by automating how styles and symbols are applied, chart production and data plotting. The former 
MAP Stylesheets have been integrated into MAP Themes and is now called Stylesheet theme. Two new types are the 
Chart theme and Dot Density theme.

The new Stylesheet theme offers enhancements over the previous version of MAP Stylesheets. Adobe Illustrator 
graphic styles can be assigned to stylesheet rules and stroke fill and opacity can now be assigned on a per rule 
basis within the Stylesheet dialog box. The Stylesheet dialog box now offers a Rule Generator where attributes can be 
automatically classified using a variety of common classification methods.

The Chart theme offers an interface for quickly generating individual bar and pie charts for a chosen attribute of 
selected features. The Dot Density theme provides a thematic mapping tool that assigns a unit value to Illustrator 
symbols and randomly distributes symbols throughout associated areas based on attribute values.

MAP Themes offer a lot of flexibility. They can be edited, applied, duplicated, exported and cleared without affecting 
the spatial referencing of map features.

MAP Theme List - List of MAP 
Themes in the current document. 
Displayed in order of Stylesheets 

first, organized and color 
sorted by Area, Line and Point 

Stylesheets, Chart Themes and 
Dot Density Themes. 

New MAP Theme - Opens the  
New MAP Theme dialog box to specify 
theme type and options

Duplicate Selection - Create a duplicate of the 
selected MAP Theme

Edit Selection - Opens the MAP Theme Editor 
dialog box to edit the selected MAP Theme

Apply Selection - Apply selected MAP Theme 
to the document

Delete Selection - Delete selected MAP Theme

Clear MAP Theme application - Removes the 
application of the MAP theme from the 
document, not the theme itself

Create Legend - Create a legend from the 
selected MAP Theme

View Log - A log viewer that provides 
information on processes performed on 
individual MAP Themes

Export MAP Themes - Export MAP Themes to an 
Adobe Illustrator document

Import MAP Objects - Import MAP Themes from 
another open document

Preferences - Opens MAPublisher Preferences 
on the MAP Themes Panel property sheet 
(see chapter 1)

Create Legend - Create a legend 
based on the selected theme

Apply MAP Theme - Apply selected 
MAP Theme to the document

New MAP Theme - Opens the  
New MAP Theme dialog box to 

specify theme type and options

Delete MAP Theme - Delete 
selected MAP Theme



153Chapter 9: MAP Themes
MAP Themes

Load Symbols and Styles
The symbology used by MAP Themes are directly related to the symbols and styles which exist in several Adobe 
Illustrator panels. In order to correctly function, MAP Themes require that symbology or styles are established in the 
corresponding Adobe Illustrator panels:

For Stylesheet themes:

Area stylesheets: Graphic Styles panel (Window > Graphic Styles)

Line stylesheets: Graphic Styles panel (Window > Graphic Styles)

Point stylesheets: Symbols panel (Window > Symbols)

Text stylesheets: Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

For Chart and Dot Density themes:

Appearance: Graphic Styles panel (Window > Graphic Styles)

Labeling: Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

Symbols: Symbols panel (Window > Symbols)

Custom symbology can be added to the Adobe Illustrator Graphic Styles, Symbols and Swatches panels. Another 
great source of styles comes from the custom graphic style, symbol and swatch libraries installed by MAPublisher.

To open MAPublisher supplied graphic style, symbol and swatch libraries, navigate to the following panels:

Graphic Styles panel options menu > Open Graphic Style Library > MAP Graphics

Swatches panel options menu > Open Swatch Library > MAP Swatches

Symbols panel options menu > Open Symbols Library > MAP Symbols

These styles and symbols are stored in Adobe Illustrator documents in the Helpful Styles & Symbols folder. To create 
a style library, simply create your own Adobe Illustrator documents containing your symbols, graphic styles and 
character styles and save them to the appropriate Helpful Styles & Symbols subfolder. See Appendix 4 for more 
information.

Along with the ability to style map art using Adobe Illustrator Graphic Styles and Symbols, MAP Themes allow users 
to manually specify stroke, fill and scale properties on a per rule basis.
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FUNCTIONALITY

Apply MAP Themes
There are several ways to apply a MAP Theme. Click the Apply button in any of the Edit Theme dialog boxes to 
immediately apply theme options to the map document. Another way is to click the Apply MAP Theme button in 
the MAP Themes panel. This method is useful for applying themes at a later time. Save the theme settings made in 
any of the Edit Theme dialog boxes and in the MAP Themes panel, select a MAP Theme and click the Apply MAP Theme 
button. Alternatively, choose Apply "[theme name]" in the MAP Theme panel options menu.

Clear MAP Themes
Click the Additional MAP Themes options button and in the context menu, click Clear [Theme]. This does not delete 
the MAP Theme, it only removes the style from the data.

Duplicate Themes
A document can contain as many MAP Themes as desired. Choose Duplicate "[theme name]" to create a copy of an 
existing MAP Theme. The rules and styles are preserved during a copy. This is useful when creating different styles 
for a map; each theme can have the same rules, but different visual properties. To apply the different themes, clear a 
previous theme and apply another one. 

Export MAP Themes
To export MAP Themes, choose Export MAP Themes from the panel options menu. In the Export MAP Themes dialog 
box, click a check box beside each theme to select it for export. Click OK and a Save dialog box will prompt for a file 
name. MAP Themes are exported to an Adobe Illustrator document and are considered MAP Objects. They can be 
imported using the Import MAP Objects function. See chapter 4 for more information about Import MAP Objects.

MAP Theme Log
MAP Theme processes can be viewed in the log file associated with each type of theme. View the log through the 
Additional MAP Theme Option context menu. Logged theme processes include the start and finish time of theme 
processes along with the number of pieces of art found and the number of pieces stylized.

Add/Remove Item from Selection 
Add or remove warning or 
critical messages

Clear Selection - Clear selected 
feature on the map

Export - Save log to a text file

Zoom To - Zoom to the selected 
feature on the map

MAP Theme Log Operations 
Lists completed processes for 

the selected theme. Use the 
Show buttons below to filter 

information, warning, and 
critical messages.

Show - Show general 
information, warnings and 

critical messages.
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Stylesheet Themes

OVERVIEW

Stylesheet themes are able to read and work with the data found in the MAP Attributes panel and used to quickly 
style MAP Layers using Adobe Illustrator symbols, graphic styles and character styles.

Theme rules can be created in two ways: manually (one by one) or generated using a data classification method.
In addition, themes can be applied to data on a one-to-one basis, where specific attribute values are assigned with 
a specific style or symbol (e.g. each country its own distinct colour) or with attribute value ranges (e.g. a country's 
population growth that falls within a range of 2.9 to 4.6% and a colour used to represent it).

FUNCTIONALITY

Create New Stylesheet
To create a new stylesheet, click the Create New Map Theme button  in the MAP Themes panel. Alternatively, 
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, 
where the theme name, theme type, and feature type for a new stylesheet is specified. With Stylesheet selected as 
the theme type, the Feature Type drop-down list contains a list of available feature types: Area, Line, Point and Text.

Feature Type - Specify a feature 
type for the stylesheet:  
Area, Line, Point or Text

New Stylesheet MAP Theme

Name - Specify a name for the 
new Stylesheet

Theme Type - Select Stylesheet from 
theme type drop-down list

Stylesheet themes are displayed in the MAP Themes panel. To edit a Stylesheet theme, double-click a Stylesheet 
name or select Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Stylesheet Theme 
dialog box
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Stylesheet Theme Editor
The Edit Stylesheet Theme dialog box is where rule generation and styling takes place.

Theme Name - Edit name of 
Stylesheet theme

Layers - Opens the Select 
Layers dialog box

Never reset visual properties - Click to 
edit reset options (see below)

Move Up/Down - Edit rule 
hierarchy (seen in Legend)

Rule List - Selectable list of 
named rules. The green 

check mark indicates a valid  
Expression. A red X indicates 

an invalid Expression.

Rule Name - Edit rule name as 
it will appear in Legend

Expression - Determines which 
range or subset of data to 
style for each generated rule.
See Assign Expression.

Apply Visual Properties - Style 
properties applied to the 
selected rule.
See Apply Style Properties.

Stop Applying rules if art qualifies 
for this rule - Limit application 
of subsequent rules to art 
that meets rule criteria

Rule Operations  
Add a rule  

Copy a rule  
Remove selected rule 

Batch Generate Rules 
Generate multiple rules 
based on different 
classification methods. 
See Add Stylesheet Rules.
Edit Visual Property Ramps 
Edit visual properties for 
generated rules.  
See Edit Visual Property Ramps.

The Theme name is reflected in the MAP Themes panel and can be edited.

At least one MAP Layer must be specified before generating rules. Click the Select Layers button to open the Select 
Layers dialog box to choose applicable layers. Multiple layers can be chosen, however, rules can only be generated 
on a per layer basis (meaning multiple rules can not be created across multiple layers simultaneously). Selected 
MAP Layers are listed beside the Select Layers button.

The Edit Reset Options setting is used to either reset visual properties before applying rules or reset visual 
properties for art that does not qualify for any rule. The Clear instead of reset setting removes all styles from art 
objects, sets fill and stroke to none and returns opacity to 100%.
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Add Stylesheet Rules Manually
To add a single rule, click the Add Rule button. Rules are shown in the rule list on the left hand-side of the Edit 
Stylesheet Theme dialog box. When a rule is selected, the settings for it are active to the right where its Name, 
Expression and Visual Properties can be assigned.

Note:	 Use caution when assigning a Stylesheet theme to grouped objects or compound paths, the graphic styles 
may not apply universally.

Assign Expression
The Expression section provides options to define the criteria in which the data chosen will be styled. There are two 
modes to define an expression: simple and advanced.

By default, the Simple Expression mode is displayed and is intended to facilitate quick expression generation.

Attribute Column - Attribute column 
of the associated MAP Layer

Range operator - Click to activate 
the second row to enable the 

composition of range expressions

Values - List of values in the 
selected attribute column

Toggle Mode - Toggle between 
Simple and Advanced mode

Expression - The completed 
expression

Comparison - Operators used 
to compare values

First, choose an attribute column from the drop-down list or manually type in an attribute name. Secondly, choose 
from a comparison operator from the drop-down list:

> 	 Greater than >=	 Greater than or equal to

<	 Less than <=	  Less than or equal to

=	 Equal to !=	 Not equal to

�Finally, type or choose value against which the comparison will be applied. To create an expression based on a 
range, click the Range operator check box to enable an additional comparison and value input pair.

Property and read-only attributes cannot be selected in the Simple Expression mode. To use property and read-only 
attribute values, click the Toggle Mode button to switch to the Advanced Expression mode. 

Expression - Type or use the 
Expression Builder to define 

an expression.

Expression Builder - Create an 
expression in the Expression 
Builder. See Chapter 5.

Expression Library - Choose an existing 
expression. See Chapter 5.

In Advanced Expression mode, construct more complex expressions and to use read-only and property attributes.
The Expression Validity icon will report  if the expression entered is valid. Otherwise it will report  and include 
additional warning notes. Alternatively, use the Expression Builder  to create and edit expressions. To use a saved 
or recent expression, use the Expression Library . See chapter 5 for more information on both.
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Apply Visual Properties
The Apply Visual Properties section provides many options to style data including graphic style, stroke, stroke 
weight, fill, scale and opacities. Depending on the type of stylesheet feature type, the style properties may differ:

For Area and Line feature types

Style - Select a predefined 
graphic style for selected rule

Stroke/Opacity/Weight - Choose a 
predefined swatch style. Adjust 
the transparency of the stroke. 

Adjust the stroke weight (in pts)
Fill/Opacity - Choose a 
predefined swatch style. Adjust 
the transparency of the fill.

Toggle Mode - Toggle between 
Simple and Advanced mode

Scale - Adjust the scale of style 
and stroke properties

Opacity - Adjust the transparency  
for all properties

Click the check box beside each option to enable it. The Style option contains a drop-down list of styles that exist in 
the Adobe Illustrator Graphic Styles panel.

For Point feature type
Graphic Style - Select a 

predefined graphic style to 
apply to the selected symbol

Symbol - Choose a predefined 
point symbol style.

Rotation - Specify a custom 
symbol rotation

Toggle Mode - Toggle between 
Simple and Advanced mode

The Symbol option contains a drop-down list of symbols that exist in the Adobe Illustrator Symbols panel.

For Text feature type
Graphic Style - Select a 

predefined graphic style to 
apply to the selected text

Symbol - Choose a predefined 
character style symbol style.

Font - Choose font and style

Font size - Choose font size

Toggle Mode - Toggle between 
Simple and Advanced mode

The Style option contains a drop-down list of character styles that currently exist in the Adobe Illustrator Character 
Styles panel. Note that enabling the Font and Font size options will override the Style option.
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Click the Toggle Mode button to toggle between Simple and Advanced mode for style properties. In the Advanced 
mode, an expression can be entered manually, created with the Expression Builder or chosen from the Expression 
Library. This essentially allows attribute information to be used as the basis for style properties.

Toggle Mode - Currently in 
Advanced mode

Expression Builder - Create an 
expression in the Expression 
Builder. See Chapter 5.

By default, the Scale is 100%. Editing the scale will alter the symbol size (points) or stroke weight (areas and lines). 
The maximum scaling factor is 1000%.

The Opacity setting adjusts the transparency of all visual properties. For area and line feature types, there are 
separate fill and stroke opacity settings. Combine with the Opacity setting to increase overall opacity.

Move Simple Expression to Advanced Expression
It is possible to move an expression from Simple Expression mode  to the Advanced Expression mode. This may 
help when tweaking rule expressions to achieve optimal thematic results. To move a simple expression, right-click 
below the Simple Expression input settings (on the Expression line) and select Move to Advanced in the context menu.

The expression will appear in the Advanced Expression mode. 

Note:	 An advanced expression cannot be moved to a simple expression. Doing so will remove the expression from 
the Simple Expression mode.
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Add Stylesheet Rules with Rule Generator
To generate multiple rules based on a classification, click the Batch Generate Rules button in the Edit Stylesheet 
Theme dialog box. This opens the Rule Generator dialog box:

Layer - Select source layer
Add - Add these rules to 
the Rule list

Overwrite - Overwrite 
and remove all existing 
rules in the Rule list

Data classification table 
Table that shows the 
expression, starting 
and ending range 
values and any of 
the visual property 
assignment settings.

Source - Displays number of 
values and unique values

Attribute - Select attribute 
to generate rules for

Load - Load the selected 
attribute values

Classification Method  
Equal Intervals, Quantiles, 

Natural Breaks (Jenks-
Caspall) or Unique Values

Data Classes - Number of 
classes to classify by

Inclusive Boundary - Choose 
either start value or end 
value to include as class 

data boundary

Visual Property Assignment 
Set the style properties 

for the data classifications 
above. The styles are 

global and affect all of 
the rules.

The Rule Generator generates rules on a per layer, per attribute basis (however, if multiple layers share  a common 
attribute, it can be chosen). Once a MAP Layer and attribute are chosen, click the Load button to populate the 
Data Classification table below it. The default classification method is Equal Intervals, but can be changed to any 
of the data classification methods described below. The classification is dependent on how many data classes are 
specified. In addition, set the start or end value as the inclusive boundary which determines whether the data range 
starts or ends on a boundary value. Enable the Ignore option and enter an expression (or use the Expression Builder 
or Library) to specify data values that will be ignored.

Stylesheet MAP Themes support four types of data classification methods:

Equal Intervals This classification method sets the value ranges in each category equal in size. The 
entire range of data values is divided equally into the number of categories chosen.

Quantiles This method classifies data into the number of categories chosen with an equal number 
of units in each category.

Natural Breaks 
(Jenks-Caspall)

This classification method is based on the Jenks-Caspall algorithm. It uses an empirical 
approach based on minimizing the sum of absolute deviations around class means. 
Using arbitrary set of classes, it calculates a total error and attempts to reduce this error 
by moving observations between adjacent classes.

Unique Values This method creates a category for each unique value in the chosen data set. This 
method is most appropriately used when there are few unique values within a data set.
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Use the Visual Property Assignment section to specify how the data classifications are styled. Each style property 
(except for stroke weight) can be set in two ways: as a ramp or as a single application. By default, the Ramp mode 
is enabled. This applies a style property to all data classes in a ramp manner (ascending to descending, or if the 
reverse option is checked, descending to ascending). When a style property is in Single Value mode, the options 
available change. This option applies the same style property to all data classes.

For Area and Line feature types

Ramp mode - Style is 
in ramp application 
mode. The style 
ramp is applied to all 
data classifications 
in ascending (or 
descending) manner

Single Value mode 
The style is in single 

value application 
mode. The same style 

applies to all data 
classifications.

For Point feature types

For Text feature types

Any enabled style options are shown in the data classification table under its own column heading and each 
classification its respective style setting. When additional classes are added to the table, visual styles that are in 
Ramp mode will be adjusted proportionally. For example, a layer has an opacity ramp from 0% to 100% and each 
of its three classes has an opacity value of 0%, 50% and 100%. When a fourth class is added, the opacity for each 
class is proportionally changed to 0%, 33%, 66% and 100%. This works best for visual properties that may be 
continuously adjustable such as scale or colour gradients. A warning icon appears when there is a greater number 
of classes than colour swatches (groups) or styles. This will lead to colours or styles being repeated.

When the rules and style properties are set, click Add or Overwrite. Add adds more rules to the Rules list. Overwrite 
clears all existing rules in the Rules list and replaces it with the current rules and styles.
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Edit Visual Property Ramps
Instead of overwriting rules just to change styles, click the Edit Visual Property Ramps button in the Edit Stylesheet 
Theme dialog box to edit existing applied styles.

Changes - Original (left) 
changed to adjusted 
style property (right)

Property Change - Adjust 
existing style property

New Property - Add new 
style property to rules

Select (or deselect) existing rules from the Affected rules list and change style properties in the Overwrite Visual 
Properties section. Changes made to rules with existing styles are reflected in the Changes table where a green 
arrow indicates the new style changes. Similar to the Rule Generator, any new style properties added are reflected 
in the Changes table. All style changes to rules are updated in the Edit Stylesheet Theme dialog box. There is no 
need to recreate existing visual properties in order to maintain them.
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Dot Density Themes

OVERVIEW

Dot density themes are sometimes called dot distribution maps because they show where particular data 
characteristics occur. It uses dots or other symbols to represent the number of occurrences of a given data 
characteristic in a particular location. Each dot or symbol used on the map may represent a single entity 
(one dot = one person) or as a one-to-many entity (one dot = 1000 people). The data is read from each MAP Layer 
and MAP Themes quickly styles the data using Adobe Illustrator symbols and graphic styles.

Since dot density maps are most useful for showing where particular data occur, they only work on area MAP 
Layers. Most often, symbols are used to represent data occurring within a bounding polygon such as a census tract, 
zip code or county. Use caution when analyzing dot density maps, it should be understood that the dots or symbols 
do not always indicate the exact location of the data.

FUNCTIONALITY

Create New Dot Density Theme
To create a new Dot Density theme, click the Create New Map Theme button  in the MAP Themes panel. 
Alternatively, choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme 
dialog box, where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Dot Density MAP Theme

Name - Specify a name for the 
new Dot Density theme

Theme Type - Select Dot Density from 
theme type drop-down list.

Dot Density themes are displayed in the MAP Themes panel. To edit a Dot Density theme, double-click it or select  
Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Dot Density Theme dialog box.

Dot Density Theme
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Dot Density Theme Editor
The Edit Dot Density Theme dialog box is where attribute, density and symbols are chosen.

Layer - Select source layer

Theme name - Change from 
the default theme name

Dot value - The value 
represented by each dot 

Attribute - Select attribute 
to base density on

Data range - Displays the 
minimum and maximum 

values of chosen attribute 

Specify - Choose a simple 
dot style, size and 

appearance (stroke, 
stroke width and fill) 
using Custom Mode. 

Alternatively, click the 
toggle button to switch 

to Graphic Style mode 
to choose a pre-defined 

graphic style.

Use Symbol - Choose a 
custom symbol to use and 

set it's scale and opacity

Dot density is created on a per layer, per attribute basis. When an attribute is chosen from the drop-down list, click 
the Load button. The data range displays the minimum and maximum values for that attribute. These values should 
be taken into account when determining a one-to-many dot density and dot value.

A dot value of 1.00 represents a single (one-to-one) entity. A dot value greater than 1.00 represents a group 
(one-to-many) entity. See Considerations for Dot Density Maps.

Dot Options
Choosing dot size is a subjective decision based on visual perception limits and aesthetics (see Considerations for 
Dot Density Maps). There are two main options to style dots: simple and symbol. Choose the Specify option to use 
simple dot styles from the drop-down list. By default, the Appearance options are in Custom Mode. Click the toggle 
button to switch to Graphic Style mode, where a graphic style can be chosen from the drop-down list. Alternatively, 
choose the Use symbol option to use symbols sourced from the Adobe Illustrator Symbols panel. Adjust the scale and 
opacity as necessary. Check the Always regenerate dot positions when applying to randomize the dot positions when the 
Apply button or Apply MAP Theme button in the MAP Themes panel is clicked.

Note:	 Only basic appearances can be applied to dot density dots. Adobe Live Effects, graphic styles with opacity, 
multiple strokes and other non-basic appearances or effects cannot be used.
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After a Dot Density MAP Theme is applied, the effect is listed in the Adobe Illustrator Appearance panel. Select 
an area containing the dot density effect and click Dot Density in the Appearance panel to open the Dot Density 
dialog box. This dialog box differs from the Edit Dot Density Theme dialog box. The Dot Density dialog box can be 
used to fine tune the dot density appearance of individually selected areas instead of making a global change.

Considerations for Dot Density Maps
When creating one-to-many dot density maps, several considerations should be noted: enumeration units, dot size, 
dot value and dot placement. The scale, size, shape, and distribution of data across enumeration units (e.g. census 
tracts or block groups) can cause variations in how a dot density map is patterned. On average, smaller sized and 
more regularly shaped enumeration units result in a more realistic density map.

The dot value and dot size should be determined together to get an idea of how many dots will populate the map. 
Take into consideration the minimum and maximum values of the selected attribute. A rounded dot value should 
be chosen for easy approximation. There is a trial and error phase when choosing the most appropriate dot value 
and size. Generally, a medium sized dot should be chosen. Small dots produce a widely dispersed dot pattern and 
may convey disproportionate map accuracy. Large dots produce overly dense dot patterns and hide any noticeable 
map patterns. As a general rule when an appropriate dot value and dot size are chosen, two to five dots should be 
seen in enumeration units with the smallest values. MAPublisher allows for automated, random placement of dots.

Too sparse Too dense Optimal

When the value for a particular feature is lower than the "Dot value", a dot may not be assigned for that object.  This 
happens because MAPublisher only accepts values that are greater than fifty percent of the dot value to be given 
a dot. For example, if an object has a value of 4,000 and the dot value is 5,000, it will be assigned a dot because it 
is greater than fifty percent (or 2,500) of the dot value. Alternatively, an object that has a value of 2,000 will not be 
assigned a dot because it is less than fifty percent (or 2,500) of the dot value.



166 Chapter 9: MAP Themes
Chart Themes

Chart Themes

OVERVIEW

Chart themes come in two types: bar chart and pie chart. A bar chart is represented by rectangular bars with 
lengths proportional to the attribute values that they represent. A pie chart is comprised of a circle divided into 
sectors, showing attribute value proportion. These charts are generally placed near the center of the aggregation 
area (e.g. census tract or state).

Chart data is read from attributes from a MAP Layer and MAP Themes quickly styles the data using Adobe Illustrator 
symbols and graphic styles. Charts can plot both discrete and continuous data. Some examples of discrete data 
include voters or hair color. Some examples of continuous data would be temperature or height.

FUNCTIONALITY

Create New Chart Theme
To create a new Chart theme, click the Create New Map Theme button  in the MAP Themes panel. Alternatively, 
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, 
where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Chart MAP Theme

Name - Specify a name for the 
new Chart theme

Theme Type - Select Chart from theme 
type drop-down list.

Chart themes are displayed in the MAP Themes panel. To edit a Chart theme, double-click it or select  Edit "Theme 
Name" from the MAP Themes panel option menu. This opens the Edit Chart Theme dialog box.
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Chart Theme Editor
The Edit Chart Theme dialog box is where the chart type, style and its options are chosen:

Theme Name - Edit name 
of Chart theme

Output Layer - Choose 
which layer where 

charts are saved

Layer - Choose a layer 
to load the Attribute 

drop-down list

Labeling - Click to 
open the chart 
Labeling dialog box

Scaling - Click to 
open the chart 
Scaling dialog box

Type - Choose Bar 
chart or Pie chart

Move Up/Down - Adjust 
placement of attribute 
in the bar or pie chart

Options - Options to 
adjust the width, 

height, orientation, 
spacing, scale, sort 

order and border

Appearance - Adjust 
the stroke, stroke 
width, fill, and 
opacity of each 
attribute using 
Custom Mode 
(default) or Graphic 
Style Mode

Chart Preview - A 
preview of the 
chart with the 
current and options. 
Adjust the quality 
of the preview in 
the Quality drop-
down list

Chart Attributes 
Add attribute  

Remove attribute 

The Theme name is reflected in the MAP Themes panel and can be edited. Specify either Bar chart or Pie chart from 
the Type drop-down list. Depending on the type of chart chosen, several appearance and option settings will differ.
Choose the appropriate Legend layer to store the charts from the Output layer drop-down list. Enable the Ignore 
option and enter an expression (or use the Expression Builder or Library) to specify data values that will be ignored.

Add Source Data
In the Source Data section, choose a MAP Layer to load its attributes from the Layer drop-down list (Text layers 
are not supported). Click the Select Layers button to open the Select Layers dialog box to choose applicable 
layers. Only the attributes of a single layer may be chosen at a time (meaning mixing layers and attributes is 
simultaneously is not possible). Click the Add attribute button to add an Unspecified attribute slot into the list. 
Select an <Unspecified> item in the list and choose an attribute from the Attribute drop-down list. The attribute 
name is automatically used in the Label box, however it can be edited and any change is reflected in the attribute 
list. To change the sort order, select an attribute in the list and click the Up or Down arrow.
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Adjust Bar Chart Appearance and Options
To change the appearance of an attribute, select one from the list to enable its appearance properties. The 
Appearance section, in Custom Mode (default), has adjustments for stroke, stroke opacity, stroke width, fill and 
fill opacity. Alternatively, click the Toggle Mode button to switch to the Graphic Style Mode. In that mode, choose 
a predefined graphic style from the drop-down list (sourced from the Graphic Styles panel). Changes made are 
reflected in the style indicator in the attribute list as well as the chart preview at the bottom of the dialog box. 

Style Indicator - Color 
chip shows a preview 
of the bar chart style

Stroke Width

Stroke

Fill
Toggle Mode

Stroke Opacity

Fill Opacity

In the Options section, adjust basic bar chart settings—width, height, bar orientation and bar spacing. Other 
options include setting the bars relative to maximum data value. In this case, all the bar values are divided by the 
maximum value and then drawn as a relative proportion to it. The Scale by option is useful for instances where 
a chart size may be used to represent overall proportion in comparison with other charts. The scale value is 
determined by an attribute in the selected MAP Layer. The Sort Values option sorts (from left to right) increasing 
and decreasing values. It is not shown in the chart preview. The Draw chart border option is not enabled (default). 
Click the check box to enable it and adjust its appearance options. Choose from a low, medium, high or very high 
preview chart quality setting in the Quality drop-down list.

Draw chart border - Enable 
to draw a border 

Margin - Adjust the 
space between the 
chart and the border 

Initial Alignment - For Point layers only. 
Choose alignment position for the chart. 
It will only be aligned the first time.

Bar thickness/Maximum bar length 
Adjust the size of each bar

Bar orientation - Choose 
vertical up/down or 
horizontal right/left

Bar spacing - space between 
each bar

All bars relative to maximum data 
value - the bars are adjusted 

to a relative maximum 
attribute data value

Apply style to chart - Choose a 
graphic style to apply to the 

entire chart

Sort Values - Sort the bars 
in either increasing or 
decreasing order (not 

shown in preview)

Border style - Adjust the 
stroke, stroke width, 
fill, and opacity of each 
attribute using Custom 
Mode (default) or 
Graphic Style Mode

Note:	 For charts based on a point layer, the Alignment setting will only be applied the first time the chart is created. 
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Adjust Pie Chart Appearance and Options
The Pie Chart Appearance options differ slightly from the Bar Chart options. Only the options applicable to pie 
charts are shown here. The other Appearance options function identically as explained in the previous section. 
The Explode option creates separation of a selected attribute (slice) from the rest of the pie chart. To adjust the 
separation of all slices, use the Explode option in the Options section.

Explode - Adjust how 
far the selected 
attribute is separated 
from the pie chart

In the Options section, adjust basic pie chart settings—pie radius, hole radius, explode and rotation. The Hole 
Radius option creates a hole in the middle of the pie chart and results in chart that looks like a ring. The Explode 
option here is different than the attribute Explode option in that this applies to all the slices and not just a single 
slice. The Rotation (default at 0) starts at the top (12:00 o'clock position) of the pie chart and rotates clockwise 
(negative rotation values cannot be used) up 359 degrees.

The other chart options function identically as explained in the previous section.

Pie Radius - Adjust the size of 
the pie chart

Hole Radius - Adjust size of 
the hole in the pie chart

Explode - Adjust the 
separation of all slices

Rotation - Adjust the rotation 
of the pie chart from 0 to 

359 degrees
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Chart Labeling
There are multiple options to label both bar and pie charts. In the Edit Chart Theme dialog box, click the Labeling 
button to access the Labeling dialog box. By default, all labeling options are disabled. Click the check box beside 
Show title, Show value labels and Show name labels to enable labeling options for each one. The Show name labels 
option only applies to bar charts. The labeling options are shown below with an example of what some of the 
settings do.

Appearance - Adjust the font 
and font size of the title. 

Specify a title in the box or 
choose from an attribute 

that contains text

Examples
Show title

Show value labels

Show name labels

Offset - Adjust how far the 
label is from the chart

Alignment - Align the title to 
the left, center or right

Rotation - Align the title to 
the left, center or right

Shrink title to fit chart - Adjusts 
the title so that it is 

proportional to the overall 
size of the chart

Displayed decimals - Set how 
many decimal places are 

shown with each label

Show name labels - These 
options only applies to bar 

chart themes

Show title line - Add a line 
below the title. Adjust 

its style properties using 
Custom or Graphics Mode.

Align value labels - Align all 
chart values horizontally

Label with pie percentage - 
Only for pie charts. Place 
percentage beside slice.

Click the Appearance text link to edit labels in the Edit Text Rendition dialog box. Click the Rendition toggle to 
choose a predefined Character Style in the Character Style mode or set appearance options in the Custom mode.

Custom mode Character Style mode
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Chart Scaling
There are multiple options to adjust how charts are scaled. In the Edit Chart Theme dialog box, click the Scaling 
button to access the Scaling dialog box. There are two options to scale charts: fixed size or use a value from an 
attribute. The fixed size option scales all the charts equally by the set percentage. From the initial size, a scale above 
100% increases chart size and a scale below 100% decreases chart size.

To scale from attribute, click the attribute drop-down list and choose the appropriate attribute. Click the Load 
button to load the data range so that the Scaling dialog box knows which values to use. When the data range 
values are clicked, they populate the boxes below (Normalize and Tie to value).

Use the perceptual scaling option to create a more visually accurate depiction of the scale. Perceptual scaling 
modifies the scaling slightly in a way that tends to make users perceive the relationship between scaled symbols as 
intended. When checked, the scaling will not be mathematically accurate but should be viewed as visually accurate.

From attribute - Scale the 
chart based on an attribute 
value. Load the data range 

to obtain values.

Attribute value is scale 
percentage - Use this option 
if the attribute is contains 

percentage values

Normalize - Enter a value to 
set it as 100%. Other values  

scaled based on it.

Attribute value determines scale 
from range - Use the data 

range to determine scale. 
Option to tie values to the 
minimum and maximum.

Fixed size - Scale the chart at 
a set percentage

Use perceptual scaling  
Adjusts the scaling so that it 

is more visually accurate 

Use the Attribute value is scale percentage option to scale the charts directly using the values for the selected 
attribute. The maximum scale value allowed is 999 percent. Any values that do not conform will be marked by the 
MAP Themes Log as an error and the scale for that chart will not be applied.

Use the Normalize option to set a value as 100 percent. All other values are converted to a percentage based on 
the set value and used to scale the charts. For example, if an attribute has a value of 2000 to be normalized as 100 
percent, that means a value of 1500 will be considered as 75 percent, effectively reducing the size of the chart.

The Attribute value determines scale from range option contains a number of setting to fine tune how the scale 
is set based on a range of values. The settings of the Minimum (default 5%) and the Maximum (default 100%) are 
based on the minimum and maximum of the data range. The Tie to value box specifically states which value in the 
range that is set as the Minimum or Maximum. It has two options available where any values below (minimum) or 
above (maximum) can be discarded or bound. This may be useful if there are extreme low or high values that could 
affect the scaling.
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MAP Theme Legends

OVERVIEW

A legend can be created from any MAP Theme—Stylesheets, Dot Density and Charts. Each theme has its own 
options and settings to create a legend. A legend is composed of boxes to represent area layers, lines to represent 
line layers, point symbols to represent point layers and text for text layers.

FUNCTIONALITY

MAP Theme legends must be added to a  Legend layer. One can be created first using the Add MAP Layer button in 
the MAP Views panel and choosing a Legend feature type (see chapter 4). Alternatively, MAP Themes will create one 
if no Legend layers are present.

To create a legend, select a MAP Theme and click the Create Legend button at the bottom of the panel. Alternatively, 
choose Create Legend in the panel options menu.

Create Legend

The Legend Editor dialog box will differ depending on the type of MAP theme chosen: Stylesheets open the 
Stylesheet Legend Editor, Dot Density opens the Create Dot Density Legend, and Charts open the Create Chart Legend.

Similar to other MAPublisher functions, the legend editors are dependent on several Adobe Illustrator panels 
including Swatches, Graphic Styles, and Character Styles to style legend symbol elements. Populate these panels 
with swatches and styles before creating legends.

Legends are not dynamically linked to the MAP Themes. When MAP Theme styles change, a new legend must be 
generated. Select a MAP Theme that already has an existing legend, click the Create Legend button and adjust 
the settings to create a new legend. It is most useful when tweaking a legend to make it match or fit a layout 
design. Furthermore, legend elements can edited freely using the Direct Selection tool, in isolation mode or if it is 
ungrouped (menu Object > Ungroup).
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Stylesheet Legend Editor
The Stylesheet Legend Editor is used to create legends from point, line and area Stylesheet MAP Themes.

Output Layer - Select a 
Legend layer as output

Include icon - Check to 
include the legend 

icon. Set the size, icon 
style or use Advanced 

to match legend 
entries to rules. 

Draw border - Check to 
place border around 

legend entries. Use 
options to style border.

Columns - Specify 
number of columns in 

the legend

Alignment - Align the 
legend elements to 

the left, center, or right

Space between entries - 
The distance between 

each legend entry

Draw title - Check and 
specify a legend title in 
the box. Use options to 

align and style title

Display name - Rule 
name displayed in 
legend (if enabled)
Display expression 
Expression 
displayed in the 
legend (if enabled)

Legend Preview - A 
preview of how 
the legend key 
looks with current 
settings. Choose 
from several 
preview qualities 
and actual size.

Include expression - 
Check to include the 

legend rule expression

Include name - Check 
to include the legend 

entry names

Reset - Reset 
legend entries to 
its original setting

The Legend Entries list determines how many items are listed in the legend. Use the Add and Remove entry buttons 
to adjust how many entries are listed and use the Up and Down arrows to adjust the hierarchy. Select a legend entry 
and adjust the Display name and Display expression. These labels are used in the legend and are dependent on 
whether or not the Include name and Include expression options are enabled.

By default, the Include icon option is enabled. This is the legend icon to the left of an entry display name. Edit the 
size of the graphic using the vertical and horizontal size adjustments. Click the Advanced button to apply more than 
one rule style to a legend layer. This may be useful in cases where two styles such as one for a highway and one to 
represent high traffic volume, can be both chosen for one legend entry to represent a high trafficked highway. In 
addition, there are many shapes available in the Icon style drop-down list. The Icon style list is different for Line and 
Area Stylesheet themes (unavailable for Point Stylesheet themes). Use the Alignment option to align the legend 
entries left, center or right. Use the Columns option to adjust how many columns are in the legend. The minimum 
number of columns is one and the maximum number is dependent on how many legend entries exist. The Space 
between entries option determines the distance (in pixels) between each entry.

In the Additional Options section, use the Draw border options to add a border around the legend entries. Toggle 
between Custom Mode and Graphic Style mode to choose border style settings. Use the Draw title options to add 
a title to the legend. Specify a title in the title box and use the options to align and set a style. Enable the Draw title 
line to place a horizontal line in between the title and the legend entries. The Element spacing option determines 
the distance (in pixels) between the title, title line and legend entries.
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Create Dot Density Legend
The Create Dot Density Legend dialog box is used to create a legend from Dot Density MAP Themes.

Border - Check to place 
border around legend 
entries. Use options to 

style border.

Appearance - Adjust the legend 
label font and font size

Margin - Adjust the distance 
between the border and 

legend label

Legend label - Label is entered 
by default. Edit to change it.

Dot spacing - The space between 
the dot and the legend label

Dot icon size - The dot size 
represented in the legend

By default, the Use actual size check box for the Dot icon size setting is enabled. Uncheck it to manually set a size (in 
pixels). The preview shows how the legend will look depending on the settings. Adjust the Dot spacing option to 
increase or decrease the distance between the dot and the legend label.

The Legend label box provides the legend with a title. It uses a %value% variable to determine the value from 
the Dot Density theme. To adjust the value, close this dialog box and edit the Dot Density theme. Click the label 
appearance link to change the label font, style and size.

By default, the Border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to set the 
style of the border. Increase or decrease the value Margin option to adjust the distance between the legend label 
and the border.
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Create Chart Legend
The Create Chart Legend dialog box is used to create legends from Chart MAP Themes.

Draw border - Check to place 
border around legend entries. 

Use options to style border.

Draw title - Check to place a 
title. Use appearance options 

to style the title.

Style - Choose either Standard 
or Chart style

Style Options - Depending on 
Standard or Chart style, these 
options will differ. See below.

Label appearance - Adjust the 
legend label font and font size

Margin - Adjust the distance 
between the border and 

legend label

Click the Label appearance link to change the font, style and size of the legend entry labels.

Use the Draw title options to add a title to the legend. Specify a title in the title box and use the options to align 
and set a style. Enable the Draw title line to place a horizontal line in between the title and the legend entries. Use 
Custom Mode or Graphic Style Mode to set the line style.

By default, the Draw border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to 
set the style of the border. Increase or decrease the value Margin option to adjust the distance between the legend 
entries and the border.

The Style drop-down list has two options: Standard and Chart. The Standard option gives the legend an icon and 
label style (see above screenshot).

Standard style options
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The Chart option provides more options to create a legend that is representative of the chart. When the legend is 
created for bar charts, these options are provided:

Bar chart style options

The chart size is the overall size of the chart, not the individual bars themselves. The Label offset is the distance 
between the bars and its respective label. The Do not apply chart graphic style option removes any graphic styles 
that were applied to the chart when it was created. The Label angle rotates the label to a specified degree. Bar sizes 
can be set to Increasing, Decreasing or Equal. These are for visual purposes only and do not reflect the actual data.

When the legend is created for bar charts, these options are provided:
Pie chart style options

By default, the Ignore explodes option does not display an exploded pie chart in the legend when it is checked. Set 
a Rotation to rotate the pie chart clockwise.
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One of the most useful features of MAPublisher is the ability 
to create labels for map objects using values from the MAP 
Attributes panel. Manually entering and placing labels is not 
necessary, provided that the labeling information is included 
in the map attributes of the MAP Layer being labeled.

MAPublisher provides two methods of adding labels 
to a map, both of which contain options to place labels 
intelligently using defined label settings.

One way to create feature labels is to first select all the 
features to be labeled and use Label Features to label all of 
them by specified attribute values. 

An alternate method involves using the MAP Tagger Tool to 
apply labels individually, also by specified attribute values.

As a complement to the labeling functions, Create Knockouts 
masks the part of line features covered by text labels for 
improved text legibility.

Topics covered in this section:
Label Features
MAP Tagger Tool
Create Knockouts

For more advanced labeling capabilities refer to chapter 17 
about MAPublisher LabelPro (additional license required).

Labeling
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Labeling Tools 
For Label Features and MAP Tagger Tool

See Settings panels below

Source Layer - Lists the Point, Line and Area 
layers which can be labeled. Only selected 

features are listed.

Source Column - Select the column that 
contains the values you wish to use to 

label the selected features

Label Settings - Click the appropriate button 
to assign label settings and rules for each 

layer type (see below)

Destination Text layer - For each Source Layer, 
select the destination text layer you wish to 
place the generated text labels on.

Point Label Settings

Label Position - Choose the position of the 
label relative to the point symbol

Use sounding style labels - Specific options 
to label symbols marking a water depth 
position according to hydrographic 
conventions. See details in this chapter.

Distance from start - Controls how text is 
placed relative to the line: 

Auto - places text at the midpoint for straight 
lines and find the smoothest portion closest 

to the midpoint for curved lines.  
Fixed - allows for precise placement of text 

along a line.

Adjust label if larger than line - Specify rules for 
the scaling of text if the text will not fit onto 

the text path in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labeling process.

Line Label Settings
Label type - Select whether text should 
follow lines or be placed at a point near 
the selected line. Path length option 
creates short or long text on path.

Reverse right-to-left paths (flip upside-down text) 
Always enabled by default, it automatically 
orients labels uniformly. Disabling this 
feature will not flip the label.

Line Smoothing / Offset Line - Check to smooth 
the generated text path. Then, specify an 
offset distance for the text path from the 
original.

Label Position - Choose how the text will be 
placed on the generated text path

Set all labels to same minimum size - If at least 
one label has been reduced in font size 
due to the implementation of rules, then 
ALL text items will be reduced to that font 
size ( in Label Features only)

Area Label Settings

Placement Accuracy - To quickly generate 
labels, choose Low. To force labels within 
the boundaries of area of complex shape, 
choose High.

Set all labels to same minimum size - If at least 
one label has been reduced in font size 
due to the implementation of rules, then 
ALL text items will be reduced to that font 
size (Label Features only)

Labels curve with lines of latitude  
For projected layers, choose this option to 

generate curved text along latitude lines

Adjust label if larger than line - Specify rules 
for the scaling of text if the text will not fit 

inside the area object in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labeling process.

Labels curve with lines of latitude
For projected layers, choose this option to 

generate curved text on latitude lines.
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Label Features 
Object > MAPublisher > Label Features or MAP Toolbar 

FUNCTIONALITY

The Label Features function adds labels to a map based on the attribute data of the selected features for Line, Point 
or Area MAP Layers. All selected features on MAP Layers (which contain appropriate attribute information) can be 
labeled using this tool. Data selected on multiple MAP Layers can be labeled simultaneously. Additional options can 
be specified, such as alignment to lines of latitude, minimum font size, horizontal scaling and label position in order 
to place labels intelligently.

PREREQUISITES

Labels will be added to a   Text layer created using the MAP Views panel. To create a new text layer, use the Add MAP 
Layer function in the MAP View panel(see chapter 4):

•	 Set the feature type to Text.
•	 To enable copying the attributes from the source MAP layer to the label destination layer, check the 

option Base attribute schema on and select the appropriate layer to copy its attribute schema. 

For best results, set up a character style for type font, size, justification and color. (Adobe Illustrator menu Window > 
Type > Character Style). Select the appropriate style in the Character Style panel before starting the Label Features 
tool and MAPublisher will generate labels based on these settings. Otherwise labels applied will appear in the 
current default color, font and font size. Once text attributes have been specified, select the features to be labeled 
and go to Objects > MAPublisher > Label Features or the MAPublisher toolbar button  to access the function.

LABEL FEATURES SETTINGS

Source Layer and Column
First set the options in MAPublisher to determine the attributes that will be converted to text labels. The Source Layer 
list shows the Area, Point and/or Text layers currently containing selected data.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Choose the 
appropriate column that holds the attributes you wish to label the map with.

Destination Text Layer
In the Text layer drop-down list, specify a Text layer that the labels will be output to. Note that labels can only be 
created on text layers in the same MAP View as the Source Layer.
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LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These label settings are 
common to Label Features and the MAP Tagger Tool (including MAP Contour Tagger).

 Line Labels
MAPublisher places Line labels depending on the curvature and length of the line string. Click the Line Labels button 
to assign MAPublisher Line Label Settings. Choose a Label type to either Follow line and create text on a path, Follow line 
and create point text or Don't follow line and create point text. The first option creates text that follows a path where its 
position can be adjusted along it. The second option creates text that follows the angle of the path, but uses a point 
of reference. The last option places the text at the middle point of a line and uses a point of reference.

MAPublisher controls where text is placed along lines by using the Distance from start option. Selecting Auto will place 
text at the midpoint for straight lines and, for curved lines, will find the smoothest portion of the curved line closest 
to the midpoint. When selecting Fixed, the distance from start is set as a percentage of the length of the line.

Reverse right-to-left paths (flip upside-down text) is enabled by default and will automatically orient labels uniformly if 
some lines are flipped. Disabling this feature will not flip labels.

When the Line smoothing option is enabled, MAPublisher creates a smoothed version of the selected path for each 
text object in the layer and places the text along it at the specified offset value. The labels can be dragged and 
positioned at any position along a line. When Line Smoothing is not enabled, the labels follow the original path.

Note:	 For lines with a high number of vertices (e.g. contour lines), using the Line Smoothing option significantly 
speeds up the labeling process.

The Label position option allows for the selection of the vertical position of the labels relative to the line. Three 
options are available: 

•	 Baseline: places labels above the generated text path. 
•	 Descender: places the portion of a letter in a Latin-derived alphabet that normally extends below the 

baseline of a particular font above the generated text path. 
•	 Center: places the label on the generated text path.

Labels can be modified if they exceed the length of the line in the current default font size. Check the Adjust label if 
larger than line option to activate the label reduction rules. These rules are executed in a hierarchical order and can 
be reordered with the Up and Down buttons. The Reduce font size option reduces the size of the font to a specified 
minimum size in points. The Reduce horizontal scaling option allows text to be scaled down horizontally by the 
percentage specified. 

Label Features also provides an additional option (not applicable for the MAP Tagger Tool). If any of the labels have 
been adjusted in size due to the activation of a line adjustment rule, all labels can be resized to the same size by 
checking the Set all labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered 
over the line. Also note that text generated for Line labels will be automatically orientated above the lines, 
irrespective of the direction of the line.
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 Area Labels
MAPublisher places Area labels depending on the shape and size of the area polygon. Click the Area Labels button to 
assign MAPublisher Area Label Settings.

The High Placement Accuracy option makes more advanced calculations for the label positions so as to force them to 
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands). However, it 
does slows down the labeling process so a Low accuracy can be preferable depending on the expected results.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines 
of latitude and place the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.

Labels can be modified if they exceed the size of the area in the current default font size. Check the Adjust label if 
larger than area option to activate the label reduction rules. These rules are executed in a hierarchical order and can 
be reordered with the Up and Down buttons. The Reduce font size option allows to reduce the size of the font to a 
specified minimum size in points. The Reduce horizontal scaling allows text to be scaled horizontally by the fraction 
specified. The Wrap Labels that are longer than area option adds a carriage return at the nearest space in the text.

Note:	 The Wrap Labels that are longer than area option is not available if the Labels curve with lines of latitude option 
is checked. 

Label Features also provides an additional option which is not available with the MAP Tagger tool. If any of the labels 
have been adjusted in size due to the deployment of an area adjustment rule, all labels can be resized to the same 
size by checking the Set all labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered 
over the area. In situations with compound areas, MAPublisher labels the largest area in the compound.

 Point Labels

Click the Point Labels button to assign MAPublisher Point Label Settings.

The Label Position offers nine position options for the text anchor. Choose one of the placements in the drop-down 
list: Upper Left, Upper Middle, Upper Right, Left, Center, Right, Bottom Left, Bottom Middle, Bottom Right. A preview 
shows the label placement.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines 
of latitude and places the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.
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Special Point Labels: Sounding Style Labels
The Use sounding style labels option is specific for users wishing to label point symbols marking measured water 
depth positions. These types of labels are officially known as Charted Soundings and its representation on official 
navigational charts are ruled by international standards. 

The aspect of the soundings is always according to the following rule: Numerals representing the decimeter part of 
a sounding should be visibly smaller than those representing whole metres and positioned slightly lower than the latter 
(subscript). Zero decimeter values must not be shown. 

For example:  	 12 	 92

Note:	 Traditionally, slanted text (in italic) represents depth values in metre, straight text represents depths in feet.

On official nautical charts, the actual depth symbol is not plotted — the label itself indicates the depth position. 
Two options are possible for the soundings' placement relative to the depth point:

•	 Use standard label style: soundings are placed in such a way that the centre of gravity (geometric centre) of 
the set of numerals (integer and decimal parts) coincides with the position referred to. This option is the 
most commonly used.

•	 Center on whole number: soundings are placed in such a way that the center of gravity of the integer part of 
the number coincides with the position referred to.

74 74
Depth  position relative 
to label (if it was drawn).

Standard style Centered on whole number

Note:	 More information on these standards can be found on the International Hydrographic Office Website,	  
www.iho.int, see publication S-4 (formerly M-4).

The relative size and position of the decimal (subscript) relative to the integer number (regular type) is controlled 
by the Adobe Illustrator document setup. Choose the menu File > Document Setup to change the subscript size and 
position under Type Options. These settings should be performed prior to running the labeling function because 
they affect the labels placement relative to the source symbols.

LABEL FEATURES RESULTS

When all the Layer Label Options have been set and the Label Settings have been specified click OK to label the 
selected features.

Labels applied using Label Features appear in the current default color, font and font size (as set by the selected 
character style). 

If the destination text layer and source layer have the same attribute schema, the attributes of the labeled features 
are copied as attributes to text features (to apply MAP Themes for example).
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MAP Tagger and MAP Contour Tagger Tool 
Tools > MAP Tagger Tool              and MAP Contour Tagger Tool

FUNCTIONALITY

The MAP Tagger Tool and MAP Contour Tagger Tool are interactive labeling tools that use the attribute data of selected 
features as a source for the labels. These tools function similarly to the Label Features function, however, labels are 
created by clicking features on the artboard. It provides greater control over the initial placement of the label. For 
the MAP Tagger Tool, labels are placed at the position of the mouse click and leader lines can easily be created in 
dense areas. For the MAP Contour Tagger Tool, labes are placed for Line layers only and works best on contour lines.

PREREQUISITES

Labels are added to a   Text layer created using the MAP Views panel.

For best results, set up a character style for type font, size, justification and color in the Adobe Illustrator Character 
Style panel. Select the appropriate style while using MAP Tagger tools otherwise labels will appear using the default 
color, font and font size. 

Double-click the  tool to enter new label settings or to edit settings. Click and hold the button to switch to the 

MAP Contour Tagger tool .

MAP TAGGER TOOL SETTINGS

Source Layer and Column
First set the options in MAPublisher to determine the attribute values that will be converted to text labels. The Source 
Layer list shows all Area, Point and/or Text layers in the current document.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Select the column 
that holds the desired attributes to label the data with.

Target Text Layer
In the Text layer drop-down list, specify the Text layer that the labels will be output to. Note that labels can only be 
created in text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are 
common to Label Features, MAP Tagger Tool and MAP Contour Tagger Tool (Lines only).
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TAG MAP DATA

Ensure the label settings are completed. With the MAP Tagger Tool enabled, click a map object to add a label for it. It 
may be convenient to lock the layers in the Adobe Illustrator Layers panel or disable undesired features by setting 
the attribute column option to No attribute selected for those data layers that do not require labeling to avoid 
undesired results.

The following list of keyboard modifiers can be used for additional labeling options with the MAP Tagger Tool:
 = click map object with MAP Tagger Tool

Standard label 	  Line labels are placed at click point and assigned angle of line at click point
	  Area labels are placed horizontally at click point
	  Point labels are placed horizontally at click point

Label horizontally
 + Shift

	  Line labels are placed horizontally at click point

Create leader line
+ Shift  + drag

	  Line labels are placed horizontally. Leader line connects text to line feature.
	  Area labels are placed horizontally. Leader line connects text to area feature.
	  Point labels are placed horizontally. Leader line connects text to point feature.

Label and move
 + drag

	  Line labels are assigned angle of line at click point and can be moved immediately
	  Area labels are placed horizontally and can be moved immediately
	  Point labels are placed horizontally and can be moved immediately

Note:	 To create custom leader lines use a graphic style. Create or load a graphic style and select it in the Graphic 
Styles panel while using the MAP Tagger Tool function.

The labeling procedure for MAP Tagger Tool differs slightly. Labels are placed by drawing a line and dragging it across 
lines (instead of clicking features to label them). This is particularly useful for contour lines, routes or rivers that are 
positioned near each other. The label follows the path.
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Create Knockouts 
Object > MAPublisher > Create Knockouts or MAP Toolbar 

FUNCTIONALITY

The Create Knockouts function masks parts of line features that are covered by text. The knockouts can be created 
for any MAP Layer. All lines in the selected feature layer are affected by the function. A knockout is created for all 
text in the selected  Text layer.

Line Feature - Line feature being masked

Text Feature - Text base for the knockout mask

Knockout - Knockout extents

The opacity of knockout masks can be set in the Create Knockouts dialog box and can be modified afterwards 
through the Adobe Illustrator Transparency panel.

By default, the size of the knockouts correspond to the Adobe Illustrator text bounding box—that includes 
ascenders and descenders (e.g. bottom of letter g). This size can be increased by adding a buffer in pixels (side, top 
and bottom) or limited to the height of capital letters. Optionally, choose the knockout to correspond to the shape 
of the text. This allow for finer control over the appearance of the knockouts.

Create Knockouts can either append new knockouts to the selected feature layer or replace the exiting ones. It is 
also used to clear knockouts that were previously created with the function.

Note:	 Any text layer can be used to create knockouts, it does not have to be generated by MAPublisher Labeling 
functions. The Feature and Text layers do not have to be in the same MAP View.

PREREQUISITES

Create Knockouts requires any type of MAP Layer and a  Text layer to be unlocked and visible. 

All features in the selected layers will be affected by the function. Text and features that are not supposed to be 
masked must be moved to a different layer beforehand.

Feature Layer - Select the line layer that 
will be masked with knockouts

Text Layer - Select the layer containing 
the base text for the knockouts

Mask Opacity - Set the mask opacity 
(100% creates transparent knockout)

Knockout boxes - Set a buffer size 
around the text box

Text shaped knockout - Set a buffer 
knockout based on the shape of 
the text

Limit to cap height - Check this 
option to limit the text box height 
to the size of capital letters.

Clear - Click here to remove all 
knockouts from the selected 
Feature Layer

Replace existing knockouts - Choose 
this option to clear the existing 
knockouts in the Feature Layer 

before adding new ones. Do not 
choose this option to append new 

knockouts to the existing ones. 

Use clipping mask instead of opacity mask 
Choose this option only when 

exporting document to PDF or 
PostScript. It uses a clipping mask 

instead of an opacity mask beneath 
the label.
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USING CREATE KNOCKOUTS

To access the function, click the Create Knockouts button  on the MAPublisher toolbar. Alternatively, choose 
Object > MAPublisher > Create Knockouts from the main menu.

Layers
In the Create Knockouts dialog box, click the Select Layers button to choose at least one Feature Layer (visible and 
unlocked), and then choose a  Text layer from the drop-down list. Use the Layer Type Filter to filter which layers 
are shown. Text in the selected text layer should overlap with some of the features in the selected feature layer to 
get reasonable knockout results. 

Mask Opacity
The Mask Opacity option sets the opacity of the masks created behind the text: a 100% setting creates an opaque 
mask (the feature will be invisible behind the text) and a 0% setting does not hide any features at all.

Replace Existing Knockouts
The Replace existing knockout option clears the existing knockouts on the selected Feature Layer before adding the 
new knockouts. This is useful when running the Create Knockouts function again after adjusting the settings 
slightly. To append the new knockouts to the existing one, make sure this option is not checked.

Knockout Boxes
Several parameters are available to set the size of the knockout. By default, the knockout corresponds to the Adobe 
Illustrator text bounding box. That bounding box can be slightly taller than the characters in the selected text 
because it takes into account the size of ascenders and descenders (e.g. | and g characters). To increase the size of 
the knockout, three buffer options are available: Side Buffer, Top Buffer and Bottom Buffer. Buffer sizes are entered as 
pixel values. The Limit to cap height option reduces the knockout size to the height of the capital letters. For example, 
this option is useful when labeling contour lines that are close to one another where the regular knockout size 
could create masks that overlap from one contour to the next. The knockout boxes are represented below by the 
dashed line (for visual reference only).

Default knockout size Limit to cap height 
knockout size

Buffer knockout size (2 px)

To achieve a knockout that does not conform to a box, choose the Text shaped knockout option and specify a buffer 
size. This creates a knockout that is based on the shape of each text character. It allows for finer knockout control.

Text shaped knockout (1 px)

Note:	 Text shaped knockouts may increase document file size.
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KNOCKOUT RESULTS

All art in the MAP Layers are masked by the text objects in the selected Text layer, where appropriate.

To achieve the knockout effect, Create Knockouts applies an opacity mask at the layer level as can be seen in the 
Adobe Illustrator Layers panel.

This masking does not affect the MAP Layer attributes or properties.

Edit Knockout Masks Opacity
The opacity of all the knockouts within MAP Layers can be edited using the Adobe Illustrator Transparency panel:

1.	 In the Adobe Illustrator Layers panel, click the target button next to the master layer name  .
2.	 Choose Window > Transparency to open the Transparency panel.
3.	 In the Transparency panel, click the right-side preview to start editing opacity mask.

4.	 Click the left-side preview in the Transparency panel to exit the opacity mask editing mode.

Note:	 If for some reason the knockouts are not selected when you exit the opacity mask editing mode, the next 
time you return to this mode, they will not be selected by default—you'll have to select the knockouts again 
from within the opacity mask editing mode (click the object or use the Layers panel target button).

CLEAR KNOCKOUT MASKS

Open the Create Knockouts dialog box, ensure that the MAP Layers that contain the knockouts are selected and click 
the Clear button.

Edit Opacity Mask - Click to edit 
opacity mask

Exit Edit Opacity Mask - Click to stop 
editing opacity mask

Opacity - Edit the opacity

Layer with Opacity Mask - In Adobe Illustrator, 
a dashed line under a layer name indicates 
that the layer has an opacity mask
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MAPublisher contains tools for selecting data graphically and 
by attribute values. 

The MAP Selections panel provides functionality to create, 
edit and save multiple selection criteria: based on attribute 
expressions, manual art selections or spatial filters. MAP 
Selections are saved with the document.

The Split Layer function allows to split MAP Layers based on 
attributes values to facilitate data management.

The topics covered in this section:
MAP Selections
Split Layer
Right-to-Left Text
Text Utilities

MAP Selections 
and Document 
Operations
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MAP Selections 
Window > MAPublisher > MAP Selections or MAP Toolbar  

Delete MAP Selection - Delete highlighted 
MAP Selections

Create New MAP Selection- Opens the New 
MAP Selection dialog box (below)

Get Subset of Current Selection - Makes a 
selection within the current selection

Remove from Current Selection - Removes 
the highlighted criteria from the current 
selection

Add to Current Selection - Adds the 
highlighted criteria to the current 
selection

Apply as New Selection - Makes a new 
selection using the highlighted criteria

MAP Selections Panel

MAP Selections List - MAP Selections saved 
in the current document

Three different types of MAP Selections: 
•	 Attribute Filter 

•	 Art Selection 

•	  Spatial Filter 

Invalid MAP Selections for the currently 
selected layer are marked with an 
additional  sign.

MAP Selections Panel Preferences

Show filters on two lines - cleared

Show filters on two lines - selected

MAP Selection Name - Name given to the 
MAP Selection. It can be changed in the 
Edit MAP Selection dialog box.

MAP Selection Parameters - Summary of 
the selection parameters. They can 
be changed in the Edit MAP Selection 
dialog box.

Duplicate MAP Selection - Copies the 
selected MAP Selection

Edit MAP Selection - Opens the Edit MAP 
Selection dialog box

Import MAP Objects - Opens the Import 
MAP Objects function (see chapter 4)

Preferences - Opens the MAPublisher 
Preferences on the MAP Selections 
property sheet

Panel options:
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New/Edit MAP Selection

Expression Validity - Indicates if the 
expression is  valid or  invalid. 
If invalid, additional information is 
reported

Expression - Enter or edit the expression 
directly into the entry field, or access

 Expression Builder  - see chapter 5

 Expression Library - see chapter 5

Name - Assign or edit the name of 
the MAP Selection

Type (new MAP Selection only) - Choose 
the MAP Selection type:
•	  Attribute Filter  

•	  Art Selection 

•	  Spatial Filter 

 Attribute Filter
Layer(s) - Choose layers to base 

the selection on. By default, the 
selection will be done on the 

currently selected layer.

Click to  make a different choice 
in the Select Layers dialog box

 Art Selection
Art must be selected first.

 Spatial Filter
Filter Using - Choose where the features 
that delimit the spatial filter are taken 
from:
•	  Existing MAP Selection: select a MAP 

Selection name from the Existing MAP 
Selection drop-down list

•	  Art Selection: use the current art 
selection (see options above for edit)

•	  Attribute Filter: enter new attribute 
filter parameters (see Attribute Filter 
dialog box above)

Select From Layers - Choose layers to 
select from. By default, the selection 
will be done on all layers.

Click to  make a different choice in 
the Select Layers dialog box (see above)

Spatial Relationship - Choose the method 
applied for the spatial filter:

•	 Intersect and contain: objects that 
intersect or are contained within the 

delimiting features will be selected
•	 Fully contained: only objects that are 

fully contained within the delimiting 
features will be selected

Filter Text By - Choose the specific 
behavior for selecting text:

•	 First letter of text: the position of 
the first letter of a text is used to 

make a selection
•	 Full size of text: the bounding box 
of the text is used for the selection

Do not select art on the same layer as the 'Filter 
Using' art - Check this option so as not 
to select art that is on the same layer 

delimiting feature

Edit Art Selection
Show Selection - Highlights the Art 

Selection on the artboard

Replace - Replaces the saved Art Selection 
with the current artboard selection

Add - Adds the current artboard 
selection to the saved Art Selection
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FUNCTIONALITY

The MAP Selections panel provides options to build, edit, save and apply multiple selection criteria based on:
•	 Attribute Filters: selections based on attributes and properties of MAP Layers
•	 Art Selections: saved selections (done with the MAP Selections filters or with the Adobe Illustrator 

selection functions)
•	 Spatial Selections: selections based on a feature's position relative to another (e.g. select points 

contained in a given area). 

MAP Selections are saved in the Adobe Illustrator document. The Import MAP Objects function (see chapter 4) provides 
a method to exchange MAP Selections between documents opened in Adobe Illustrator.

Expressions created for Attribute Filter type MAP Selections can be saved in the Expression Library so that it can be 
used in MAP Attributes and MAP Themes stylesheets (see chapter 5 and chapter 9, respectively).

PREREQUISITES

To save or use a MAP Selection, at least one piece of art must be selected on the artboard before creating a new 
selection. This selection does not have to be on a MAP layer, although it must be visible and unlocked.

CREATE A MAP SELECTION

To open the MAP Selections panel, choose Window > MAPublisher > MAP Selections or click the MAPublisher toolbar 
button . 

To create a new MAP Selection, click the Create New MAP Selection button  or the panel options menu to open the 
New MAP Selection dialog box.

Enter a meaningful Name for the new MAP Selection to facilitate its use. For example, a MAP Selection could be 
named Cities or Countries with 80% or higher literacy or US Highways. 

Choose the desired MAP Selection Type: Attribute Filter, Art Selection or Spatial Filter.

Attribute Filter
Attribute Filters select objects on one or more MAP Layers based on the features' attributes values or properties. 
The selection criteria is an expression created from attributes names, values and/or preset functions.

By default, the selection is done on the currently selected layer. Users may choose a different layer or more layers by 
clicking the  button to open the Select Layers dialog box. Check any layers that may need to be included.

In the Expression field, enter a valid expression. Optionally, click the  button to open the Expression Builder dialog 
box or click the  button to select an expression from the Expression Library — see chapter 5 for more details. 
The Expression Validity icon will report if the expression entered is valid  or invalid  (and will include additional 
warning notes).

Note:	 The expression validity depends on the layer selection since it is based on some attribute column names.
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The following are some examples of basic expressions which can be entered for use as selection filters.

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

NAME = “Ontario” OR NAME = “Alberta” Result: Items with the value “Ontario” OR “Alberta” in the NAME column 
are selected.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
selected.

NAME = “Ontario” AND POPULATION < 1000000 Only items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are selected.

Note:	 MAP Selections created in versions earlier than MAPublisher 8.3 are converted to MAP Selection Attribute 
Filters, based on the <current layer>.

Art Selection
To store a current selection — done through the MAP Selections panel or using the Adobe Illustrator selection 
functions (e.g. Selection tool, menu Select or Layers panel) — select the MAP Selection type Art Selection. No 
parameters are required for this type of MAP Selection.

The current selection must be performed before creating a new MAP selection. 

Spatial Filter
A Spatial Filter MAP Selection selects sets of objects based on their position on the artboard.

A Spatial Filter is based on a selection of features, the boundaries of which are used as a limit for the final selection. 
The Filter Using drop-down list sets the selection of these features. Three options are available:

•	  Existing MAP Selection: the delimiting features are taken from a saved MAP Selection. The MAP Selection 
name is chosen in the Existing MAP Selection drop-down list below.

•	  Art Selection: the current artboard selection is used (the selection must be performed before creating the 
new Spatial Filter). The current selection is stored as part of the Spatial Filter for later use.

•	  Attribute Filter: the delimiting features are selected based on new attribute filter parameters (see 
Attribute Filter MAP Selection).

Once the delimiting features are specified, additional Options can be set.

By default, all objects contained within the delimiting features will be selected, regardless on which layer they 
belong to. The Select From Layer(s) option can be applied to limit which layers will be included in the final selection. 
To do so, click the  button to open the Select Layers dialog box. Note that MAP Layers and Non MAP Layers are 
available for selection.

The Spatial Relationship drop-down list offers two options for the selection method: 
•	 Intersect and contain: objects that intersect or are contained within the delimiting features will be selected.
•	 Fully contained: only objects that fully contained within the delimiting features will be selected.

The option Do not select art on the same layer as the 'Filter Using' art is meant to avoid art that is on the same layer as 
a delimiting feature from being selected based on that feature. For example, if the Spatial Relationship is set to 
Intersect and contain, all areas that share a boundary with an area that is a delimiting feature will be selected. With 
this option, areas that are on the same layer as the delimiting feature will be excluded from the selection.
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EDIT A MAP SELECTION

To edit an existing MAP Selection, click the selection name in the MAP Selections panel and choose Edit MAP Selection 
in the panel options menu. Alternatively, double-click the selection name.

The Edit MAP Selection dialog box allows to rename the MAP Selection and to edit the selection parameters. The dialog 
box options depend on the MAP Selection type.

When editing an Attribute Filter, the selection layer and the expression may be edited as new. 

When editing an Art Selection, three options are offered: 
•	 Show Selection: shows the stored Art Selection on the artboard.
•	 Replace: if art is selected, replace the stored Art Selection with the current selection.
•	 Add: if art is selected, add the current selection to the stored Art Selection.

When editing a Spatial Filter, all the parameters may be changed. If the Filter Using option is set to an Art Selection, 
the same edit options as above are available (Show Selection, Replace and Add).

DELETE A MAP SELECTION

Click one or more selection names in the MAP Selections panel, then click the delete button  or choose Delete 
MAP Selection in the panel options menu.

Note:	 Use caution when deleting, some selections may be dependent on others.

MAKE SELECTIONS

When a MAP Selection is first created, the matching art is automatically selected. Saved MAP Selections can be 
applied again at any time.

Note:	 MAP Selections based on Attribute Filters that are set to <use current layer> may become invalid when a 
different layer is selected because its attribute schema may not match the expression.

There are four methods for applying a MAP Selection (available as buttons and menu items):

Apply as New Selection Clears the current selection and selects any art on the current layer that meets 
the criteria of chosen selection filters

Add to Current Selection Adds any art on the current layer that satisfies chosen selection filters to the 
current selection

Remove from Current Selection Deselects any art on the current layer that is selected and satisfies chosen 
selection filters

Get Subset of Current Selection Deselects any art on the current layer that is selected and does not satisfy 
chosen selection filters

Note:	 These selection combinations can themselves be saved as an Art Selection.
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FUNCTIONALITY

Split Layer divides a MAP Layer into new MAP layers based on its objects' attribute values. The new layers can either 
contain a copy of the original objects or objects can be moved from the source layer.

The split can be done:
•	 Based on an expression: when an object's attribute values satisfy the specified expression it is added to 

a new layer.
•	 By unique attribute value: objects that have a same attribute value are grouped into a new layer. Hence 

multiple layers are created (one per unique value).
 
This function is particularly useful to split a layer that contains a lot of objects. For example, a road layer with classes 
such as street, highway and toll road could be split in three distinct layers. Split Layer can be used as a preliminary 
to running MAPublisher LabelPro (to allow labelling of multiple classes with different styles, see chapter 17), or to 
exporting layers to external GIS formats.

USING SPLIT LAYER

The MAP Layer to be split must first be selected in the MAP Views panel or in the Adobe Illustrator Layers panel, then 
choose Object > MAPublisher > Split Layer or click the MAPublisher toolbar button .

In the Action options, specify if the split art should be either copied or move to the new layer.

Note:	 If the source layer is locked, the only option is to copy to the new layers.

Destination - Enter the name of the new layer to 
be created. Or enter a prefix when using split by 

attribute value.

Copy attribute schema - Check this option to copy 
the attribute schema into the new layer

Action - Select the option to copy or move objects 
from the source layer to the destination layer

Split art based on unique values - Choose this 
method to split the selected layer into multiple 
layers - one per unique value of the selected 
attribute column in the Attribute drop-down list.

Split Layer 
Object> MAPublisher > Split Layer or MAP Toolbar  

Source Layer - Indicates the currently selected layer

Expression Validity - Indicates if the expression 
is  valid or  invalid. If invalid, additional 
information is reported.

Expression - Enter or edit the expression directly 
into the entry field, or access:

 Expression Builder  - see chapter 5.

 Expression Library - see chapter 5.

Split art by expression - Choose this method to 
create a new layer from objects that satisfy the 
specified expression.
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When the Split art that satisfies this expression method is selected, enter a valid expression in the Expression field, click the 
 button to use the Expression Builder dialog box, or click the  button to select an expression from the Expression 

Library — see chapter 5 for more details (the Expression Validity icon  will report if the expression entered is valid. 
Otherwise it will report  and include additional warning notes). A layer name for the new layer must be entered in 
the Destination frame.

When the Split art by unique attribute value method is selected, choose an attribute name from the Attribute drop-down 
list. Each new layer created will contain only art that share the same attribute value. By default, the name of these 
layers correspond to each single attribute value. In the Destination frame, users can enter a prefix to be prepended to 
every layer name.

The Copy attribute schema option duplicates the attribute schema from the source layer to the destination layer.

RESULTS

When Split Layer is run, a message is displayed that indicates the number of layers that will be created. Click No to 
cancel the split layer function or Yes to continue.

Depending on the method chosen, one or more new layers are created according to the splitting criteria. The new 
layers are placed on the top of the layers hierarchy in the Adobe Illustrator Layers panel.

The new layers have the same feature type as the source MAP layer and are included in the same MAP View. 

If the Copy attribute schema was enabled, the new layers contain the same attributes as the source layer. 
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Right-to-Left Text
Object> MAPublisher > Right-to-Left Text or MAP Toolbar  

Preset - Choose a preset or use 
custom settings below

Paragraph direction - Choose a Left 
to right or Right to left direction

Digits - Choose which language 
numeric digits are to be typed

Kashidas - Check to insert 
Kashidas in Arabic language

Target - Choose which text to 
apply right-to-left correction to 
and whether to apply it to only 

selected text or not

Composer engine - Choose from 
Standard or Adobe World-Ready 
Composer to handle text

Justification Method - Choose from 
Arabic or Naskh justification

FUNCTIONALITY

Many right-to-left languages, such as Arabic and Hebrew, require additional language-specific processing to get 
the correct glyph output given the incoming character stream. The Right-to-Left Text tool is used to apply proper 
formatting to right-to-left languages.

USING RIGHT-TO-LEFT TEXT

From the main menu choose Object > MAPublisher > Right-to-Left Text or click the MAPublisher toolbar button .

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, 
check Apply to selected text only to only apply formatting to text that was selected before opening the dialog box. 
In the Settings section, the Preset contains options (Left-to-right, Arabic, Hebrew) that sets Paragraph direction, 
Justification method, and Digits. Any other settings chosen are considered as Custom.

The Composer engine has two modes: Standard and Adobe World-Ready Composer. The Standard mode uses 
the default Adobe Illustrator text engine. The Adobe World-Ready Composer enables support for complex script 
languages (such as Arabic and Hebrew). 

The Paragraph direction can be chosen as Left to right or Right to left (this is the result, not the current text).

The Justification method can be left as Default (the same as the language set in the Character panel) or set to Arabic 
or Naskh. To convert text to right-to-left without changing the justification or location of text, �uncheck all options 
and set the composer to Adobe World-Ready Composer.

Choose the language in which numeric Digits are to be typed. The Default setting means that the numbers will be 
in the same language as set in the Character panel, otherwise, choose between Arabic, Hindi, or Farsi digits.

Kashida is a type of justification that elongates characters at certain chosen points. Kashida justification can be 
combined with white-space justification to various extents.
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Text Utilities
Object > MAPublisher > Text Utilities or MAP Toolbar  

Actions - Choose an action to 
perform it on the target text. 
Explained on the next page.

Target - Choose which layer to 
apply text utilities to or choose 

to apply it to all text in the 
document. Optionally, only apply 

it to selected text.

FUNCTIONALITY

The Text Utilities dialog box centralizes many text related actions that map makers require. Many of these text 
actions have come about due to the complexities of working with text, geographic data and follow cartographic 
conventions. Common text issues that Text Utilities can handle are correcting upside down text, separating 
multiline text into single line and cropping text path to text length. These actions can be applied to either all text 
layers or specific text on a layer. Optionally, actions can be applied to selected text only.

USING TEXT UTILITIES

From the main menu choose Object > MAPublisher > Text Utilities or click the MAPublisher toolbar button .

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, check 
Apply to selected text only to only apply formatting to text that was selected before opening the dialog box. In the 
Actions section, choose an action to be performed (actions explained on the next page). Only one text action may 
be performed at a time. Click the Preview button to see how the text may be affected.
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Actions

Convert text on a path to point text
Converts text on a path to 
point text removes curvature 
and creates "straight" text.

Separate multiline text
Separates multiline text into 
individual lines of text.

 
Example result produces three separate lines of text.

Extend overflowing text
Extends text elements that 
contain overflow.

Flip upside down text
Flips upside down text 
(corrects left-to-right direction) 

Shorten text path to text length
Remove extra line segments at 
the start and end of a path

Set text alignment
Text alignment can be set to 
left, center or right.

 
Example result produces right justified text.

Rectify point text to angle
Rotates point text to any 
angle for text within a specific 
tolerance angle.

 
Example result rotated 8 degrees for text within a 10 degree tolerance angle.

Draw shape around text
Draws text shapes or boxes 
around text. Change the style 
using the appearance options. 
Optionally, limit box to cap 
height of text and choose a 
specific layer for output.

 
Example result has a box shape with side, top and bottom buffer of 4 px.

Note: some text may not appear centered if no descenders are present and the limit to cap 
option is disabled.

Original Result
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Working With 
Images
MAPublisher contains tools for working with georeferenced 
raster images such as aerial photography and satellite imagery.

The Register Image function accurately registers raster images 
with georeferencing information to vector map data. 

Export raster images to various georeferenced formats 
through the MAP Views panel.

Georeferencing information for raster images are usually 
stored in a separate text file where the image and its 
associated reference file have the same file name but a 
different file extension. 

The reference file formats that can be read by Register Image 
or written to by Export Image are:
World (*.tfw)
Image Report (*.irp) 
MapInfo TAB (*.tab)
Blue Marble Reference (*.rsf )
ER Mapper ERS (*.ers)
ListGeo (*.lgo)
GeoTIFF (*.tif ) (contains both the image and reference data)

Topics covered in this section:
Register Image
Export Image
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Tie Points† - Change the tie point 
of the image by clicking another 

corner of the graphic

Pixel Size† - Specify the size of each 
pixel in the selected map unit 

(updates the Effective Map Size). 
Register Image supports non 

square pixels.

Constrain Proportions - Check this 
option to maintain X and Y pixel 

proportions (in map units)

Effective Map Size X/Y† - Specify the 
X and Y size of the image in map 

units (updates the Pixel Size)

Rotation - Displays the amount of 
rotation of an image

Register Image 
Object > MAPublisher> Register Image or MAP Toolbar 

FUNCTIONALITY

Register Image applies geospatial properties to raster images imported using the Adobe Illustrator Place command. 
Register Image uses a coordinate system and coordinates—entered manually or loaded from a reference file—
to properly georeference and scale an image. If the coordinate system of an image matches one of existing 
vector data, the image can be scaled and rotated to fit the vector data. If no matching vector data is found in the 
document, a new MAP view can be created to store the cartographic information of the image to allow for data 
digitization with accurate positioning.

Note:	 Register Image does not have the capability to transform images from one coordinate system to another. Use 
a product like Avenza Geographic Imager to transform images.

Units - Select a unit to use for the 
specification of georeferencing 
information. The default selection is the 
current map unit.† Editing these options is 

not required when using 
the Load File function.

Placement X/Y† - Specify the coordinates 
(in map units) of the selected corner of 
the raster image

Load File - Choose a file containing 
the georeference information for the 
selected raster image. The information 
from the file will be inserted into the 
appropriate fields.

Register Image

Undefined Layer

Reference File Coordinate System - Indicates 
the coordinate system of the loaded file 
(for GeoTIFF images). Set to Unknown 
by default.

This dialog box appears if the image to 
register is not placed on a MAP Layer

Feature type - Choose Image 
feature type

Create or Add to existing MAP View 
Choose to create a new MAP View 

or choose an existing one from 
the drop-down list



203Chapter 12: Working With Images
Register Image 

PREREQUISITES

To use Register Image, the geospatial properties of the raster image must be known. Some raster image formats 
store the relationship between source image coordinates (pixel location) and real-world reference coordinates 
in an associated reference file but do not save the coordinate system information (e.g. world file *.tfw). The 
commonly used GeoTIFF format is embedded with geographic information such as position and coordinate system. 
Depending on the image format, check the position and coordinate system of imagery with the data provider 
before attempting to use this tool.

To import a raster image into a document, select a layer from the Layers panel (Image MAP Layer or not) and 
choose the Adobe Illustrator Place command (File > Place). The image is placed on the artboard, but is not spatially 
referenced at this point—it needs to be registered. 

Notes:	 When placing an image, do not use the Convert Layers to Objects option. It will treat images that may have 
multiple layers as grouped objects and will prevent it from being registered properly. 
 
Using an embedded, unflattened image with an existing transparency may result in incorrect registration.

USING REGISTER IMAGE

With an image selected, choose Object > MAPublisher > Register Image or click the Register Image button  on 
the MAPublisher toolbar.

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate 
system of the MAP View containing that MAP Layer.

If the raster image was not imported to a MAP Layer, the Undefined Layer dialog box will appear. Choose either to 
create a new MAP View based on the image or choose to add the image to an existing MAP View. In either case, the 
Image feature type is the only one available for rasters. It is recommended to use the Image feature type for image 
registration and for better layer management and workflow.

When creating a new MAP View, the anchor point and scale are derived from the registration information 
(placement and image size). In the case of GeoTIFF images, the MAP View coordinate system is automatically read 
from the image header—for other image formats, the coordinate system has to be specified manually in the MAP 
View Editor after the registration process (see chapter 4 for more information on Specify coordinate system).

Registration using Reference File
To register an image using a reference file, click the Load File button and navigate to the folder containing the file. 
The reference file may have the same name as the image, but may have a different extension (.irp, .tfw, .tab, .rsf, .ers 
or .lgo). In the case of the GeoTIFF format, the image file itself contains both the image and reference data and the 
needs to be chosen to retrieve the georeferencing information.

The values contained in this reference file are automatically entered into the image parameters. If the file is in 
GeoTIFF format, the image coordinate system is read and displayed under Reference File Coordinate System—for other 
file formats, the coordinate system is left as unknown.
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Manual Registration
To manually enter image parameters, one of the following combinations must be available in page units or map units:

•	 The X and Y coordinates of one corner of the image and the X and Y Pixel Size.
•	 The X and Y coordinates of one corner of the image and the X and Y size of the image.

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click 
the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for 
this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single 
pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either 
option will update the other accordingly. 

Note:	 MAPublisher Register Image supports the registration of images having non-square pixels.

RESULTS

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image 
does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while 
creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to 
finalize the georeferencing. 

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled 
and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can 
be used to check the positions (see chapter 4).

Notes:	 Raster images cannot be transformed into another coordinate system. If the vector data is transformed 
through the MAP View Editor Perform Coordinate System Transformation function after the image has been 
register, the image will have to be transformed externally (with Avenza Geographic Imager for example) and 
registered again in MAPublisher.

Registered images will be scaled and rotated together with the vector data, but not automatically. After 
the vector data has been scaled or rotated using the MAP View Editor, Register Image must be used to apply the 
image referencing information. In the case of a manual registration, it is recommended to use the Export 
Image function before applying the changes to the vector data (see next paragraph). This way, registering the 
image again is only a matter of loading a reference file.

SUPPORTED GEOREFERENCED IMAGE REFERENCE FORMATS

World File (*.tfw, *.tifw, *.wld, *.eww, *.jgw, *.jpw, *.pgw, *.sdw, *.eww, *.blw, *.dmw) 
World files contain the affine relationship between source image coordinates (pixel locations) and real-world 
reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed 
relationship between source image coordinates and reference coordinates and not the complete reference point 
information. World files do not support storing coordinate system information.

IRP Image Report File (*.irp)
IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the 
pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.
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MapInfo TAB File (*.tab)
MapInfo Table file formats save the complete reference point list information such that it can be loaded again in the 
future. MapInfo TAB files support storing coordinate system information.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Azimuthal Equidistant 
Cylindrical Equal Area*
Eckert IV*
Eckert VI*
Equidistant Conic*
Gall Stereographic*

Hotine Oblique Mercator
Lambert Azimuthal Equal Area*
Lambert Conic Conformal
Mercator*
Miller Cylindrical*
Mollweide*
New Zealand Map Grid

Hotine Oblique Mercator 1pt
Polyconic 
Robinson*
Sinusoidal*
Swiss Oblique Mercator
Stereographic Transverse Mercator

* Coordinate Systems using this projection will not be stored when saving the reference file. 

Blue Marble Reference File (*.rsf)
The Blue Marble Reference Settings File saves the complete reference point list information such that it can be 
loaded again in the future. Within a Blue Marble Reference File, the first line contains the version of the file format 
(not to be confused with the version of the software) and the total number of points in the file. The remaining lines 
contain, in each line, the point ID, the x (row) pixel, the y (column) pixel, the z (elevation) value which is usually 0.00, 
followed by the ground coordinates expressed as Latitude or Northing (Y), Longitude or Easting (X) and Elevation 
(Z). The last value indicates whether the point described on that line is included in the solution, 0 = not included 
and 1 = included. Blue Marble Reference files support storing coordinate system information (all are supported).

ER Mapper File (*.ers)
The ER Mapper header file is an ASCII file describing the raster data in the data file. The entire header file holds 
information about the data source and is contained in the DatasetHeader block. There are two compulsory 
sub-blocks, the CoordinateSpace block (to define the coordinate space and location) and the RasterInfo block (to 
define the characteristics of the data in the accompanying data file). The RasterInfo block my contain a number of 
optional sub-blocks. To completely define coordinate information in an ER Mapper header file you need to include 
the following data: datum, projection, coordinate type, units, X and Y dimensions for cell size, registration cell X and 
Y values, registration cell coordinates, and possibly null cell value. Coordinate information is frequently, but not 
always, given for the upper left corner of an image. This would be registration cell X and Y values of 0.0 and 0.0. 
For most projections registration coordinates are entered as eastings and northings, the coordinate type will be 
"EN", and units will be meters (or occasionally feet). If you are using latitude and longitude the projection is Geodetic, 
coordinate type will be "LL", and the X and Y dimensions for the cell size will be in decimal degrees.

ER Mapper files support storing a limited number of pre-defined coordinate systems. Check the coordinate system 
details to ensure the ER Mapper identifier exists as the issuer for the coordinate system to be saved. The file will still 
be exported however the coordinate system will not be saved with the reference file.

Note:	 ER Mapper reference files do not support rotated images. When attempting to export a reference file with a 
rotated image ER Mapper will not be listed.
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ListGeo file (*.lgo)
A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and 
may also be used as input to other programs.

GeoTIFF File (*.tif, *.tiff)
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format and one of the most common 
geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored 
in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world 
coordinates, coordinate system or an explicit list of ground control points.

Note:	 The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial 
imaging software application (such as Avenza Geographic Imager).

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a 
separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the 
Load File dialog box—the required georeference information is contained in the file header.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Cassini-Soldner - Cassini
Cylindrical Equal Area
Equidistant Conic
Equidistant Cylindrical
Equirectangular
Gnomonic
Hotine Oblique Mercator
Laborde Oblique Mercator

Lambert Azimuthal Equal Area
Lambert Conic Conformal (1SP)
Lambert Conic Conformal (2SP)
Lambert Cylindrical Equal Area
Mercator
Miller Cylindrical
New Zealand Map Grid
Oblique Mercator 
Oblique Stereographic 
Orthographic

Polar Stereographic
Polyconic
Robinson
Sinusoidal 
Stereographic
Transverse Mercator
Transverse Mercator (South Oriented)
VanDerGrinten
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Georeference Type - Select the output 
format for the georeferencing 

information for the selected image

Export Image 
MAP Views panel options menu > Export Image

FUNCTIONALITY

MAPublisher has the ability to export placed raster files as georeferenced images for use in other programs 	
and/or for archival purposes. This can be useful in a number of ways. For example, when working with an image 
for which there is no georeferencing file, use the MAPublisher Export Image function to create a GeoTIFF or other 
georeferenced image file based upon the coordinate system of the host MAP View.

The Register Image function can be used to accurately position and scale imagery with vector data. Alternatively, 
the imagery can be manually moved, scaled or rotated to align with artwork in a designated MAP View. If the host 
MAP View contains accurate georeferencing information, Export Image can be used to save raster data to a fully 
georeferenced image format. It is also possible to convert the vector artwork to a georeferenced raster image.

MAPublisher exports selected images as a TIF/TIFF, with a choice of the five reference file formats (see the previous page).

USING EXPORT IMAGE

With an image selected, go to the MAP Views panel options menu > Export Image.

In the Export Image dialog box, the Georeference Type drop-down list shows the five available reference file formats: 
World File (TFW), Image Report file (IRP), MapInfo TAB file (TAB), Blue Marble Reference file (RSF), ER Mapper file (ERS), ListGeo file (LGO) 
and GeoTIFF. A regular TIF file is generated with TFW, IRP, TAB, RSF, ERS or LGO reference files. A single TIF file is produced 
with GeoTIFF selected, which contain both the image and the georeference information.

Note:	 Image MAP layers are not included when an entire MAP View is exported to a spatial format (e.g. shapefile).

RESULTS

When all of the export options have been set, click the Save As button. Specify a name for the TIF file and the folder 
location where it will be saved. The reference file will have the same file name as the TIF and will be saved to the 
same location.

This image file can be subsequently used in imagery applications, such as Avenza Geographic Imager for Adobe 
Photoshop, or in other Adobe Illustrator documents using MAPublisher.

Notes:	 Exporting a linked image in CMYK color mode or an embedded image with an existing transparency may 
create incorrect color results. For the former situation, an image must either be set to a different color mode or 
embedded. For the latter, the transparency must be removed from the source file.

If a MAP View is rotated, the exported image will not store any rotation parameter (it will be automatically 
rectified—oriented north up).

Save As - Choose a destination name 
and directory for the exported image
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MAPublisher contains tools to easily create map grids and 
map indexes. Grids can be created for reference purposes, 
or to follow designated lines such as latitude and longitude 
(graticule), with optional labeling (cells or axis).

A grid or a graticule can be used as a base to generate 
index files. MAPublisher outputs a text file containing grid 
indexes of text or map object locations that can contain map 
attribute information.

Topics covered in this section:
Grid and Graticules
Make Index

Grids and 
Indexes
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Grids and Graticules 
Object > MAPublisher > Grids and Graticules or MAP Toolbar 

Object > Edit Grid / Edit Graticules

Advanced - Access the Advanced 
dialog box to specify additional 
options for the grids or graticules

Axis Labels - Click an axis label 
to toggle all labels on that axis 

ON or OFF. 

Coordinates Labels - Click the 
label to toggle between X, Y, 

Both, OFF or Lng, Lat, Both, OFF. 
(Labeled as X,Y for measured 

grids or Lat/Long for graticules). 

Label Direction - Click to reverse 
the direction that labels 

increment

Cell Labels - Click any cell label 
to toggle all center labels ON 

or OFF.  

Flip Label Axes - Click to flip alpha 
and numerical labels.

Custom mode
Specify grid and border styles using custom options.

Specify grid and border styles based on graphic styles already created.
Graphic Style mode

Grid/Graticule Selection - Click the 
appropriate button to select the 
grid type required and to assign 

settings (see below).
Note: Measured Grids can only be 

created on MAP Views in projected 
coordinate systems.

See next page for individual  
grid/graticule settings

See below for Grid Style Option settings

Coordinate Values along 
Grid/Graticule Border:

X and Y Axis style - Select the 
Character Style to use for the X 
and Y labels

X and Y Axis label rotation - Choose 
Horizontal or Vertical rotation

If line does not hit bounds, label - 
Specify if the lines that do not 
intersect with  the graticule 
bounding box should be labeled. 
Options are: None, Latitude, 
Longitude, Latitude & Longitude

Place labels off line by - Select a 
distance off the grid to place 
the labels

Number of decimals - Specify the 
number of decimals

Labels values - Select the type 
of labels to display (distances 
measured from the lower left 
corner of the grid, or actual 
coordinates (X/Y or lat/long)

Dialog Units - Set the units for 
Measured Grid dimensions if 
appropriate

Apply locale formatting to numbers - Choose 
to apply locale formatting (e.g. 
decimal separator as dot or comma), 
see MAPublisher Preferences.

Append units to labels - Choose to include 
units (i.e. degree symbols or m) to 
Line Labels.

Stroke/Fill - Choose a colour from the 
drop-down lists. Alternatively, click the 
colour chip to pick a custom colour.

Stroke/Fill Opacity - Set the transparency 
of the stroke or fill. 100% is solid.

Stroke Weight - Set the stroke width of 
the grid/border line. 1.0 pt is default.

Graphic Style - Choose a graphic style 
predefined in the Adobe Illustrator 
Graphic Style panel.

† If the Center, Axes and X 
or Y Axis style lists do not 
contain a recently created 
character style, simply 
return to the Character 
Style panel, double-click 
this style and click OK in 
the Character Style Options 
dialog box. This forces 
Adobe Illustrator to re-load 
the list of character styles.

Line Style - Set custom styles for 
the grid lines 

Switch Mode - Click to switch to 
Graphic Style mode

Switch Mode - Click to switch to 
Custom mode

Cell References:

Place labels off cell by - Select a distance 
off the grid to place the labels.

Center Style†- Select the Character 
Style to use for the Center Labels

Axes Style†  - Select the Character Style 
to use for the Axis Labels

Draw Border - Check this option to 
draw the grid border (frame) and 

set the custom styles for it

Preview - Click this button to 
preview the grid

Hide on preview - Minimizes this 
dialog box during preview

Labeling: Label in boldface denotes 
it is as enabled. Not in boldface 

denotes it as not enabled.
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Measured Grid Settings

Preset Origin - Choose a position for the 
X and Y origin

Grid passes through point - Choose this 
option to specify coordinates for the 
X and Y origin

Cell Width/Height - Specify the 
dimensions of each cell comprising 

the grid in the current map units

Number of Columns and Rows -Select 
this option to create a grid with 

the specified number of rows 
and columns

Index Grid Settings

Graticule Settings

Cell Size in Page Units - Select 
this option to specify the cell 
size in page unit (as specified 
in the Adobe Illustrator 
Document Setup)

Latitude Interval - Specify the interval for 
each line of latitude

Pass through latitude - Specify a line of 
latitude that must be included (any 

great circle)

Longitude Interval - Specify the interval 
for each line of longitude

Pass through longitude - Specify a line 
of longitude that must be included 
(any meridian).

Vertices - Use the slider to increase or 
decrease the number of nodes which 

will be used in the construction of the 
graticule (use more for curved)

Don’t label - Check to prevent the 
corresponding row or column from 

being labeled

Partial cells get labeled - Check 
this option to label cells that 
do not reach its full size (in 
page units)

Minimum size of cells - the 
minimum size of partial cells 
before being labeled

Partial cells get labeled - Check this option 
to label partial cells (cells that do not 
reach the full size in page units)

Minimum size of cells - set the minimum 
size of partial cells to be labeled

These settings will differ depending on the type of grid or graticule option chosen:
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FUNCTIONALITY

The Grids and Graticules tool generates grid lines based on a number of user-defined settings. 

There are three grid types available:

Index Grid Divides grid extents based on a specified number of cells or by entering a cell 
size in document units.

Graticules Plots grid lines at specific intervals of latitude and longitude which will be 
automatically curved as applicable. 

Measured Grid Place grid lines based on a grid size in real-world dimensions.

Numerous options for labels, placement, size and alignment are provided.

All grids plotted with this tool can be subsequently resized using the bounding box of the grid, and can be edited 
by clicking the Adobe Illustrator menu Object > Edit Grid / Edit Graticules.

PREREQUISITES

Grids and Graticules are added on  Legend layers. If no legend layer is present in the document, a new legend 
layer will be created automatically. To manually create a new Legend layer, use the Add MAP Layer button on the 
MAP View panel and specify the feature type as Legend (see chapter 4 for more details).

By default, MAPublisher uses the Normal Character Style when generating grid labels. If custom character styles are 
to be used for the labels, they should be created beforehand (Window > Type > Character Styles).

A default grid line style will also be used. Use the Grid Style Options section to choose an alternate style for the grid 
and border lines, in either Custom mode or Graphic Style mode. In Custom mode, choose the style options directly 
in the dialog box. In Graphic Style mode, choose desired styles that are populated in the Adobe Illustrator Graphic 
Styles panel.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be 
generated for any coordinate system. Measured Grids cannot be generated for geodetic coordinate systems.

To access the function select the legend layer and navigate to Object > MAPublisher > Grids and Graticules or 
MAPublisher toolbar button .
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INDEX GRIDS

The Index Grid option divides the grid extents based on a specified number of cells or by entering a cell size in 
document units. The grid dimension can be either calculated from the specified number of columns and rows or by Cell 
Size in Page Units. Finally, graphic styles for the grid lines and border, and character styles for labels may be specified.

Note:	 The page units are specified in the Adobe Illustrator document setup (main menu File > Document Setup).

The By Cell Size in Page Units option may result in partial cells being created. By default, the labeling of these partial 
cells is enabled (in order to include them in the indexing process), uncheck the Partial cells get labeled check box to 
disable this option. The Minimum size of cells drop-down list is used to set the minimum size of the partial cells to be 
labeled — cells that are smaller than this minimum will not get labeled and will not be used as a base for indexes.

GRATICULES

The Graticules option permits grid lines to be placed at specific intervals of latitude and longitude (in degrees). 
Specify the interval for lines of latitude and longitude and as required a latitude and longitude value to pass through. 
Use the vertices slider to increase or decrease the number of vertices used in the graticules if required (use a higher 
number if the graticules are highly curved due to the current projection). 

To control which axis are to be labeled, set the following features:
•	 Don’t label: allows not labeling a specific column or row (first or last, row or column).
•	 If line does not hit bounds, label (None, Latitude, Longitude or Latitude & Longitude): choose to label or not label curved lines 

that do not intersect with the grid extents (applies even if the line hits the grid border but not the bounding box).
•	 None, Lat, Lng or Both axis labels: a click on the axis in the label placement control switches the label caption from 

off (text grayed out), Lat, Lng or Both. This is useful for rotated grids or for labels of curved lines.

MEASURED GRIDS

The Measured Grid option creates a grid based on a grid cell size specified in real world units, when the current MAP 
View is in a projected coordinate system. The size is specified in the Width and Height text boxes (the map units can 
be specified in the Units list).
 
The grid position can be specified as relative to the page extent (Preset Origin) or by entering an X, Y position (Grid Pass 
Through Point). Finally, graphic styles for the grid lines and border, and character styles for labels may be selected.

Measured grids may contain partial cells. By default, the labeling of these partial cells is enabled (in order to include 
them in the indexing process), uncheck the Partial cells get labeled check box to disable this option. The Minimum size 
of cells drop-down list is used to set the minimum size of the partial cells to be labeled — cells that are smaller than 
this minimum will not get labeled and will not be used as base for indexes.
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LABELING OPTIONS

A number of labeling options are available for use in grids and graticules. 

The Cell Reference options are relative to the indexing labels of grids and graticules. In the label placement control 
diagram, click on the axes labels (A, B or 1, 2) and cell labels (A1, A2, B1, or B2) to enable or disable the display of these 
labels. Use the arrows to change the direction of axes and flip the numeric labels. Click a corner graphic to swap 
which axes are labeled numerically and which are labeled alphabetically. Then specify the axes label distance from 
the grid border (Place Labels off cell by option — a negative value places labels inside the grid) and choose a character 
style for the Center and Axes styles.

Note:	 Indexing labels for graticules are always generated as if the graticules covered the full map extents, 
regardless of the actual graticules' bounding box. 

The Coordinate Values along Grid/Graticule Border options are relative to the coordinate labels of the grids and graticules 
(X,Y for indexed and measured grids and Lat, Lng for graticules). In the label placement control, click on the X/Y or 
Lat/Lng axis labels to select which values are labeled (disable, X, Y or X&Y for grids, disable, Lat, Lng, Both for graticules). 
These options are useful for rotated grids where grid lines may intersect on the wrong border of the grid or curved 
lines of latitude or longitude. Rotate labels using the X or Y Axis label rotation drop-down list (Horizontal or Vertical).

Other options for the coordinate labels are: 
•	 If line does not hit bounds, label: (None, Latitude, Longitude or Latitude & Longitude) Applies only to Graticules 

only.
•	 Place labels off line by: a negative value places labels inside the grid.
•	 Number of decimals: decimal places for grid labels.
•	 Label values: coordinates or distance from the lower left corner of the grid — Applies only to Index and 

Measured grids.
•	 Append units to labels: e.g. ° (degree symbol), or m (meters)
•	 Apply locale formatting to numbers: apply number formatting according to the locale settings in the 

MAPublisher Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).
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Start alpha/numeric index at - Edit the first 
value used for cell labels

Do not use characters - Enter alpha 
characters to omit from cell references 

Reference Separator - Enter one or more 
characters to separate the alpha 

and numeric indexes (e.g. - or / for 
A-1 or A/1)

Reference label order - Choose to make 
Center Labels alpha-numeric (A1) or 

numeric-alpha (1A)

Lower Left - Adjust X and Y values for 
the lower left of the grid extents

Top Right - Adjust X and Y values for 
the upper right of the grid extents

Advanced Grid Settings Advanced Graticules Settings

Auto-Detect Graticule Bounds - Auto-detect the 
maximum graticule extents from the MAP 

View's coordinate system definition

Graticule Start | Graticule End - Enter specific 
coordinates for the graticule limits. 

Use only if the resulting graticule is 
truncated  or wrapped.

ADVANCED OPTIONS 

Click the Advanced button to access additional grid extents and labeling options. 

Modify the bounding box extents of the grid or graticules by entering new coordinates for the Lower Left and Top Right 
position of the grid.

It is also possible to edit the first value used for cell labels by editing the Start alpha/numeric index at values. Omit 
certain alpha characters from cell references with the Do not use characters option. For example, it may be useful to 
omit the characters “I” and “O” for indexing purposes (when entering alpha characters to omit, separate characters with 
a comma). The Reference label order option can be edited to change the center labels from alpha-numeric (A-1) to 
numeric-alpha (1-A), or vice versa.

When creating graticules, users may need to edit the maximum graticule extents allowed. By default, MAPublisher 
automatically detects the maximum graticule extents as +/- 180° from the central meridian specified in the coordinate 
system definition of the current MAP View for longitudes and +/- 90° from the Equator for latitudes. The graticule is 
then created as the intersection of the bounding box and the maximum graticules extents.

In some rare cases, the bounding box specified may extend beyond the default limit (with some polar projections or 
some cases where the data crosses the 180 degrees west/east meridian), and the created graticule will be truncated or 
wrapped. In these cases, users may enter specific values for the Graticule Start and Graticule End coordinates in the Advanced 
dialog box — e.g. Start: -180, -90 | End: 360, 90. In most cases this is not necessary, so we recommend using Auto-Detect 
Graticule Bounds and only edit the graticule start and end coordinates if the resulting graticule is truncated (increase 
extents) or wrapped (reduce extents).
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GENERATING AND EDITING THE GRID

When all the options have been set, click the Preview button to display a preview of the result. The Grids and 
Graticules dialog box can be minimized in the preview mode by clicking Hide In Preview.

OK - Creates the grid on the artboard 
and closes the dialog box

Cancel - Closes the dialog box without 
creating a grid

Restore - Restores the full size Grids 
and Graticules dialog box to further 

edit the parameters

Click OK to create the grid or click Restore to return to setting up the parameters. The grid is plotted on the legend 
layer using the entered parameters. 

Once the grid is added on the artboard, use the bounding box of the generated grid (View > Show Bounding Box) to 
resize if required. Re-sizing grids horizontally or vertically adds, removes or re-sizes (index grid) component cells in 
the grid.

After transforming a MAP View containing a grid, the grid will be transformed and scaled within its current bounds 
(the physical extents of the grid on the page is not edited). The grid may have to be resized manually.

To change any parameter without generating a new grid, simply select the grid and choose from the main 
menu, Object > Edit Grid/Edit Graticules. This opens the Grids and Graticules dialog box populated with the current 
parameters of the grid. All parameters can be edited, even the grid type selection. 

IMPORTANT NOTES

Manually editing text position, font, color etc is not possible on grids and graticules in their default grouped state. 
Manual editing is possible however if the grid is first expanded (Object > Expand), though this will negate any 
opportunity to subsequently edit the art via the Grids and Graticules dialog box. When expanded, grids cells are 
converted to both polygons (from index) and lines.

Measured grids cannot be labeled properly using actual coordinates when the data is projected using a 
stereographic or orthographic coordinate system (because some areas may have some high curvature).

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:

1.	 Transform the MAP View to a geodetic coordinate system (e.g. WGS 84). 
2.	 Generate a grid or graticules on this MAP View.
3.	 Expand the object (Object > Expand).
4.	 Create a new area layer in the MAP View. Drag the expanded grid to this new layer.
5.	 Transform the MAP View back to the original projection. 

Please see Appendix A3 for more information on working with grids and graticules in MAPublisher.



217Chapter 13: Grids and Indexes
Make Index 

Make Index 
Object > MAPublisher > Make Index or MAP Toolbar 

Sort by - Choose to sort the 
entries in the index file by 
either Feature label or Grid 

cell address

Click a button to open the 
Edit Separator dialog box. 
Choose between Tab, None 
or a Custom separator.

Make index based on label position - An index 
will be created by assigning one index 

location for each label found on the 
selected label text layer

Make index based on label and matching 
feature position - MAPublisher will 

determine what features to index by 
matching label text on the indicated 
Label layer to the indicated attribute 
on the Feature layer. An index will be 

created for every grid cell in which the 
labeled feature can be found.

Advanced - Click this button to open 
the Advanced Options dialog 
box (below) to specify additional 
options for the index format

Description - Provides a brief 
description about the index option  
that is chosen above

Advanced Options

Output Format
Single-line condensed  

Creates one index entry 
for each unique label. The 

index is compressed in the 
format: A1-3;B2,4

Single-line expanded  
Creates one index entry 

for each unique label. The 
index is in the format:  

A1,A2,A3,B2,B3

Multiline  
Creates one index per 

label recurrence

Select Additional Attributes 
Select one or more 
attributes to be added 
to the index file. The 
selected attributes appear 
in separated columns 
delimited by the chosen 
Index Separator.

Select Additional Attributes 
from Bounding Geometry 
Select one or more 
attributes from another 
layer to be added to the 
index file.

Make index based on feature position and 
attribute value - An index location is 

added for each feature found on the 
selected label Feature layer. The index 
label will be the value of the selected 

Attribute for each feature.

Specify Index Separator  
Select a delimiter to 
separate the different 
elements of the index 
file: label, attribute, 
grid column, grid row, 
continuous spanning, 
discreet spanning and 
next in the list. Choices are 
reflected in Sample Indexes

Apply locale formatting 
to numbers - Choose to 
apply locale formatting 
(e.g. decimal separator 
as dot or comma), see 
MAPublisher Preferences. 

Treat grouped text as single entry 
Select this option to create a 

single index for grouped text 

Filter area layer - Select a 
layer and corresponding 
attributes to filter by.
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FUNCTIONALITY
The Make Index feature can be used to generate a map index based on the position of text elements or map features 
in a grid (index or measured), a graticule or a MAP Area Layer. Index files generated using this function are produced 
as a simple text file and sorted alphabetically (by label or cell reference). A typical file would be formatted as follows:

		  Millwood Road	 B4
		  University Street	 A4
		  Broadway Ave	 B5

For text elements, the position of the first letter of the text is indexed. For map features of type Line or Area, all cells 
intersecting the feature are index. For map feature of type Point, the center of the symbol is indexed.

The index file contains a header indicating the name of each column (name, attribute name [if applicable], and grid 
locations).

PREREQUISITES
To create a map index, an Index Grid, Measured Grid or set of Graticules must have been created using the Grids and 
Graticules feature. This grid must exist on a  Legend layer, and not be expanded (by Adobe Illustrator), in order to use 
the Make Index function. An index will be created even if grid labels are hidden. A MAP Area Layer can can also be 
used as the basis for a map index.

The  Text layer containing the labels to be indexed and/or the Feature layer must be located in the same MAP View 
as the grid.

USING MAKE INDEX

Click the Make Index button on the MAPublisher Toolbar   or choose Object > MAPublisher > Make Index.
•	 The selected grid will be used as the index reference.
•	 When no grid is selected, Make Index will detect a grid in the document. If more than one grid is 

found, the Select Index Grid dialog box opens. Click the Previous Grid or Next Grid buttons to browse through 
available grids in the document. The selected grid is highlighted on the artboard.

•	 Alternatively, Use area layer as grid (choose appropriate area layer and grid label attribute). This layer can 
be of irregular shape (non-rectangular).
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Index Based on Label Position
Select the Make index based on label position button to generate an index using this method. Then choose the layer 
containing the text to be indexed from the Label layer drop-down list. This method creates an index by assigning one 
index location for each label found on the selected text layer. For example, if the label "High Street" is only found in 
grid cell A4, the only entry for "High Street" in the index file would be as follows:  High Street A4

Index Based on Label and Matching Feature Position
This method creates an index by matching label text on a selected Label Layer to the indicated attribute on the 
Feature layer, creating an index entry for every grid cell in which the feature can be found. Note that only features 
that have labels can be indexed. For example if "High Street" passes through grid cells A3, B3 and C4, each grid cell 
will be in the index — on a single or multiline (see advanced options). For example as:  High Street A3, B3, C4

Use this function as follows:
•	 Select the Make index based on label and matching feature position option to generate an index using this method.
•	 Choose the layer containing the text to be indexed from the Label layer drop-down list.
•	 Choose the layer that was used to generate the labels from the Feature layer drop-down list. 
•	 In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches 

the labels to be indexed.

Index Based on Feature Position and Attribute Value
This method creates indexes for map features without creating labels beforehand. 

The map features to be indexed are contained in the selected Feature layer. Any MAP Layer of type Point, Line or 
Area contained in the same MAP View as the grid can be selected. 

The index position is based on each feature on the grid — for Area and Line layers all cells that intersect with the 
feature are indexed; for Point layers the cells that contain the center of the feature symbol are indexed. 

The actual index label listed in the output index file corresponds to the value of the selected Attribute.

Advanced Formatting Options
To set additional options to control the formatting of the index file, click the Advanced button.

The Sort index by option controls the order of the index entries. The default setting is Feature label — entries  are 
ordered based on the label text (alphabetical). Alternatively, Grid cell can be selected to sort by the cell indexes.

The Specify Index Separator indicates which delimiter is used to separate the different columns in the index file (label, 
additional attributes and indexes). To change a specific delimiter, click the separator button in between the two 
desired elements. The separator options are Tab, None, or a Custom delimiter. When using a custom delimiter, type the 
desired character(s) in the adjacent text field. The separator settings are reflected in the Sample Indexes section.

The Treat group text as single entry option is required to create a single index for grouped text. Enabling this option is 
recommended to create index for labels created with MAPublisher Label Pro because the generated text is often 
grouped (e.g. multiline labels or along a curve).
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There are three output formats for indexes (examples are using the default separators):

Output format Description Example Notes

Single-line condensed One index for 
each unique 
label is created, 
condenses grid 
locations

Label A1-3; B2,4; F-H9 •	 A dash (-) indicates a range: A1-3 
means the label is found in cells A1, 
A2 and A3; F-H9 means the label 
is found in cells F9, G9 and H9. The 
ranges by number are grouped first 
and then the ranges by letter.

•	 A comma (,) indicates a list: B2,4 
means the label is found in cells B2 
and B4 but not B3.

•	 A semicolon (;) separates each entry.

Single-line expanded One index for 
each unique 
label is created

Label A1, A2, A3, B2, B4, 
F9, G9, H9

•	 A comma (,) separates each entry.

Multiline One index 
for each cell 
reference is 
created

Label A1
Label A2
Label A3

•	 Each entry is on its own line

			 
Users can add more attributes to the index file by selecting one or more attributes from the Select addition attributes 
drop-down list. Additional attributes are inserted in the file in columns between the label and the grid locations, 
separated by the chosen Index Separators. For example:

			   Label	 Attribute1	 Attribute 2	 A1-3;B2,4;F-H9 

Note:	 Duplicated labels that have different selected attribute values, will have a separate entry in the index file 
(single-line options). Duplicated labels that share the same attribute values will have a single index entry but 
each location will be reflected in the cell references.

The Apply locale formatting to numbers option applies number formatting according to the locale settings in the 
MAPublisher General  Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).

The Filter area layer drop-down lists uses an area layer to filter corresponding attributes and add that information to 
the index file. Choose the appropriate attributes that will be used as a filter. For example, it can find which country a 
city is located based on its location on the map.

Saving the Index File
When all indexed options have been set, click the Save As button. Then specify a name for the text file, and the 
location where it will be saved. The index file can be opened in a text editor, or placed back into the document 
using the Adobe Illustrator Place function*.

*	 Adobe Illustrator CS4 Mac OS X users: It is recommended to copy the index contents into a text box instead of using 
the Place function.
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Scale Bars and 
North Arrows

MAPublisher contains tools for plotting accurate scale bars 
and north arrows onto your map. 

The Scale Bar tool offers a number of different designs that 
you can choose from, including double-bar designs for the 
placement of scale bars in multiple units. 

North Arrows are created from selected artwork on the page 
using the Create North Arrow tool and are immediately aligned 
to true north.

Topics covered in this section:
Scale Bar
Create North Arrow
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Scale Bar 
Object > MAPublisher > Scale Bar or MAP Toolbar 

Object > Edit Scale Bar

Interval Options:

Labeled intervals - Enter the 
number of interval which will 
comprise each bar.

Horizontal lines - Select the desired 
number of horizontal lines to be 
included in the scale bar. Used 
with certain scale bar styles only.

Intervals to subdivide - Enter the 
number of scale bar intervals to 
be subdivided.

Sub intervals - Select the number 
of sub-intervals for each 
subdivided scale bar interval. 

Apply locale formatting to numbers 
Insert a comma (or another 
locale format) to the scale and 
ratio numbers.

Scale Appearance 
Set the scale label style in the 

Edit Text Rendition dialog box.
Scale Label and Ratio Label 
Set the scale or ratio label. Use 
the variables available below. A 
preview of the scale or ratio is 
shown below the text box.

Customize Labels 
Opens the Customize Labels dialog box. Use 
it to change the label of page and world units 
and adjust the appearance and variable of 
scale and ratio labels. See below.

Display page to map units ratio 
Check this option enable 

options to show the scale as 
page unit to map unit ratio 

(select from Inches, Centimeters 
and Millimeters), the  decimal 

precision and placement.

Preview Panel - Displays a preview 
of the generated scale bar.

Select Style - Click the up or down 
button to browse through the 

scale bar styles.

Units - Select the desired 
map units to be used in the 

selected scale bar.

Interval - Specify the length of 
each interval in the selected 

map unit.

Tick label spacing - Specify the  
spacing between the scale bar 

and scale bar label.

Maintain relative size - Check this 
option to convert the interval 

values when units are changed

Apply local - Use the locale 
format settings specified 
in the General section of 
MAPublisher Preferences

Add interval label left of '0' - 
Places an interval label left 
of the zero marker on the 
scale bar.

Labeling Options:
Tick label appearance - Select the 

Adobe Illustrator Character 
Style to be applied to the text

Display scale value - Check this 
option to enable options to 

position the scale value above 
or below the bar and left, 

center or right aligned.

Page unit and World units - Check 
these options to be able to 

specify custom labels. These 
override the unit labels specified 

in the Scale Bar dialog box.

Variables - Use these 
variables in the Scale and 

Ratio label text boxes.

Display units to right of last interval label 
Check this option to display the 

interval unit at the end of the last 
interval label.
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FUNCTIONALITY

MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation, 
MAPublisher scale bars can be subsequently resized using the bounding box (for example to add or remove 
component intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate 
system must be projected. (i.e. not in degrees). Scale bars are added on  Legend layers. If no legend layer is present 
in the document, a new legend layer will be created automatically.  To manually create a new Legend layer, use the 
Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see chapter 4 for more details).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style 
(Window > Type > Character Styles) before opening this dialog box. Alternatively, use the Edit Text Rendition dialog 
box to specify the font, colour, size and style of text to use.

ADDING A SCALE BAR

Click the Scale Bar button  on the MAPublisher toolbar or choose Object > MAPublisher > Scale Bar.

Standard Options

Use the Up and Down buttons to select a scale bar design. Note that some scale bar designs contain two bars and 
when such a design is selected, the Second Bar column of options is enabled.

In the Units drop-down list, specify the units for the scale bar intervals to be based on. The default units are that of 
the current MAP View.

In the Interval text box, specify a real-world distance that each interval of the scale bar will represent. This number 
will be in the unit specified in the Units list.

Note:	 A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user defined) 
point styles or units.

Specify the number of cells in the scale bar by entering a number in the Number of labeled intervals scroll box. 

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will 
compose the scale bar.

To subdivide some of the intervals or cells in the scale bar, specify a number in the Number of intervals to subdivide scroll 
box. The subdivided cells begin at the left side of the scale bar. The Number of sub-intervals that compose each of these 
cells can be specified in the next scroll box. As required, choose to Add an interval left of zero.
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Labeling Options
Click the Tick label appearance to adjust the tick labels of a scale bar in the Edit Text Rendition dialog box. Choose a 
predefined Character Style in the Graphic Style mode or set font, stroke and fill options in the Custom mode.

In Graphic Style mode, labels can be styled using predefined Adobe Illustrator Character Styles. Graphic Styles can 
be applied to these labels by choosing one from the Graphic style drop-down list. In Custom mode, labels can be 
styled using the font, font size, stroke, stroke width and fill options available.

Graphic Style modeCustom mode

Adjust the Tick label spacing to increase or decrease spacing between the tick label and the scale bar.

The Display scale value option shows the scale value above and to the left of the scale bar (by default). The position 
and alignment can be changed using the respective drop-down lists. The Display page to map units ratio option adds the 
page unit to map unit ratio label (select from Inches, Centimeters and Millimeters). Use the decimal precision and 
placement options to adjust the appearance as necessary.
 
To further enhance the look of scale bar labels, click the Customize Labels button. Under the Label Unit Overrides 
section, check the options to override the Page unit and World unit labels and type text into the text boxes. Under 
the Formatting section, click the Scale and Ratio appearance links to open the Edit Text Rendition dialog box (same 
as above) to adjust the font, color, size, stroke and fill of the scale and ratio labels. Type text into the Scale and Ratio 
label text boxes to specify custom labels along with using the available variables (e.g. %page_unit%). The variables 
represent stored values from the Scale Bar dialog box and the map document. A preview of the scale is shown 
below each of the text boxes.

Click OK to place the selected scale bar on the legend layer at a default position (centered on the artboard).
The Adobe Illustrator editing tools may be used to move the scale bar to a desirable location.
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EDIT A SCALE BAR

Use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars 
horizontally will add or remove intervals from it. Resizing vertically will adjust the width of the bars.

Scale bars can also be resized using the Adobe Illustrator menu Object > Transform >Transform Each, by changing 
the horizontal or vertical scales. 

To change the design of the scale bar, or to modify any parameter without generating a new version, select the 
scale bar and access the Object > Edit Scale Bar menu item. This will re-open the Scale Bar dialog box and the current 
parameters of the bar are available for editing.

Note:	 Manually editing a scale bar is not possible in its default grouped state. However, manual editing is still 
possible if the object is expanded first (Object > Expand). Note, that this will break the dynamic link between 
MAPublisher and the scale bar and it cannot be edited through the Object > Edit Scale Bar menu item 
anymore. Please see Appendix A3 for more information on working with scale bars in MAPublisher.
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Create North Arrow 
Object > MAPublisher > Create North Arrow or MAP Toolbar 

FUNCTIONALITY

The Create North Arrow tool converts selected art into a directional true north arrow.

In this process, the selected art is rotated toward true north at the art location. This property is maintained through 
subsequent moves of the map, projection or rotation. 

The true north is the direction to the geographic North Pole — this direction may vary on a map depending on the 
selected MAP View coordinate system. To visualize this, think of the lines of latitude in a graticule (see chapter 13) — 
these lines can be straight or curved.

Note:	 True north usually differs from magnetic north (the direction of the magnetic north pole, which varies in time 
and space) and grid north (the direction northwards along the measured grid of a projected map).

PREREQUISITES

Any Adobe Illustrator artwork (path or symbol) may be used as a base to create a north arrow. The only requirement 
is that the art resides on a  Legend layer, and be selected. 

This Legend layer must be hosted by the MAP View base for the alignment of the north arrow.

Note:	 Sample north arrow symbol designs are included with MAPublisher. In the Symbols panel options menu,  
choose Open Symbol Library > MAP Symbols > Other Symbols > North Arrows.

CREATING A NORTH ARROW

Select the piece of art to be converted to a north arrow and click the MAPublisher toolbar button . 
Alternatively, choose Object > MAPublisher > Create North Arrow.

Upon creation, the selected art is aligned to true north, based on the coordinate system of the host MAP View and 
its position on the map. If the north arrow symbol is repositioned on the map, it will be re-oriented to the true north 
at the new location.

Note:	 If the selected art is not already a symbol, it is converted to an Adobe Illustrator symbol and is added to the 
Adobe Illustrator Symbols panel.
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Users should have a basic understanding of HTML syntax 
to use this feature.

MAPublisher introduces the MAP Web Author tool that 
exports Adobe Illustrator documents with GIS attribute data 
to interactive Flash maps complete with callout bubbles, 
rollovers, layer control, pan and zoom controls.

Like other MAPublisher functions, MAP Web Author is 
completely built-in to Adobe Illustrator. Interactive Flash 
maps can be exported without any additional coding or 
software requirements. Therefore, users are not required to 
have Adobe Flash installed to benefit from this tool.

Flash map export offers controls for the layers visibility. 
Additionally, map features (point, line, and area) can be 
identified from the attribute information when users type a 
keyword in a search box.

Users with a good understanding of HTML, CSS and 
JavaScript will be able to customize maps to embed into any 
web page using the MAP Web Author API and CSS tools.

Topics covered in this section:
MAP Web Author Workflow
MAP Web Author Panel
Web Tag Dialog
Web Export Dialog
Advanced Features

MAP Web 
Author
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MAP Web Author Workflow 

MAPublisher is installed with tutorial materials. It is recommended that users work with the exercises in order to 
gain familiarity with MAPublisher tools. The tutorial materials have an exercise dedicated to the new MAP Web Author 
panel. The following workflow can be used for guidance.

1) MAP COMPILATION WITH ADOBE ILLUSTRATOR / MAPUBLISHER

Users must create their map document using MAPublisher 8 and Adobe Illustrator tools. If the only purpose of the 
map is to create a Flash map, consider at this stage the document size parameter, as this determines the size of map 
viewer extents in the Web browser.

2) PREPARING FOR MAP WEB AUTHOR

a) Create a working directory
Create a folder on your computer. This folder is used to store all the components for the Web Flash map and 
the exported Flash files. 

b) Prepare graphics for callouts
Images or Flash animations that will be used in the Web tagging process must be grouped in a Source Media 
Folder. When inserting graphics using a MAP Attributes field for multiple artwork, note that it is not possible to 
change the graphic dimensions in the Web Tag Dialog. Graphic dimensions should be set beforehand.

c) Set document size for the Flash map
If the document size hasn't been set at step one (document creation), it should be modified through the 
Adobe Illustrator menu File > Document Setup prior to Web export.

Note:	 Changing the document size after artwork is created may result in the adjustment of MAP View 
Scale, symbol and text sizes as well as stroke widths.

d) Use attribute table information for callouts
To use attribute information for Web tags, it must be organized using the MAPublisher MAP Attributes panel. 
This may require creating new attribute columns for elements such as Website links or graphic file paths.

e) Data preparation
Run the crop tool, simplify lines and remove unneeded attributes.
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3) USING MAP WEB AUTHOR

a) Setup the Source Media Folder
Users have a choice between entering an absolute or relative path for the Source Media Folder.

Note:	 If an image is placed under C:\Work\Flash_Project\Images\MyImage\MyImage1.jpg, and the Source 
Media Folder is C:\Work\Flash_Project\Images, then the path \MyImage\MyImage1.jpg must be typed 
in the Web Tag Dialog (or in the MAP Attributes panel when using attributes).

b) Create callout bubbles
Using the Web Tag Dialog, insert content  (such as a title, images and text) into the callout bubbles Use the 
Callout Preview to see an example of how the callout bubble will look, prior to the export process.

4) EXPORT FLASH DOCUMENTS

The settings entered in the Web Export Dialog are determined by the desired aspect of the Web map. It is 
recommended that users try different configurations. Here are some basic examples:

Simple MAP - No layer control, no navigation 
(Basic Settings). No Search box (Advanced 
Settings).

Default Style Map - Built-in layer control and 
navigation button added through the 
Basic Settings only.
No Advanced Settings required.

Customized Style Map - External layer control 
and navigation button added through the 
Basic Settings. Removed zoom buttons 
and changed callout bubble style through 
Advanced Settings.

5) VIEWING FLASH MAPS WITH A WEB BROWSER

Download the latest Flash Player version (http://get.adobe.com/flashplayer/) and install it. Open the Flash map in a 
Web browser to view it (i.e. select the exported HTML file and open it locally).

Note:	 If the Flash Player Security Sandbox is set to Network during the export, the folder permissions must be set in the 
Adobe Flash Player Settings Manager, as explained earlier in this chapter. If the option Auto or Local has been 
chosen during the export, the map can be opened while offline with no further settings.
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MAP Web Author Panel 
Window > MAPublisher > MAP Web Author or MAP Toolbar  

FUNCTIONALITY

The MAP Web Author tool exports a MAPublisher document as an interactive Flash map for Web display. Together 
with the map artwork, Web tags (also known as callout bubbles) are included in the export. Prior to the export 
process, the MAP Web Author panel is used to create, edit or modify these interactive objects.

Web tags can either be populated one object at a time or for a selection of objects. To create or edit multiple Web 
tags, select artwork and click the Edit button. Using this method, the same Web tag format is applied to all selected 
artwork. Information can be entered manually or extracted from the MAP Attributes fields (when available for the 
object layer). At any time, Web tags can be edited or modified by selecting them and clicking Edit.

Text and image formatting is created using simple HTML (Hyper Text Markup Language). The results can be checked 
in the Callout Preview window available in the Web Tag Dialog.

Additional settings such as customizing the navigation and callout bubbles are available during the export process.

Export to Web - Opens the Web Export 
Dialog to finalize settings for export

Zoom - Zooms to selected Web tags

Edit - Opens the Web Tag Dialog. 
Create or modify Web tags

Remove - Delete Web tags of any 
selected objects

All Web Art - Select all artwork that have 
a Web tag in the document

Previous/Next Web Artwork - Navigate 
between Web tags. Status displays how 

many Web tags are selected.

Specify Source Media Folder

Specify Source Media Folder - Specify the 
directory path to the media files

Browse - Browse to the directory 
containing the media files (images and 
Flash animations)

Absolute Path - Select this option to set 
an absolute path (best used when 

working on a single computer)

Relative Path - Select this option to set a 
path relative to the current location of 
the Adobe Illustrator document (best 

used when files have to be moved). 
Newly created documents must be saved 

for this option to be enabled.

Reset - clear the current Source Media 
Folder settings

MAP Web Author Panel

Web Art on Layer - Select all the artwork 
that have a tag in the currently 
selected layer



231Chapter 15: MAP Web Author
MAP Web Author Panel 

PREREQUISITES

In order to use MAP Web Author, first complete a map using MAPublisher and Adobe Illustrator tools. The Adobe 
Illustrator artboard will determine the size of the Flash map. It is recommended to set the document size before any 
work is started. The document size may be changed using the Adobe Illustrator Artboard Tool at any time. Using pixel 
units is the most practical to determine Flash map sizes in a Web browser.

To populate Web tags, MAP layers must have relevant attributes populated in their MAP Attributes tables. For example, 
to insert links to graphics (images and Flash animations), the MAP layer must have a dedicated attribute field 
containing a path (e.g. \images\picture1.jpg). The Source Media Folder containing the graphics must be organized 
properly. The supported image formats are JPEG, PNG and GIF and supported Flash animation format is SWF.

Notes:	 Not just any map can be made into a Flash map. A print ready map does not necessarily mean that it is a 
Flash ready map. Unneeded art and attributes should be removed, lines should be simplified. Layers that do 
not require tagging will still be exported. 

Only the active artboard will be exported to Flash (Adobe Illustrator CS4/CS5 only).

MAPublisher Flash export requires the Firefox version of the Flash Player to be installed. Full support for Internet 
Explorer Flash plug-in is partially complete at the time of printing. Also, the user is no longer warned if the Flash 
plug-in is not installed/detected prior to loading the Flash map, instead, a link is provided when an attempt to 
load the file is made. To ensure compatibility, download and install the latest Flash Player at http://get.adobe.com/
flashplayer/otherversions.

USING MAP WEB AUTHOR

Specify the Source Media Folder
The Source Media Folder is the directory containing graphics that might be displayed in the Web tags (callout bubbles). 
The path to this directory is chosen through Specify Source Media Folder in the MAP Web Author panel options menu.

Either an Absolute Path or a Relative Path may be entered. An absolute path refers to the full folder directory path 
(e.g. C:\folder1\folder2...). A relative path refers to the folder path from the current location of the Adobe Illustrator 
document. In the example below, the relative path starts from \MAPWebAuthor_Tutorial.

Absolute Path example Relative Path example

If the Adobe Illustrator file is to be exchanged between computers, it is good practice to use a Relative Path to avoid 
having to reset the link to Source Media Folder when the files are moved.
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Add, Edit and Remove Web Tags
To add or edit a Web tag, select a piece of artwork and click the Edit button in the MAP Web Author panel. This opens 
the Web Tag Dialog where the Web tag settings can be defined. When multiple artwork is selected, any settings made 
in the Multiple Web Tag Dialog are applied for all of the selected artwork. They may be individually modified by scrolling 
through the Web tags or at a later time by selecting the artwork and clicking the Edit button.

To remove Web tags, select artwork with an associated Web tag and click the Remove button.

Note:	 Document artwork (lines, areas, points) associated with callout bubbles are also called Web Art. Only Web Art 
will be searchable in the resulting Flash map (see Export to Web). Text cannot be tagged as Web Art.

Selection
Select any artwork in the document and the MAP Web Author panel displays the number of Web tags (assuming 
the artwork contains a Web tag). To select all the artwork with Web tags in a document, click the All Web Art button. 
To select all the artwork with Web tags on a specific layer, select the layer in the Adobe Illustrator Layers panel, and 
click the Web Art On Layer button. Use the navigation buttons to consecutively move to the previous or next artwork 
that contains a Web tag.

The Zoom To Selected Art option centers the Adobe Illustrator document view to the selected artwork with Web tags. 
Check this option and use the Previous/Next Web Art buttons to navigate between them.

Export to Web
The Export to Web button opens the Web Export Dialog described later in this chapter.
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Web Tag Dialog 

Callout Title - The title of the 
callout bubble

Callout Preview - Open or close the 
preview of the callout bubble

Callout Editor - Edit the callout 
contents. Supported HTML tags 
may be used to format the text 
and images in the contents

Callout Size - Set the size (width 
and height in pixels) of the 
callout bubble

Auto Size - Check this option to 
automatically size the callout 
bubble around its contents

Callout Image - Choose Manually 
to browse to the media. 

Choose By Attribute and type 
the attribute name containing 

the path to the media.

HTML Tags and Graphic Tools 
Use these tools to edit the text. 

From left to right: Bold, Italic, 
Link, Line Break, Unordered 

List, and Image. Chart options 
include Bar Chart and Pie Chart. 
The insert attribute drop-down 

list contains attributes 
contained in the layer.

Image Width and Height - Specify 
the image width and height in 

pixel or use default size

HTML Supported Tags - Open 
Adobe Flash documentation to 

view more information about 
supported HTML tags

Trigger External URL (Advanced)
Control how URLs are opened 
when either clicking or hovering 
over Web art. Framesets or target 
must be created to direct the Web 
page to a specific frame.

Callout Bubble example

Callout title

Callout Image - as set in the 
Callout Image section

Callout Contents - can contain text, 
images and graphics. Set in the 
contents frame.

FUNCTIONALITY

Click the Edit button in the MAP Web Author panel to open the Web Tag Dialog (Multiple Web Tag Dialog if multiple artwork is 
selected). These dialog boxes are used to design the Web tags (callout bubbles) using HTML. These callout bubbles 
appear when objects in the Flash map are clicked or hovered over. Not all objects in the map need to be associated 
with a callout. Use the Callout Preview to see how the HTML affects the Web tag.

Previous and Next - Click Previous or Next button to 
switch from one Web tag to another (enabled when 
multiple artwork is selected).
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PREREQUISITES

In the Web Tag Dialog, text and image parameters are edited using HTML tags. HTML tags are key codes written 
between less than (<) and greater than (>) signs, that indicate how the Web browser should display the text. There 
are opening and closing version for most (but not all) of the tags, and the text to be affected is contained between 
the both tags. Both the opening and closing tags use the same key code but the closing tag is preceded by an initial 
extra forward slash sign (/).

Examples of text formatting

			   <b>Maps of the World</b>  Maps of the World	
	
			   <i>Maps of the World</i>  Maps of the World	

Examples
Some HTML tags are used to insert links and images.
•	<a href="http://www.avenza.com">Avenza Web Page</a> 

 Creates a link to www.avenza.com accessed when clicking "Avenza Web Page" text.

•	<img src="sourcemedia/picture.jpg" hspace="0" vspace="0" align="left" >

 Inserts an image (picture.jpg located in the Source Media Folder).

HTML ignores extra spaces and returns, therefore tags such as <br> (to create line breaks) and <p> (to start a 
new paragraph) should be used. In addition to the HTML tags, MAPublisher can use text extracted from the MAP 
Attributes table. The reference to the attribute field name is indicated between two percent (%) signs. For example, 
%AttributeName%.

Examples of using attribute fields
•	<b>%Street_Name%</b>

 Main Street

•	<img src="sourcemedia/%image%" hspace="0" vspace="0" align="left" >

 Displays image indicated in the attribute called "image" (a string text). hspace and vspace sets the 
horizontal and vertical space left blank around the image. The align setting sets the image alignment to the 
left of the page.

•	<a href="http://%WebSite%">Avenza Web</a>

 Avenza Web (opens the Website value indicated in the WebSite attribute).

Opening Tag Closing Tag
Text

Result
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USING THE WEB TAG DIALOG

Callout Setup and Preview
The Preview button opens or closes the preview of the callout. As text and graphics are inserted, the preview gets 
updated to show the aspect of the callout bubble prior to export. Set the Height and Width of the callout bubble in 
pixel units or use the Auto Size option. This option sets the size of the bubble automatically based on the contents of 
the callout.

Note:	 Flash is used to generate a callout preview of exactly what you will see in a web tag. However, due to some 
known Flash Player HTML rendering limitations, some callouts may not appear in a Web browser exactly as 
shown in the MAP Web Author preview. For example, ordered and unordered lists (<ol> and <ul> tags) are 
not recognized by Flash Player so they do not modify how the list is rendered and all list items will be shown 
using bullets.

Insert a Title
Callout bubbles can be given a title. The title can be typed in as text, but it can also be formatted using HTML tags 
and MAP Attribute values. The attribute field name must be entered between percent (%) signs, e.g. %TITLE%.

Insert an Image or Flash Animation
Images and Flash animations (SWF) can be inserted into callout bubbles. To insert graphics manually,  choose the 
Manually option and browse to the graphic file. To use an attribute value containing the path to the graphic file, 
choose the By Attribute option and type the attribute field name into the box. The attribute field name must be 
entered between percent (%) signs, e.g. %Image_File%.

By default, the original graphic size is used. To change the graphic size, enter a new Width and Height into the boxes 
(the width/height ratio is maintained). The Callout Preview shows the size of the graphic. The By Attribute option is 
not available for Multiple tagging.

Note:	 The maximum size for a callout is 800 pixels by 800 pixels. When this limit is reached, graphics are 
automatically scaled to fit (aspect ratio is maintained).

Add and Edit Contents
The Web Tag Dialog provides a series of tools to create HTML tags more quickly. The Table title (next page) shows the 
tag buttons and functions that are available.

To insert a tag into the callout editor box, click a tag button. Then type callout text in between the opening and 
closing tags. Alternatively, highlight text with the cursor and click a tag button to wrap tags around it. Use the 
Callout Preview to see how the text, links or charts are displayed.

Aside from the HTML tags, the Web Tag Dialog provides a drop-down list to pick MAP Attributes (visible attributes only). 
Choose an attribute from the drop-down list and it will be entered into the callout editor box.

Note:	 MAP Attributes column names are case sensitive.
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Tag button Tag Function HTML tag example Result

Bold <b>Madrid, Spain</b> Madrid, Spain

Italic <i>Land Parcels</i> Land Parcels

Hyperlink <a href=”http://www.avenza.com”>Avenza Page</a> Avenza Page

Line Break Orlando,<br>Florida
Orlando, 
Florida

Unordered List
<ul> 
  <li>Roads</li> 
  <li>Avenues</li> 
</ul>

•	 Roads
•	 Avenues

Insert Image <img src=”ImageFile/Canada.png”>

Pie chart
<chart type=”pie” showLegend=”true” values=”’key1’, 
‘%attrib1%’ | ‘key2’, ‘%attrib2%’” colors=”0xff0000, 
0x00ff00” width=”180” height=”180” >

Horizontal bar chart
<chart type="horizontalbar" showLegend="true" 
showAxisValues="true"  values="'key1', '%attrib1%' 
| 'key2', '%attrib2%'" colors="0xff0000, 0x00ff00" 
width="180" height="180" >

Vertical bar chart
<chart type="verticalbar" showLegend="true" 
showAxisValues="true"  values="'key1', '%attrib1%' 
| 'key2', '%attrib2%'" colors="0xff0000, 0x00ff00" 
width="180" height="180" >

Additional information for pie and bar charts:
•	 key1: Legend for the first value. Enter a text in between single quotes. For example: 'Table Title'
•	 %attrib1%:  Attribute that contains the first numerical value for the graph, as found in the MAP Attributes 

panel. For example, if the attribute is named MALE_POP enter '%MALE_POP%'
•	 key2:  Legend for the second value. You can enter a text of your choice in between ' sign. For example: 

'Female Population'
•	 %attrib2%:  Attribute that contains the second numerical value for the graph, as found in the MAP 

Attributes panel. For example, if the attribute is named FEMALE_POP enter '%FEMALE_POP%'
•	 colors: enter a list of colors for the chart (first color, second color etc...). The color values must be entered 

in hexadecimal values. For example, use the Adobe Illustrator Color Picker and select color : the hex 
value (below the B of RGB). However, Illustrator writes the color as #BC1E1E , but in MAP Web Author, 
the # sign by 0x (zero-x) replaces the # — so 0xBC1E1E must be entered.

•	 width and height: Size of the graph in pixels.
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Advanced HTML tag combinations can be used to create more effects. For more information and a complete list of 
HTML tags supported by Adobe Flash, click the link on the Web Tag dialog box or go to http://livedocs.adobe.com/
flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00000922.html.

Auto Size Option
When this option is used, the callout bubble automatically resizes to fit its contents.

Trigger External URL
The Trigger External URL options allow an advanced Web designer to load a specified HTML document (designated 
by its URL address) into a targeted HTML frame. Attributes may be used (i.e. %ATTRIBUTE_NAME%). This option 
occurs when the Web Art is clicked or hovered over. 

A Web browser can be divided into multiple panes called HTML frames in order to present documents in multiple 
views, which may be independent windows or subwindows. For example, within the same window, one frame 
might display a static banner, a second a navigation menu, and a third the main document that can be scrolled 
through or replaced by navigating in the second frame. An example layout could be as follow:

Frame 1

Frame 2

Frame 3

Names of frames created by Web designers must begin with an alphabetic character (a-z/A-Z). Some special 
purpose HTML frames have reserved names with a leading underscore. The following reserved names are available 
for selection from the Target drop-down list.

_blank Loads a linked document into a new blank window (unnamed). 

_self Loads a linked document into the same frame in which the link was 
clicked (frame containing Flash map).

_parent Loads a linked document into the immediate parent of the document 
the link is in (frame containing Flash map).

_top Loads a linked document into the entire window, clearing the frames.

To use the Trigger External URL options, enter the URL address of the HTML document to open in the Hover 
URL or Click URL fields. The specified URL can be any page available locally or any external Web page (for 
example http://www.avenza.com). In the Target drop-down list, enter the name of the destination frame (type in the 
name given by Web designers or use one of the four available reserved names).
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Web Export Dialog

Export Settings

Export Location- The destination 
folder of the exported 

Flash documents

Layer Controls - Lists all the layers 
in the active artboard. All layers 
will be visible, but only checked 

layers under User Toggle can be 
shown/hidden by a user. 
Options - Set layer export 

options. Show a layer at certain 
zoom levels, set initial layer 

visibility and static content is 
affected by pan and zoom.

Export - Export the document to 
a Flash map

Compress Metadata File - Check 
this option to compress the 

map data file, map.xml

Viewer Settings 
See next section for more details

Viewer Style 
See next section for more details

Viewer Style - Use these 
setting to control the 
style and position of 

navigation objects and 
map elements. Any 

changes to the default 
settings will output a 

new CSS file. 

Use External CSS File - If 
an external CSS file 

is specified, it will 
override any of the 

settings specified 
above. When a CSS file 

is specified, an Edit link 
is enabled. It opens 

the file in the system's 
default text edtior.

Viewer Settings - Customize the navigation controls of 
the map. The default settings shown are shown here.

JPEG Image Quality & Resolution
Drag the slider to control 

the amount of JPEG file 
compression

Simplify Outlines - Check to 
simplify outlines of tagged 

artwork in the Flash map

Map Settings 
Width and Height - Size of the 
Flash map in the browser. 
Cannot be larger than the 
Adobe Illustrator document.
Set to Artboard - Reset the width 
and height to its original values
Pan X and Pan Y - Initial pan shift 
applied to the Flash map (from 
top-left corner)
Initial Zoom - Zoom level when 
the Flash map is opened 
Minimum Zoom - The minimum 
zoom level that the map can 
be set to 
Maximum Zoom - The maximum 
zoom level that the map can 
be set to

Preserve Appearance - When 
unchecked, path simplifications 
are applied by Adobe Illustrator. 

Flash Player Security Sandbox 
Provides a restricted area for 
the map that prevents access 
to private data. Depending 
on location of final Flash map, 
choose Local or Network. It is 
set to Auto by default.
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FUNCTIONALITY

Use the Web Export Dialog to set the look and feel of the Flash map: style navigation objects and map elements such as 
buttons, the search box, overview map, layer list, callout bubble, zoom slider, and highlight lines and colours. These 
are the final settings before exporting the document as a Flash map.

PREREQUISITE

Web tags must be first created using the Web Tag Dialog.

USING WEB EXPORT DIALOG

In the MAP Web Author panel, click the Export to Web button  to access the Web Export Dialog. The Web Export Dialog 
contains two tabs. The Export Settings tab controls the export location, layer options (visibility, toggability, etc.) and 
the Flash map settings. The Viewer Settings tab control the appearance and disposition of the Flash widgets.

WEB EXPORT DIALOG - EXPORT SETTINGS

In the Export Location box, specify the directory that will store the HTML index file (by default index.html) and Flash 
export files. Click the Export button to complete the Web export.

Layer Controls
To insert a layer list in the Flash map, at least one layer check box under the User Toggle column must be checked 
(Export Settings tab) and the Show Layer List option must be enabled (Viewer Settings tab). Layers that are checked 
are included in the Flash map layer list and can be toggled on or off. The layers that are unchecked are exported, but 
can not be toggled on or off.

Navigation buttons - Pan up, pan down, 
pan left and pan right buttons. 

Home button in the center of the 
pan buttons centers the map to its 

original view.

Zoom Slider - Move the slider arrow 
up or down to zoom in or out, 

respectively. Use the Zoom In or 
Zoom Out buttons to zoom at 

specific increments.

Layer list - Check boxes toggle 
layer visibility. Only layers 

checked under User Toggle are 
shown in the layers list.

Search box - Type text into search box 
and it searches through the contents 
of all the exported callout bubbles. 
Results are highlighted on the map.

Callout Bubble - Web tag or pop-up 
displays content created in the Web 
Tag Dialog

Overview Map - Displays the full 
extent of the map at all times. When 
zoomed into the main map it shows 
the zoom extent. The zoom extent is 
interactive and can be used to pan 
around the map.

Highlighted Lines - By default, objects 
clicked on are highlighted in blue, 
objects hovered on are in green 
and objects found by the search are 
in yellow
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Layer Export Options
It is also possible to customize the visibility and zoom of each layer. Double-click [Double Click Here To Set Layer Options] 
to access the Layer Export Options dialog box.

Map Settings
Use these settings to change how the Flash map is displayed in a Web browser:

•	 Change the width and height of the Flash map. It cannot be larger than the Adobe Illustrator document. 
Click the Set To Artboard button to reset the width and height to its original values.

•	 Set the initial position of the Flash map upon load using Pan X and Pan Y (if zoomed-in).
•	 Set the initial zoom upon load. Set the minimum and maximum zoom that the map is allowed to have.

Additional Settings
Images in Adobe Illustrator are exported as JPEG. The JPEG Image Quality & Resolution slider sets the compression level 
of exported images. This setting does not apply to images included in Web tags.

The option Use Preserve Appearance Settings For Flash Export flattens the artwork to a single layer before exporting. It is 
recommended to maintain the artwork quality. However, some known issues with Adobe Illustrator Flash export 
cause some documents to fail to export with this option enabled.

The Flash Player Security Sandbox provides a secure area in which a Flash map will load. Three options are offered:
•	 Auto: If the file is opened from a Web based URL, the sandbox is automatically switched to Network.  

If the file is opened from a file folder, the sandbox switches to Local. 
•	 Network: When Network is selected, Flash Player classifies assets (including SWF files) from the Internet 

in separate sandboxes that correspond to their Website origin domains. By default, these files are 
authorized to access any resources from their own server, but can not load any local files or resources 
unless these are enabled through the Flash Security Settings (see later in this chapter).

•	 Local: With this option, Flash Security Settings are not required, however only contents from the local 
host computer can be accessed by Flash Player (i.e. hyperlinks, API will not function). This option is 
recommended when distributing Flash maps on CD, for example.

Initial Visibility - Show or hide 
the layer when the map is first 

loaded in a Web browser.

Zoom Range Visibility - By default, 
the layer is always shown. 

Choose a zoom level range for 
the layer to be visible within. 
When the layer is outside the 

zoom range, it is hidden.

Static Content Layer - By default, 
the layer will be affected by pan 

and zoom. Choose the second 
option so that a static layer is 

not affected by pan and zoom.

Layer Export Options
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The Compress Map Data File (map.xml or map.xml.zip) is used by the Flash viewer to get information on the initial zoom 
level, Web tag content, tagged object geographic coordinates. It is recommended to keep this option enabled to 
use a compressed version of this file (map.xml.zip) to maintain a fast loading map. However, advanced users may 
use the uncompressed version (map.xml). For example, an advanced user could create programs that automatically 
update the Web Tag contents. Once compressed, this file cannot be uncompressed to map.xml. If this file is required, 
the export must be run again with this option disabled.

Note:	 In MAPublisher 8.0, the metadata file was named map.afm or map.afm.compressed. The decision was made to 
change the file extensions because these file formats were not recognized by all Web servers.

WEB EXPORT DIALOG - VIEWER STYLE

To set the style and position of the MAP Web Author map viewer controls, users can edit the Viewer Style list or use a 
CSS (Cascading Style Sheet). CSS is a style sheet language that enables the separation of document content (HTML, 
JavaScript) from document presentation — it is a simple mechanism for adding style (e.g. fonts, colors, spacing) to 
multiple Web pages at once.

The Viewer Style list contains MAP Web Author map viewer controls which include navigation buttons, zoom slider, 
search bar and callout bubbles. Each control can be styled and positioned by adjusting basic property values. Users 
can export with the default values without further adjustment. If any control properties are changed from the 
default values, a custom CSS file is exported to the export data folder.

Note:	 The controls in the Viewer Style list contain only basic properties, for more advanced designs an external CSS 
file should be used (see below).

Map viewer controls and properties in the Viewer Styles list are as follows — all positions are relative to the top left 
corner of the Flash map:

•	 Pan Up Button (Top, Left) - Position of the pan up button.
•	 Pan Down Button (Top, Left) - Position of the pan down button.
•	 Pan Left Button (Top, Left) - Position of the pan left button.
•	 Pan Right Button (Top, Left) - Position of the pan right button.
•	 Pan Home Button (Top, Left) - Position of the pan home button.
•	 Zoom In Button (Top, Left) - Position of the zoom in button.
•	 Zoom Out Button (Top, Left) - Position of the zoom out button.
•	 Zoom Slider (Top, Left) - Position of the zoom slider widget.
•	 Click Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is clicked.
•	 Hover Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is hovered over.

DropShadowAngle (here 45°)

DropShadowDistance 
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•	 Fixed Position Callout Bubble (Top, Left, Width, Height, Corner Radius, Draw Bubble, Fill Colors Start, Fill Colors 
End) - position and style of a static position callout bubble.

•	 Click Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Hover Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Box (Top, Left) - Position of the search box.
•	 Layer List (Top, Left, Width, Height) - Position and size of the map layer list.
•	 Overview Map (Top, Left, Proportion) - Position and proportion (relative to map size) of the overview map. 

For advanced users, the appearance of the MAP Web Author map viewer can be fully customized using CSS. Enable 
the Use External CSS File option and browse to a CSS file. The file will overwrite any of the configurations made in the 
Viewers Style list. Using an external CSS file for styling the viewer is advantageous because more visual aspects of 
the viewer can be set—such as, callout bubble style, text font, images for buttons—and external CSS can be reused 
for multiple maps. If the need arises, the external CSS file can be updated after the map has been exported.

The CSS implementation is based on the Adobe Flex 3 CSS system. Only class selectors are supported. Full 
documentation is located at http://www.avenza.com/mapublisher/mapwebauthor/css. This site includes full maps, 
CSS samples and examples of CSS code.

WEB EXPORT DIALOG - VIEWER SETTINGS

In the Viewer Settings tab, check/uncheck any of the options to enable/disable them. Most of these options are 
enabled by default unless otherwise specified. The visibility of these controls may also be set through an external 
CSS file (specified in the Viewer Style tab).

Navigation
•	 Enable Navigation - Displays all of the navigation buttons, search box, layers list and overview map.

•	 Show Panning Widget - Show pan widget in map viewer.
•	 Show Zooming Widget - Show zoom widget in map viewer.
•	 Show Search Box - Show search box in the map viewer.

•	 Automatically Zoom to Search Results - Zoom the map viewer to search results. Disabled by default.
•	 Show Click Callout for Search Results - Show click callouts for search results. Disabled by default.

•	 Show Layer List - Show the layer list in the map viewer.
•	 Show Overview Map - Show the overview map in the map viewer.
•	 Drag Map With Mouse to Pan - Allows the user to pan the map using the mouse in the map viewer.

Callout Bubbles
•	 Show the Click Callout Bubble - Display a callout bubble when a feature with a Web tag is clicked.

•	 Use Lightbox Style for Click Callout. Disabled by default.
•	 Show the Hover Callout Bubble - Displays a callout bubble when a feature with a Web tag is moused over.

•	 Use Full Callout Content for Hover Callout - Displays full callout bubble when option to show hover callout 
bubble is enabled. Disabled by default.

•	 Show the Fixed position Callout Bubble - Displays a fixed position callout bubble. Disabled by default.
•	 Use Centroid Instead of Mouse for Callout Position - places the callout bubble position of a feature with a Web tag on 

the centroid. Disable it so that the callout position occurs where the mouse position is.
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Animations
•	 Disable Viewer Navigation Animations - Enabling this option disables panning and zooming animations. Disabled by 

default.
•	 Use Low Stage Quality During Animations - Lowers the quality of animations for improved performance. Disabled by 

default.

Attributes
•	 Export All Attributes With Map Features - Forces all attributes to export, regardless of whether they are used in a Web 

tag or not. Disabled by default.

Expressions
•	 Allow Expressions in Search Box - Allow users to type expressions into the search box. Disabled by default.
•	 Allow Expressions in Web Tags - Evaluate expressions in web tags at runtime. Disabled by default.

EXECUTE WEB EXPORT

Click the Export button to execute Web export. The export summary is displayed in the Web Export Log.

The export creates an index.html file and an index_data folder in the export location (the "index" name is default, a 
custom name can be substituted here in the Export Location box). Some of the important files are:

•	 map.xml.zip (or map.xml when the Compress Map Data File option is not checked).
•	 MAPublisherViewer-local.swf and MAPublisherViewer.swf (map viewer implementation files).
•	 map_L#.swf (where # is the layer number; one file per layer when option to toggle is checked). 

View the README.txt file inside the export data folder for more information about each file.

The Web Export Log displays several export file size statistics: the total SWF file size and the metdata file size. These file 
sizes are meant to warn the users when files get very large. Large files should be avoided as they may be very slow 
to open on a Website.

Layer List - List of the exported 
layers, including file name, 
number of vertices and file size

Export Folder - Link to the export 
folder. Right-click to copy link 

location to clipboard.

Metadata (.xml) File Size - Size of 
the created metadata.xml file.
Less than 50 KB compressed 

(xml.zip) is ideal.

Total SWF File Size - Total file size 
of the created SWF files. 

Less than 600 KB is ideal.

Set Folder Permissions - Set folder 
permissions. Read more 

about Flash Security and 
permissions.

Export Again - Return to the Web 
Export Dialog

Web Export Log
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Flash Security and Permissions
When exporting a Flash map intended for Web distribution, choose the Network option in the Flash Player Security 
Sandbox drop-down list. If a Flash map is intended for only local use, choose the Local option. By default, the Auto 
option is chosen and automatically detects whether the Flash map is run on a network or locally. If the Network 
option is selected, the Global Security Settings must be configured in the Adobe Flash Player Settings Manager 
before an Internet browser can properly view the Flash map without posting it on a server. If the Local option is 
chosen, it is not necessary to set folder permissions. However, files exported with this option will not work for a 
Website and will have to be exported again with either the Network or Auto option.

Click the Set Permissions button in the Web Export Log dialog box to access the Adobe Flash Player Settings Manager 
(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html):

1.	 Click Edit Locations.
2.	 Click Add Location.
3.	 Click Browse For Folder or copy the full path as written in 

the Web Export Log dialog box and click Confirm.

The folder is added to the list of trusted locations. Locations 
can be modified or deleted at a later time.

Note:	 You must be connected to the Internet in order to set these permissions.

View Flash Map
To view the exported Flash map, browse to the Flash export folder (as specified in the Web Export Dialog) and open the 
file index.html (or name specified in Export Location) in a Web browser. Check that the Web browser has the latest 
version of Flash Player installed (http://www.adobe.com/products/flashplayer/). An outdated version may cause the 
Flash map to display incorrectly.

Note:	 Depending on the security settings of the Web browser used, some warnings may appear when opening files 
exported with Local option enabled. These can be ignored.
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Advanced Features 

Additional to the common MAP Web Author functions, users with good knowledge of HTML and Javascript can 
benefit from some advanced features. The information for these features is provided on the Avenza Systems Inc. 
Website (www.avenza.com) to allow for frequent updates. This information is available to all MAPublisher customers.

EXTERNAL CSS

As explained earlier in this chapter, the visual aspects of the widgets that appear in the MAPublisher Web Author 
viewer can be configured using CSS (Cascading Style Sheet). The CSS implementation is based on the Adobe Flex 3 
CSS system. Only class selectors are supported. 

Refer to the Web page http://www.avenza.com/mapublisher/mapwebauthor/css for information on how to edit the 
CSS file and for a reference to the list of classes available for styling and their supported properties. 

MAP WEB AUTHOR JAVASCRIPT API

The MAP Web Author JavaScript API allows developers to embed and interact with maps produced by MAPublisher 
in web pages.

Some Web pages have been developed on the Avenza Systems Inc. Website to provide a guide to the API and are 
available to all MAPublisher customers. They include an API reference, FAQs and examples.

For more information please refer to http://www.avenza.com/mapublisher/mapwebauthor/api. 

The Web Author examples are also provided on the MAPublisher DVD.
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Adobe Illustrator documents with GIS data can be exported 
to georeferenced PDF files thanks to the MAPublisher Export 
Geospatial PDF feature. 

A geospatial PDF is an Adobe Acrobat file that contains 
geospatial coordinates. With coordinates, users can view and 
interact with the PDF to find and mark location data.

MAPublisher exports all the MAP Attributes data in an Adobe 
Illustrator document into the geospatial PDF. Attribute values 
can subsequently be accessed and searched in Acrobat 9 
(and 8 with limitations).

Geospatial PDF exported with MAPublisher can be used in 
Adobe Acrobat to:

•	 Find and mark location coordinates
•	 Measure distance, perimeter, and area
•	 View coordinates in measurement units in 

various formats/units
•	 Copy  location coordinates to clipboard.
•	 View attributes of map objects
•	 Reopen geospatial PDF in Adobe Illustrator with 

MAPublisher capabilities maintained.

Topics covered in this section:
Export Geospatial PDF
View Geospatial PDF

Export 
Geospatial PDF
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FUNCTIONALITY

The Export Geospatial PDF function exports any MAPublisher document containing a MAP View with a specified 
coordinate system to the Adobe Acrobat geospatial PDF format while retaining the georeference and attribute 
information. All layers are exported to PDF, including non MAP layers (regular Adobe Illustrator layers).

The geospatial PDF files exported from MAPublisher are compatible with Adobe Acrobat 9 and later. The Adobe 
Acrobat Analysis Tools allow viewing and marking coordinates, viewing attributes, measuring distances, perimeters 
and areas.

With Acrobat Pro and Pro Extended, the measurement tool is always enabled. To enable this tool in Acrobat Reader 
9 (standard), the file must first be opened in Acrobat Pro to enable annotations on the PDF (menu Comments > 
Enable for commenting and analysis).

Note:	 Geospatial PDF files can also be opened in Adobe Acrobat 8, however no geospatial information will be 
visible, only attributes.

PREREQUISITES

Export Geospatial PDF can only be used with MAPublisher documents, meaning that it must contain at least one 
MAP View with a specified coordinate system. All coordinate systems within MAPublisher are supported, including 
user-defined systems*. Multiple MAP Views are supported with no limitation. Individual document size must be 
smaller than 14,400 pixel by 14,400 pixel to maintain correct georeferencing.

* With some unusual coordinate systems, measurements in Adobe Acrobat may not give proper results. This is an Adobe Acrobat 
limitation. Predefined coordinate systems with an EPSG code will provide accurate results.

Export Geospatial PDF 
File > Export> Geospatial PDF or MAP Toolbar 

Export Attributes  - Enable which 
layers will be exported  

with attributes:

MAP View name: click the check 
box to enable/disable the 

attribute export of all layers in 
the selected MAP View

Layer name: click the check box  
to enable/disable the attribute 

export for the selected layer
Use attribute for item name 
Enable display of attribute 
name rather than the Adobe 
Illustrator  object name in the 
Adobe Acrobat Model Tree. Then 
choose an attribute from the 
drop-down list.

Model Tree Preferences - Set the 
Model Tree display options for 
the selected layer (shown):

Item Sorting:
Sort order - choose Ascending or 
Descending for the sorting order

Check Use Natural String 
Comparison to sort numerical 
values in a natural order (e.g. 1-2-
10 rather than 1-10-2)

Include round-trip data - Enable this 
option to preserve the Adobe 

Illustrator editing capabilities in 
the exported PDF
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Depending on the expected behavior of the geospatial PDF, settings for MAP Views, MAP Attributes, and MAP 
Layers may need additional attention. See sections below.

Adobe Illustrator documents created using MAPublisher legacy versions (8.1 or earlier) as well as documents 
created by third-party software (such as Cartographica) must be opened, saved and closed with at least 
MAPublisher 8.3 prior to exporting to geospatial PDF. If these steps are not taken, a warning may be prompted on 
export and the Adobe Acrobat data tools (see later in this chapter) will not function properly.

Note:	 Some Adobe Illustrator effects are not supported during export. The attributes will not be visible for objects 
with the following effects† : 

•	 All Adobe Photoshop effects
•	 Any effect that modifies the outline shape of the artwork will cause attributes to fail. (i.e. Warp effects, 

Convert to Shape, 3D effects, Distort and Transform, and some of the Pathfinder effects).
•	 Any effect that rasterizes the art will cause attributes to fail (several SVG filters do this).
•	 Gradient Fills are supported, although transparency gradients (going from opaque to transparent) and 

Gradient Mesh are not supported. 

Geospatial Information Extents
A geospatial PDF only contains geographic information in the extent covered by a MAP View. In other words, Adobe 
Acrobat Geospatial Location Tool and Measurement Tool will not work outside the spatial extents of a MAP View. To 
increase the extents of the MAP View so that it covers a larger part of the document, create a polygon on a MAP 
area layer.

Layers and MAP Views Structure
All layers in the Adobe Illustrator document are exported including locked and hidden layers. The visibility status 
is maintained in the exported geospatial PDF, however not the locking status. Locking layers must be done within 
Adobe Acrobat.

Layer name and order are maintained as they are in the Adobe Illustrator document (with the exception of nested 
layers). Layers must have a unique name. If multiple layers have the same name, a warning message is prompted 
upon export. Adobe Acrobat does not support nested layers therefore only top most layers are maintained in the 
exported geospatial PDF. Objects in nested layers are still exported but they are included in the top most layer. It is 
not recommended to use nested MAP Layers because their attributes will not be exported unless the master layer is 
also a MAP Layer. 

All MAP Views are exported in the order that they appear in the MAP Views panel (alphabetical): the top most 
is exported first and lowest is exported last. If some MAP Views are overlapping, the positions shown in Adobe 
Acrobat are calculated based on the coordinate system of the latest exported MAP View (the lowest one in the MAP 
Views panel). When working with inset maps, the inset MAP View should be placed at the bottom of the tree in the 
MAP Views panel (using an appropriate MAP View name since the order is alphabetical).



250 Chapter 16: Export Geospatial PDF
Export Geospatial PDF 

MAP Attributes
The Geospatial PDF Settings dialog box allows the user to customize which layer attributes to export. When attributes 
are exported, only visible attributes for map objects are exported to PDF. The attribute name displayed in the Adobe 
Acrobat Model Tree Property list corresponds to the attribute Display Name specified in the MAP Attributes panel. 

Prior to exporting, users can delete or hide/display relevant attributes in the MAP Attributes panel (through the Edit 
Schema dialog box or using the Show/Hide button). The Edit Schema dialog box is also used to change the attribute 
display name - see chapter 5 for details):

USING EXPORT GEOSPATIAL PDF

To export to geospatial PDF, choose File > Export and select Geospatial PDF in the Save as type (Windows) or Format (Mac)
( drop-down list)—or click the Export Geospatial PDF button  on the MAPublisher Toolbar.

After selecting an export directory and file name, the Geospatial PDF Settings dialog box opens to offer the export 
options described hereafter.

Export Attributes For Layer
The Export Attributes For Layer tree lists all the MAP Layers that can be exported with attributes (  Area layer,  Line 
layer or  Point layer), sorted by MAP View and document. To select which layers will have their attributes exported: 

•	 Click the Export Attributes check box for each individual layer to enable or disable the export of attributes.
•	 Click the Export Attributes check box for a given MAP View to enable or disable the export of attributes for 

all layers within the MAP View. 
•	 Click the Export Attributes check box next to the document name or next to MAP Views to enable or disable 

the export of attributes for all layers of all MAP Views.

Layers that are exported without attributes will be visible in the Adobe Acrobat Layers panel but not in the Model Tree.

Notes:	 Due to Adobe Acrobat limitations, attributes of  Text layers cannot be exported. In addition, 
<compound path> objects that have an element outside the artboard are exported without attributes.

Display Name - Attribute name 
displayed in the Object Data pane of 
the Model Tree

Column - Select the column to edit

Visible - Set the visibility status of the 
selected attribute column
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Model Tree Preferences
In Adobe Acrobat, the Model Tree displays a list of all the map objects in the document along with their attribute 
information (if applicable), organized in a tree structure in MAP View/Layer Name/Object Name—see next section 
on how to view Geospatial PDF. 

The Model Tree Preferences options control, by layer, how objects will be displayed in the Adobe Acrobat Model Tree. 
To set these options, first select a layer in the Export Attributes for Layer tree. The name of the selected layer is then 
written next to the Model Tree Preferences caption. 

The Use attribute for item name option assigns a specific attribute value as a name to objects prior to export in order to 
make the geospatial PDF more readable for users.

By default, the name of the objects displayed in the Structure Pane of the Model tree are derived from the map 
object's name as shown in the Adobe Illustrator Layers Panel. The default names given by Adobe Illustrator 
to objects are often meaningless an end user. For example, lines and areas have a default name of <Path> or 
<Compound Path>, points have the name of the symbol or ordering number.

To use a specific attribute value as an object name, enable the Use attribute for item name option and choose the 
desired attribute column from the drop-down list.

MAP Views Panel Adobe Illustrator Layers Model Tree Objects List

The Item Sorting options control the order of the objects in the object tree (even if objects are not renamed):
•	 In the Use attribute for item name drop-down list, choose the attribute column that will be used for sorting. 
•	 In the Sort Order drop-down list choose Ascending or Descending order. 
•	 Enable Use natural string comparison to sort numeral values by natural order (e.g. 1,2,10 instead of 1,10,2).
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Include Round-Trip Data
The Include round-trip data option preserves the Adobe Illustrator editing capabilities in the resulting PDF.

If the Adobe Illustrator editing capabilities are preserved, users will be able to retrieve MAP Views, MAP Layers and 
MAP Attributes when re-opening the exported geospatial PDF in Adobe Illustrator. If the Include round-trip data 
option is disabled, the geospatial PDF will open in Adobe Illustrator with no georeferencing or attribute information 
and all layers will be merged into one—this might be recommended for secured documents.

Note:	 If a preserved geospatial PDF is opened in Adobe Illustrator and some changes are made, the file will have to 
be exported again using the Export Geospatial PDF function. Simply saving the document will not maintain 
the geospatial capabilities of the PDF.

RESULTS

The exported geospatial PDF can be opened in Adobe Acrobat—the geographic reference and attribute 
information are available for query (see next section).

The MAPublisher data is accessible through the Object Data Pane of the Model Tree - this displays either the coordinate 
system of a MAP View, if a MAP View is selected in the Model Tree, or the exported attribute information of a 
selected object.

MAP Views properties Attributes properties

Notes:	 Layers exported without attributes can be seen in the Adobe Acrobat Layers panel, but not in the Model Tree. 
 
During export, a warning may appear: "Multiple Art Objects Matched - One or more map objects may be 
missing attribute information". This simply states that the layers listed in the warning have objects that are 
close enough in proximity to each other that they are indistinguishable. There is an option in the warning to 
select these objects in the event that the user may want to work on them.

The default PDF settings are applied, regardless of any specific preferences set elsewhere: 
•	 Compatibility: Acrobat 8, PDF 1.7.
•	 General: Embed Page Thumbnails and Create Acrobat Layers from Top-Level Layers. 
•	 Compression: no image compression, Compress Text and Line Art is enabled.
•	 Security: no master or user password required.

To change PDF file settings (compression, password access, etc.) open the exported geospatial PDF file in Adobe 
Acrobat Pro or Pro Extended (version 9 or higher) and resave the document.
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Geospatial PDF files are compatible with the geospatial tools introduced in Adobe Acrobat 9. The availability of 
these tools depends on the user's Acrobat version (Reader, Standard, Pro or Pro Extended), but no additional 
Acrobat plug-in is necessary to use geospatial PDF. 

All traditional Adobe Acrobat tools apply with the following being the most relevant:
•	 Search: selects objects with matching name first, then objects that have a matching attribute value. 
•	 Acrobat Layers panel: displays all layers and controls the display and lock of the layers.
•	 Object Data Tool: to select map objects and display their attributes in the Adobe Acrobat Model Tree 

(Structure Pane and Object Data Pane).

Geospatial PDF files can also be read in Adobe Acrobat 8, however, the attribute information is only accessible 
(through the menu Tools > Object Data > Object Data Tool) and it does not have the geospatial tools that are 
available in version 9.

Adobe Acrobat 9 has the following special tools to access geospatial information:
•	 Measuring Tool: to measure distance, area and perimeter.
•	 Geospatial Location Tool: to display, mark and query geospatial locations.
•	 Geospatial Registration Tool: to spatially register any PDF document by digitizing control points (Adobe 

Acrobat Pro Extended only).

These tools and the Object Data Tool are found on the Analysis Toolbar (menu View > Toolbars > Analysis).
Object Data Tool - Enable selection 

of MAP objects and display name 
and information in the Adobe 

Acrobat Model Tree (menu View > 
Navigation Panels > Model Tree).

Measuring Tool - Measure 
distance, perimeter and area.

Geospatial Location Tool 
Display, mark and query 
geospatial locations. 

Geospatial Registration Tool
Register PDF documents 
(Acrobat Pro Extended only).

The settings for the Measurement and Geospatial tools are found in the Adobe Acrobat Preferences (menu Edit > 
Preferences), under the category Measuring (Geo). 

View Geospatial PDF
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These analysis tools are described in detail in the Adobe Acrobat documentation that can be found under the 
Adobe Acrobat menu Help > Adobe Acrobat Help or on the Adobe Website www.adobe.com.

Not all tools are available for every Adobe Acrobat version, below is a matrix showing the features availability per 
Adobe Acrobat version:

Acrobat 9 Reader Acrobat 9 Standard 
Acrobat 9 Pro

Acrobat 9 Pro 
Extended

(Windows only)

Geospatial Measuring Tool

Measure distance/perimeter/area PÛ P P
Store measurements as comments PÛ P P
Export/import PDF comments PÛ P P
Geospatial Location Tool

Show on-screen coordinates P P P
Search for/zoom to a location P P P
Mark location with right click O P P
Copy coordinates to clipboard O P P
Geospatial PDF Registration Tool

Create from GeoTIFF/JPG2000 O O P
Georegister a PDF map/image O O P
Add shapefile layers to a map O O P

* To enable the measurement tool in Acrobat Reader 9, the file must first be opened in Acrobat Standard, Pro or Pro 
Extended to enable annotations on the PDF (menu Comments > Enable for commenting and analysis).

Note:	 The extended tools of Adobe Acrobat Pro Extended are not necessary for MAPublisher users because these 
functions can be performed by MAPublisher. Adobe Acrobat Pro Extended is currently not supported for Mac 
operating systems.
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MAPublisher LabelPro is a comprehensive collision-free 
labeling solution integrated into MAPublisher. Using rules 
and styles for text placement, it extracts label information 
from map layer attributes and performs fast, intelligent, 
cartographic text placement. Placement rules can be saved to 
a file and imported into other labeling work sessions.

Topics covered in this section:
MAP LabelPro
MAP LabelPro Settings
MAP LabelPro Styles
MAP LabelPro Rules
Label Verification

MAP LabelPro is available as an optional add-on to 
MAPublisher. To purchase a MAPublisher LabelPro license, 
please contact sales@avenza.com or visit www.avenza.com.

For information on how to activate a purchased or evaluation 
license please refer to chapter 1.

Note:	 The evaluation version of MAPublisher LabelPro 
scrambles the text of placed labels but preserves the 
case, spacing and punctuation, so that the results give 
a sense of how actual labels would be placed based on 
the rule settings.

MAPublisher 
LabelPro™
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MAPublisher LabelPro 
Object > MAPublisher > MAP LabelPro or MAP Toolbar 

Source - Displays MAP 
Views and its associated 
MAP Layers specified in 

Setup Layers

Attribute - Select the 
attribute column 
containing the data to 
be used as labels for 
selected features

Destination - Specify 
a destination from a 
list of available text 
layers. The destination 
layer holds the labels.

Priority - For multiple layers 
being simultaneously 
labeled, assign a priority 
level to each. The same 
priority can be set to 
multiple layers.

Style - Create a 
new label style 
or choose from a 
list of established 
label styles

Rules - Select a default 
set of rules or create 
custom rules that 
dictate how labels 
are placed

Suppression Layer
Repository for labels 
that could not be 
placed based on the 
rules set

Save & Label - Save the 
current settings in the 
LabelPro configuration 
dialog box and perform 
the labeling operation 
based on these settings

Save - Save the current 
settings in the LabelPro 
configuration dialog 
box without performing 
labeling process

Setup Layers - Open the 
Setup Layers dialog box to 
choose which layers are 
to be used for labeling 
and/or obstacles
Advanced - Specify user 
defined extents for 
labeling operations

Obstacle Layers - Displays MAP 
Views and its associated 

MAP Layers specified 
as obstacles during the 

labeling session

Label all art on source layers
By default, only generate text 

labels for all data contained 
on the source layers

Label only selected art on source layers 
When enabled, generate text 

labels for currently selected data 
on the source layers

Statistics type - Choose an 
option from the drop-down 
list to display labeling 
statistics after the process

Import/Export Settings - Import 
or export a MAP LabelPro 
Settings file (*.lps), a format 
that stores all the settings in 
the current dialog box

Right-click (Windows) or Ctrl-click (Mac) to display the menus:
Pop-up menus

In Source: 

In a Obstacle Layers: 

Source MAP View Source MAP Layer

Obstacle MAP View Obstacle MAP Layer

Set destination layer - Set the same 
destination layer for all source 

layers in the MAP View

Set suppression layer - Set the same 
suppression layer for all source 

layers in the MAP View

Add to obstacle list - Add all or the 
selected layer to obstacle list

Move to obstacle list - Move all or 
the selected layer to obstacle list

Remove from labeled list - Remove 
all or selected layer from the 
source list

Setup layers - Opens the 
Setup  Layers dialog box

Edit style - Opens the 
Style dialog box

Edit rules - Opens the 
Rules dialog box

Add to labeled list - Add all or the 
selected layer to the list of 
source layers

Move to labeled list - Remove from 
the obstacle list and add all or 
the selected layer to source list

Remove from obstacle list - Remove 
all or selected layer from the 
obstacle list

In Source column header: 

Resize all to fit contents - Resize the 
width of all columns to fit content

Resize [column name] to fit content  
Resizes only the selected columns
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FUNCTIONALITY

The MAPublisher LabelPro labeling engine offers advanced labeling capabilities beyond those available in 
MAPublisher Feature Text. The MAP LabelPro engine contains sophisticated algorithms that solve many of the most 
common map labeling problems such as complex conflict resolution across multiple layers, the ability to specify 
data as obstacles and the ability to create complex labeling conventions via user defined rules. The MAPublisher 
LabelPro engine uses map data attributes for labeling and provides a much greater level of sophistication and 
control that can be configured through an intuitive user interface. Data layers may be assigned an order of 
prioritization for labeling sequences and existing text can be recognized as obstacles for multiple labeling sessions 
if necessary. Placement rules and properties, once set, can be saved to a file and imported into other files or shared 
over a network.

Only Point, Line and Area layers can be labeled using MAPublisher LabelPro, however, Text layers may only be used 
as obstacles.

PREREQUISITES

MAPublisher LabelPro can only be used in conjunction with MAPublisher documents. MAPublisher LabelPro 
generates static text, meaning the map extent and scale should be established prior to labeling. Once placed, labels 
do not maintain a link with the source data.

Before labeling with MAPublisher LabelPro, it is necessary to create the destination  Text layers (where the new 
labels will be contained). To use suppression layers (for labels that could not be placed by MAPublisher LabelPro) 
create other text layers for this purpose. To create a new text layer, use the Add MAP Layer function in the MAP View panel 
(see chapter 4): 

•	 Set the feature type to Text.
•	 To copy the attributes from the source MAP layer to the label destination layer, check the option 

Base attribute schema on and select the appropriate layer to copy its attribute schema. 

For each source layer, MAPublisher LabelPro derives the labels from a selected attribute column. Use the 
MAP Attributes panel to analyze and/or edit the information prior to labeling. For instance, to force some labels to be 
stacked, users can insert the characters && in the MAP Attribute value to indicate a Carriage Return — this can be 
done by combining two columns into a new one or using the Find and Replace function.

It is not possible to label based on an expression (e.g. a road layer with classes such as street, highway and toll road 
can only be labeled with a single style and rule). To label multiple classes of a layer, use the Split Layer option of the 
MAP Selections to create new layers for each class (see chapter 11). 

In the MAPublisher Preferences section for MAP LabelPro, base rule and style folder paths can be set. By default, 
invisible objects are ignored by MAPublisher LabelPro (they will not be labeled or used as obstacle). To take them 
into consideration, uncheck the Ignore invisible artwork option. Also, check the Merge multiline text option to create 
single line text labels. See chapter 1 on MAPublisher Preferences for more information on this topic.

USING MAPUBLISHER LABELPRO

To start MAPublisher LabelPro click the MAP LabelPro button  on the MAPublisher Toolbar or choose from the 
menu Object > MAPublisher > MAP LabelPro.
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SETUP LAYERS

Before labeling, the Setup Layers dialog box must be configured to specify which MAP Layers are to be labeled 
and which layers, if any, will be denoted as obstacles. Obstacles are map objects that are included in the conflict 
resolution decision making process, and are considered objects that must be avoided when trying to place a label. 
The Setup Layers dialog box displays all valid MAP Views and their MAP Layers in the document. To mark a layer for 
labeling purposes or as an obstacle, check the appropriate check boxes to the right of the layer name. All layers are 
listed, but only layers that are checked will be included in the labeling process or considered as obstacles.

Note:	 Layers may be used as both a label and an obstacle concurrently. It is possible to perform labeling operations 
for multiple MAP Views simultaneously, however, source data layers and destination text layers must belong 
to the same MAP View.

ADVANCED OPTIONS

In the Advanced options dialog box, set the Label Placement Area option to the extents based on the current 
artboard or the extents of labeled source layers. To set Label Margins, enable the option and enter the extents of the 
label container in increments of the current document units. Data that is outside of the label margins is disregarded 
in the labeling process.

Extents of the current artboard 
(Default) Label all designated data 
that falls within the extents of the 

current artboard.

Extents of labeled layers – Label data 
only to the extents of the selected 

MAP Layers.

Label Margins – Enable the check box 
to add margins to the  

selected extents.

Obstacles – Enable the check box to 
specify that paths without stroke 

are not considered obstacles.

Note:	 These settings are applied in conjunction to the settings from the Source Art section in the main MAP LabelPro 
configuration dialog box. Units for margins are determined by Document Setup in Adobe Illustrator.

Name – Displays all MAP Views 
and the layers within them 

that may be specified for 
labeling purposes

Label – Enable the check box for 
each data layer to be labeled.  
Enabling the option beside the 
MAP View name will enable 
the label option for all the data 
layers that belong to it.

Obstacle – Check this option 
should you want the 
contents of the layer to be 
used as obstacles for label 
conflict resolution

MAPublisher LabelPro Settings
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SOURCE AND ATTRIBUTE COLUMNS

These settings determine which attribute information is converted 
into text labels for a respective layer. The Source column shows the 
Area, Point and Line layers in the document that have been enabled 
for labeling through the Setup Layers option. For each layer listed 
in Source column, the Attribute column holds a drop-down list 
populated with the attribute structure of that MAP layer. Specify the 
appropriate attribute to be used for generating that layer's labels.

Note:	 By default, label case is left exactly as it is found in the attribute table. To modify a label's case, see the options in 
the Label Case drop-down list located in the Style dialog box of each layer.

DESTINATION AND SUPPRESSION TEXT LAYERS

The layers on which generated labels should be placed are specified in the Destination and Suppression Layer 
column drop-down lists. Destination layers will contain only the labels that could be placed successfully on the 
map based on the defined rules. Suppression layers are repositories for labels that could not be placed successfully 
according to the rules and have not met all placement conditions. For best viewing results after labeling, hide the 
suppression type text layers. Alternately, the suppression layer can be set to Ignored and unsuccessfully placed labels 
will not output to any layer.

Note:	 Rows that have incomplete configuration settings (locked destination or suppression layers/unspecified 
destination layers) are displayed in red under the Source list in the configuration dialog box. It is normal 
for a certain percentage of labels to not succeed in being placed due to rule or data conflicts. Information 
regarding the success rate of placement can be reviewed by enabling one of the Statistic type options 
located in the Options frame.

PRIORITY

The Priority setting allows for complex hierarchical labeling sequences. 
The priority is the order of preference in which labels are placed. Layers 
with a priority of 1 will be placed first (or have a high priority). Layers with 
a priority of 12 will be placed last (or have a low priority). Consequently, 
layers with a low priority might have more suppression labels generated 
for them. Priorities are set by selecting a number in the Priority drop-down 
list for a respective layer.

Note:	 A maximum of twelve priorities may be assigned at any given time however the same priority number can be 
assigned to multiple layers.
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POINT AND AREA STYLES

The Style dialog box is used to set label style properties for each map layer. To access the dialog box, click the Style 
edit button  . Set the text properties for font family, style, size and colour. A sample preview of the stylized text 
is shown in the large text box. Once the desired settings have been made, they can be collectively saved into a style 
file by clicking Save As. MAP LabelPro offers a pre-configured default style of 12 point Arial as a base labeling option.
Once saved, Styles are added to the Styles drop-down list in the MAP LabelPro Configuration dialog box. 

MAPublisher LabelPro Styles

This is very helpful in maintaining labeling consistency among similar mapping projects or when multiple users are 
working on the same project. Existing styles may be deleted by selecting it from the Style drop-down list and then 
clicking on the  delete button. Style files are saved to either a point, line or area folder depending on the type of 
map layer it is associated with.

By default, styles are saved in the following location:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Styles
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Styles
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Styles

The default save path for the Styles can be modified in the MAP LabelPro section of the MAPublisher Preferences 
dialog box. Choose Edit > MAPublisher Preferences (Windows) or choose Illustrator > MAPublisher Preferences (Mac).

Notes:	 On Windows, labeling with PostScript Type 1 fonts that are not placed in the Windows system font folder will 
produce an error message Failed to perform label placement: FontNotFound Exception. In these very rare cases, 
the font files should be copied from the Adobe font folder (usually under C:\Program Files\Common Files\
Adobe\Fonts\Reqrt\Base) to the Windows font folder (found from Control Panel > Fonts). Notably, Myriad font 
is such a PostScript Type 1 font that is not installed on the Windows font folder by default.

Attributes consisting of Unicode characters must be labeled with a Unicode font that contains the 
appropriate characters. For example, attempting to label Japanese characters with an Arial font will result in 
an error or incorrect results.

Family – Specify the font for the labels

Style – Indicate the desired font style

Size – Specify the font size

Colour – Click the color chip to 
open the Adobe Illustrator  

Color Picker dialog box.
Selected colour values will be 

converted to the document 
colour mode (e.g. CMYK to RGB).

Preview – Text sample (result may not 
be exact for some font families)

Save As – Save the current settings 
into a style file

Label Case – Select the appropriate 
label case from the drop-down list:
•	 Leave as is: keep case set in 

attribute value.
•	 Convert to lower case: e.g. abcd
•	 Convert to upper case: e.g. ABCD
•	 Convert to proper case: e.g. Abcd

Opacity – Specify the level of 
opacity for the labels

Name – Enter a name to 
save the style
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LABEL LINE DATA WITH SYMBOLS

MAPublisher LabelPro has the ability to place labels inside symbols. A typical application of this would be 
numbered highway route shields. To label lines with symbols, check the Label with symbol check box to enable 
the symbol options. Choose an appropriate symbol set from the Symbol File drop-down list and select a symbol 
from the Symbol drop-down list. Use the Height option to change the size of the symbol in the Adobe Illustrator 
document unit (e.g. inches or millimeters).

Symbols are stored in the location set in the MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols

Notes:	 The label font size and a fixed symbol height (not Auto size) affect how a label is sized inside a symbol. For 
example, if a fixed symbol height of 0.5 in is used, but the label font size of 5 pt, the symbol will be 0.5 in but 
the label inside will be no greater than 5 pt. If the label font is set to 50 pt, but the fixed symbol size is 0.5 in, 
the label will have a maximum size of whatever fits inside the symbol or the selected font size. 
 
Each symbol file has one version in RGB colour and one in CMYK. 
 
Labeling with symbols is only available for Line layers. To label areas with symbols, use the Plot Centroids 
function from the MAP Point Plotter (see chapter 6).

Label with symbol – Enable this 
check box to activate the 

symbology options

Symbol file – Choose a symbol file 
(.lsf ) that contains the desired 

set of symbols

Symbol – Choose the symbol from 
this drop-down list

Height– Specify a height manually 
or allow the symbol to be scaled 
automatically to fit the label's text 
via the Auto option.
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MAPublisher LabelPro provides users with an intuitive, easy to understand 
graphical user interface for setting up labeling rules. Each Point, Line and Area 
rule dialog box has numerous label placement options for a high level of label 
detail and a variety of configurations.

To access label rules, click the Rules edit button  in the Rules column of the 
main MAP LabelPro dialog box. Depending on the layer type, this will open 
either the Area, Line or Point Rules dialog box. Configure label rules and, if 
needed, save the rules to add it to the Rules drop-down list.

Rules operate in a very similar approach to Styles in that once added to the 
Rules list, they can be immediately applied, reused later in the same file or in other documents provided they are 
being applied to the same type of data. Rules are saved to the Area, Line or Point folder depending on the feature 
type of the MAP layer.

MAPublisher LabelPro offers a pre-configured Default rule for each data type. It is loaded by default and used until 
new rules have been created or selected. The default rule is a good starting choice as it is configured to be useful 
for the most common labeling situations, however, creating custom rules can be very useful when specific labeling 
conventions are required.

In an Area, Point or Line Rule dialog box, the sequence in which the rule options appear and are checked have no 
bearing on the order of label placement, only whether the option is enabled or not. Adjust the Priority value of 
layers to adjust the sequence of label placement. Existing rules may be deleted by selecting them from the Rule 
drop-down list and then clicking the delete button . 

Rules are saved to the location set in MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Rules
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Rules
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Rules

Note:	 Labeling results will vary depending on which rules are enabled. If no rules are enabled, MAP LabelPro will 
not perform any labeling.

MAPublisher LabelPro Rules
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AREA RULES

The Area Rules dialog box contains the label configuration options for labeling Area layers. Rules can be set by 
selecting an area feature type layer and clicking the Rules edit button  in the Rules column. The placement 
settings in the screenshot below represent the default configuration, however, these settings may be changed to 
match any labeling requirements. Click the Save As button to save the label configuration. The rule will be saved 
with a user assigned name. Click OK to apply the current settings.

About Allow overlapping labels
When the Allow overlapping labels option is enabled, labels are placed without applying other placement rules. 
Generally it is recommended to leave this option off and use Allow font reduction, Allow stacking, and Allow use of leader 
lines to increase label placement.

Notes:	 For Area type data, labels are placed relative to an object's centroid.

For areas grouped in a compound path, the largest area of the compound will be labeled.

Allow horizontal inside 
Labels are allowed to be 

placed horizontally inside 
the polygon

Allow dominant angle – Labels 
are allowed to be placed 
parallel to the dominant 

angle of the polygon

Allow extending beyond boundary  
Labels are allowed to exceed 

the boundaries of the 
polygon being labeled

Allow outside – Labels are 
allowed to be placed outside 

the polygon being labeled

Allow inside, along boundary 
Labels are allowed to be 

placed inside the polygon, 
following the polygon 

boundary

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, 
or four lines. Choose 
Alignment option: Feature, 
Left, Center or Right.

Allow overlapping labels 
Area Labels are allowed to 
overlap other labels in the 
same labeling session

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow labels to cross lines 
Labels are allowed to cross 
line features and area 
boundaries.

Allow use of leader lines – Incorporates the use of 
leader lines. Options include the number of 
lines the leader line are allowed to cross, the 
width of the leader line being used and the 
style of arrow to be used as the leader line.
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LINE RULES

The Line Rules dialog box contains the label configuration options for labeling Line layers. Rules can be set by 
selecting a line feature type layer and clicking the Line Rules edit button  in the Rules column. The placement 
settings in the graphic below represent the default configuration, however, these settings may be changed to 
match any labeling requirements. Click the Save As button to save the label configuration. The rule will be saved 
with a user assigned name. Click OK to apply the current settings.

Starting Point – Specify where the start of the label will be placed with 
options including Start, Center and End. Start will have the start of 
the label placed at the starting point of the line, Center will place 
the label in the center of the line and End will place the label at the 
end of the line. The starting point of a line depends on the direction 
of the vertices.

Placement – Place labels 
using an offset or on a 

centerline. Offset labels 
Above or Below a line. 

Vertical Split places multiple 
word labels above and 

below the line and relative 
to the center of the line. If 

the generated label only 
has one word, it will be 

placed on the suppression 
layer. The Centerline option 
places labels directly on top 

of the line.

Allow overhang – Labels  
are allowed to overhang 
the line up to a set 
percentage. The 
percentage of overhang 
is relative to the start of 
the label and the end of 
the line.

Allow stacking – Labels 
are allowed to stack to a 
maximum of two lines

Allow Labels to Cross Lines 
Labels are allowed to cross 
line features and area 
boundaries

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow use of leader lines 
Incorporate the use of 
leader lines. Allowed 
Line Crosses permits the 
number of lines the leader 
line will be allowed to 
cross. Leader Width and 
Arrow Style adjusts the 
thickness and style of the 
leader line, respectively.

Label joined feature – Places 
one label on a line that is 

joined together

Label each feature – Labels 
each and every  

line segment

Divided highways – Label 
multiple road segments 
with a common symbol 

such as a shield. Lines must 
be within 0.25 inch and 

75% of the lines must be 
parallel to be considered 

a divided highway. The 
divided highway symbol 
will be placed on the line 

with the longest geometry.
Repeat labels– Repeat labels along 
a line at specified amounts

Allow overlapping labels – Check 
this option to allow line labels to 
overlap with other labels in the 
same labeling session

Spread words – Multiple word 
labels placed a specified 
amount apart

Notes:	 Text as obstacles will not work unless the Allow labels to cross lines option is disabled. This is because text 
obstacles are treated as areas and not text. Also, text will only be avoided being placed where it intersects 
the outline of the shape and not within it.

Using the Placement option Vertical Split may require additional line smoothing (straightening or simplifying). 
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POINT RULES

The Point Rules dialog box contains the label configuration options for labeling Point layers and follows the same 
conventions mentioned for the previous two data types.

Placement – Click the 
placement buttons in 

the desired order of 
priority. Use the Clear 

Last or Clear All options 
to remove selections. 
Unselected positions 

will not be considered. 

Centered on point
Labels are placed on 

the center of the point

Allow use of leader lines 
Incorporate the use of 

leader lines. Allowed 
Line Crosses permits 
the number of lines 

the leader line will 
be allowed to cross. 

Leader Width and 
Arrow Style adjusts 

the thickness and 
style of the leader line, 

respectively.

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, 
or four lines.

Allow labels to cross lines 
Labels are allowed to 
cross line features and 
area boundaries.

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each 
step shrinks the selected 
font by 0.5 pt.

Allow overlapping label 
Check this option to allow 
point labels to overlap 
with other labels in the 
same labeling session

Note:	 For each point label there is a fixed minimal zone of 0.3 inches, within which no other point feature can be 
labelled. Consequently, when two point features are closer than 0.3 inches of each other, their labels are 
automatically placed in the suppression layer (if selected).

SAVE AND LABEL

Once the layers, main configuration, style and rule based options have been completed, proceed to label the map data 
by clicking the Save & Label button. Clicking the Save & Label button will save the current settings, close the main 
MAP LabelPro configuration dialog box and begin the labeling process.

Due to the complexity of the calculations involved in rule based text placement, it is likely that a progress meter 
will be displayed for most labeling processes except those that are sufficiently simple or small. Cancel the labeling 
process at any time by clicking on the  button in the progress dialog box.

Alternatively, save the current settings without labeling by clicking the Save button. This will close the main MAP 
LabelPro configuration dialog box and will not label any features. The dialog box can be reopened later to edit the 
saved label settings or be used to label the map.
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The graphic below shows results of a typical labeling result using options such as stack labels, repeat labels, allow 
labels to cross lines, and many others.

Verify that labels were successfully placed in accordance to the rule base set out in the MAP LabelPro configuration. 
Also verify that labels were placed on the appropriate Destination text layers. Text failing to meet the labeling 
criteria will be placed in a Suppression layer (if one is available and has been set). If no Suppression layer is available, 
the non-compliant text is ignored and is not generated. Once placed, the labels are considered standard text and 
may be modified using Adobe Illustrator or MAPublisher operations.

Note:	 Undo and Redo operations are supported when labeling. Be aware that undoing a labeling operation will 
also undo any changes to rules, styles or settings made at the same time. It may be useful to save without 
labeling, close the MAP LabelPro Editor, re-open it, then proceed to click Save & Label.

OPTIONS
None – (Default) No statistics panel will 
display after labeling

Just overall totals – Totals for all placed and 
unplaced labels (not separated by layer)

Just layer totals – Totals for each layer. 
Shows both placed and unplaced labels.

Show all – Show all statistics

The Statistics type drop-down lists several options for displaying statistical information after the labeling process 
is completed. This information is useful in determining how successful the labeling operation was based on the 
number of labels written to Destination and Suppression layers. It may help indicate whether adjustments to the 
rule base are required to achieve a higher rate of successful placement. Statistics reports may be saved as a text file 
for future reference.

Label Verification
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Graphic File Formats 
AI
The Adobe Illustrator native postscript file format. Refer to the Adobe Illustrator User Guide for more information.

DOQ
Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and 
are stored in the JPG format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register 
Image function. DOQ are usually very large files (30 MB or more) and require extremely large amounts of RAM.

DRG
Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF 
format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image function. DRG 
are also usually very large files (30 MB or more) and require extremely large amounts of RAM.

EPS
The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications. EPS 
files are easily opened by Adobe Illustrator because the format is widely supported by most graphics programs. It 
is the preferred format for export to most illustration and page-layout programs. EPS files are vector based, but can 
contain embedded raster graphics and fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file 
transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale GIF.

JPEG
Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital 
Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image function.

PDF / GEOSPATIAL PDF
Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows, 
DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics. 
A Geospatial PDF is an Adobe Acrobat file that retains geospatial coordinates.

TIF/TIFF (GEOTIFF)
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe 
Illustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported 
by Adobe Illustrator and registered by the MAPublisher Register Image function. A GeoTIFF is a TIFF file with 
embedded geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe Illustrator User Guide for other graphics file formats supported by Adobe Illustrator.

Appendix 1: Technical Reference Guide
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This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find 
an overview of the structure of each format, as well as information on supported format versions and elements 
unique to each data type. Each file format will carry a checklist covering which core elements are supported by 
MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for 
information on any issues associated with the various file formats. 
Also see chapter 2 on Map Data File Formats.

AUTOCAD DRAWING (*DWG) AND DRAWING EXCHANGE (*.DXF)

There are two formats used by AutoCAD: DXF and DWG. DXF is a CAD data file format, developed by Autodesk as 
their solution for enabling data interoperability between AutoCAD and other programs. The DWG format is used for 
storing two and three dimensional design data and is the internal format for the AutoCAD Computer Aided Design 
package. DWG is also the common name for AutoCAD proprietary DWG technology developed by Autodesk for 
their AutoCAD package.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dwg, *.dxf	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes 
	 Coordinate System Support 	 No		  Elliptical Arc 	 Yes 
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: Releases vrs. R12 to 2007
	 Mac OS X: Releases vrs. R12 to 2007. 

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Group Entities - Group entities by Layer Name or Geometry. 
•	 Hatches - Check this box if you want MAPublisher to read your hatch patterns upon import.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

MAPublisher Import Formats 
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DELIMITED ASCII TEXT (*CSV, *TSV,*TXT )

An ASCII file containing a tabular data where delimiters separate the columns and rows. Common delimiters are 
commas, spaces or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.csv, *.tsv, *.txt	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 No 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  No
	 Schema Required 		  Yes		  Donut Polygon 	 No
						      Point 		  Yes
						      Line 		  No
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import: 

•	 Axis Column - Specify which columns contain the x and y coordinates for the point data to be read in.
•	 Coordinate Format - Choose the formatting type of the data you wish to import (e.g. Decimal Degrees, Delimited 

Degrees Minutes Seconds, Packed DMS) — formats are described in chapter 6.
•	 Use first line as header - Allows the user to enable the first line of the text file to be used as column headings.

ESRI INTERCHANGE FILE (*.E00)

An archive of files that describes a complete ArcInfo coverage. This is either ASCII or compressed into a binary and is 
used to transfer files between different versions of ArcInfo. It is a commonly found format for freely distributed data 
such as that found at the GIS Data Depot (http://www.geocomm.com).

A single E00 file describes a complete ArcInfo coverage. The file itself is actually an archive of several smaller files, 
referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage, and 
follow a predefined data format. The remainder of the subfiles contained within an E00 are the info files. These files 
may contain user-defined attributes, and have names which vary from coverage to coverage. 

	 Supported Elements				     Supported Geometry
	 Typical File Extensions 	 *.e00		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes 
	 Coordinate System Support 	 Yes		   Elliptical Arc 	 Yes 
	 Spatial Index 		  Never		   Ellipses 		  No 
	 Schema Required 		  Yes		   Polygon 		  Yes
	 Geometry Type Attribute 	 e00_type		  Donut Polygon 	 Yes
						      Point 		  Yes
			    			   Line 		  Yes
						      Text 		  Yes		

There are essentially four types of geometry defined in E00 files, which will be reproduced as layers during import:
Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

•	 Tic points layer - This option enables you to include an additional layer which will hold the registration points for the 
imported data. The default is to set to Yes.
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ESRI ARCINFO GENERATE (*.GEN)

Esri simple ASCII storage and interchange format. There are three different types of .gen files each with of its own 
syntax one for points, one for lines, and one for text geometries. This is the format exported by ArcInfo generate 
command. The *.gen files are use by ArcInfo to transfer coverages to other mapping systems.

	 Supported Elements			    	Supported Geometry
	 Typical File Extensions 	 *.gen		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 No		   Circular Arc	 No 
	 Coordinate System Support 	 No		   Elliptical Arc 	 No 
	 Generic Colour Support 	 No		   Ellipses 		  No 
	 Spatial Index 		  Never		   Polygon 		  No
	 Schema Required 		  Yes		   Donut Polygon 	 No
	 Geometry Type Attribute 	 arcgen_geometry	  Point 		  Yes
						       Line 		  Yes
						       Text		  Yes		

ESRI GEODATABASES

A Geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types used in ArcGIS and managed in either a file folder or a relational database. There are two 
main types of geodatabases: 

•	 Single-User: Personal Geodatabases (extension *.mdb) and File Geodatabases (extension *.gdb)
•	 Multi-User: server based geodatabases, also known as ArcSDE Geodatabases.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.mdb (personal), *.gdb (file) 	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 No			   Ellipses 		  Yes
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  Yes			   Point 		  Yes
	 Enhanced Geometry		  Yes			   Line 		  Yes
	 Geometry Type Attribute 	 geodb_type		  Text 		  Yes
	 Encoding Support		  Yes			   Raster		  No
							       Solid		  No
							       Surface		  No
							       Z value		  Yes
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ESRI SHAPEFILE (*.SHP)

The Esri Shapefile is a geospatial vector data format for geographic information systems software. It is developed 
and regulated by Esri as a mostly open specification for data interoperability among Esri and other software 
products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute 
information. This format lacks the capacity to store topological information

A single logical Shapefile consists of three physical files, each with one of the following file name extensions:
*.shp :	 Geometric data
*.shx :	 Index to the geometric data
*.dbf :	 Attributes for the geometric data

These extensions are added to the base name of the Shapefile , creating separate physical files that must all reside 
in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric 
data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in 
a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated 
*.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the 
*.shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf. 

A single Shapefile may also consist of a number of additional files, with the following file name extensions:
*.sbn / *.sbx : 	Spatial index files for the geometric data. These two files are only generating by an Esri product 
however they are not required by MAPublisher for import and will they be generated when exporting data to the 
Shapefile format..
*.prj :	 Spatial coordinate system information.

If a *.prj file exists in your Shapefile directory, holding the coordinate system information of the Shapefile , this will 
automatically be read by MAPublisher on import. If your Shapefile folder does not contain a .prj file you will be 
required to specify the coordinate system in order to fully utilize MAPublisher. 

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.shp (*.shx, *.dbf, *.prj)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 No
	 Coordinate System Support 	 Yes (if have *.prj)		  Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No 
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 SHAPE_GEOMETRY		  Line 		  Yes
							       Text 		  No
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GEOGRAPHIC MARKUP LANGUAGE - SIMPLE FEATURES (*.GML)

GML was designed as a geographic interface language for the Geo-Web. It is currently in draft as an ISO standard 
(ISO 19136). The goal of the format is to provide users with a set of abstract base objects that can be built into 
working real world datasets. It uses as XML base to store geometry and feature information that can easily be 
transported across the Internet. 

The GML simple feature profile was created by the Open Geospatial Consortium as a restricted subset of the GML 
specification. It provides a reduced geometry and metadata profile that can be shared across many GIS tasks. This 
simple feature model can be used as a base to generate local application profiles for a specific work area. Since the 
GML models base abstract classes, these application profiles (schemas) are required for accessing and processing 
any GML datasets. Generally, GML data has a *.gml extension, and requires any application specific schema files 
(*.xsd).  For more information on GML, and the GML simple features profile, please visit the Open Geospatial 
Consortium web site: www.opengeospatial.com
	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.gml (*.xml) *.xsd		  Aggregate 	 Yes
	 Automated Translation	 Varies			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes (*.xsd)			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 xml_type			   Line 		  Yes
							       Text 		  No

KEYHOLE MARKUP LANGUAGE (*.KML/*.KMZ)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs 
Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each 
feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares 
some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped 
KML files with a .kmz extension. MAPublisher uses KML version 2.2 specifications for import and export.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.kml, *.kmz	 Aggregate 	 Yes
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import. 
The following parameters can be applied to the import: 

•	 Allow Random Colour Mode - This option allows Adobe Illustrator to generate random colour settings for the data.
•	 Expand Network Links - Checking this box will enable the use of network linked KML files.
•	 Import KML Properties as Visible - Check this option to make KML properties visible attributes (hidden by default).
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MAPINFO INTERCHANGE (*.MIF/*.MID)

MIF is a published ASCII storage format used by the MapInfo. It is used as a file format for map and database 
exporting/importing in MapInfo software products. The MapInfo Reference Manual describes the MIF format and all 
constants it uses for colour, style, symbol, and fill patterns. MapInfo Interchange Format Files are often called MIF or 
MIF/MID files. 

A single logical MIF file consists of two physical files, having the following file name extensions:
*.mif :	 Geometric data
*.mid :	 Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in 
the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many 
different types of geometry however, the associated attribute in the *.mid file must have the same number and 
type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example, 
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number 
and type of attributes associated with each entity is specified by the user. There must be at least one attribute field 
in the *.mid file.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.mif (*.mid)	  Aggregate 	 Yes
	 Automated Translation	 Yes		   Circles 		  Yes 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 		   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		   Ellipses 		  Yes 
	 Spatial Index 		  Never		   Polygon 		  Yes
	 Schema Required 		  Yes		   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mif_type		   Point 		  Yes
						       Line 		  Yes
						       Text 		  Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table.

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in *.mif files. Each geometric entity present in a *.mif file has 
display properties such as pen and brush width, pattern, and colour. Supported MID/MIF properties are as follows:

MAPublisher supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts 
(family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed 
the style library equivalents. Two library files have been created, MIF - Line Styles.ai and MIF - Area Styles.ai, which 
provide support for many of the standard MapInfo pen styles (stroke patterns) and brush styles (fill patterns). These 
files can be found in the Helpful Styles & Symbols folder installed with MAPublisher. Please refer to your Adobe 
Illustrator User Guide for details about how to add these libraries to your Adobe Illustrator Graphic Style panel. 
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MAPINFO TABLE (*.TAB)

TAB is a proprietary geospatial vector data format for geographic information systems software used by MapInfo 
mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute 
data and the .TAB ASCII file which is the link between all other files and holds information about the type of data 
file. The MapInfo TAB importer is closely patterned after the MapInfo MIF/MID reader and writer. This commonality 
makes it easy to support both MIF and MapInfo native formats in the same mapping file. 

A single logical TAB file consists of a number of physical files, having the following file name extensions:
*.tab :	 The main file for a MapInfo table, it is associated with the appropriate dat, map, id and ind files.
*.dat :	 Tabular data for a table in MapInfo native format
*.id :	 An index to a MapInfo graphical objects (MAP) file.
*.map :	 Contains geographic information describing map objects
*.ind :	 An index to a MapInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in 
the same directory. You must select the *.tab file for import.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.tab (*.dat, *.id, *.map, *.ind)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes			   Ellipses 		  Yes 
	 Spatial Index 		  Always			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mapinfo_type		  Point 		  Yes
								        Line 		  Yes				  
								        Text 		  Yes		

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file 
has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those 
described for MID MIF files on the previous page.

Raster TAB files cannot be imported in MAPublisher.
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MICROSTATION DESIGN (*.DGN)

DGN are the native files created for Bentley Systems Inc. MicroStation product. These files consist of a header, 
followed by a series of elements. The header contains global information including the transformation equation 
from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains 
standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to 
its element type. For example, a text element has fields for font, size, and the text string in addition to the standard 
display attributes.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dgn		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes
	 Coordinate System Support 	 No 		  Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 igds_type		  Point 		  Yes
	 3D Support		  Yes		  Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: V7, V8. Mac OS X: V7,V8

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import. Note: versions V7 and V8 are supported for import, attached raster 
files are ignored.

•	 Group Elements - Choose how you want to group the elements of the file on import. If you group the elements by 
level, it may result in a large number of output files. By Level is the default.

•	 Coordinate Units - Choose Master or UOR (Unit of Resolution) as the coordinate units. Master is the default.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

•	 Other - Check Drop complex chains if you want each component of a complex chain to be returned as its own 
feature, otherwise all elements of the complex chain will be merged into a single linear feature. 

Note:	 Line weight in Microstation are integer number only, as such, the Microstation export will round the Adobe 
Illustrator stroke width. 0 is a valid line weight in Microstation.
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S57 FORMAT (*000)

S57format is intended for the exchange of digital hydrographic data between national hydrographic offices and 
for its distribution to manufacturers, mariners and other data users. It is used for the supply of ENC cells (Electronic 
Navigational Charts) to ECDIS (Electronic Chart Display and Information System).

The format is public, developed and maintained by the IHO (International Hydrographic Office) CHRIS working 
committee (Committee on Hydrographic Requirements for Information Systems). The objects spatial geometry can 
be of Point, Line or Area geometry, while object descriptions are categorized in object classes, organized in specific 
attributes schemas. For a full format description, please visit http://www.iho.shom.fr/PUBLICATIONS/IHO_Download.
htm#S-57 (Appendix A in particular). An online object catalog is also available on www.s-57.com

An S57 base file has the extension *.000, while the update files have extensions like .001, .002 and so on. It can also 
be accompanied by other files:
*.000: main file
*.001: update file 1
*.002: update file 2
*.00n: update file n
files.TXT and files.JPG: ancillary text and picture files indicated in attribute definition

Update files contains only the changed (new/deleted/modified) objects and are only used as a complement 
of a .000 file. Only the *.000 file is required for the import into MAPublisher. The update files will be applied at 
conversion, when present. However, text and image files linked to attributes will be ignored.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.000 (*.001 *.002...)		  Aggregate 	 No
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 No			   Circular Arc	 No
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  N/A			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 s57_type			   Line 		  Yes
							       Text 		  No

Note:	 Most ENC producers (private and public) publish their .000 files in encrypted formats. Only non-encrypted 
files can be imported in MAPublisher (from NOAA or USACE for example).
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TIGER/LINE (*.RT1) (*.BW1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau 
format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings, 
rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the 
geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts, 
and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block 
groups, and census block. The database contains information about these features such as their location in latitude 
and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other 
features, and other related information. More information on the TIGER/Line file format and data product can be 
found on the U.S. Census web page at: http://www.census.gov/geo/www/tiger/
This web site contains a detailed description of the current TIGER/Line format, with an explanation of field meaning 
for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for 
each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.rt1, *.bw1	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 tiger_type		 Line 		  Yes
						      Text 		  No
	 Supported Versions:  	 1992, 1995, 1997, 1998, 1999, 2000, 2002

USGS SDTS (*CATD.DDF)

SDTS is the USGS robust way of transferring Earth-referenced spatial data between dissimilar computer systems with 
the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers, 
i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all 
included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will 
have the extension *.ddf. More information on this format can be found at: http://mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single 
SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in CATD, 
i.e. HP01CATD.DDF. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.ddf		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Yes		  Polygon 		  Yes
	 Schema Required 		  N/A		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 sdts_type		  Line 		  Yes
						      Text 		  No
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USGS DIGITAL LINE GRAPH (*.DLG) (*.OPT)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format 
developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange 
with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
	 • Large-scale DLG data (1:24,000-scale)
	 • Intermediate-scale DLG (1:100,000-scale)
	 • Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics 
formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics 
format is not supported. Most DLG data is distributed in the optional format. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types 
are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features 
within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a 
feature coding approach in which unique feature codes are assigned to the different types of features stored within 
the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dlg, *.opt		 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 dlg_type		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No
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MAPublisher Unicode Support 

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports 
Unicode character encoding in MAP Views, MAP Attributes, MAP Themes, and MAP Selections. MAPublisher can also 
reference Adobe Illustrator layers, graphic styles and character styles using Unicode encoding.  

To use Unicode character encoding you require a Unicode compliant font. Mac OS X users will have Unicode 
compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For 
more information on Unicode visit http://www.unicode.org. 

The following tables display Unicode—UTF8 support in MAPublisher, for GIS data formats that are Unicode—UTF8 
compliant. Unicode support for importing and exporting data is different, so for each platform two tables have 
been created. For each data format there are four areas where Unicode character encoding can be used:

1. File Directory - when Unicode encoding is used in the path to where the file is located.
2. Filename - when Unicode encoding is used in the filename.
3. Attribute column name - when Unicode encoding is used in a column name for attributes.
4. Attribute value - when an attribute value contains Unicode encoding.

Windows Unicode Support (Importing)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

Esri ArcSDE 
Geodatabase P P P P

Esri File 
Geodatabase P P P P

Esri Inter-
change File P P P P

Esri Personal 
Geodatabase P P P P

Esri  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 
NAMES AND MOST VALUES

Windows Unicode Support (Exporting)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri Inter-
change File P P P P
Esri ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

Esri  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P
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Mac OS X Unicode Support (Importing)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

Esri ArcSDE 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri File 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri Inter-
change File P P P P

Esri Personal 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 

NAMES AND MOST 
VALUES

Mac OS X Unicode Support (Exporting)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri Inter-
change File P P P P
Esri ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

Esri Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P
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Windows Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw) P 
Û

/ P
t

P 
Û 

/ P 
t

P 
Û

/ O
t

P 
Û

/ O
t

Image Report (.irp) P 
Û 

/ P 
t

P 
Û 

/ P
t

P 
Û

/ O 
t

P 
Û

/ O 
t

MapInfo TAB (.tab) P 
Û

/ P
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O 
t

ListGeo (.lgo) P 
Û 

/ P 
t

P 
Û 

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

GeoTIFF (.tif) P 
Û

/ P 
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

ÛWhen using system encoding  
 on Windows XP 
 (for example, using the default 
Japanese encoding on Japanese 
Windows XP)

t�When using non-system 
encoding on Windows XP 
(for example, using Japanese 
encoding on English Windows XP)

Mac OS X Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw)  P 
�

P 
�

P 
�

P 
�

Image Report (.irp)  P 
�

P 
�

P 
�

P 
�

MapInfo TAB (.tab)  P 
�

P 
�

P 
�

P 
�

ListGeo (.lgo)  P 
�

P 
�

P 
�

P 
�

GeoTIFF (.tif)  P 
�

P 
�

P 
�

P 
�

�Limited support 
 (not all combinations of Unicode 	 
characters are supported) 
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Technical Support Options / FAQ 

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program 
(MMP) subscription. All new license and upgrade purchases include a one year MMP subscription. Customers 
without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the 
rate of US$49 per incident.

TECHNICAL SUPPORT 
Please consult the FAQs, the additional how-to’s on the following pages as well as the following online options 
before contacting Avenza technical support as your situation may be easily addressed by one of the answers 
contained therein.

MAPublisher Online Resources
The Avenza Systems Inc. Website provides additional source of information to assist you in the use of MAPublisher. 
The Avenza Resources are located at http://www.avenza.com/resources

•	 Avenza Resources Blog: tips, how-tos and news on MAPublisher and Geographic Imager software.
•	 Map Gallery: examples of maps created with MAPublisher.
•	 Styles and Symbols: a collection of styles and symbols to help make your maps look better. 
•	 User Forums and Frequently Asked Questions: answers to common technical questions may be 

found in the Common Support Issues and FAQs category. All users with a MAPublisher license (evaluation or 
permanent) can post and read topics under the General Questions for Evaluation and Licensed Users category. 
Additionally, users with maintenance have access to the Maintenance Users category. There, users can find 
additional information relative to software updates, etc.

•	 MAP Web Author API and CSS: find advanced information on MAP Web Author API functions and CSS 
support - see chapter 15 for more details.

Contacting Avenza Technical Support

Avenza offers a number of methods for direct communication with our qualified and experienced technical experts. 
Please have your MAPublisher registration details handy to get prompt attention and include it in any email 
correspondence. Support issues are handled on a first come, first-served basis. For non-maintenance users, Avenza 
does not guarantee a response within any specified time. MAPublisher Maintenance Program subscribers receive 
free and unlimited support. All others are eligible for support at the rate of US$49 per incident.

•	 Hours: 9:00am to 4:00pm Eastern Standard Time
•	 Email: support@avenza.com 
•	 Online request form: http://www.avenza.com/support/form
•	 Phone: +1 (416) 487-6442
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MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
•	 unlimited priority technical support—guaranteed same business day or next business day response
•	 unlimited telephone support
•	 free MAPublisher updates
•	 free MAPublisher version upgrades
•	 additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are 
well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the 
MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for 
one calendar year.

Your email address has been automatically entered in the mp-maintenance-l online email list for MMP subscribers 
so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you 
purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the 
software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the 
MMP notification group.

Renewal
You will be notified regarding renewal options approximately six to eight weeks prior to the expiration of your 
annual MMP subscription. You will be contacted a minimum of five times prior to expiration in order to ensure that 
you have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for 
an additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP 
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase 
future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew 
without penalty. All post-expiration renewals will be backdated to the actual expiry date.

Lapsed Subscriptions
Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed 
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product. 
Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.
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RAM RECOMMENDATIONS

Occasional User: 2 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels, 
and some low-resolution or small coverage raster images.

Power User: 4 GB or more of RAM is recommended. 
A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large 
transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill 
patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe Illustrator requires a 
significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases 
the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in 
memory. Since we are adding a database to Adobe Illustrator this increases the file size, which increases the 
RAM requirements. MAPublisher builds a mini-GIS application inside Adobe Illustrator so that it can geo-code 
information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The 
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it 
from disk, thus more RAM memory is required.

When you are importing a large number of files into Adobe Illustrator using MAPublisher, you’ll notice that the 
amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory 
management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly 
returned when the import is done or even when it is cancelled. The solution is simple: save your file, close it and 
open it again. It’s not even necessary to close Adobe Illustrator itself. By closing the file, the reserved memory is 
properly returned. 

RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, remove any redundant or otherwise unnecessary 
attribute fields from the MAP Attributes table of a layer.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You 
can use the MAPublisher Join Lines function to join these into single linear features based on a selected attribute 
field. Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import function 
starts to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to 
periodically save your work, quit Adobe Illustrator and then restart. This will free up the available scratch memory.

Memory Considerations 
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Reduce the minimum number of Undo commands (since they all reside in memory).

Use polylined or pre-joined linear feature data sets where available.

In your GIS application, strip out the attributes you won’t be using for queries or labeling before importing the data 
into Adobe Illustrator.

You can set a primary and secondary scratch disk under the Adobe Illustrator preferences option in order to draw 
additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers panel. 
This can be done by clicking the options menu in the layers panel and then selecting small panel rows in the panel 
option dialog box.
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For geographic information system (GIS) users, the appeal of graphics is strong and the increasing ability to discover 
and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-related web 
sites from which you can access map and information data sets. To find some information on the source listed it, use 
any internet search browser such as Google to get access to the websites.

For the general public, there’s general information about countries, states, and places; simple maps of areas (e.g., 
GIF, PS format); lists and maps of Internet resources in an area. For cartographers and geography researchers, there 
are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g., 
census data); and complete GIS data sets (e.g., Esri Interchange Files).

FREE MAP DATA

Many sites on the Internet offer GIS data free of charge. Data is available from these and other Internet sites in a 
wide variety of formats. Please consult the sections in this manual on file formats (chapter 2) to ensure that you 
download usable data. Some popular sites:

•	 CAST data: Center of Advanced Spatial Technologies, University of Arkansas.
•	 EROS Data Center: access to USGS digital datasets.
•	 Geocommunity and GIS Data Depot: very good source of free GIS data.
•	 Geoconnections/Geoconnexions: Canada Ministry of Natural Resources site.
•	 Geography Network: world-wide geographic contents.
•	 Geogratis: maps offered by Natural Resources Canada.
•	 Geoscience Australia: Australian National Mapping Agency.
•	 National Atlas of the United States: excellent data source for the United States.
•	 NOAA ENC Download: free download of electronic nautical charts in S-57 format (USA).
•	 Robert E. Kennedy Library @ California Polytechnic State University: US based map inventory.
•	 United State Geological Survey: various data formats available (DLG, GeoTIFF, etc.) from the USGS website.
•	 United States Fish and Wildlife Service: variety of map data in USGS DLG format.
•	 USACE IENC download: US Army Corps of Engineers, S-57 and Esri Shapefile of US waterways.

OTHER VALUABLE GEOSPATIAL RESOURCES

In some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and 
geographic information. Some popular sites:

•	 Directions Magazine
•	 Geospatial World
•	 GIS Cafe
•	 GIS Dictionary
•	 GIS Lounge
•	 GIS Development
•	 GISuser
•	 University of Edinburgh
•	 University of Florida - Geoplan Center
•	 US Census Bureau

Online Sources 
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General Tips and Hints 

CREATING DELIMITED XY TEXT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS or 
ASCII file containing these points ready for import. Provided you have the real-world coordinates for the locations 
you wish to plot*, you can manually create a delimited ASCII file using a text editor (e.g. Notepad) or a spreadsheet 
program (e.g. Microsoft Excel). This file can then be imported using either Simple or Advanced Import using the 
Delimited XY Text Data format.

In a text editor, one column in the file must contain the X coordinate and another must contain the Y coordinate. 
Add as many additional columns as you wish containing additional information to be imported as attribute data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitude and south latitude, respectively. Also 
make sure to enter a carriage return using the Enter key on your keyboard after the last line of data otherwise the 
last line may be ignored by MAPublisher Simple or Advanced Import.

In a spreadsheet application, enter your point information as a table and save the file in a text format, preferably 
.csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the text automatically. 

*	 The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point 
Files. See chapter 4 for more information.
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JOINING SDTS TABLES
The following information should be used in conjunction with the MAPublisher Join Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order 
to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is 
constructed such that the primary vector data is held separately from the various attribute tables that one might 
want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually 
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For 
example, a particular vector file containing the geography of rivers would contain a data column called RCID. 
Various data tables containing information such as vegetation, fish counts or flow rates might be available each also 
with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the 
techniques described in the previous pages. 

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same 
character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD” at the 
end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table, 
you do the join based on the column from the layer matched to the RCID column of the table. Note that the CATD 
catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR
On some occasions you may wish to rotate selected objects about their own centres rather than as a group about 
a common origin. This can be accomplished using the Adobe Illustrator Transform Each function. To use this function, 
first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the Rotate box enter a 
desired rotation value and click OK. Each of the selected objects will be rotated individually about their own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a 
specified value. See chapter 5 for guidelines on how to use this function.

GEOREFERENCING AN ADOBE ILLUSTRATOR FILE
If you are using an existing Adobe Illustrator file that was created without the use of MAPublisher and as such does 
not contain any geographic parameters or attribute data, the following steps will enable you to georeference your 
Adobe Illustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your 
map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user 
guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views 
section (see chapter 4) before proceeding.

Before beginning to georeference an Adobe Illustrator file you must be in possession of the following information:
1.	 The real-world scale of your data
2.	 Details of the coordinate system the data is in (i.e. Projection, Datum etc)
3.	 The X-Y coordinates of one tie-in point in the coordinate system of your data
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To determine the real-world scale of your data, use the scale bar drawn on the map for reference (measure the 
page size using the Adobe Illustrator Measure tool and divide by the scale size indicated - make sure to correct for 
the measurement units). If no scale bar is available, try measuring distances in page units in Adobe Illustrator and 
compare with the same distance measured in real unit with a mapping or GIS software, beware that differences in 
coordinate systems may affect the distance measurements.

Determining the coordinate system of the map may be difficult. If no information is provided as meta data or in the 
map legend, try to compare with other maps of the same area or with traditional coordinate systems used in the 
area (e.g. US State Plane zone matching a county name in the USA...).

To determine the real-world tie point, find a specific location in your document for which a real-world coordinate 
location is known or can be easily determined (such as known feature or grid or graticule crossing positions). 
Record the location of this point in real world coordinates on a piece of paper.

When you have this information please use the following guidelines in order to georeferencing data with 
MAPublisher in Adobe Illustrator. 
1.	 Identify the registration or tie-in point in your document for which you know the X,Y or Lat,Long coordinates.
2.	 Determine the page position of the same point on the Adobe Illustrator page using the Info panel (Window > 

Info).
You should now have the location of your tie-in point in both map and page units (e.g. –79.5, 43.5 in Lat/Long is located 
at 4cm, 2cm in the document).
3.	 In the MAP Views panel, choose New MAP View in the panel options menu. 
4.	 Enter a name for the MAP View. 
5.	 Click the Specify button in the Source Coordinate System section. Choose the coordinate system that matches that 

of your vector data and click OK.
6.	 Set the Scale to the proper scale of the map. It is important to set the scale after the coordinate system but 

before you enter the map anchors. 
7.	 Click OK in the MAP View Editor to apply the information to the new MAP View.
8.	 In the MAP Views panel, choose Specify Anchors in the panel options menu.
9.	 Set the Map Anchors to the value of the tie-in location in map units using the values determined earlier 

(e.g. Longitude= –79.5o, 43.5o).
10.	 Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 2 

(e.g. X=4cm, Y=2cm). Then click OK.
11.	 If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature 

type (Point, Area, Line, Text, Legend). 
12.	 In the MAP Views panel drag each of the layers which contain your data in to your new MAP View, ensuring that 

you set the appropriate Feature Type in the Define Layer dialog box.
13.	 Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for 

example).
14.	 Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and 

capable of accepting attributes using MAP Attributes (see chapter 5). You can also use the MAPublisher Export 
function to create a GIS file from this newly georeferenced Adobe Illustrator map.
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TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER
These strategies do not focus on how to do the procedures, as these are discussed in the Export section of the MAP 
Views chapter, but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP 
imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher only 
recognizes objects that have been imported by or created with its functions. If a layer was not imported with 
MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer. 

If you have an entire layer that was not created by MAPublisher then:
1.	 Ensure that your layer contains only a single feature type (Point, Area, Line or Text). 
2.	 In the MAP Views panel, check that you have a designated MAP View with a matching coordinate system. If you 

do not, create a new MAP Views.
3.	 Select the layer in the MAP Views panel.
4.	 Drag the layer to the MAP View containing the matching coordinate system to georeference the layer. 
There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you 
need to compensate for this. If you have Bezier curves in your Adobe Illustrator file they will not be recognized in 
the GIS software. In order for these features may be represented correctly you will need to add points to these lines 
in Adobe Illustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path 
> Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of 
your curves will not be lost on export.

Adobe Illustrator stores the origin of text that has been applied along paths differently from other text objects. We 
have found the following steps to be the most successful way to get such Text exported to GIS files:
1.	 Create a new Adobe Illustrator layer
2.	 Select any text that has been created along paths.
3.	 Drag this text to the new Adobe Illustrator layer
4.	 Select Type > Create Outlines. The text will be converted to vector objects.
5.	 In the MAP Views panel, drag this layer back into your MAP View, specifying Area as the feature type
You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts. 
We recommend that you make a copy of the original text objects before you do this process. These hints on how to 
transfer Adobe Illustrator files are necessary because the graphics environment handles text and curves differently 
and they need some modification in order for the GIS software to represent these accurately.

DOUGLAS-PEUCKER LINE SIMPLIFICATION
The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a 
vector line. A common problem in digital cartography and geographic information systems can occur when lines 
are generated automatically from a mathematical function, which records points at a fixed interval regardless if 
they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable 
cartographic line. As well in cartographic work within Adobe Illustrator the removal of points along a path can 
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the 
University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following 
article: Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature, 
Canadian Cartographer, Vol. 10, No. 2, December 1973.
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BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other 
two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is 
actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend 
of the values of several control points.

Most GIS formats do not support Bezier curves when used in graphics software such as Adobe Illustrator. Typically, 
curved sections of GIS data will be composed of a series of small line segments rather than an actual curve. This is 
also how features imported by MAPublisher will first appear in Adobe Illustrator. Use Adobe Illustrator Object > Path 
> Simplify to convert this type of feature into a Bezier curve (see chapter 8). Furthermore, Bezier curves cannot be 
simplified using the MAPublisher Simplify Line tool.

If Bezier curves are exported from Adobe Illustrator using any of the MAPublisher Export functions they will be 
converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is 
therefore necessary to create additional points to curves to retain their true shape. This can be done globally by 
using the Adobe Illustrator Object > Path > Add Anchor Points function.

This version of MAPublisher supports Bezier curve features during the following operations:
•	 Scale and Projection transformations via the MAP View Editor
•	 Area and length calculations

CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Helpful Styles & Symbols 
folder. You may also find that a search on the internet may be useful for finding additional libraries. If you are 
required to create new symbols, the steps below will help you to quickly create symbols manually in Adobe 
Illustrator.

1.	 Use Adobe Illustrator Tools for the manual creation of artwork that will comprise the new symbol. If you wish to 
use a character that are contained in a font library, select the text character instance and click the menu 	
Type > Create Outlines to convert the text to vector art.

2.	 Open the Adobe Illustrator Symbols panel (Window > Symbols).
3.	 Select the artwork that will comprise the new symbol and drag it into the Adobe Illustrator Symbols panel 

double-click the symbol in this panel to assign a name.
4.	 When Edit Stylesheet Theme is accessed for Point stylesheets, this symbol will be available in the Style column.

CREATING A MAP THEMES TEMPLATE

You can create template files with legends to automate the production of a series of similar maps. The procedure 
when using MAP Themes is as follows:
1.	 Create a prototype map using MAP Themes to create the desired look.
2.	 Make a copy of your prototype map file. Delete all the layers from the file so that only the designated MAP 

Themes exist.
3.	 Save it to a new Adobe Illustrator template file (*.ait).
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4.	 Use this template file as a base for future maps as follows:
a) 	 Make a copy of the template file.
b) 	 Import all map layers into the template file and do any needed processing.
c) 	 In the MAP Themes panel, assign your MAP Layers into the desired MAP Themes type. 
d) 	 Apply the MAP Themes and your new layers will be symbolized.

CREATING A MULTI-CONDITIONAL IF EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style 
column. In the following example this is achieved by creating a multi-conditional IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C” in the CAPITAL 
attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C).
There are three point symbols to assign to the type of point. In this example the following expressions can be 
assigned to the #Style column of the point layer (both expressions have the same result):
Expression 1:
IF(CAPITAL = “Y”, “MAP Symbol 01”, IF(CAPITAL = “C”, “MAP Symbol 02”, “MAP Symbol 03”)) 
Expression 2:
IF_CASE("MAP Symbol 01", CAPITAL="C", "MAP Symbol 02", CAPITAL="N", "MAP Symbol 03")

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01”. If the capital is “C” assign the symbol “MAP Symbol 
02”. All other symbols assign “MAP Symbol 03”.

NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to 
RGB mode. 

If the image is linked consider the following:

1.	 The image will be exported in the original colour mode of the image irrespective of the current colour mode of 
the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas 
a linked RGB image in an CMYK document will be exported as a RGB image).

2.	 A linked image with Alpha channels may be exported in a different colour model. For example a grayscale with 
two alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

3.	 Linked images in CMYK mode (regardless of the color mode of the document) will export with an incorrect 
result and should therefore be avoided (see chapter 12).

If the image is embedded consider the following:

1.	 The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK 
document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be 
exported as an RGB image).

2.	 Embedded grayscales do not pick up the document colour model (i.e. an embedded grayscale image will be 
exported as grayscale).

3.	 The export of embedded Bitmap images is not supported.
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In the MAPublisher application, the coordinate system option must be entered at two levels: coordinate system of 
the source data (when importing GIS data) and coordinate system of the final map.

SOURCE DATA COORDINATE SYSTEM

The Source coordinate system is usually detected when the coordinate system information is available with the 
GIS data being imported and when supported in the native GIS format (such as Shapefile , e00). However, in some 
cases, this information is not imported because it is not supported in the original GIS format (e.g. DWG, DXF) or 
when using a non-referenced Adobe Illustrator files. In that case, the coordinate system must be specified by the 
user. It generally can be found from an attached metadata document, by contacting the data provider or in textual 
information on the original data itself (e.g. title or legend of a scanned map). 

In all cases, the source coordinate system must be known with certainty. Then only can the proper parameter 
be specified in the MAPublisher interface. A wrongly specified source coordinate system would make the map data 
unusable for transformations and merging with other datasets.

FINAL MAP COORDINATE SYSTEM

Most of cartographic projects are restricted in the choice of coordinate system for the final map. This parameter 
is usually part of the project requirement. It is the task of the professional cartographer to analyze carefully the 
situation to make the wise decision. For general purpose mapping projects (interpretive or marketing maps for 
example), a more approximative selection of the coordinate systems might be acceptable. Following the request 
from some of our users, who may not have a cartographic expertise, here are a list of simple considerations to take 
into account before making a choice:

•	 Use of a Geodetic Coordinate system (angular coordinates, Lat/Long):
•	 Appropriate for overlay with GPS data recorded in Lat/Long format.
•	 WGS84 system is required to export vector data to KML format (for display 

in Google Earth, Google Maps).

•	 Use of a Projected coordinate system:
•	 Appropriate for printed map (so that users can use a ruler to measure 

distances on the map).
•	 Required to add a scale bar. 

•	 Use of a particular system (within the list of projected and geodetic systems):
•	 Maps that are part of a portfolio or Atlas have to comply to the same 

system to be consistent. 
•	 When a geo-referenced image (geotiff or world tiff) is to be used together 

with the data, it is easier to use the same coordinate system for the vector 
data as of the raster.

•	 Most countries or geographic areas have published standards or usual 
way for representing the land (e.g. for road maps or meteorological maps). 
In this case, the user should make some test with the systems listed in 
MAPublisher. For a convenient use, coordinate systems are sorted by 
continent>country>sub-division (state or county for example).

Appendix 2: Coordinate Systems
Overview
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In doubt, it is recommended to test different coordinate systems and visualize the results.

For more information on the supported coordinate systems and projections in MAPublisher, please refer to the 
Avenza Projections Guide installed with MAPublisher.

Examples of appearance of the USA depending of the chosen coordinate system

Geodetic > World > WGS84 (unprojected) 

Projected > World > Robinson 

Projected > North America > United States > US National Atlas 
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The Geodetic Datasource 

MAPublisher includes an extensive geodetic parameter database called the Geodetic Datasource. It contains all the 
latest updates from the widely used  EPSG Geodetic Parameter Dataset maintained by the Geodesy Subcommittee 
of OGP (International Association of Oil and Gas producers) as well as custom systems maintained by Avenza. 
In addition, the MAPublisher Geodetic Datasource supports user's custom definitions and allows for importing 
external WKT (Well-Know Text) and PRJ (Esri projection file) parameter files.

Over 3500 pre-defined coordinates systems are readily available for use in most cartographic projects. Even though 
the current list of systems is comprehensive, there may be instances where the end users may wish to add a brand 
new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to 
change the units for example.  A complementary Avenza Projections Guide is installed with MAPublisher. It describes 
all the projections and datum shifts methods supported by MAPublisher, to assist users in the process of creating or 
editing a coordinate system.

The default parameters installed with MAPublisher are stored within read-only XML database files referred to 
as the Geodetic Datasource (files named geodata.xml and avenza.xsp).  The base datasource files shipped with 
MAPublisher are installed in the Data Source Files folder at the following location:

Windows:  C:\Program Files\Avenza\MAPublisher 8\Data Source Files
Mac OS X:  /Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

Custom definitions and parameters are saved or loaded from separate XML files that must always accompanied 
with a file named geocalc.xsd (when not present, this file can be copied from the Data Source Files folder).

The custom and read-only entries are organized into categories and sub-folders — users may create new folders, 
move entries or create short-cuts. That folder structure is saved in a view file (*.xvw). 

When MAPublisher is uninstalled or a newer release is installed, an option will be given to backup the custom 
coordinates systems and view file (Windows only). The backup files can be found:

Windows XP:	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	 C:\ProgramData\Avenza\MAPublisher 8 
Mac OS X: 	 /Applications/Avenza/MAPublisher 8/Data Source Backup

LOAD CUSTOM COORDINATE SYSTEMS

A geodetic datasource or coordinate system database can be loaded into MAPublisher, greatly extending the 
coordinate systems available for use. To load a geodetic database within MAPublisher, choose Load Custom Coordinate 
Systems from the MAP Views panel options menu. 

The directory containing the XML file must also contain the file geocalc.xsd. This file can be found in the directory 
of the default geodata.xml file (see above). So the custom XML file can either be copied to the Data Source File 
directory prior to loading, or geocalc.xsd should be copied from there to the custom XML directory.

Any additional change will be saved into the loaded xml file.
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Note:	 Coordinate systems may also be extracted from the input data formats (during import process).

EDIT CUSTOM COORDINATE SYSTEMS

MAPublisher includes an extensive geodetic parameter database. The contents of the Geodetic Datasource can be 
browsed or searched by using a search frame. Users can extend MAPublisher Geodetic Datasource to support an 
unlimited number of custom linear and angular units, ellipsoids, datums, datum shifts, and coordinate systems. 

MAPublisher Custom Coordinate Systems Editor is accessed from the MAP Views panel options menu Edit Custom 
Coordinate Systems. Coordinate systems may also be edited/created from the Specify Destination Coordinate System 
dialog box (opened using the Specify button in MAP Views panel and import dialog boxes), but the other geodetic 
objects are only accessible through Edit Custom Coordinate Systems.

Individual entries in the geodetic data source are known as Data Source Objects. There are different types of objects 
for different types of definition. Objects contained in the geodetic data source are:

•	 *All*: used to define the orientation of axes used and the type of units used in the system.

•	 Angular Units: type of units for measuring rotation.

•	 Coordinate Systems: a complete definition needed to express the context of a set of map data.

•	 Datum Transformations: parameters to transform coordinates from one datum to another.

•	 Ellipsoids: an ellipsoid gives a horizontal datum its size and shape. An ellipsoid does not have an origin 
and cannot be used as a base model for coordinates on its own.

•	 Envelopes: defines a geographic area of use for a particular object.

•	 Horizontal Datums: more commonly referred to as just "datum" is the base model maps are built 
on. All coordinate systems must have a datum associated with them to be related to any other map. 
Without a known datum, coordinates are meaningless.

•	 Linear Units: units for measuring straight line, Cartesian distances.

•	 Prime Meridians: defines longitude values of meridians.
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You can define new coordinate systems, make copy and modify existing objects. The custom objects are stored 
in a separate xml file saved by the user. Users can also re-organize the Geodetic Datasource (default and custom 
parameters) into categories and sub-folders. These changes are saved to a view file (.xvw). The view file may be 
deleted to reset the Edit Custom Coordinate Systems dialog box to its default state.

Datasource - File contains the 
default geodetic parameter 

(geodata.xml).

Custom Data - File contains 
custom geodetic 

parameters. It is loaded or 
saved by the user.

Data Source Object Folders - See 
list on previous page

Search - Search for 
geodetic objects. Search 

in categories such as EPSG 
Code, Envelope, Source 
Datum, Class Type, etc.

Add/Remove - Add and 
remove folders and 

categories.

Save / Save As - Save 
changes to a custom 
file (data to XML and 
view to XVW).

Edit Object Buttons - 
Add, remove, edit, 
information or copy 
objects.

At the top of the Edit Custom Coordinate Systems dialog box, two directory paths are listed: the geodetic data source 
path and the custom data path.

Note:	 The geodetic data source file is protected (read-only). Any additions or modifications to coordinate systems 
are stored in a separate XML file called customsystems.xml.

On the left-hand side of the dialog box is the data source object folders. To expand a folder to see its subfolders, 
click the plus sign (Windows) or arrow (Mac) to the left of the category name. To see the entries at any particular 
level of category, click the category itself. When an object, folder or subfolder is selected, the data source objects 
list box to the right displays the information stored within each one. User defined coordinate system objects can 
be organized using drag-and-drop between folders. Columns can be resized and sorted alphabetically/numerically.  
Right-click on a column header to show or hide it. Entries loaded from the main geodetic data source will be shown 
in black text, while entries from the custom data file will be shown in blue.

To create a new folder, click the New Folder button. A new folder will be titled "New Folder" by default and can be 
renamed. Subfolders can also be created using the same method. Only user-defined categories can be deleted 
using the Delete Folder button.

Changes are saved to customsystems.xml located in:
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 8	
Mac OS 		  Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

The default XVW file (folder structure) is saved to customview.xvw, located in:
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 8	
Mac OS X:		  Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/ 
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CREATE NEW DATA SOURCE OBJECTS

In the Edit Custom Coordinate Systems dialog box, click the New Object button  to create a new data source 
object. When creating new data source objects, the identification information and definition parameters need to be 
completed. Complete this information in the respective Identification and Definition tabs.

The Identification tab is used to name the object and associate identification codes with it (if applicable). It is 
important to enter an appropriate name for the object. The Remarks field can be used to add notes on a definition 
and is optional. The Identifiers list may be used to add identifying codes for an object that may come from other 
databases. The GC code is a unique identifier assigned by Geographic Imager and should not be altered. To enter 
additional codes use the space below it.

The Definition tab is used to define the parameters of an object. Each object has parameters unique to it. Refer to the 
list below when creating new objects.

Note:	 Refer to the Avenza Projections Guide for more information on supported projections and their parameters 
as well as supported datum transformations methods.

*All*
For coordinate points, specify the coordinate point dimensions in either 2D or 3D. For Geodetic and Projected 
Coordinate Points, the Longitude and Latitude style of units must be entered for all 2D Dimensional Points. The 
Longitude, Latitude and Ellipsoid Height style of units must be entered for 3D Dimensional Points.

            

Angular Units
For angular units, enter a conversion for the new unit in terms of the scientific 
standard Degrees. The Abbreviation is used to identify the unit within the 
application interface (Example: The abbreviation for degrees is "deg").
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Coordinate Systems
For Coordinate Systems, select an Envelope defining the appropriate area 
of use. If you are unsure of the appropriate envelope, you can leave it set to 
the default World envelope. The Point Style is how you will select the style 
of linear units for your system. For most projected systems, you will want to 
select "Projected point in (units)". Then select the Geodetic model that using 
the appropriate datum for your system. When you select the appropriate 
projection for your system, the parameters needed to define the system will 
appear in the table below. Enter the needed parameters and define the units 
each parameter is specified in.

   

Datum Transformations
For Datum Shifts, select an Envelope (appropriate geographic area of use), 
Source, Target and Method. If you are unsure of a more specific envelope, leave 
it set to the default "World" Envelope. The Source and Target fields are used 
to specify the two geodetic models the Transformation is valid for. The Method 
specifies the necessary parameters to define a particular datum transformation. 
With the proper method selected, enter the appropriate parameters for 
your datum transformation. Be sure to define the appropriate units for each 
parameter by clicking the Units button.

Ellipsoids
For Ellipsoids you must enter the parameters for the Semi-Major Axis and Semi-
Minor Axis (often noted as "a" and "b" respectively) define the linear units the 
axes are specified in by selecting a predefined unit in the appropriate fields. 
The Inverse Flattening (often noted as "1/f") will automatically calculate in 
the field below. Alternately, you can make the Inverse Flattening definitive by 
enabling the check box at the bottom. You can then manually enter the Inverse 
Flattening rather than the Semi-Minor Axis parameter.
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Envelopes
For Envelopes, specify the extents of the envelope (it is not required but 
recommended). If the Specify Extents Points check box is checked, it is required to 
enter the minimum and maximum points of the envelope and the point style the 
value represent.

Horizontal Datums
For Horizontal datums you must select the Ellipsoid the datum is based on, as well 
as the prime meridian used.

Linear Units
For Linear units, enter a conversion for the new unit in terms of the scientific 
standard Meters. The Abbreviation is used to identify the unit within the 
application interface (Example: The Abbreviation for Meters is "m")

Prime Meridians
For Prime Meridians you must enter the longitude value of the Prime Meridian 
and the angular unit that value is in.
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EDIT OBJECTS

To edit a custom or user-defined object, click the Edit Object button . Edits may be made in the respective object 
editor dialog box. Alternatively, double-click an object to open the editor dialog box. When a data source object 
belonging to the master data set is selected, the Edit Object button  is disabled (because these objects are read-
only). To modify an original object, create a copy of the object first then edit it.

DELETE OBJECTS

When a data source object belonging to the master data set is selected, the Delete Object button  is disabled. 
Only user-defined objects can be deleted.

COPY OBJECTS

Any object can be copied. To create a copy of an object, select an object and click the Copy Object button . A 
dialog box will appear with "Copy of:" preceding the object name in the Name box.

MOVE OBJECTS

Any user defined object can be moved. Drag-and-drop an object from the Data Source Objects List to a Data Source 
Object Folder. A dialog box will prompt you to move the object or to create a shortcut to it.

LOAD CUSTOM COORDINATE SYSTEM DEFINITIONS

In some instances, the coordinate system of an image is not listed in the geodetic data source or the reference file 
format does not support the coordinate system. In such cases, it may be useful to load custom coordinate system 
definitions. In the Geographic Imager panel options menu, click Load Custom Coordinate System. MAPublisher can use 
the following coordinate system file formats: WKT definitions (.wkt), MapInfo MAP files (.map), MapInfo TAB files 
(.tab) and ESRI projection files (.prj).

When a new coordinate system definition is loaded, it automatically replaces the source coordinate system of the 
currently selected image. To transform the image to the loaded coordinate system, open another referenced file 
and then load the coordinate system to that file. In the Transform dialog box, choose the Same As option to make 
the destination coordinate system identical to the image of the loaded coordinate system. 
 
When a coordinate system definition is loaded, it is added to the geodetic data source but not saved. If the loaded 
file matches an existing definition, the original definition will be used and the loaded definition will not be added. 
All new definitions are located at the top level of the appropriate category in the Coordinate Systems folder list (in 
either Geodetic or Projected). Before exiting Adobe Photoshop, be sure to save your geodetic data source if you 
wish to use the coordinate system definition again. 
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Appendix 3: MAPublisher 8 How-To’s For Legacy Users

Legend Functionality in MAP Themes 

A number of functions have been redesigned in MAPublisher 8.4. Users of MAPublisher 6 or earlier should consult 
the following pages for information on how to perform common legacy MAPublisher tasks in MAPublisher 8.4.  

BUILDING COLOUR RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line 
styles. A possible use for this would be in the creation of relief maps.
1.	 Determine the number of new graduated styles you wish to create. 
2.	 Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base. 
3.	 Colour the first (top) and last (bottom) elements with two end colours for the ramp.
4.	 Choose Object > Blend > Blend Options.
5.	 Choose Specified Steps from the list. Enter the value you determined in the first step minus two. Click OK.
6.	 Select the two rectangles. Choose Object > Blend > Make. The legend elements will be blended between the two 

end colours.
7.	 Choose Object > Expand, then choose Object > Ungroup. This ungroups the art so that the new styles can be 

added to the Graphic Styles panel and be used in the MAP Themes.

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on Equal to expressions. The following 
examples can be used as a basis for new stylesheets, providing the functionality which was previously available in 
the Unique Occurrences option in Auto Assign Legend Info.

Example 1 (Rule 1 assigned first listed value and first style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the first listed value in a 

specified attribute column, i.e. Style A assigned to Column X = "Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned an incremental expression, i.e. Style B 

assigned to Column X = "Value 2”. 
3.	 Keep clicking the Add button until all the values or styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the third listed value in a 

specified attribute column, i.e. Style C assigned to Column X ="Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned the first unused style, i.e. Style A assigned 

to Column X = "Value 2”. 
3.	 Keep clicking the Add button. Assignments will be incremental, but will not include the third style again, i.e. 

Style B assigned to Column X ="Value 3”; Style D assigned to Column X = "Value 4”; etc
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CREATING STYLE RULES BASED ON MULTIBLE ATTRIBUTE COLUMNS

Assign Legend Info previously provided options to assign legend criteria to legend elements based on values in 
multiple attribute columns. This functionality can be achieved in the Edit Stylesheet Theme dialog box. Toggle to 
the Advanced mode to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type 
column named CONTINENT and an integer type column named POPULATION).

CONTINENT=“Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT=“Africa” OR POPULATION<1000000
Result: all African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,“America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT=“Europe” AND POPULATION>1000000 OR CONTINENT=“Asia” AND POPULATION>10000000
Result: countries in Europe with populations more than one million and countries in Asia with populations more than ten 
million are assigned the selected style.

Copy and Paste 
The MAP Copy/Paste function was removed in MAPublisher version 7. You can now achieve the same functionality 
via Adobe Illustrator native Copy/Paste tools.

1.	 Use Edit > Copy or Edit > Cut to copy art. 
2.	 Deselect the art.
3.	 Select the destination layer in the Layers panel 
4.	 Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location. 

•	 When pasting to layers which already contain an attribute structure, the destination layer must have an attribute 
schema which matches the source layer (only attributes in common will be transferred). 

•	 When pasting to layers which contain no attribute structure, the destination layer will be assigned the same 
attribute schema as the source layer. 

•	 The destination layer can be contained in any MAP View as required. 
•	 The destination layer must be of a matching feature type as the source layer. 
•	 Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View, 

then recreate the schema, attributes will be populated appropriately. 
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Grid and Scalebar Operations 
EDITING CUSTOM ART

Manually editing type (position, font, colour, etc) is not possible on Grids and Scale Bars in their default grouped 
state. Manual editing is possible but objects must be first expanded (choose Object > Expand). Note that this will 
negate any opportunity to subsequently edit the art using MAPublisher editing tools. 

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without 
generating a new version, simply select the Grid or Scale Bar and choose Object > Edit Grid or Scale Bar. This will 
re-open the Grids and Graticules or Scale Bar dialog box with the current parameters of the object for subsequent 
editing. Editing the style of text (text colour, font, alignment, etc) used in the Grid or Scale Bar can be achieved by 
modifying the properties of the style in the Character Styles panel.

Use the bounding box of the generated grid or scale bar (choose View > Show Bounding Box) to resize. Resizing scale 
bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of 
the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

EXPORTING GRIDS

To export a grid you must first expand the object (choose Object > Expand), then move it to an Area layer. 
Alternatively expand your grid, move the legend layer to the [Non-MAP layers] category, then move it back into the 
MAP View specifying the feature type as Area.

MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View 
is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:
1.	 Reproject the MAP View to a standard Lat/Long projection (e.g. NAD27 Lat/Long, Degrees). 
2.	 Generate your grid or graticules on this MAP View.
3.	 Expand the object (choose Object > Expand).
4.	 Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.
5.	 Reproject the MAP View back to the original projection. 
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Legacy Text Conversion 
Opening legacy files, you may be prompted to update text (legacy text conversion).

Only text objects that are associated to attributes are required to be updated. For other text with no attributes, you 
do not necessarily need to update.

All text art - Choose this option to convert all text 
to the Adobe Illustrator current version.

MAPublisher text art only - Choose this option to 
convert only the MAPublisher text (on MAP 

layers)

Nothing - Choose this option if no conversion is 
necessary
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Appendix 4: Helpful Styles and Symbols Files
The Helpful Styles & Symbols folder is found in the following locations:

Windows XP: C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols
Windows Vista/7: C:\Users\Public\Public Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols

Helpful Styles & Symbols > MAP Graphic Styles
This folder contains eight sets of graphic styles for areas and lines:

MAP - Area Effects.ai A set of area gradients

MAP - Area Patterns.ai A set of black and patterns for areas

MAP - Area Solid Colors.ai A set of solid colors for areas

MAP - Line Styles.ai A set of line styles

Format specific styles

DGN - Line Styles.ai A set of MicroStation DGN line styles 1-7

MIF - Area Styles.ai A set of MapInfo MIF/MID area styles 1-71

MIF - Line Styles.ai A set of MapInfo MIF/MID line styles 1-77

S57 - Line and Area Styles.ai A set of S-57 specific styles for lines and areas

Helpful Styles & Symbols > MAP Swatches
This folder contains two sets of swatches:

MAP - Color Groups and Gradients.ai A set color groups and gradient swatches

MAP - Patterns.ai A set of various swatch patterns

Helpful Styles & Symbols > Symbols
This folder contains nine symbol sets of categorized symbols:

MAP - Symbols.ai A set of useful map symbols

S57 - Symbols.ai A set of S-57 specific symbols

Aeronautical Symbols.ai A set of aeronautical point symbols

Bank Symbols.ai A set of symbols from major world banks

North Arrows.ai A set of north arrow symbols

Park Symbols.ai A set of U.S. National Parks Service symbols

Subway Symbols.ai A set of symbols from major subway lines

Transit Symbols.ai A set of symbols from major transit systems

Weather Symbols.ai A set of weather-related point symbols
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Helpful Styles & Symbols > S-57 Symbolization
The S-57 Symbolization folder contains two templates with a series of MAP Theme stylesheets linking S-57 
imported features to appropriate nautical symbols and graphic styles inspired from the International Hydrographic 
Office S-4 publication (previously M-4) (Regulations of the IHO for international (INT) charts and charts specifications 
of the IHO). Graphic styles and symbol names are mostly based on the S-57 naming conventions. The basic template 
allow users to quickly apply styles to the imported data. The advanced template is more detailed to help users learn 
the format and make use of the data.

Subway Symbols.ai Adobe Illustrator template with detailed MAP Themes for use with S-57 data

S57_Basic_Template.ait Adobe Illustrator template with simplified MAP Themes for use with S-57data

US5FL12M Sample ENC file in S-57 format (chart of Tampa Bay, courtesy of NOAA®)

How to use S-57 templates:
•	 Open S-57_Basic_Template.ait or S-57_Basic_Template.ait and import S-57 data.
•	 In the MAP Themes panel, double-click a stylesheet theme to see its settings.
•	 For depth sounding labels, use attribute values with the Label Features - Use sounding style option for 

points labels. To round the depth values according to hydrographic standards, use the expression 
provided in the Expression Library (see chapter 5 on MAP Attributes and chapter 10 on Labeling)

Note:	 This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 format 
to interpret the data contents more easily. The created map must not be used for navigation, unless further 
processing is supervised by a trained hydrographer.

More Helpful Styles & Symbols on Avenza.com
For even more styles and symbols, visit http://www.avenza.com/resources/styles-symbols.
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